部署 macOS LOB 应用时出现错误0x87D13BA2

本文提供了在 Microsoft Intune 中部署 macOS 业务线 (LOB) 应用时以下错误消息的解决方案:

一个或多个应用包含无效的捆绑 ID。 (0x87D13BA2)

症状

使用 Intune 发布 macOS LOB 应用。 在 Microsoft Intune 管理中心中选择应用时,设备安装状态会显示有关该应用的以下信息:

  • 状态:失败
  • 状态详细信息:一个或多个应用包含无效的捆绑 ID。 (0x87D13BA2)

下面是 Microsoft Teams 的示例:

Microsoft Teams 中错误0x87D13BA2的屏幕截图。

即使已在设备上成功安装应用,也可能会出现此问题。

原因

在以下情况下会出现此问题:

  • macOS 应用包中包含多个应用程序。
  • 包中包含的所有单个应用程序的安装状态不会报告回Intune。

具有多个组件的任何应用(例如 Microsoft Teams)都可以生成此错误消息。

解决方案

使用以下步骤来解决此问题,并使 macOS LOB 应用能够正确报告其状态。

  1. 在通过 Intune 安装应用的 macOS 设备上,打开终端并运行以下命令,将已安装的应用列表输出到当前目录:

    sudo /usr/libexec/mdmclient QueryInstalledApps > InstalledApps.txt
    
  2. 在文本编辑器中打开 InstalledApps.txt 文件:

    InstalledApps.txt 文件的屏幕截图。

  3. 选择“属性>”“应用信息>编辑”,转到Intune中受影响的应用:

    “编辑应用程序”页的屏幕截图。

  4. 将 Intune 中包含的应用列表与 InstalledApps.txt 文件中列出的应用进行比较,并删除文本文件中未显示的任何应用:

    Intune中包含的应用列表。

    文本文件中包含的应用列表。

  5. 查看并保存应用程序,然后同步设备以检索最新的应用安装状态:

    最新应用安装状态的屏幕截图。