macOS LOB 应用未部署在 Microsoft Intune

本文提供故障排除步骤来帮助解决Microsoft Intune无法将 macOS 业务线 (LOB) 应用部署到目标设备的问题。

症状

macOS 业务线 (LOB) 应用添加到Microsoft Intune,然后尝试将应用部署到 macOS 设备。 但是,应用未安装在目标设备上,并且Intune中未显示任何错误消息。

原因

如果 .pkg 包信息文件中不包含以下信息,则会出现此问题:

  • versionCFBundleVersion 字符串
  • 正确的 install-location

此信息是必需的,以便Intune可以在目标设备上部署应用。

使用以下步骤检查包.pkg是否包含所需信息。

  1. 运行以下命令,从 .pkg 包中提取 pkg-info 文件:

    xar -x -f <.pkg file path> -C <Output folder>

  2. 检查输出是否包含 CFBundleVersioninstall-location。 安装位置应为 /Applications 或其子文件夹,如以下示例所示:

    <pkg-ref id=“com.microsoft.teams” version=“1.00.522362”>
    <choice id=“TeamsApp” title=“Microsoft Teams” customLocation=“/Applications”/>

解决方案

若要解决此问题,请与应用开发人员联系以重新生成 .pkg 包以包含所需信息。 有关 Apple 特定的开发人员文档,请参阅 https://developer.apple.com/

更多信息

目前,对 macOS 应用部署的支持仅限于安装在 /Applications 文件夹中的简单.pkg应用,Office 365适用于 macOS 的应用

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。

第三方联系人免责声明

Microsoft 提供第三方联系信息,帮助你查找有关本主题的其他信息。 该联系信息如有更改,恕不另行通知。 Microsoft 不保证第三方联系信息的准确性。