你的组织已删除与此应用关联的数据

本文可帮助你解决以下问题:打开由Microsoft Intune应用保护策略管理的 Outlook for Android 应用时,收到组织已删除与此应用关联的数据错误消息, (应用) 。

症状

打开由 Intune 应用管理的 Outlook for Android 应用时,会收到以下消息:

由于已删除Microsoft Intune 公司门户数据或应用程序,组织已删除与此应用关联的数据。 若要重新连接,必须使用工作或学校帐户登录。

“你的组织已删除与其与此应用关联的数据”错误消息的屏幕截图。

原因

此问题由以下原因之一导致:

  • Outlook 已脱机很长时间。 因此,你已根据现有的应用保护策略注销 Outlook。
  • Outlook 无法检测系统更新后是否安装了 公司门户 应用。 由于 Outlook 无法获取预期的访问令牌,因此会脱机。 因此,你已根据现有的应用保护策略注销 Outlook。

解决方案

若要避免将来出现此问题,请在 Android 设备上完成以下步骤:

  1. 关闭 Outlook 和 公司门户 的电池优化。
  2. 将 Outlook 和 公司门户 的应用启动设置从“自动”更改为“手动管理”。 然后,启用以下“ 手动管理 ”选项:
    • 自动启动
    • 辅助启动
    • 在后台运行
  3. 如果启用了“数据保护程序”,请选择“Outlook”,公司门户无限制的数据使用。
  4. 为 Outlook 和 公司门户 启用通知。

注意

我们还建议对由 Intune APP 管理的其他应用执行这些步骤。

如果问题仍然存在,请按照以下步骤获取支持:

  1. 收集 Outlook 诊断日志信息:

    1. 在 Outlook for Android 设置中,点击 “帮助 & 反馈”。
    2. 点击“收集诊断”。
    3. 点击 “开始使用”。
    4. 点击 “收集日志”。
    5. 向Microsoft 支持部门提供事件 ID。
  2. 收集 Android 调试日志信息。

  3. 创建服务请求。 为此,请按照如何在Microsoft Intune管理中心获取支持中的步骤操作。