使用扫描程序进行扫描可能会导致 TWAIN 感知应用程序挂起
本文解决了使用扫描程序扫描可能导致 TWAIN 感知应用程序挂起的问题。
适用于: Windows 7 Service Pack 1
原始 KB 编号: 982436
来源:Microsoft 支持部门
快速发布
快速发布文章直接从 Microsoft 支持组织内部提供信息。 此处包含的信息是针对新出现或独特的主题创建的,或旨在补充其他知识库信息。
症状
当 32 位 TWAIN 感知应用程序在 64 位 Windows Vista 或 Windows 7 系统上使用 WIA 驱动程序扫描时,TWAIN 应用程序可能会停止响应。
原因
如果在按下 [扫描] 按钮之前将扫描对话框保持打开状态约 10 分钟,则不会向 TWAIN 应用程序发送用于将扫描图像从 WIA 驱动程序传输到 TWAIN 应用程序的消息。
解决方案
可以通过执行以下操作之一来避免此问题:
打开扫描对话框后,立即扫描图像。
使用 WIA 感知应用程序,而不是 TWAIN 感知应用程序。
更多信息
此行为是设计使然。
免责声明
Microsoft 和/或其供应商对网站上发布的文档和相关图形中包含的信息的适用性、可靠性或准确性不作任何声明或保证, (“材料”) 出于任何目的。 这些材料可能包含技术不准确或排版错误,可随时在不通知的情况下进行修改。
在适用法律允许的最大范围内,Microsoft 和/或其供应商拒绝并排除所有明示、默示或法定的陈述、保证和条件,包括但不限于与材料有关的所有权、不侵权、令人满意的条件或质量、适销性和特定用途适用性的陈述、保证或条件。
反馈
https://aka.ms/ContentUserFeedback。
即将发布:在整个 2024 年,我们将逐步淘汰作为内容反馈机制的“GitHub 问题”,并将其取代为新的反馈系统。 有关详细信息,请参阅:提交和查看相关反馈