使用扫描仪扫描可能会导致 TWAIN 感知应用程序挂起

本文提供了对使用扫描程序进行扫描的问题的解决方案,这可能会导致 TWAIN 感知应用程序挂起。

原始产品版本:   Windows 7 Service Pack 1
原始 KB 数:   982436

源: Microsoft 支持

快速发布

快速发布文章可直接从 microsoft 支持组织内提供信息。 此处包含的信息是为响应新兴或独特的主题而创建的,或旨在补充其他知识库信息。

症状

当32位 TWAIN 的应用程序使用64位 Windows Vista 或 Windows 7 系统上的 WIA 驱动程序进行扫描时,TWAIN 应用程序可能会停止响应。

原因

如果在推送 "扫描" 按钮之前,将 "扫描" 对话框保持打开约10分钟,则用于将扫描的图像从 WIA 驱动程序传输到 TWAIN 应用程序的邮件不会发送到 TWAIN 应用程序。

解决方案

可通过执行以下任一操作来避免此问题:

  • 在打开 "扫描" 对话框后立即扫描图像。

  • 使用 WIA 感知应用程序,而不是具有 TWAIN 意识的应用程序。

详细信息

此行为是设计使然。

免责声明

Microsoft 和/或其供应商对本网站上发布的文档和相关图形中包含的信息的适用性、可靠性或准确性不作任何陈述或保证, ("资料" ) 出于任何目的。 这些材料可能包含技术上的不准确或打字错误,并且可能随时修订,恕不另行通知。

对于适用法律允许的最大范围,Microsoft 和/或其供应商不允许并排除所有明示、暗示或法定的表示、担保和条件,包括但不限于职务、非侵权性、令人满意的条件或质量条件的表示、不侵权性、令人满意的条件或质量、适销性和针对特定用途的适用性(针对材料)。