TaskSettings.Compatibility 属性

对于脚本编写,获取或设置一个整数值,该值任务计划程序与哪个版本的任务兼容。

此属性是可读写的。

语法

TaskSettings.Compatibility As Integer

属性值

含义
TASK _兼容性 _ 0
任务与 AT 命令兼容。
TASK _兼容性 _ V1
1
该任务与 任务计划程序 1.0 兼容。
TASK _兼容性 _ V2
2
该任务与 任务计划程序 2.0 兼容。

备注

通过 Compatibility 属性设置的任务兼容性仅在需要从 _ Windows _ XP、Windows Server 2003 或 Windows 2000 计算机访问或修改任务时,才应设置为 TASK COMPATIBILITY V1。 否则,建议任务计划程序 2.0 兼容性,因为任务将具有更多功能。

与 AT 命令兼容的任务只能有一个时间触发器。

与 任务计划程序 1.0 兼容的任务只能具有时间触发器、登录触发器或启动触发器,并且任务只能具有可执行操作。

有关任务兼容性的详细信息,请参阅任务和任务计划程序新增功能

要求

要求
最低受支持的客户端
Windows仅 [ Vista 桌面应用]
最低受支持的服务器
Windows仅服务器 2008 [ 桌面应用]
类型库
Taskschd.tlb
DLL
Taskschd.dll

另请参阅

任务 _ 兼容性

任务计划程序