建立、使用及刪除 Visual Studio 專案和方案

在本文中,您將瞭解如何從頭開始建立和使用 Visual Studio 專案,以儲存您需要用來建立應用程式的構件。 如果您不熟悉 Visual Studio 中的專案,請參閱此專案和方案的總覽。 若要瞭解如何從範本快速建立專案,請參閱 從範本建立專案

「專案」用以保存在 Visual Studio 中建置您應用程式所需的項目,例如原始程式碼檔、點陣圖、圖示,以及元件和服務參考。 當您建立新的專案時,Visual Studio 會建立一個包含該專案的「解決方案」。 接著可以視需要將新的或現有專案新增至解決方案。 您也可以建立 空白或空白的解決方案。 解決方案也可以包含未連線至任何特定專案的檔案。

顯示方案和專案階層的圖表。

注意

本主題適用於 Windows 上的 Visual Studio。 針對 Visual Studio for Mac,請參閱在 Visual Studio for Mac 中建立專案

您可以在稱為 方案總管 的工具視窗中,檢視方案和專案。 下列螢幕擷取畫面顯示方案總管中的範例解決方案 (BikeSharing.Xamarin-UWP) 包含兩個專案:BikeSharing.Clients.CoreBikeSharing.Clients.Windows。 每個專案包含多個檔案、資料夾和參考。 以粗體顯示的專案名稱是「啟始專案」,也就是當您執行應用程式時所啟動的專案。 您可以指定哪一個專案是啟始專案。

有兩個專案方案總管的螢幕擷取畫面。

雖然您可以將必要檔案新增至專案來自行建構專案,但 Visual Studio 也提供一系列專案範本,方便您著手進行。 從範本建立新的專案提供您一個專案,其中包含適用於該專案類型的基本資訊,而且您可以視需求重新命名檔案,或是將新的或現有程式碼和其他資源新增至專案。

也就是說,在 Visual Studio 中開發應用程式不需要方案和專案。 您也可以直接開啟從 Git 複製或從其他位置下載的程式碼。 如需詳細資訊,請參閱在 Visual Studio 中不使用專案或方案來開發程式碼

從專案範本建立專案

如需如何選取範本以建立新專案的詳細資訊,請參閱在 Visual Studio 中建立新專案。 而且,如需從頭建立的專案和解決方案範例,請參閱 專案和方案簡介,以取得逐步指示及範例程式碼。

從現有程式碼檔案建立專案

如果您有程式碼來源檔案的集合,您可以輕鬆地將其新增至專案。

  1. 在功能表上 ,選取 [ > > 從現有程式碼新增 Project]。

  2. 在 [從現有程式碼檔建立 Project ] 嚮導的 [您要 建立哪種類型的專案? ] 下拉式清單方塊中,選取您要的專案類型,然後選取 [下一步] 按鈕。

  3. 在精靈中,瀏覽至檔案的位置,然後在 [名稱] 方塊中輸入新專案的名稱。 當您完成時,請選取 [ 完成] 按鈕。

注意

這個選項最適合用於相對簡單的檔案集合。 目前僅支援 c + +、Apache Cordova、Visual Basic 和 c # 專案類型。

將檔案新增至方案

如果您有一個套用至多個專案的檔案 (例如方案的讀我檔案),或邏輯上位於方案層級而不是特定專案下的其他檔案,則可以將這些檔案新增至方案本身。 若要將專案加入至方案,請在內容 (以滑鼠右鍵按一下 方案總管 中方案節點的) 功能表,然後選取 [加入 > 新專案] 或 [加入 > 現有專案]。

提示

方案檔是在 Visual Studio 中組織專案的結構。 它包含兩個檔案中該資訊的狀態: .sln (以文字為基礎的共用) 檔案, 以及 (二進位 、隱藏、使用者專屬的解決方案選項) 檔。 因此,解決方案不是應該複製和重新命名的東西;相反地,最好是建立新的方案,然後將現有的專案加入其中。

建立以特定 .NET Framework 版本為目標的 .NET 專案

當您建立 .NET Framework 專案時,您可以指定要讓專案使用的特定 .NET Framework 版本。 (當您建立 .NET Core 專案時,您不會指定 Framework 版本。)

若要指定 .NET Framework 版本,請選取 [新增 Project ] 對話方塊中的 [架構] 下拉式功能表。

[新增 Project] 對話方塊中 [Framework] 下拉式清單的螢幕擷取畫面。

注意

您必須在系統上安裝 .NET Framework 3.5,才能存取早於 .NET Framework 4 的 .NET Framework 版本。

若要指定 .NET Framework 版本,請選取 [建立新專案] 頁面上的 [架構] 下拉式功能表。

[設定新專案] 對話方塊中的架構選取器螢幕擷取畫面。

建立空的方案

您也可以建立不含專案的空方案。 這可能比較適合您想要從頭建構方案和專案的情況。

建立空的方案

  1. 在功能表列上 ,選取 [ 檔案 > 新增 > Project]。
  1. 在左側 (範本]) 窗格中,在展開的清單中選取 其他 Project 類型 > Visual Studio 方案

  2. 在中間窗格選取 [空白方案] 。

  3. 輸入解決方案的 名稱位置 值,然後選取 [確定]

  1. 在 [建立新專案] 頁面的 [搜尋] 方塊中鍵入 解決方案

  2. 選取 [空白方案] 範本,然後按一下 [下一步]。

  3. 輸入方案的 名稱位置 值,然後選取 [ 建立]。

建立空的方案之後,您可以在 [專案] 功能表上,選擇 [新增項目] 或 [新增現有項目],將新專案或項目或是現有專案或項目新增至該方案。

如前所述,您也可以開啟程式碼檔案而不需要專案或解決方案。 若要了解以此方式開發程式碼,請參閱在 Visual Studio 中不使用專案或解決方案來開發程式碼

建立暫存專案

(僅限 C# 和 Visual Basic)

如果您建立 .NET 專案而不指定磁碟位置,它會是暫存專案。 暫存專案可讓您試驗 .NET 專案。 使用暫存專案時,隨時都可以選擇儲存或捨棄它。

若要建立暫存專案,請先移至 [工具 > 選項 > 專案和方案 > 一般],並取消核取 [建立新專案時,儲存新專案] 核取方塊。 然後像往常一樣開啟 [新增專案] 對話方塊。

刪除方案、專案或項目

您可以使用滑鼠右鍵內容功能表來刪除或移除 Visual Studio 中的方案、專案或專案,但只會從目前的方案或專案中移除它們。

若要從系統永久刪除方案或其他元件,請使用 Windows 中的 檔案總管 來刪除包含 .sln.suo 方案檔的資料夾。 (在刪除解決方案之前,您可能會想要在需要時備份專案和檔案。 )

注意

.Suo 檔案是隱藏檔案,不會顯示在預設的檔案總管設定下。 若要顯示隱藏的檔案,請在檔案總管的 [檢視] 功能表中,選取 [隱藏的項目] 核取方塊。

永久刪除解決方案

您可以使用 Visual Studio 中的方案總管來存取 Windows 中的檔案總管。 方法如下。

  1. 方案總管 中,在您要刪除之方案的快顯功能表 (內容功能表) 上,選取 [ 開啟資料夾] 檔案總管

  2. 在 [檔案總管] 中,瀏覽上一層。

  3. 選取包含解決方案的資料夾,然後按下 Delete 鍵。

另請參閱