Rozhraní Návrháře sestav

Důležité

Vítejte na stránkách docs.microsoft.com. s nápovědou k aplikaci Microsoft Dynamics 365 for Operations. Na toto místo migrujeme náš obsah wiki stránky s nápovědou pro aplikaci Dynamics 365 for Operations.

Tento článek vysvětluje, jak navigovat v návrháři sestav, a jak používat různé možnosti podle specifických požadavků.

Příkazy nabídky Návrháře sestav

V následujících tabulkách jsou popsány příkazy a možnosti nabídky, které lze použít při návrhu finančních sestav. Některé příkazy a možnosti nabídky jsou k dispozici pouze za zvláštních okolností. Například příkazy pro zvýšení a snížení úrovně vykazovacích jednotek jsou k dispozici pouze v případě, že měníte definici stromu výkaznictví.

Nabídka Soubor

Nabídka Soubor je k dispozici všem uživatelům a obsahuje následující příkazy.

Příkaz Popis
Nový Vytvořte novou definici sestavy, definici řádku, definici sloupce, definici stromu výkaznictví, definici skupiny výkaznictví nebo složku. Další možnosti jsou k dispozici v závislosti na vaší uživatelské roli.
Otevřené Otevřete existující definici řádku, definici sloupce, definici stromu výkaznictví nebo definici sestavy.
Zavřít Zavře aktuální stavební blok.
Zavřít vše Zavře všechny stavební bloky.
Uložit Uloží aktuální definici řádku, definici sloupce, definici stromu výkaznictví nebo definici sestavy.
Uložit jako Uloží aktuální definici řádku, definici sloupce, definici stromu výkaznictví nebo definici sestavy pod novým názvem.
Vlastnosti Otevře dialogové okno Vlastnosti, ve kterém můžete změnit název a popis sestavy.
Vytvořit Vygeneruje aktuální sestavu. Tento příkaz je k dispozici z definice sestavy.
Zobrazit sestavu Otevře nejnovější verzi vygenerované sestavy v aplikaci Dynamics 365 for Operations. Tento příkaz je k dispozici z definice sestavy, pokud jste vygenerovali alespoň jednu sestavu.
Poslední definice sestav Zobrazí seznam sestav, které byly naposledy vytvořeny nebo upraveny. Poté můžete vybrat sestavu ze seznamu.
Poslední definice řádků Zobrazí definic řádků, které byly naposledy vytvořeny nebo upraveny. Poté můžete vybrat definici řádku ze seznamu.
Poslední definice sloupce Zobrazí seznam definice sloupce, které byly naposledy vytvořeny nebo upraveny. Poté můžete vybrat definici sloupce ze seznamu.
Poslední definice stromu výkaznictví Zobrazí seznam definic stromů výkaznictví, které byly naposledy vytvořeny nebo upraveny. Poté můžete vybrat definici stromu výkaznictví ze seznamu.
Ukončit Ukončí Návrhář sestav.

Nabídka Upravit

Nabídka Upravit je k dispozici pro uživatele, kteří mají role Návrhář nebo Správce. Tato nabídka obsahuje následující příkazy:

Příkaz Popis
Zpět Vrátí zpět předchozí akci.
Znovu Zopakuje dříve vrácenou akci.
Vyjmout Vymaže vybraný text a zkopíruje ho do schránky.
Kopírovat Zkopíruje vybraný text do schránky.
Vložit Vloží naposledy vyjmutý nebo zkopírovaný text ze schránky.
Vymazat Vymaže obsah vybrané buňky stavebního bloku.
Najít Otevře dialogové okno Najít a nahradit, kde můžete prohledávat text v podokně náhledu.
Nahradit Otevře dialogové okno Najít a nahradit, kde můžete prohledávat a nahrazovat text v podokně náhledu.
Vložit řádky z dimenzí Otevře dialogové okno Vložit řádky z dimenzí, kde můžete vybrat hodnoty dimenze, které mají být zahrnuty v definici řádku. Tento příkaz je k dispozici z definice řádku.
Přečíslovat řádky Přečísluje všechny číselné kódy řádků. Tento příkaz je k dispozici z definice řádku.
Odkazy řádků Otevře dialogové okno Odkazy řádků, kde můžete určit zdroje pro datové odkazy v definicích řádků a definicích stromů výkaznictví. Tento příkaz je k dispozici z definice řádku.
Vyrovnání rozdílů po zaokrouhlení Otevře dialogové okno Vyrovnání rozdílů po zaokrouhlení, kde můžete zadat parametry pro zaokrouhlování. Tento příkaz je k dispozici z definice řádku.
Správa sad dimenzí Otevře dialogové okno Sady dimenzí, ve kterém můžete vytvořit a upravit sady dimenzí. Tento příkaz je k dispozici v definici řádku nebo definici stromu výkaznictví.
Vložit řádek Vloží prázdný řádek do definice řádku nebo prázdný řádek záhlaví do definice sloupce. Tento příkaz je k dispozici v definici řádku nebo definici sloupce.
Odstranit řádek Odstraní vybraný řádek z definice řádku nebo vybraný řádek záhlaví z definice sloupce. Tento příkaz je k dispozici v definici řádku nebo definici sloupce.
Vložit sloupec Vloží prázdný sloupec do definice sloupce. Tento příkaz je k dispozici z definice sloupce.
Odstranit sloupec Odstraní vybraný sloupec z definice sloupce. Tento příkaz je k dispozici z definice sloupce.
Vložit jednotky výkaznictví z dimenzí Otevře dialogové okno Vložit jednotky výkaznictví z dimenzí, kde můžete vybrat hodnoty dimenze, které mají být zahrnuty v definici stromu výkaznictví. Tento příkaz je k dispozici z definice stromu výkaznictví.
Importovat hierarchii sady dimenzí Otevře dialogové okno Hierarchie sady dimenzí, kde můžete importovat hierarchii sady dimenzí z finančních dat. Tento příkaz je k dispozici z definice stromu výkaznictví pro systém ve složce.\financial-dimensions\systém založený na dimenzích.
Vložit jednotku výkaznictví Vložte prázdný řádek do definice stromu výkaznictví. Tento příkaz je k dispozici z definice stromu výkaznictví.
Odstranit jednotku výkaznictví Odstraní vybranou jednotku výkaznictví z definice stromu výkaznictví. Tento příkaz je k dispozici z definice stromu výkaznictví.

Nabídka Zobrazení

Nabídka Zobrazení je k dispozici všem uživatelům a obsahuje následující příkazy.

Příkaz Popis
Podokno Navigace Zobrazí nebo skryje navigační podokno.
Panely nástrojů Vyberte panely nástrojů, které jsou zobrazeny.
Stavový řádek Zobrazí nebo skryje informace o stavu v okně Návrhář sestav.
Uvítací stránka Otevře stránku Vítejte.

Nabídka Formát

Nabídka Formát je k dispozici pro uživatele, kteří mají role Návrhář nebo Správce. Tato nabídka obsahuje následující příkazy:

Příkaz Popis
Styly a formátování Otevře dialogové okno Styly a formátování, ve kterém můžete vytvářet a upravovat styl textu v definicích řádků a definicích sloupců. Tento příkaz je k dispozici v definici řádku nebo definici sloupce.
Šířka sloupce Otevře dialogové okno Šířka sloupce, kde můžete nastavit šířku vybraného sloupce. Tento příkaz je k dispozici v definici řádku, definici sloupce nebo definici stromu výkaznictví.
Skrýt Skryje vybraný sloupec. Tento příkaz je k dispozici v definici řádku, definici sloupce nebo definici stromu výkaznictví.
Zobrazit Zobrazí skryté sloupce mezi vybranými sloupci. Tento příkaz je k dispozici v definici řádku, definici sloupce nebo definici stromu výkaznictví.

Nabídka Společnost

Nabídka Společnost je k dispozici pro uživatele, kteří mají role Návrhář nebo Správce. Tato nabídka obsahuje následující příkazy:

Příkaz Popis
Společnosti Otevře dialogové okno Společnosti, ve kterém můžete vytvářet a upravovat společnosti.
Skupiny stavebních bloků Otevře dialogové okno Skupiny stavebních bloků, kde můžete vytvořit, upravit, importovat a exportovat skupiny stavebních bloků.

Nabídka Přejít

Nabídka Přejít je k dispozici všem uživatelům a obsahuje následující příkazy. Poznámka: Tyto příkazy nemají žádný viditelný efekt, pokud není zobrazeno navigační podokno.

Příkazy Popis
Definice sestavy Zobrazí definice sestavy v navigačním podokně.
Definice řádku Zobrazí definice řádku v navigačním podokně.
Definice sloupce Zobrazí definice sloupce v navigačním podokně.
Definice stromu výkaznictví Zobrazí definice stromu výkaznictví v navigačním podokně.
Zabezpečení Zobrazí informace o zabezpečení pro uživatele, skupiny a společnosti v navigačním podokně.

Nabídka Nástroje

Nabídka Nástroje je k dispozici všem uživatelům, avšak některé příkazy mají omezenou dostupnost. Tato nabídka obsahuje následující příkazy:

Příkaz Popis
Chránit Přiřadí aktuálnímu stavebnímu bloku heslo. Tento příkaz je k dispozici pro uživatele, kteří mají role Návrhář Správce.
Stav fronty sestav Otevře dialogové okno Stav fronty sestav, v němž se zobrazí všechny nedávno vygenerované sestavy a podrobnosti jednotlivých sestav.
Informace o zdrojovém systému Zobrazí nastavení systému Microsoft Dynamics ERP. Tento příkaz je k dispozici pro uživatele, kteří mají role Návrhář Správce.
Rezervované položky Zobrazí definice řádků, definice sloupců, definice stromu výkaznictví a definice sestav, které jsou právě otevřené. Tento příkaz je k dispozici pro uživatele, kteří mají role Návrhář Správce.
Aktualizovat finanční data uložená v mezipaměti Aktualizuje data ve sloupci finanční dimenze.
Možnosti Otevře dialogové okno Možnosti, kde můžete upravit uživatelské předvolby pro Návrhář sestav.

Nabídka Okno

Nabídka Okno je k dispozici všem uživatelům a obsahuje následující příkazy.

Příkaz Popis
Uspořádat vedle sebe Zobrazí vedle sebe všechna okna.
Uspořádat nad sebou Zobrazí všechna okna nad sebou.
Na sebe Překryje přes sebe všechna otevřená okna tak, aby bylo viditelné záhlaví každého okna.
Ukotvit vodorovně Ukotví vybraný řádek tak, aby byl při posunování tento řádek stále viditelný v okně. Tento příkaz je k dispozici pro uživatele, kteří mají role Návrhář Správce.
Ukotvit svisle Ukotví vybraný sloupec tak, aby byl při posunování tento sloupec stále viditelný v okně. Tento příkaz je k dispozici pro uživatele, kteří mají role Návrhář Správce.
Seznam otevřených oken Zobrazí seznam oken, která jsou otevřená. Výběrem můžete okno přesunout dopředu.

Nabídka Nápověda

Nabídka Nápověda je k dispozici všem uživatelům a obsahuje následující příkazy.

Příkaz popis
Nápověda Otevřete stránku tématu s nápovědou k aplikaci Dynamics 365 for Operations pro finanční výkaznictví.

Tlačítka panelu nástrojů Návrháře sestav

Následující tabulky popisují tlačítka na panelu nástrojů, která lze použít při navrhování sestav. Některá tlačítka panelu nástrojů jsou k dispozici pouze za zvláštních okolností. Například tlačítka pro zvýšení a snížení úrovně vykazovacích jednotek jsou k dispozici pouze v případě, že měníte definici stromu výkaznictví.

Standardní panel nástrojů

Standardní panel nástrojů poskytuje rychlý přístup k příkazům pro soubory a úpravy. Tento panel nástrojů obsahuje následující tlačítka.

Tlačítko Popis
Tlačítko Nový Můžete vytvořit novou (prázdnou) definici sestavy, definici řádku, definici sloupce nebo definici stromu výkaznictví.
Tlačítko Otevřít Otevřete existující definici řádku, definici sloupce, definici stromu výkaznictví nebo definici sestavy.
Tlačítko Uložit Uloží aktuální definici řádku, definici sloupce, definici stromu výkaznictví nebo definici sestavy.
Tlačítko Kopírovat Zkopíruje vybraný text do schránky.
Tlačítko Vyjmout Vymaže vybraný text a zkopíruje ho do schránky.
Tlačítko Vložit Vloží text ze schránky.
Tlačítko Zpět Vrátí zpět předchozí akci.
Tlačítko Znovu Zopakuje dříve vrácenou akci.
Tlačítko Najít Otevře dialogové okno Najít a nahradit, kde můžete prohledávat a nahrazovat text v aktivním okně.
Tlačítko Vložit řádek Vloží prázdný řádek do definice řádku nebo prázdný řádek záhlaví do definice sloupce. Toto tlačítko je k dispozici v definici řádku nebo definici sloupce.
Tlačítko Vložit sloupec Vloží prázdný sloupec do definice sloupce. Toto tlačítko je k dispozici z definice sloupce.
Tlačítko Zámek Přiřadí aktuálnímu stavebnímu bloku heslo. Toto tlačítko je k dispozici pro uživatele, kteří mají role Návrhář Správce.
Tlačítko Odkaz řádku Otevře dialogové okno Odkazy řádků, kde můžete určit zdroje pro datové odkazy v definicích řádků a definicích stromů výkaznictví. Toto tlačítko je k dispozici z definice řádku.
Tlačítko Zvýšit úroveň Zvýší úroveň jednotky definice stromu výkaznictví. Když vyberete podřízenou jednotku a kliknete na tlačítko Zvýšit úroveň, podřízená jednotka bude přesunuta na stejnou úroveň jako nadřazená jednotka.
Tlačítko Snížit úroveň Sníží úroveň jednotky definice stromu výkaznictví. Pokud vyberete jednotku a kliknete na tlačítko Snížit úroveň, jednotka se stane podřízenou pro jednotku, která jí předchází.
Tlačítko Rozbalit Rozbalte všechny jednotky definice stromu výkaznictví na úrovni vybrané jednotky.
Tlačítko Sbalit Sbalí strom výkaznictví.
Tlačítko Nápověda Otevřete nápovědu.

Panel nástrojů formátování

Panel nástrojů formátování nabízí snadný přístup k příkazům stylů. Tento panel nástrojů obsahuje následující tlačítka.

Tlačítko Popis
Tlačítko Styl písma Použije vybraný styl písma na aktuální text.
Tlačítko Písmo Nastaví aktuální text na vybrané písmo.
Tlačítko Velikost písma Nastaví aktuální text na vybranou velikost písma (v bodech).
Tlačítko Tučné Nastaví tučné písmo pro aktuální text.
Tlačítko Kurzíva Nastaví kurzívu pro aktuální text.
Tlačítko Podtržené Nastaví podtržení pro aktuální text.
Tlačítko Zmenšit odsazení Zmenší odsazení aktuálního textu.
Tlačítko Zvětšit odsazení Zvětší odsazení aktuálního textu.
Tlačítko Barva pozadí Změní barvu pozadí aktuální buňky.
Tlačítko Barva písma Změní barvu aktuálního textu.

Panel nástrojů návrháře sestav

Panel nástrojů návrháře sestav poskytuje rychlý přístup k příkazům navigace v návrháři sestav. Tento panel nástrojů obsahuje následující tlačítka.

Tlačítko Popis
Tlačítko Definice sestavy Zobrazí definici sestavy uvedenou v nabídce Okno.
Tlačítko Definice řádku Zobrazí definici řádku, která je přiřazena k aktivní definici sestavy.
Tlačítko Definice sloupce Zobrazí definici sloupce, která je přiřazena k aktivní definici sestavy.
Tlačítko Definice stromu výkaznictví Zobrazí definici stromu výkaznictví, která je přiřazena k aktivní definici sestavy.
Tlačítko Report Viewer Spustí aplikaci Report Viewer a zobrazí nejnovější verzi vygenerované sestavy. Toto tlačítko je k dispozici z definice sestavy, pokud jste vygenerovali alespoň jednu sestavu.
Tlačítko Generovat sestavu Vygeneruje sestavu z aktivní definice sestavy. Toto tlačítko je k dispozici z definice sestavy.

Viz také

Finanční výkaznictví

Generování finanční sestavy