Publikování do Power BI z Microsoft ExceluPublish to Power BI from Microsoft Excel

Pomocí Microsoft Excelu 2016 nebo novějšího můžete publikovat excelové sešity přímo do pracovního prostoru Power BI, kde můžete vytvářet vysoce interaktivní sestavy a řídicí panely, které jsou založené na datech těchto sešitů.With Microsoft Excel 2016 and later, you can publish your Excel workbooks directly to your Power BI workspace, where you can create highly interactive reports and dashboards based on your workbook’s data. Svoje přehledy pak můžete sdílet s jinými uživateli ve vaší organizaci.You can then share your insights with others in your organization.

Publikování sešitu do Power BI

Při publikování sešitu do Power BI je potřeba vzít v úvahu několik věcí:When publishing a workbook to Power BI, there are few things to consider:

  • Když se přihlašujete k Office, OneDrivu pro firmy (pokud používáte sešity, které tam jsou uložené) a Power BI, musíte použít stejný účet.The account you use to sign in to Office, OneDrive for Business (if using workbooks saved there), and Power BI must be the same account.
  • Prázdný sešit nebo sešit, ve kterém není obsah podporovaný v Power BI, nelze publikovat.You cannot publish an empty workbook, or a workbook that doesn’t have any Power BI supported content.
  • Šifrované sešity, sešity chráněné heslem a sešity se správou Information Protection nelze publikovat.You cannot publish encrypted or password protected workbooks, or workbooks with Information Protection Management.
  • Publikování do Power BI vyžaduje, aby bylo povolené moderní ověřování (výchozí nastavení).Publishing to Power BI requires modern authentication be enabled (default). Pokud je zakázané, není v nabídce Soubor možnost Publikovat dostupná.If disabled, the Publish option is not available from the File menu.

Publikování excelového sešituPublish your Excel workbook

Když chcete publikovat excelový sešit, vyberte v Excelu Soubor > Publikovat a potom vyberte Nahrát nebo Exportovat.To publish your Excel workbook, in Excel, select File > Publish and select either Upload or Export.

Pokud vyberete Nahrát a nahrajete sešit do Power BI, budete s ním moct pracovat stejně, jako byste to dělali pomocí Excelu Online.If you Upload your workbook to Power BI, you can interact with the workbook just as you would interact using Excel Online. Také budete moct připínat výběry ze sešitu na řídicí panely Power BI a sdílet sešit nebo vybrané prvky prostřednictvím Power BI.You can also pin selections from your workbook onto Power BI dashboards, and share your workbook, or selected elements, through Power BI.

Pokud vyberete Exportovat, můžete exportovat data tabulky a její datový model do datové sady Power BI, kterou pak můžete používat k vytváření sestav a řídicích panelů Power BI.If you select Export, you can export table data and its data model into a Power BI dataset, which you can then use to create Power BI reports and dashboards.

Publikování místních souborůLocal file publishing

Excel podporuje publikování místních excelových souborů.Excel supports publishing of local Excel files. Není potřeba tyto soubory ukládat na OneDrive pro firmy nebo do SharePointu Online.They do not need to be saved to OneDrive for Business or SharePoint Online.

Důležité

Místní soubory můžete publikovat jenom v případě, že používáte Excel 2016 (nebo novější) s předplatným Microsoft 365.You can only publish local files if you're using Excel 2016 (or later) with a Microsoft 365 subscription. Samostatné instalace Excelu 2016 umožňují publikování do Power BI, ale jenom v případě, že je sešit uložený na OneDrivu pro firmy nebo SharePointu Online.Excel 2016 standalone installations can Publish to Power BI, but only when the workbook is saved to OneDrive for Business or SharePoint Online.

Když vyberete Publikovat, můžete vybrat pracovní prostor, do kterého chcete publikovat.When you select Publish, you can select the workspace to which you want to publish. Pokud je excelový soubor umístěný na OneDrivu pro firmy, můžete ho publikovat jen do svého Pracovního prostoru.If your Excel file resides on OneDrive for Business, you can only publish to your My Workspace. Pokud je excelový soubor umístěný na místním disku, můžete ho publikovat do svého Pracovního prostoru nebo do sdíleného pracovního prostoru, ke kterému máte přístup.If your Excel file resides on a local drive, you can publish to My Workspace or a shared workspace to which you have access.

Snímek obrazovky ukazuje možnost Publikovat do Power BI s vybranou položkou Můj pracovní prostor.

Máte dvě možnosti, jak sešit dostat do Power BI.Two options on how to get your workbook into Power BI.

Snímek obrazovky ukazuje možnost Publikovat s vybranou položkou Můj pracovní prostor.

Když sešit publikujete, jeho obsah se naimportuje do Power BI a stane se nezávislým na místním souboru.Once published, the workbook content you publish is imported into Power BI, separate from the local file. Pokud budete chtít soubor v Power BI aktualizovat, musíte svoji místní aktualizovanou verzi znovu publikovat – nebo můžete data aktualizovat tak, že pro sešit nebo datovou sadu v Power BI nakonfigurujete plánovanou aktualizaci.If you want to update the file in Power BI, you must publish the updated version again, or you can refresh the data by configuring a scheduled refresh, on the workbook, or on the dataset in Power BI.

Publikování ze samostatné instalace ExceluPublishing from a standalone Excel installation

Při publikování ze samostatné instalace Excelu musíte sešit nejdříve uložit na OneDrive pro firmy.When publishing from a standalone Excel installation, the workbook must be saved to OneDrive for Business. Vyberte Uložit do cloudu a zvolte umístění na OneDrivu pro firmy.Select Save to Cloud and choose a location in OneDrive for Business.

Uložení na OneDrive pro firmy

Když je sešit uložený na OneDrivu pro firmy a vyberete Publikovat, máte dvě možnosti, jak sešit dostat do Power BI – Nahrát nebo Exportovat:Once your workbook is saved to OneDrive for Business, when you select Publish, you have two options to get your workbook into Power BI, Upload or Export:

Možnosti pro Power BI

Nahrajte si sešit do Power BIUpload your workbook to Power BI

Když zvolíte možnost Nahrát, sešit se zobrazí v Power BI stejným způsobem, jako by tomu bylo v Excelu Online.When you choose the Upload option, your workbook will appear in Power BI just like it would in Excel Online. Na rozdíl od Excelu Online ale budete mít k dispozici několik možností, které vám umožní připínat prvky z vašich listů na řídicí panely.But, unlike Excel Online, you’ll have some options that enable you to help you pin elements from your worksheets to dashboards.

V Power BI sešit nejde upravovat.You can’t edit your workbook in Power BI. Pokud potřebujete udělat nějaké změny dat, můžete vybrat Upravit a pak se rozhodnout pro úpravy sešitu v Excelu Online nebo pro jeho otevření v Excelu na vašem počítači.If you need to make some changes to the data, you can select Edit then choose to edit your workbook in Excel Online or open it in Excel on your computer. Provedené změny se uloží do sešitu na OneDrivu pro firmy.Any changes you make are saved to the workbook on OneDrive for Business.

Když zvolíte možnost Nahrát, v Power BI se nevytvoří žádná datová sada.When you Upload, no dataset is created in Power BI. Sešit se zobrazí v navigačním podokně pracovního prostoru v sestavách.Your workbook will appear in Reports, in your workspace nav pane. Sešity nahrané do Power BI mají zvláštní ikonu Excelu, která je identifikuje jako nahrané excelové sešity.Workbooks uploaded to Power BI have a special Excel icon, identifying them as Excel workbooks that have been uploaded.

Možnost Nahrát zvolte, pokud máte data jenom na listech nebo máte kontingenční tabulky a grafy, které chcete zobrazit v Power BI.Choose the Upload option if you only have data in worksheets, or you have PivotTables and Charts you want to see in Power BI.

Použití možnosti Nahrát ve funkci Publikovat do Power BI v Excelu je podobné, jako když v Power BI v prohlížeči použijete možnost Získat data > Soubor > OneDrive pro firmy > Připojení, správa a zobrazení Excelu v Power BI.Using Upload from Publish to Power BI in Excel is a similar experience to Get Data > File > OneDrive for Business > Connect, Manage and View Excel in Power BI from Power BI in your browser.

Exportovat data sešitu do Power BIExport workbook data to Power BI

Když zvolíte možnost Exportovat, všechna podporovaná data v tabulkách a datový model se exportují do nové datové sady v Power BI.When you choose the Export option, any supported data in tables and/or a data model are exported into a new dataset in Power BI. Jakékoli listy Power View v sešitu se vytvoří v Power BI znovu jako sestavy.Any Power View sheets in the workbook are re-created in Power BI as reports.

Můžete pokračovat v úpravách sešitu.You can continue editing your workbook. Uložené změny se synchronizují s datovou sadou v Power BI obvykle během hodiny.When your changes are saved, they are synchronized with the dataset in Power BI, usually within about an hour. Pokud potřebujete provést aktualizaci dříve, můžete v Excelu znovu vybrat Publikovat a vaše změny se vyexportují okamžitě.If you need more immediate updates, you can select Publish again from Excel, and your changes are exported immediately. Aktualizují se i jakékoli vizualizace v sestavách a řídicích panelech.Any visualizations in reports and dashboards are updated, too.

Možnost Publikovat zvolte, pokud jste k načtení dat do datového modelu použili funkce Načíst a transformovat data nebo Power Pivot nebo pokud sešit obsahuje listy Power View s vizualizacemi, které chcete zobrazit v Power BI.Choose the Publish option if you’ve used the Get & Transform data or Power Pivot features to load data into a data model, or if your workbook has Power View sheets with visualizations that you want to see in Power BI.

Použití možnosti Exportovat je podobné, jako když v Power BI v prohlížeči použijete možnost Získat data > Soubor > OneDrive pro firmy > Export excelových dat do Power BI.Using Export is very similar to using Get Data > File > OneDrive for Business > Export Excel data into Power BI from Power BI in your browser.

PublikováníPublishing

Když zvolíte kteroukoli z možností, Excel se přihlásí k Power BI pomocí vašeho aktuálního účtu a publikuje sešit do vašeho pracovního prostoru Power BI.When you choose either option, Excel signs in to Power BI with your current account, then publishes your workbook to your Power BI workspace. Na stavovém řádku v Excelu můžete sledovat průběh publikování.You can monitor the status bar in Excel to see how the publish process is progressing.

Stavový řádek pro publikování do Power BI

Po dokončení můžete z Excelu přejít přímo do Power BI.When complete, you can go to Power BI directly from Excel.

Přejít na Power BI

Další krokyNext steps

Data Excelu v Power BIExcel data in Power BI
Máte další otázky?More questions? Zkuste se zeptat v komunitě Power BI.Try the Power BI Community