Běžné úlohy s dotazy v Power BI DesktopuCommon query tasks in Power BI Desktop

V okně Editor dotazů v Power BI Desktopu se nejčastěji využívá několik úloh.When working in the Query Editor window of Power BI Desktop, there are a handful of commonly used tasks. Tento dokument tyto běžné úlohy představuje a nabízí odkazy na další informace.This document demonstrates those common tasks, and provides links for additional information.

Běžné úlohy s dotazy, které v tomto článku vysvětlujeme:The common query tasks demonstrated here are the following:

  • Připojení k datůmConnect to data
  • Tvarování a kombinování datShape and combine data
  • Seskupení řádkůGroup rows
  • Kontingenční sloupcePivot columns
  • Vytváření vlastních sloupcůCreate custom columns
  • Vzorce dotazůQuery formulas

U těchto úloh využijeme několik datových připojení.We’ll use a few data connections to complete these tasks. Pokud si chcete úlohy projít sami, můžete si tato data stáhnout nebo se k nim připojit.The data is available for you to download or connect to, in case you want to step through these tasks yourself.

První datové připojení představuje excelový sešit, který si můžete stáhnout z tohoto odkazu.The first data connection is an Excel workbook, which you can download from this link. Druhé je webový prostředek (který se používá také v dalším obsahu nápovědy k Power BI Desktopu) přístupný na této adrese:The other is a Web resource (which is also used in other Power BI Desktop help content) which can be accessed from here:

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

S představením běžných úloh s dotazy začneme postupem, jak se k těmto zdrojům dat připojit.The steps necessary to connect to both of those data sources is where the common Query tasks begin.

Připojení k datůmConnect to data

Pokud se chcete připojit k datům v Power BI Desktopu, vyberte na kartě Domů na pásu karet Načíst data.To connect to data in Power BI Desktop, select the Get Data button from the Home tab on the ribbon. Power BI Desktop obsahuje nabídku s nejběžnějšími zdroji dat.Power BI Desktop presents a menu with the most common data sources. Úplný seznam zdrojů dat, k nimž se z Power BI Desktopu dá připojit, zobrazíte tlačítkem Další… v dolní části nabídky.For a complete list of data sources to which Power BI Desktop can connect, select the More... button at the bottom of the menu. Další informace najdete v tématu Zdroje dat v Power BI Desktopu.For more information, see Data Sources in Power BI Desktop.

Začněte tak, že vyberete Excel, přejdete k požadovanému sešitu a vyberete ho.To start with, select Excel and navigate to the workbook, then select it. Funkce dotazu sešit zkontroluje a nalezená data pak zobrazí v okně Navigátor.Query inspects the workbook, then presents the data it found in the Navigator window.

Před načtením do Power BI Desktop můžete data upravit, případně tvarovat.You can select Edit to adjust, or shape, the data before loading it into Power BI Desktop. Úprava dotazu je zvlášť užitečná, pokud pracujete s velkými datovými sadami, které chcete před načtením zredukovat.Editing a query before loading is especially useful when working with large data sets that you intend to pare down before loading. To se nám hodí, takže vybereme Upravit.We want to do that, so we select Edit.

Připojení k jiným typům dat je stejně jednoduché.Connecting to different types of data is just as easy. Chceme se připojit také k webovému prostředku.We also want to connect to a Web resource. Vyberte Načíst data > Více... a pak vyberte Jiné > Web.Select Get Data > More... and then select Other > Web.

Zobrazí se okno Z webu, kam můžete zadat URL požadované webové stránky.The From Web window appears, where you can type in the URL of the Web page.

Stiskněte OK a Power BI Desktop podobně jako předtím zkontroluje sešit a zobrazí nalezená data v okně Navigátor.Select OK, and like before, Power BI Desktop inspects the workbook and presents the data it finds in the Navigator window.

Další datová připojení fungují obdobně.Other data connections are similar. Pokud se pro připojení k datům vyžaduje ověření, v Power BI Desktopu se zobrazí výzva k zadání příslušných údajů.If authentication is required to make a data connection, Power BI Desktop prompts you for the appropriate credentials.

Ukázku, jak se připojit k datům v Power BI Desktopu krok za krokem, najdete v tématu Připojení k datům v Power BI Desktopu.For a step-by-step demonstration of connecting to data in Power BI Desktop, see Connect to Data in Power BI Desktop.

Tvarování a kombinování datShape and combine data

Pomocí Editoru dotazů můžete data snadno tvarovat a kombinovat.You can easily shape and combine data with Query Editor. Tato část obsahuje několik příkladů, jak se data dají tvarovat.This section includes a few examples of how you can shape data. Ucelenější ukázku tvarování a kombinování dat najdete v tématu Tvarování a kombinování dat v Power BI Desktopu .For a more complete demonstration of shaping and combining data, see Shape and Combine Data with Power BI Desktop.

V předchozí části jsme se připojili k dvěma sadám dat – k excelovému sešitu a k webovému prostředku.In the previous section we connected to two sets of data – an Excel workbook, and a Web resource. Po načtení do Editoru dotazů se zobrazí následující okno, kde je vybrán dotaz z webové stránky (v podokně Dotazy v levé části okna Editoru dotazů jsou uvedené dostupné dotazy).Once loaded in Query Editor we see the following, with the query from the Web page selected (taken from the available queries listed in the Queries pane, on the left side of the Query Editor window).

Při tvarování dat transformujete zdroj dat do podoby a formátu podle svých potřeb.When you shape data, you transform a data source into the form and format that meets your needs. V našem příkladu nebudeme potřebovat první sloupec s názvem Záhlaví, takže ho odebereme.In this case, we don’t need that first column, titled Header, so we’ll remove it.

Mnoho příkazů v Editoru dotazů najdete na pásu karet nebo po kliknutí pravým tlačítkem v kontextové nabídce.In Query Editor, many commands can be found in the ribbon, and in a context-sensitive right-click menu. Když například kliknete pravým tlačítkem myši na sloupec Záhlaví, zobrazí se nabídka umožňující ho odebrat.For example, when you right-click on the Header column, the menu that appears lets you remove the column. Mohli byste také sloupec vybrat a potom na pásu karet vybrat tlačítko Odebrat sloupce.You could also select the column and then select the Remove Columns button from the ribbon.

Existuje mnoho způsobů, jak data v dotazu tvarovat: mohli byste odebrat libovolný počet řádků shora nebo zdola, přidat další sloupce nebo rozdělit ty stávající, nahradit hodnoty nebo provést další úlohy tvarování tak, abyste z Editoru dotazů získali požadovaná data.There are many other ways you could shape the data in this query; you could remove any number of rows from the top, or from the bottom; you could add columns, split columns, replace values, and perform other shaping tasks to direct Query Editor to get the data how you want it.

Seskupení řádkůGroup rows

V Editoru dotazů můžete seskupit hodnoty z více řádků do jediné hodnoty.In Query Editor, you can group the values in multiple rows into a single value. To se může hodit, když potřebujete sečíst počet nabízených produktů, celkový prodej nebo počet studentů.This can be useful when summarizing the number of products offered, the total sales, or the count of students.

V našem příkladu seskupíme řádků v sadě dat o zápisech do vzdělávacích institucí.In this example, we group rows in an education enrollment data set. Data pocházejí ze sešitu v Excelu a byla v Editoru dotazů vytvarována tak, aby se načetly jen sloupce, které potřebujeme. Tabulka pak byla přejmenována a bylo provedeno několik dalších transformací.The data is from an Excel workbook, and has been shaped in Query Editor to get just the columns we need, rename the table, and perform a few other transforms.

Pojďme zjistit, kolik úřadů (to zahrnuje školní okrsky a další školské úřady, jako jsou oblastní okrsky služeb atd.) se nachází v jednotlivých státech.Let’s find out how many Agencies (this includes school districts, and other education agencies such as regional service districts, and so on) each state has. Vybereme sloupec Zkratka státu a poté tlačítko Seskupit podle na kartě Transformace nebo na kartě Domů (tlačítko Seskupit podle je dostupné na obou kartách).We select the State Abbr column then select the Group By button in the Transform tab or the Home tab of the ribbon (Group By is available in both tabs).

Zobrazí se okno Seskupit podle…The Group By… .window appears. Když Editor dotazů řádky seskupí, vytvoří nový sloupec, kam umístí výsledky operace Seskupit podle.When Query Editor groups rows, it creates a new column into which it places the Group By results. Operaci Seskupit podle můžete upravit následujícími způsoby:You can adjust the Group By operation in the following ways:

  1. Seskupit podle – to je sloupec, který se má seskupit. Editor dotazů zvolí vybraný sloupec, v tomto okně ale můžete výběr změnit na kterýkoli sloupec z tabulky.Group by – this is the column to be grouped; Query Editor chooses the selected column, but you can change it in this window to be any column in the table.
  2. Název nového sloupce – Editor dotazů navrhne název pro nový sloupec podle operace, která se uplatňuje na seskupený sloupec, můžete ale zadat jakýkoli vlastní název.New column name – Query Editor suggests a name for the new column, based on the operation it applies to the column being grouped, but you can name the new column anything you want.
  3. Operace – tady zadáte operaci, která se v Editoru dotazů použije.Operation – here you specify the operation that Query Editor applies.
  4. Přidat seskupení a Přidat agregaci – tyto možnosti se zobrazí po výběru možnosti Upřesnit.Add grouping and Add aggregation – these options appear after selecting the Advanced option. Přímo v okně Seskupit podle a v rámci jediné operace můžete provádět operace seskupení (akce Seskupit podle) u více sloupců, případně provést více agregací.You can perform grouping operations (Group By actions) on multiple columns, and perform multiple aggregations, all within the Group By window, and all in one operation. Editor dotazů vytvoří nový sloupec (na základě vašeho výběru v tomto okně), který zajistí operaci u více sloupců.Query Editor creates a new column (based on your selections in this window) that operates on multiple columns.

Vyberte tlačítko Přidat seskupení nebo Přidat agregaci a přidejte do operace Seskupit podle další seskupení nebo agregace.Select the Add grouping or Add aggregation button to add more groupings or aggregations to a Group By operation. Seskupení nebo agregaci můžete odebrat výběrem ikony ... a možnosti Odstranit. Neváhejte si to vyzkoušet a sami zjistit, jak to funguje.You can remove a grouping or aggregation by selecting the ... icon and selecting Delete, so go ahead and try it and see what it looks like.

Když stiskneme OK, funkce dotazu provede operaci Seskupit podle a vrátí výsledky.When we select OK, Query performs the Group By operation, and returns the results. No to se podívejme – v každém ze států Ohio, Texas, Illinois a Kalifornie je teď přes tisíc úřadů.Whew, look at that – Ohio, Texas, Illinois, and California now each have over a thousand agencies!

Poslední operaci tvarování můžete v Editoru dotazů vždycky odebrat tak, že vyberete ikonu X vedle právě dokončeného kroku.And with Query Editor, you can always remove the last shaping operation by selecting the X next to the step just completed. Směle se pusťte do experimentování: pokud se vám výsledky nezamlouvají, proveďte tento krok znovu, dokud Editor dotazů nevytvaruje data přesně tak, jak potřebujete.So go ahead and experiment, redo the step if you don’t like the results, until Query Editor shapes your data just the way you want it.

Kontingenční sloupcePivot columns

V Power BI Desktopu můžete využívat kontingenční sloupce a vytvořit tabulku obsahující agregované hodnoty pro každou jedinečnou hodnotu ve sloupci.With Power BI Desktop, you can pivot columns, and create a table that contains aggregated values for each unique value in a column. Pokud například potřebujete vědět, kolik různých produktů máte v jednotlivých produktových kategoriích, můžete rychle vytvořit tabulku, z které přesně tohle zjistíte.For example, if you need to know how many different products you have in each product category, you can quickly create a table the does precisely that.

Podívejme se na příklad.Let’s look at an example. Následující tabulka Produkty byla vytvarována tak, aby zobrazovala jenom jedinečné produkty (podle názvu) a kategorii, kam každý z nich spadá.The following Products table has been shaped to only show each unique product (by name), and which category each product falls under. Pokud chcete vytvořit novou tabulku zachycující počet produktů v jednotlivých kategoriích (na základě sloupce Název_kategorie), vyberte tento sloupec a na kartě Transformace na pásu karet vyberte Kontingenční sloupec.To create a new table that shows a count of products for each category (based on the CategoryName column), select the column, then select Pivot Column from the Transform tab on the ribbon.

Zobrazí se okno Kontingenční sloupec, kde zjistíte, které hodnoty ve sloupci se použijí k vytvoření nových sloupců (1). Po rozbalení rozšířených možností (2) navíc můžete vybrat funkci, která se použije na agregované hodnoty (3).The Pivot Column window appears, letting you know which column’s values will be used to create new columns (1), and when you expand Advanced options (2), you can select the function that will be applied to the aggregated values (3).

Jakmile vyberete OK, funkce dotazu zobrazí tabulku podle pokynů pro transformaci, které jste zadali v okně Kontingenční sloupec.When you select OK, Query displays the table according to the transform instructions provided in the Pivot Column window.

Vytváření vlastních sloupcůCreate custom columns

V Editoru dotazů můžete vytvářet vlastní vzorce, které provádějí operace s více sloupci v tabulce, a poté výsledky těchto vzorců vložit do nového (vlastního) sloupce.In Query Editor you can create custom formulas that operate on multiple columns in your table, then place the results of such formulas into a new (custom) column. V Editoru dotazů je vytváření vlastních sloupců snadné.Query Editor makes it easy to create custom columns.

V Editoru dotazů na kartě Přidat sloupec na pásu karet vyberte Vlastní sloupec.In Query Editor, select Custom Column from the Add Column tab on the ribbon.

Zobrazí se následující okno.The following window appears. V následujícím příkladu vytvoříme vlastní sloupec s názvem Procento – angličtina, kde se z celkového počtu studentů vypočítá procento těch, kteří se učí anglicky.In the following example, we create a custom column called Percent ELL that calculates the percentage of total students that are English Language Learners (ELL).

Stejně jako u kteréhokoli jiného kroku v Editoru dotazů platí, že pokud nový vlastní sloupec neposkytuje data, která chcete získat, můžete použitý krok v části Použitý postup v podokně Nastavení dotazu jednoduše odstranit tak, že vedle položky Přidané: Vlastní vyberete X.Like any other applied step in Query Editor, if the new custom column doesn’t provide the data you’re looking for, you can simply delete the step from the Applied Steps section of the Query Settings pane by selecting the X next to the Added Custom step.

Vzorce dotazůQuery formulas

Postup vygenerovaný Editorem dotazů můžete upravit nebo můžete vytvořit vlastní vzorce, které vám nad připojením k datům a jejich tvarováním poskytnou přesnou kontrolu.You can edit the steps that Query Editor generates, and you can create custom formulas to get precise control over connecting to and shaping your data. Vždycky, když Editor dotazů provede s daty nějakou akci, vzorec přidružený k této akci se zobrazí na řádku vzorců.Whenever Query Editor performs an action on data, the formula associated with the action is displayed in the Formula Bar. Pokud chcete řádek vzorců zobrazit, zaškrtněte na kartě Zobrazení na pásu karet políčko Řádek vzorců.To view the Formula Bar, select the checkbox next to Formula Bar in the View tab of the ribbon.

Editor dotazů uchová všechny kroky použité v jednotlivých dotazech jako text, který můžete zobrazit nebo upravit.Query Editor keeps all applied steps for each query as text that you can view or modify. Text libovolného dotazu můžete zobrazit nebo upravit v Rozšířeném editoru, který zobrazíte tlačítkem Rozšířený editor na kartě Zobrazení.You can view or modify the text for any query using the Advanced Editor, which is displayed when you select Advanced Editor from the View tab of the ribbon.

Tady vidíte Rozšířený editor s postupem přidruženým k dotazu USA_Zápisy_studentů.Here's a look at the Advanced Editor, with the query steps associated with the USA_StudentEnrollment query displayed. Kroky postupu jsou vytvořené v jazyce vzorců Power Query, který se často označuje jako M. Informace najdete v tématu Seznámení se vzorci Power Query.These steps are created in the Power Query Formula Language, often referred to as M. For information, see Learn about Power Query formulas. Pokud chcete zobrazit samotnou specifikaci jazyka, přečtěte si specifikaci jazyka vzorců Microsoft Power Query pro Excel.To view the language specification itself, see Microsoft Power Query for Excel Formula Language Specification.

Power BI Desktop nabízí rozsáhlou sadu kategorií vzorců.Power BI Desktop provides an extensive set of formula categories. Další informace a úplný popis všech vzorců Editoru dotazů najdete v článku Kategorie vzorců Power Query.For more information, and a complete reference of all Query Editor formulas, visit Power Query Formula Categories.

V Editoru dotazů se pracuje s následujícími kategoriemi vzorců:The formula categories for Query Editor are the following:

  • ČísloNumber
    • KonstantyConstants
    • InformaceInformation
    • Převod a formátováníConversion and formatting
    • FormátFormat
    • ZaokrouhleníRounding
    • OperaceOperations
    • NáhodnéRandom
    • TrigonometrickéTrigonometry
    • BajtyBytes
  • TextText
    • InformaceInformation
    • Porovnání textuText comparisons
    • ExtrakceExtraction
    • ÚpravaModification
    • ČlenstvíMembership
    • TransformaceTransformations
  • LogickéLogical
  • DatumDate
  • ČasTime
  • Datum a časDateTime
  • DateTimeZoneDateTimeZone
  • Doba trváníDuration
  • ZáznamRecord
    • InformaceInformation
    • TransformaceTransformations
    • VýběrSelection
    • SerializaceSerialization
  • SeznamList
    • InformaceInformation
    • VýběrSelection
    • TransformaceTransformation
    • ČlenstvíMembership
    • Operace se sadamiSet operations
    • ŘazeníOrdering
    • PrůměryAverages
    • SčítáníAddition
    • Číselné operaceNumerics
    • GenerátoryGenerators
  • TabulkaTable
    • Vytváření tabulekTable construction
    • PřevodyConversions
    • InformaceInformation
    • Operace na řádkuRow operations
    • Operace ve sloupciColumn operations
    • ČlenstvíMembership
  • HodnotyValues
  • Aritmetické operaceArithmetic operations
  • Typy parametrůParameter Types
  • MetadataMetadata
  • Přístup k datůmAccessing data
  • Identifikátory URIURI
  • Binární formátyBinary formats
    • Čtení číselReading numbers
  • BinárníBinary
  • SpojniceLines
  • VýrazExpression
  • FunkceFunction
  • ChybaError
  • PorovnávačComparer
  • RozdělovačSplitter
  • Kombinační funkceCombiner
  • NahrazovačReplacer
  • TypType

Další krokyNext steps

S Power BI Desktopem můžete dělat nejrůznější věci.There are all sorts of things you can do with Power BI Desktop. Další informace o jeho schopnostech najdete v těchto článcích:For more information on its capabilities, check out the following resources: