Generování aplikace z dat v ExceluGenerate an app from Excel data

Aplikaci můžete vytvořit automaticky na základě dat v souboru Excelu, který máte nahraný v účtu cloudového úložiště, jako je například OneDrive.Create an app automatically based on data in an Excel file that you upload to a cloud-storage account, such as OneDrive. Po vygenerování si můžete aplikaci přizpůsobit, aby lépe vyhovovala vašim potřebám. Jejím spuštěním pak zkontrolujte, že funguje podle vašich očekávání.After you generate the app, customize it to better suit your needs, and then run it to make sure that it works as you expect.

Vygenerovaná aplikace má ve výchozím nastavení tři obrazovky:Generated apps have three screens by default:

  • BrowseScreen1 zobrazuje podmnožinu jednoho nebo více polí, panel hledání a tlačítko řazení, pomocí kterého můžou uživatelé snadno najít určitý záznam.BrowseScreen1 shows a subset of one or more fields, a search bar, and a sort button that lets users easily find a specific record.
  • Obrazovka DetailsScreen1 zobrazuje více polí určitého záznamu nebo může zobrazovat všechna jeho pole.DetailsScreen1 shows more or all fields for a specific record.
  • Na obrazovce EditScreen1 jsou prvky uživatelského rozhraní, které umožňují uživateli vytvořit nebo aktualizovat záznam a uložit změny.EditScreen1 provides UI elements that let users create or update a record and save the changes.

Poznámka

Aplikaci můžete vygenerovat také na základě vlastního seznamu SharePointu.You can also generate an app based on a custom SharePoint list.

PožadavkyPrerequisites

Vytvoření aplikaceCreate an app

  1. V PowerApps Studiu v nabídce Soubor (u levého okraje) klikněte nebo klepněte na Nový.In PowerApps Studio, click or tap New on the File menu (near the left edge).

    Možnost Nová v nabídce Soubor

  2. Postupujte podle některého z těchto kroků:Follow any of these steps:

    • Pokud se váš účet cloudového úložiště zobrazí v části Začít vašimi daty, klikněte nebo klepněte na Rozložení pro telefon.If your cloud-storage account appears under Start with your data, click or tap Phone layout.

      Možnost vytvoření aplikace z dat

    • Pokud se váš účet cloudového úložiště nezobrazí v části Začít vašimi daty, klikněte na šipku na konci řádku dlaždic.If your cloud-storage account doesn't appear under Start with your data, click the arrow at the end of the row of tiles. Pokud se váš účet zobrazí v seznamu připojení, klikněte nebo klepněte na tuto položku.If your account appears in the list of connections, click or tap that entry.
    • Pokud se váš účet cloudového úložiště nezobrazí v části Začít vašimi daty ani v seznamu připojení, klikněte nebo klepněte na Nové připojení a potom klikněte nebo klepněte na položku pro váš účet.If your cloud-storage storage account doesn't appear under Start with your data or in the list of connections, click or tap New connection, and then click or tap the entry for your account. Klikněte nebo klepněte na Připojit a postupujte podle pokynů ke konfiguraci připojení.Click or tap Connect, and follow the prompts to configure the connection.

      Připojení k OneDrivu

  3. V části Zvolit excelový soubor vyhledejte soubor FlooringEstimates.xlsx a klikněte nebo klepněte na něj.Under Choose an Excel file, browse to FlooringEstimates.xlsx, and then click or tap it.

    Excelový soubor FlooringEstimates.xslx

  4. V části Zvolit tabulku klikněte nebo klepněte na FlooringEstimates.Under Choose a table, click or tap FlooringEstimates.

    Výběr tabulky FlooringEstimates

  5. Kliknutím nebo klepnutím na Připojit vygenerujte aplikaci.Click or tap Connect to generate the app.
  6. Pokud se zobrazí výzva ke spuštění úvodní prohlídky, klikněte nebo klepněte na Další a seznamte se s hlavními částmi rozhraní PowerApps (případně klikněte nebo klepněte na Přeskočit).If you're prompted to take an introductory tour, click or tap Next to get familiar with key areas of the PowerApps user interface (or click or tap Skip).

    Kliknutím nebo klepnutím na Další spustíte prohlídku

    Poznámka

    Prohlídku si můžete pustit i kdykoli později tak, že kliknete nebo klepnete na ikonu otazníku v pravém horním rohu a pak na možnost Vydat se na úvodní prohlídku.You can always take the tour later by clicking or tapping the question-mark icon near the upper-right corner and then clicking or tapping Take the intro tour.

Nově vytvořená aplikace má výchozí rozložení odpovídající vašim datům. Rozložení galerie si ale můžete přizpůsobit podle vlastních potřeb.When an app is created, it has a default layout based on your data, but you can customize the gallery layout to fit your needs.

  1. V levém navigačním panelu klikněte nebo klepněte na ikonu v pravém horním rohu, abyste se přepnuli do zobrazení miniatur.In the left navigation bar, click or tap an icon in the upper-right corner to switch to the thumbnail view.

    Přepnutí zobrazení

  2. Klikněte nebo klepněte na horní miniaturu a zkontrolujte, že je vybraná obrazovka procházení (BrowseScreen1).Click or tap the top thumbnail to ensure that the browse screen (BrowseScreen1) is selected.
  3. Klikněte nebo klepněte na libovolné místo v galerii, například na první obrázek.Click or tap anywhere in the gallery, such as the first image.

    Výběr obrázku

  4. V pravém podokně otevřete seznam Rozložení a potom klikněte nebo klepněte na rozložení, které zobrazuje obrázek, název a titulek.In the right-hand pane, open the Layout list, and then click or tap the layout that contains an image, a title, and a subtitle.

    Výběr rozložení

    Rozložení aplikace se změní podle provedeného nastavení.The layout of the app changes to reflect your choice.

    Obrazovka BrowseScreen1 s novým rozložením

Změna zobrazovaných datChange the data that appears

  1. V části Hledání položek klikněte nebo klepněte na Carpet, a tím vyberte ovládacího prvek Popisek.Under Search items, click or tap Carpet to select the Label control.

    V pravém podokně se zvýrazní přidružený seznam.The associated list is highlighted in the right-hand pane.

    Výběr prvního popisku

  2. V pravém podokně otevřete zvýrazněný seznam a potom klikněte nebo klepněte na Name (Název).In the right-hand pane, open the highlighted list, and then click or tap Name.

    Nastavení prvního popisku

  3. Otevřete seznam v dolní části a klikněte nebo klepněte na Category (Kategorie).Open the bottom list, and then click or tap Category.

    Nastavení kategorie

    Podívejte se, jak se obrazovka BrowseScreen1 změnila – teď se u jednotlivých záznamů zobrazuje název a kategorie.BrowseScreen1 changes to show a name and a category for each record.

    Obrazovka BrowseScreen1 s novým obsahem

    Poznámka

    Ve výchozím nastavení můžete seznam (označovaný také jako galerie) procházet kolečkem myši nebo na dotykové obrazovce potáhnutím prstem nahoru nebo dolů.By default, you can scroll through the list (called a gallery) by using a mouse wheel or by swiping up and down on a touch screen. Pokud chcete povolit použití trackpadu nebo myši bez kolečka, zvolte galerii, v seznamu vlastností klikněte nebo klepněte na Zobrazit posuvník a na řádku vzorců zadejte místo hodnoty false hodnotu true.To use either a trackpad or a mouse without a wheel, select the gallery, click or tap Show Scrollbar in the property list, and then replace false with true in the formula bar.

Změna pořadí polí ve formulářiChange the order of fields in a form

  1. Na navigačním panelu vlevo otevřete kliknutím nebo klepnutím na prostřední miniaturu obrazovku s podrobnostmi DetailsScreen1.In the left navigation bar, click or tap the middle thumbnail to open the details screen (DetailsScreen1).

    Miniatura DetailScreen1

  2. Kliknutím nebo klepnutím na obrázek zobrazte dostupné možnosti pro přizpůsobení formuláře.Click or tap the image to show options that are available to customize the form.

    Výběr karty

  3. V pravém podokně přetáhněte pole Name na začátek seznamu.In the right-hand pane, drag the Name field to the top of the list.

    Přesunutí karty

    Obrazovka se aktualizuje a projeví se na ní provedené změny.The screen updates to reflect the changes you made.

    Název v horní části obrazovky

Změna ovládacího prvkuChange a control

  1. Na navigačním panelu vlevo otevřete kliknutím nebo klepnutím na dolní miniaturu obrazovku pro úpravy EditScreen1.In the left navigation bar, click or tap the bottom thumbnail to open the edit screen (EditScreen1).

    Miniatura EditScreen1

  2. Klikněte nebo klepněte na Overview (Přehled).Click or tap Overview.

    Tímto krokem vyberete kartu Overview.This step selects the Overview card. Každá karta obsahuje text popisující její účel.Each card contains text that describes the purpose of the card. Můžete také přizpůsobit ovládací prvky na kartě.You can also customize the controls on a card. Další informace najdete v tématu Ovládací prvek Karta v PowerApps.For more information, see Card control in PowerApps.

    Výběr karty s přehledem

  3. V pravém podokně klikněte nebo klepněte u této karty na šipku dolů, potom přejděte dolů a klikněte nebo klepněte na Upravit víceřádkový text.In the right-hand pane, click or tap the down arrow for the card, scroll down, and then click or tap Edit multi-line text.

    Tento krok zobrazuje přehled jednotlivých produktů v ovládacím prvku, který je dostatečně velký, aby zobrazil text.This step shows an overview of each product in a control that's large enough to display the text.

    Změna karty

Spuštění aplikaceRun the app

Když přizpůsobujete aplikaci, otestujte si své změny tím, že aplikaci spustíte v režimu náhledu.As you customize an app, you can test your changes by running the app in Preview mode.

  1. Na navigačním panelu vlevo otevřete kliknutím nebo klepnutím na horní miniaturu obrazovku pro procházení záznamů (BrowseScreen1).In the left navigation bar, click or tap the top thumbnail to open the browse screen (BrowseScreen1).
  2. Stiskněte F5 (případně klikněte nebo klepněte na tlačítko Přehrát v pravém horním rohu) a tím otevřete režim náhledu.Open Preview mode by pressing F5 or by clicking or tapping the Play button near the upper-right corner.

    Ikona náhledu

  3. Na obrazovce BrowseScreen1 klikněte nebo klepněte na šipku vpravo od záznam, a tím zobrazte záznam na obrazovce s podrobnostmi (DetailsScreen1).On BrowseScreen1, click or tap the arrow to the right of a record to show the record in the details screen (DetailsScreen1).

    Výběr šipky na obrazovce BrowseScreen1

  4. Na obrazovce DetailsScreen1 klikněte nebo klepněte v pravém horním rohu na ikonu tužky. Záznam se zobrazí na obrazovce pro úpravy (EditScreen1).On DetailsScreen1, click or tap the pencil icon in the upper-right corner to show the record in the edit screen (EditScreen1).

    Úprava záznamu

  5. Na obrazovce EditScreen1 můžete změnit informace v jednom nebo několika polích a pak kliknutím nebo klepnutím na značku zaškrtnutí v pravém horním rohu změny uložit.On EditScreen1, change the information in one or more fields, and then click or tap the check mark in the upper-right corner to save your changes.

    Uložení změn na obrazovce EditScreen1

  6. Stisknutím klávesy Esc zavřete režim náhledu (můžete také kliknout nebo klepnout na ikonu Zavřít pod záhlavím).Close Preview mode by pressing Esc (or by clicking or tapping the close icon below the title bar).

    Zavření režimu náhledu

Známá omezeníKnown limitations

Informace o způsobech sdílení excelových dat v rámci organizace získáte v části o známých omezeních.For information about how to share Excel data within your organization, review these limitations.

Další krokyNext steps

  • Stisknutím kombinace kláves Ctrl+S uložte aplikaci, abyste ji mohli spouštět na jiných zařízeních.To save the app so that you can run it from other devices, press Ctrl-S.
  • Teď, když jste si vyzkoušeli vygenerování aplikace z dat, můžete vytvořit zcela novou aplikaci.Now that you've learned how to generate an app from data, you can create an app from scratch.
  • Nasdílejte aplikaci, aby si ji mohli spustit ostatní.Share the app so that other people can run it.