Le damos la bienvenida al IDE de Visual StudioWelcome to the Visual Studio IDE

El entorno de desarrollo integrado de Visual Studio es un panel de inicio creativo que se puede usar para editar, depurar y compilar código y, después, publicar una aplicación.The Visual Studio integrated development environment is a creative launching pad that you can use to edit, debug, and build code, and then publish an app. Un entorno de desarrollo integrado (IDE) es un programa con numerosas características que se pueden usar para muchos aspectos del desarrollo de software.An integrated development environment (IDE) is a feature-rich program that can be used for many aspects of software development. Más allá del editor estándar y el depurador que proporcionan la mayoría de IDE, Visual Studio incluye compiladores, herramientas de finalización de código, diseñadores gráficos y muchas más características para facilitar el proceso de desarrollo de software.Over and above the standard editor and debugger that most IDEs provide, Visual Studio includes compilers, code completion tools, graphical designers, and many more features to ease the software development process.

Visual Studio está disponible para Windows y Mac.Visual Studio is available for Windows and Mac. Visual Studio para Mac tiene muchas de las mismas características que Visual Studio 2017 y está optimizado para el desarrollo de aplicaciones móviles y multiplataforma.Visual Studio for Mac has many of the same features as Visual Studio 2017, and is optimized for developing cross-platform and mobile apps.

Este artículo introductorio se centra en Visual Studio 2017 para Windows.This overview article focuses on Visual Studio 2017 for Windows. Presenta las características básicas del IDE.It introduces you to the basic features of the IDE. Se explican algunas cosas que se pueden hacer con Visual Studio, incluida la creación de un proyecto simple, el uso de IntelliSense como ayuda para la codificación y la depuración de una aplicación para ver el valor de una variable durante la ejecución del programa.We'll walk through some things you can do with Visual Studio, including creating a simple project, using IntelliSense as a coding aid, and debugging an app to see the value of a variable during the program's execution. También se realizará un recorrido de las distintas ventanas de herramientas.We'll also take a tour of the various tool windows.

Instalación del IDE de Visual StudioInstall the Visual Studio IDE

Para comenzar, descargue Visual Studio 2017 e instálelo en el sistema.To get started, download Visual Studio 2017 and install it on your system.

El instalador modular le permite elegir e instalar cargas de trabajo, que son grupos de características necesarias para el lenguaje de programación o la plataforma que prefiera.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. Siga los pasos para crear un programa y no se olvide de seleccionar la carga de trabajo Desarrollo multiplataforma de .NET Core durante la instalación.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation.

Carga de trabajo de desarrollo multiplataforma de .NET Core en el Instalador de Visual Studio

Cuando se inicia Visual Studio por primera vez, se puede iniciar sesión opcionalmente con la cuenta de Microsoft o con la cuenta profesional o educativa.When you start Visual Studio for the first time, you can optionally sign in using your Microsoft account, or your work or school account.

Paseo por el IDETour of the IDE

Para ofrecerle una amplia información gráfica de Visual Studio, la siguiente imagen muestra Visual Studio con un proyecto abierto y varias ventanas de herramientas clave que probablemente use:To give you a high-level visual overview of Visual Studio, the following image shows Visual Studio with an open project and several key tool windows you'll likely use:

El IDE de Visual Studio

  • El Explorador de soluciones (parte superior derecha) permite ver, desplazarse por y administrar los archivos de código.Solution Explorer (top right) lets you view, navigate, and manage your code files. El Explorador de soluciones puede ayudar a organizar el código al agrupar los archivos en soluciones y proyectos.Solution Explorer can help organize your code by grouping the files into solutions and projects.

  • La ventana del editor (centro), donde es probable que pase la mayor parte del tiempo, muestra el contenido del archivo.The editor window (center), where you'll likely spend a majority of your time, displays file contents. Es donde puede editar código o diseñar una interfaz de usuario, como una ventana con botones y cuadros de texto.This is where you can edit code or design a user interface such as a window with buttons and text boxes.

  • La ventana Resultados (parte inferior central) es donde Visual Studio envía notificaciones, como mensajes de error y de depuración, advertencias del compilador, mensajes de estado de publicación, etc.The Output window (bottom center) is where Visual Studio sends notifications such as debugging and error messages, compiler warnings, publishing status messages, and more. Cada código fuente de mensaje tiene su propia pestaña.Each message source has its own tab.

  • Team Explorer (parte inferior derecha) permite realizar el seguimiento de los elementos de trabajo y compartir código con otros usuarios mediante tecnologías de control de versiones como Git y Control de versiones de Team Foundation (TFVC).Team Explorer (bottom right) lets you track work items and share code with others using version control technologies such as Git and Team Foundation Version Control (TFVC).

Algunas de las características populares de Visual Studio que ayudan a ser más productivos durante el desarrollo de software incluyen:Some of the popular features in Visual Studio that help you to be more productive as you develop software include:

  • RefactorizaciónRefactoring

    La refactorización incluye operaciones como el cambio de nombre inteligente de variables, la extracción de una o más líneas de código en un nuevo método, el cambio del orden de los parámetros de método, etc.Refactoring includes operations such as intelligent renaming of variables, extracting one or more lines of code into a new method, changing the order of method parameters, and more.

    Refactorización en Visual Studio

  • IntelliSenseIntelliSense

    IntelliSense es un término que define un conjunto de características que muestran información sobre el código directamente en el editor y, en algunos casos, escriben pequeños fragmentos de código automáticamente.IntelliSense is a term for a set of features that displays information about your code directly in the editor and, in some cases, write small bits of code for you. Es como tener documentación básica insertada en el editor, lo que evita tener que buscar información escrita en cualquier otro lugar.It's like having basic documentation inline in the editor, which saves you from having to look up type information elsewhere. Las características de IntelliSense varían según el lenguaje.IntelliSense features vary by language. Para más información, vea IntelliSense para C#, IntelliSense para Visual C++, IntelliSense para JavaScript e IntelliSense de Visual Basic.For more information, see C# IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSense, and Visual Basic IntelliSense. La siguiente ilustración muestra cómo IntelliSense muestra una lista de miembros de un tipo:The following illustration shows how IntelliSense displays a member list for a type:

    Lista de miembros de Visual Studio

  • Inicio rápidoQuick Launch

    Visual Studio puede parecer abrumador a veces con tantas propiedades, opciones y menús.Visual Studio can seem overwhelming at times with so many menus, options, and properties. El cuadro de búsqueda Inicio rápido supone una excelente manera de encontrar rápidamente lo que necesita en Visual Studio.The Quick Launch search box is a great way to rapidly find what you need in Visual Studio. Al empezar a escribir el nombre de lo que está buscando, Visual Studio muestra resultados que llevan exactamente a donde necesita ir.When you start typing the name of something you're looking for, Visual Studio lists results that take you exactly where you need to go. Si necesita agregar funcionalidad a Visual Studio, por ejemplo, agregar compatibilidad con otro lenguaje de programación, Inicio rápido proporciona resultados que abren el Instalador de Visual Studio para instalar un componente individual o una carga de trabajo.If you need to add functionality to Visual Studio, for example to add support for an additional programming language, Quick Launch provides results that open Visual Studio Installer to install a workload or individual component.

    Cuadro de búsqueda Inicio rápido en Visual Studio

  • Subrayados ondulados y Acciones rápidasSquiggles and Quick Actions

    Los subrayados ondulados son rayas con formas de onda debajo de las palabras que alertan de errores o posibles problemas en el código a medida que se escribe.Squiggles are wavy underlines that alert you to errors or potential problems in your code as you type. Estas pistas visuales permiten corregir problemas inmediatamente sin esperar a que el error se detecte durante la compilación o cuando se ejecute el programa.These visual clues enable you to fix problems immediately without waiting for the error to be discovered during build or when you run the program. Si mantiene el cursor sobre un subrayado ondulado, se ve información adicional sobre el error.If you hover over a squiggle, you see additional information about the error. También puede aparecer una bombilla en el margen izquierdo con acciones, conocidas como Acciones rápidas, para corregir el error.A light bulb may also appear in the left margin with actions, known as Quick Actions, to fix the error.

    Subrayados ondulados en Visual Studio

  • Jerarquía de llamadasCall Hierarchy

    En la ventana Jerarquía de llamadas se muestran los métodos que llaman a un método seleccionado.The Call Hierarchy window shows the methods that call a selected method. Puede ser información útil si está pensando en cambiar o quitar el método, o si está intentando realizar un seguimiento de un error.This can be useful information when you're thinking about changing or removing the method, or when you're trying to track down a bug.

    Ventana Jerarquía de llamadas

  • CodeLensCodeLens

    CodeLens ayuda a buscar referencias al código, cambios en él, errores vinculados, elementos de trabajo, revisiones de código y pruebas unitarias, todo sin salir del editor.CodeLens helps you find references to your code, changes to your code, linked bugs, work items, code reviews, and unit tests, all without leaving the editor.

    CodeLens

  • Ir a definiciónGo To Definition

    La característica Ir a definición lleva directamente a la ubicación donde se define una función o un tipo.The Go To Definition feature takes you directly to the location where a function or type is defined.

    Ir a definición

  • Ojear la definiciónPeek To Definition

    En la ventana Ojear la definición se muestra la definición de un tipo o método sin abrir en realidad un archivo independiente.The Peek Definition window shows the definition of a method or type without actually opening a separate file.

    Ojear la definición

Creación de un programaCreate a program

Vamos a profundizar y crear un nuevo y sencillo programa.Let's dive in and create a new, simple program.

  1. Abra Visual Studio.Open Visual Studio. En el menú, elija Archivo > Nuevo > Proyecto.On the menu, choose File > New > Project.

    Archivo > Nuevo proyecto en la barra de menús

  2. En el cuadro de diálogo Nuevo proyecto se muestran varias plantillas de proyecto.The New Project dialog box shows several project templates. Una plantilla contiene los archivos básicos y la configuración necesaria para un tipo de proyecto concreto.A template contains the basic files and settings needed for a given project type. Elija la categoría .NET Core bajo Visual C# y, después, elija la plantilla Aplicación de consola (.NET Core).Choose the .NET Core category under Visual C#, and then choose the Console App (.NET Core) template. En el cuadro de texto Nombre, escriba HelloWorld y después haga clic en el botón Aceptar.In the Name text box, type HelloWorld, and then select the OK button.

    Plantilla de aplicación de .NET Core

    Visual Studio crea el proyecto.Visual Studio creates the project. Es una aplicación "Hola mundo" sencilla que llama al método Console.WriteLine() para mostrar la cadena literal "¡Hola mundo!"It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" en la ventana de la consola (salida del programa).in the console (program output) window.

    Note

    Si no ve la categoría .NET Core, debe instalar la carga de trabajo de Desarrollo multiplaforma de .NET Core.If you don't see the .NET Core category, you need to install the .NET Core cross-platform development workload. Para ello, elija el vínculo Abrir el instalador de Visual Studio en el panel inferior izquierdo del cuadro de diálogo Nuevo proyecto.To do this, choose the Open Visual Studio Installer link on the bottom left of the New Project dialog. Una vez que se abra el Instalador de Visual Studio, desplácese hacia abajo y seleccione la carga de trabajo de desarrollo multiplataforma de .NET Core y luego Modificar.After Visual Studio Installer opens, scroll down and select the .NET Core cross-platform development workload, and then select Modify.

    En breve, debería ver algo parecido a lo siguiente:Shortly, you should see something like the following:

    IDE de Visual Studio

    En la ventana del editor se muestra el código de C# de la aplicación, que ocupa la mayor parte del espacio.The C# code for your application shows in the editor window, which takes up most of the space. Observe que el texto se colorea automáticamente para indicar diferentes partes del código, como palabras clave y tipos.Notice that the text is automatically colorized to indicate different parts of the code, such as keywords and types. Además, líneas pequeñas, verticales y discontinuas en el código indican qué llaves coinciden, y los números de línea sirven para ubicar código más adelante.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. Puede elegir el pequeño signo menos de la casilla para contraer o expandir bloques de código.You can choose the small, boxed minus signs to collapse or expand blocks of code. Esta característica de esquematización de código le permite ocultar el código que no necesita, ayudando a minimizar el desorden en la pantalla.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter. Los archivos del proyecto se muestran en el lado derecho de una ventana llamada Explorador de soluciones.The project files are listed on the right side in a window called Solution Explorer.

    IDE de Visual Studio con cuadros rojos

    Hay otros menús y ventanas de herramientas disponibles, pero por ahora vamos a continuar.There are other menus and tool windows available, but let's move on for now.

  3. Ahora, inicie la aplicación.Now, start the app. Para ello, elija Iniciar sin depurar en el menú Depurar de la barra de menús.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. También puede presionar Ctrl+F5.You can also press Ctrl+F5.

    Menú Depurar > Iniciar sin depurar

    Visual Studio compila la aplicación y se abre una ventana de consola con el mensaje ¡Hola mundo!Visual Studio builds the app, and a console window opens with the message Hello World!. ¡Ya tiene una aplicación en ejecución!You now have a running app!

    Ventana de consola

  4. Para cerrar la ventana de consola, presione cualquier tecla del teclado.To close the console window, press any key on your keyboard.

  5. Ahora vamos a agregar código adicional a la aplicación.Let's add some additional code to the app. Agregue el siguiente código de C# antes de la línea que dice Console.WriteLine("Hello World!");:Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Este código muestra What is your name? en la ventana de la consola y espera a que el usuario escriba algún texto seguido de la tecla Entrar.This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  6. Cambie la línea que indica Console.WriteLine("Hello World!"); por el código siguiente:Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  7. Vuelva a ejecutar la aplicación mediante la selección de Depurar > Iniciar sin depurar o presionando Ctrl+F5.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Visual Studio recompila la aplicación y se abre una ventana de consola que le solicita su nombre.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  8. Escriba su nombre en la ventana de consola y presione Entrar.Enter your name in the console window and press Enter.

    Entrada de la ventana de consola

  9. Presione cualquier tecla para cerrar la ventana de consola y detener la ejecución del programa.Press any key to close the console window and stop the running program.

Usar IntelliSense y la refactorizaciónUse refactoring and IntelliSense

Veamos un par de formas en las que la refactorización e IntelliSense pueden ayudar a crear código de forma más eficaz.Let's look at a couple of the ways that refactoring and IntelliSense can help you code more efficiently.

En primer lugar, vamos a cambiar el nombre de la variable name:First, let's rename the name variable:

  1. Haga doble clic en la variable name para seleccionarla.Double-click the name variable to select it.

  2. Escriba el nombre nuevo de la variable, username.Type in the new name for the variable, username.

    Observe que aparece un cuadro gris alrededor de la variable y una bombilla en el margen.Notice that a gray box appears around the variable, and a light bulb appears in the margin.

  3. Haga clic en el icono de bombilla para mostrar las Acciones rápidas disponibles.Select the light bulb icon to show the available Quick Actions. Seleccione Rename 'name' to 'username' (Cambiar "name" a "username").Select Rename 'name' to 'username'.

    Acción de cambio de nombre en Visual Studio

    Se cambia el nombre de la variable en el proyecto, que en nuestro caso es solo en dos lugares.The variable is renamed across the project, which in our case is only two places.

    Gif animado en el que se muestra la operación de refactorización de cambio de nombre en Visual Studio

  4. Ahora echemos un vistazo a IntelliSense.Now let's take a look at IntelliSense. Debajo de la línea que dice Console.WriteLine($"\nHello {username}!");, escriba DateTime now = DateTime..Below the line that says Console.WriteLine($"\nHello {username}!");, type DateTime now = DateTime..

    Los miembros de la clase DateTime se muestran en un cuadro.A box displays the members of the DateTime class. Además, la descripción del miembro seleccionado actualmente se muestra en un cuadro independiente.In addition, the description of the currently selected member displays in a separate box.

    IntelliSense enumera los miembros en Visual Studio

  5. Seleccione el miembro denominado Now, que es una propiedad de la clase, haciendo doble clic en él o presionando la tecla Tab. Complete la línea de código mediante la adición de un punto y coma ;.Select the member named Now, which is a property of the class, by double-clicking on it or pressing Tab. Complete the line of code by adding a semi-colon ;.

  6. Por debajo, escriba o copie las líneas de código siguientes:Below that, type in or copy the following lines of code:

    int dayOfYear = now.DayOfYear;
    
    Console.Write("Day of year: ");
    Console.WriteLine(dayOfYear);
    

    Tip

    Console.Write es algo diferente a Console.WriteLine ya que no añade un terminador de línea después de la impresión.Console.Write is a little different to Console.WriteLine in that it doesn't add a line terminator after it prints. Esto significa que el siguiente fragmento de texto que se envía a la salida se imprimirá en la misma línea.That means that the next piece of text that's sent to the output will print on the same line. Puede mantener el ratón sobre cada uno de estos métodos en el código para ver su descripción.You can hover over each of these methods in your code to see their description.

  7. A continuación, vamos a volver a usar la refactorización para que hacer que el código sea más conciso.Next, we'll use refactoring again to make the code a little more concise. Haga clic en la variable now en la línea DateTime now = DateTime.Now;.Click on the variable now in the line DateTime now = DateTime.Now;.

    Observe que aparece un pequeño icono de destornillador en el margen de esa línea.Notice that a little screwdriver icon appears in the margin on that line.

  8. Haga clic en el icono de destornillador para ver las sugerencias disponibles en Visual Studio.Click the screwdriver icon to see what suggestions Visual Studio has available. En este caso, se muestra la refactorización Variable temporal en línea para quitar una línea de código sin cambiar el comportamiento general:In this case, it's showing the Inline temporary variable refactoring to remove a line of code without changing the overall behavior:

    Refactorización de variable temporal en línea en Visual Studio

  9. Haga clic en Variable temporal en línea para refactorizar el código.Click Inline temporary variable to refactor the code.

  10. Vuelva a ejecutar el programa presionando Ctrl+F5.Run the program again by pressing Ctrl+F5. La salida tendrá un aspecto similar a este:The output looks something like this:

    Ventana de consola con la salida del programa

Depurar códigoDebug code

Cuando se escribe código, debe ejecutarlo y probarlo para ver si hay errores.When you write code, you need to run it and test it for bugs. El sistema de depuración de Visual Studio permite examinar el código por cada instrucción e inspeccionar las variables a medida que se avanza.Visual Studio's debugging system lets you step through code one statement at a time and inspect variables as you go. Puede establecer puntos de interrupción que detengan la ejecución del código en una línea determinada.You can set breakpoints that stop execution of the code at a particular line. Puede observar cómo cambia el valor de una variable a medida que el código se ejecuta, etc.You can observe how the value of a variable changes as the code runs, and more.

Vamos a establecer un punto de interrupción para ver el valor de la variable username mientras el programa se encuentra "en marcha".Let's set a breakpoint to see the value of the username variable while the program is "in flight".

  1. Busque la línea de código en la que se indica Console.WriteLine($"\nHello {username}!");.Find the line of code that says Console.WriteLine($"\nHello {username}!");. Para establecer un punto de interrupción en esta línea de código, es decir, para que el programa detenga la ejecución en esta línea, haga clic en el margen izquierdo del editor.To set a breakpoint on this line of code, that is, to make the program pause execution at this line, click in the far left margin of the editor. También puede hacer clic en cualquier lugar de la línea de código y, después, presionar F9.You can also click anywhere on the line of code and then press F9.

    Aparece un círculo de color rojo en el margen izquierdo y el código se resalta en color rojo.A red circle appears in the far left margin, and the code is highlighted in red.

    Punto de interrupción en una línea de código en Visual Studio

  2. Para iniciar la depuración, seleccione Depurar > Iniciar depuración o presione F5.Start debugging by selecting Debug > Start Debugging or by pressing F5.

  3. Cuando aparezca la ventana de consola y se le solicite su nombre, escríbalo y presione Entrar.When the console window appears and asks for your name, type it in and press Enter.

    Observe que el foco se devuelve al editor de código de Visual Studio y la línea de código con el punto de interrupción se resalta en color amarillo.Notice that the focus returns to the Visual Studio code editor and the line of code with the breakpoint is highlighted in yellow. Esto significa que es la siguiente línea de código que el programa va a ejecutar.This signifies that it's the next line of code that the program will execute.

  4. Mantenga el ratón sobre la variable username para ver su valor.Hover your mouse over the username variable to see its value. Como alternativa, puede hacer clic con el botón derecho en username y seleccionar Agregar inspección para agregar la variable a la ventana Inspección, donde también puede ver su valor.Alternatively, you can right-click on username and select Add Watch to add the variable to the Watch window, where you can also see its value.

    Valor de la variable durante la depuración en Visual Studio

  5. Para permitir que el programa se ejecute hasta completarse, vuelva a presionar F5.To let the program run to completion, press F5 again.

Para obtener más detalles sobre el proceso de depuración de Visual Studio, consulte Paseo por las características del depurador.To get more details about debugging in Visual Studio, see Debugger feature tour.

Personalizar Visual StudioCustomize Visual Studio

Puede personalizar la interfaz de usuario de Visual Studio, incluso cambiar el tema de color predeterminado.You can personalize the Visual Studio user interface, including change the default color theme. Para cambiar al tema Oscuro:To change to the Dark theme:

  1. En la barra de menús, seleccione Herramientas > Opciones para abrir el cuadro de diálogo Opciones.On the menu bar, choose Tools > Options to open the Options dialog.

  2. En la página de opciones Entorno > General, cambie la selección de Tema de color a Oscuro y, después, elija Aceptar.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    El tema de color para todo el IDE se cambia a Oscuro.The color theme for the entire IDE changes to Dark.

    Visual Studio con tema oscuro

Para obtener información sobre otras maneras de personalizar el IDE, vea Personalizar Visual Studio.To learn about other ways you can personalize the IDE, see Personalize Visual Studio.

Pasos siguientesNext steps

Profundice aún más en Visual Studio con alguno de estos artículos introductorios:Explore Visual Studio further by following along with one of these introductory articles:

Si está listo para profundizar más sobre codificación, siga con uno de los siguientes tutoriales específicos sobre lenguaje:If you're ready to dive into more coding, one of the following language-specific quickstarts is a good next step:

Vea tambiénSee also