Report Designer -ohjelman käyttöliittymä

Tässä artikkelissa käsitellään Report Designerissa liikkumista ja omia tarpeita vastaamien asetusten käyttämistä.

Report Designer -ohjelman valikkokomennot

Seuraavassa taulussa kuvataan talousraporttien suunnittelussa käytettävät valikkokomennot ja asetukset. Jotkin valikkokomennot ja asetukset ovat käytettävissä vain tietyissä tilanteissa. Esimerkiksi raportointiyksiköiden ylennysten ja alennusten komennot ovat käytettävissä vain, kun raportointipuun määritystä muokataan.

Tiedosto-valikko

Tiedosto-valikko on kaikkien käyttäjien käytettävissä. Valikon komennot esitellään alla.

Komento Kuvaus
Uusi Luo uusi raportin, rivin, sarakkeen, raportointipuun tai raporttiryhmän määritys tai kansio. Lisäasetuksia on käytettävissä käyttäjäroolin mukaan.
Avoin Avaa aiemmin luotu rivin, sarakkeen, raportointipuun tai raportin määritys.
Sulje Sulje nykyinen rakenneosa.
Sulje kaikki Sulje kaikki rakenneosat.
Tallenna Tallenna nykyinen rivin, sarakkeen, raportointipuun tai raportin määritys.
Tallenna nimellä Tallenna nykyinen rivin, sarakkeen, raportointipuun tai raportin määritys uudella nimellä.
Ominaisuudet Avaa Ominaisuudet-valintaikkuna, jossa voit muuttaa raportin nimen ja kuvauksen.
Luo Luo nykyinen raportti. Tämä komento on käytettävissä raportin määrityksestä.
Tarkastele raporttia Avaa luodun raportin uusin versio Dynamics 365 for Finance and Operationsissa. Tämä komento on käytettävissä raportin määrityksestä, jos luotuna on vähintään yksi raportti.
Viimeisimmät raporttien määritykset Näytä äskettäin luotujen tai muokattujen raporttien luettelo. Tämän jälkeen voit valita raportin luettelosta.
Viimeisimmät rivien määritykset Näytä äskettäin luotujen tai muokattujen rivien määritysten luettelo. Tämän jälkeen voit valita rivin määrityksen luettelosta.
Viimeisimmät sarakkeiden määritykset Näytä äskettäin luotujen tai muokattujen sarakkeiden määritysten luettelo. Tämän jälkeen voit valita sarakkeen määrityksen luettelosta.
Viimeisimmät raportointipuiden määritykset Näytä äskettäin luotujen tai muokattujen raportointipuiden määritysten luettelo. Tämän jälkeen voit valita raportointipuun määrityksen luettelosta.
Lopeta Lopeta Report Designer.

Muokkaa-valikko

Muokkaa-valikko on niiden käyttäjien käytettävissä, joilla on suunnittelijan tai järjestelmänvalvojan rooli. Tämä valikko sisältää alla esiteltävät komennot.

Komento Kuvaus
Kumoa Kumoa viimeisin toiminto.
Tee uudelleen Palauta viimeisin peruutustoiminto.
Leikkaa Poista valittu teksti ja kopioi se leikepöydälle.
Kopioi Kopioi valittu teksti leikepöydälle.
Liitä Lisää viimeisin leikattu tai kopioitu teksti leikepöydältä.
Tyhjennä Poista valitun rakenneosan solun sisältö.
Etsi Avaa Etsi ja korvaa -valintaikkuna, jossa voit hakea tekstiä näkymäruudussa.
Korvaa Avaa Etsi ja korvaa -valintaikkuna, jossa voit hakea ja korvata tekstiä näkymäruudussa.
Lisää rivejä dimensioista Avaa Lisää rivejä dimensioista -valintaikkuna, jossa voi valita rivin määritykseen sisällytettäviä dimensioarvoja. Tämä komento on käytettävissä rivin määrityksestä.
Numeroi rivit uudelleen Numeroi kaikki numeeriset rivien koodit uudelleen. Tämä komento on käytettävissä rivin määrityksestä.
Rivien linkit Avaa Rivien linkit -valintaikkuna, jossa voi määrittää rivien ja raportointipuiden määritysten tietolinkkien lähteet. Tämä komento on käytettävissä rivin määrityksestä.
Pyöristyksen oikaisu Avaa Pyöristysten oikaisut -valintaikkuna, jossa voi määrittää pyöristyksen parametrit. Tämä komento on käytettävissä rivin määrityksestä.
Hallitse dimensioyhdistelmiä Avaa Dimensioyhdistelmät-valintaikkuna, jossa voi luoda ja muokata dimensiojoukkoja. Tämä komento on käytettävissä rivin tai raportointipuun määrityksestä.
Lisää rivi Lisää tyhjä rivi rivin määritykseen tai tyhjään otsikkoriviin sarakkeen määrityksestä. Tämä komento on käytettävissä rivin tai sarakkeen määrityksestä.
Poista rivi Poista valittu rivi rivin määrityksestä tai valitusta otsikkorivistä sarakkeen määrityksessä. Tämä komento on käytettävissä rivin tai sarakkeen määrityksestä.
Lisää sarake Lisää tyhjä sarake sarakkeen määritykseen. Tämä komento on käytettävissä sarakkeen määrityksestä.
Poista sarake Poista valittu sarake sarakkeen määrityksestä. Tämä komento on käytettävissä sarakkeen määrityksestä.
Lisää raportointiyksiköitä dimensioista Avaa Lisää raportointiyksiköitä dimensioista -valintaikkuna, jossa voi valita raportointipuun määritykseen sisällytettäviä dimensioarvoja. Tämä komento on käytettävissä raportointipuun määrityksestä.
Tuo dimensioyhdistelmän hierarkia Avaa Dimensioyhdistelmän hierarkia -valintaikkuna, jossa voit tuoda dimensioyhdistelmän hierarkian taloushallinnon tiedoista. Tämä komento on käytettävissä järjestelmässä raportointipuun määrityksestä ..\financial-dimensions\dimension-based.
Lisää raportointiyksikkö Lisää tyhjä rivi raportointipuun määritykseen. Tämä komento on käytettävissä raportointipuun määrityksestä.
Poista raportointiyksikkö Poista valittu raportointiyksikön rivi raportointipuun määrityksestä. Tämä komento on käytettävissä raporttipuumäärityksestä.

Näytä-valikko

Näytä-valikko on kaikkien käyttäjien käytettävissä. Valikon komennot esitellään alla.

Komento Kuvaus
Siirtymisruutu Näytä tai piilota siirtymisruutu.
Työkalurivit Valitse näkyvissä olevat työkalurivit.
Tilarivi Näytä tai piilota Report Designer -ikkunan tilatiedot.
Aloitussivu Avaa aloitussivun.

Muotoilu-valikko

Muotoilu-valikko on niiden käyttäjien käytettävissä, joilla on suunnittelijan tai järjestelmänvalvojan rooli. Tämä valikko sisältää alla esiteltävät komennot.

Komento Kuvaus
Tyylit ja muotoilu Avaa Tyyli ja muotoilu -valintaikkuna, jossa voi luoda ja muokata rivien ja sarakkeiden määritysten tekstin tyyliä. Tämä komento on käytettävissä rivin tai sarakkeen määrityksestä.
Sarakkeen leveys Avaa Sarakkeen leveys -valintaikkuna, jossa voi määrittää valitun sarakkeen leveyden. Tämä komento on käytettävissä rivin, sarakkeen tai raportointipuun määrityksestä.
Piilota Piilota valittu sarake. Tämä komento on käytettävissä rivin, sarakkeen tai raportointipuun määrityksestä.
Tuo esiin Tuo esiin valittujen sarakkeiden välissä olevat piilotetut sarakkeet. Tämä komento on käytettävissä rivin, sarakkeen tai raportointipuun määrityksestä.

Yritys-valikko

Yritys-valikko on niiden käyttäjien käytettävissä, joilla on suunnittelijan tai järjestelmänvalvojan rooli. Tämä valikko sisältää alla esiteltävät komennot.

Komento Kuvaus
Yritykset Avaa Yritykset-valintaikkuna, jossa voi luoda ja muokata yrityksiä.
Rakenneosaryhmät Avaa Rakenneosaryhmät-valintaikkuna, jossa voi luoda, muokata, tuoda ja viedä rakenneosaryhmiä.

Siirry-valikko

Siirry-valikko on kaikkien käyttäjien käytettävissä. Valikon komennot esitellään alla. Huomautus: Näiden komentojen vaikutus ei ole näkyvä, jos siirtymisruutu ei ole näkyvissä.

Komennot Kuvaus
Raporttien määritykset Näytä raporttien määritykset siirtymisruudussa.
Rivien määritykset Näytä rivien määritykset siirtymisruudussa.
Sarakkeiden määritykset Näytä sarakkeiden määritykset siirtymisruudussa.
Raportointipuiden määritykset Näytä raportointipuiden määritykset siirtymisruudussa.
Suojaus Näyttää käyttäjien, ryhmien ja yritysten suojaustiedot siirtymisruudussa.

Työkalut-valikko

Työkalut-valikko on kaikkien käyttäjien käytettävissä, mutta joidenkin komentojen käytettävyyttä on rajoitettu. Tämä valikko sisältää alla esiteltävät komennot.

Komento Kuvaus
Suojaa Käytä valittuna olevassa rakenneosassa salasanaa. Tämä komento on suunnittelijan tai järjestelmänvalvojan roolin omaavien käyttäjien käytettävissä.
Raportin jonon tila Avaa Raportin jonon tila -valintaikkuna, jossa näkyvät kaikki uusimmat luodut raportit ja kunkin raportin tiedot.
Lähdejärjestelmän tiedot Näytä Microsoft Dynamics ERP -järjestelmän asetukset. Tämä komento on suunnittelijan tai järjestelmänvalvojan roolin omaavien käyttäjien käytettävissä.
Uloskuitatut kohteet Näytä avoinna olevat rivien, sarakkeiden, raportointipuiden ja raporttien määritykset. Tämä komento on suunnittelijan tai järjestelmänvalvojan roolin omaavien käyttäjien käytettävissä.
Päivitä välimuistiin tallennetut taloushallinnon tiedot Päivitä taloushallinnon dimensioiden sarakkeen tiedot.
Optiot Avaa Asetukset-valintaikkuna, jossa voi muokata Report Designer -ohjelman käyttäjän asetuksia.

Ikkuna-valikko

Ikkuna-valikko on kaikkien käyttäjien käytettävissä. Valikon komennot esitellään alla.

Komento Kuvaus
Järjestä vierekkäin Näytä kaikki avoimet ikkunat vierekkäin.
Järjestä allekkain Näytä kaikki avoimet ikkunat allekkain.
Limittäin Asettele kaikki avoimet ikkunat niin, että kunkin ikkunan otsikkorivi on näkyvissä.
Lukitse vaakasuunnassa Lukitse valittu rivi niin, että rivi näkyy ikkunassa myös silloin, kun ikkunaa vieritetään. Tämä komento on suunnittelijan tai järjestelmänvalvojan roolin omaavien käyttäjien käytettävissä.
Lukitse pystysuunnassa Lukitse valittu sarake niin, että sarake näkyy ikkunassa myös silloin, kun ikkunaa vieritetään. Tämä komento on suunnittelijan tai järjestelmänvalvojan roolin omaavien käyttäjien käytettävissä.
Avointen ikkunoiden luettelo Näytä avointen ikkunoiden luettelo. Valitse näkyville tuotava ikkuna.

Ohje-valikko

Ohje-valikko on kaikkien käyttäjien käytettävissä. Valikon komennot esitellään alla.

Komento kuvaus
Ohje Avaa Dynamics 365 for Finance and Operationsin ohjeen talousraportoinnin aihesivu.

Report Designer -ohjelman työkalurivin painikkeet

Seuraavassa taulukossa esitellään raporttien suunnittelussa käytettävissä olevat työkalurivin painikkeet. Jotkin työkalurivin painikkeet ovat käytettävissä vain tietyissä tilanteissa. Esimerkiksi raportointiyksiköiden ylennysten ja alennusten painikkeet ovat käytettävissä vain, kun raportointipuun määritystä muokataan.

Vakiotyökalurivi

Vakiotyökalurivi mahdollistaa tiedostojen ja muokkauskomentojen nopean käyttämisen. Tämä työkalurivi sisältää seuraavat painikkeet.

Painike Kuvaus
Uusi painike Luo uusi (tyhjä) raportin, rivin, sarakkeen tai raportointipuun määritys.
Avaa-painike Avaa aiemmin luotu rivin, sarakkeen, raportointipuun tai raportin määritys.
Tallenna-painike Tallenna nykyinen rivin, sarakkeen, raportointipuun tai raportin määritys.
Kopioi-painike Kopioi valittu teksti leikepöydälle.
Leikkaa-painike Poista valittu teksti ja kopioi se leikepöydälle.
Liitä-painike Lisää teksti leikepöydältä.
Kumoa-painike Kumoa viimeisin toiminto.
Tee uudelleen -painike Palauta viimeisin peruutustoiminto.
Etsi-painike Avaa Etsi ja korvaa -valintaikkuna, jossa voit hakea ja korvata tekstiä aktiivisesta ikkunasta.
Lisää rivi -painike Lisää tyhjä rivi rivin määritykseen tai tyhjään otsikkoriviin sarakkeen määrityksestä. Tämä painike on käytettävissä rivin tai sarakkeen määrityksestä.
Lisää sarake -painike Lisää tyhjä sarake sarakkeen määritykseen. Tämä painike on käytettävissä sarakkeen määrityksestä.
Lukitse-painike Käytä valittuna olevassa rakenneosassa salasanaa. Tämä painike on suunnittelijan tai järjestelmänvalvojan roolin omaavien käyttäjien käytettävissä.
Rivin linkki -painike Avaa Rivien linkit -valintaikkuna, jossa voi määrittää rivien ja raportointipuiden määritysten tietolinkkien lähteet. Tämä painike on käytettävissä rivin määrityksestä.
Ylennä-painike Ylennä raportointipuun määrityksen yksikkö. Kun valitset aliyksikön ja sen jälkeen Ylennä-painikkeen, aliyksikkö siirretään samalle tasolle kuin sen pääyksikkö.
Alenna-painike Alenna raportointipuun määrityksen yksikkö. Kun valitset yksikön ja sen jälkeen Alenna-painikkeen yksiköstä tulee sitä edeltävän yksikön aliyksikkö.
Laajenna-painike Laajenna kaikki raportointipuun määrityksen yksiköt valitun yksikön tasolla.
Tiivistä-painike Tiivistä raportointipuu.
Ohje-painike Avaa Ohje.

Muotoilutyökalurivi

Muotoilutyökalurivin avulla tyylikomennot on helppo ottaa käyttöön. Tämä työkalurivi sisältää seuraavat painikkeet.

Painike Kuvaus
Fonttityyli-painike Ota valittu fonttityyli käyttöön nykyisessä tekstissä.
Fontti-painike Määritä nykyinen teksti valitulla fontilla.
Fonttikoko-painike Määritä nykyinen teksti valitulla fonttikoolla (pisteinä).
Lihavoi-painike Lihavoi nykyinen teksti.
Kursivoi-painike Kursivoi nykyinen teksti.
Alleviivaa-painike Alleviivaa nykyinen teksti.
Pienennä sisennystä -painike Pienennä nykyisen tekstin sisennystä.
Suurenna sisennystä -painike Suurenna nykyisen tekstin sisennystä.
Taustaväri-painike Muuta nykyisen solun taustaväriä.
Fontin väri -painike Muuta nykyisen tekstin väriä.

Report Designer -työkalurivi

Reporter Designer -työkaluriviltä voi käyttää nopeasti Report Designerin siirtymiskomentoja. Tämä työkalurivi sisältää seuraavat painikkeet.

Painike Kuvaus
Raportin määritys -painike Näytä Ikkuna-valikossa näkyvä raportin määritys.
Rivin määritys -painike Näyttää aktiivisen raportin määritykseen liitetyn rivin määrityksen.
Sarakkeen määritys -painike Näyttää aktiivisen raportin määritykseen liitetyn sarakkeen määrityksen.
Raportointipuun määritys -painike Näyttää aktiivisen raportin määritykseen liitetyn raportointipuun määrityksen.
Report Viewer -painike Käynnistä Report Viewer ja näytä luodun raportin uusin versio. Tämä painike on käytettävissä raportin määrityksestä, jos luotuna on vähintään yksi raportti.
Luo raportti -painike Luo raportin aktiivisen raportin määrityksestä. Tämä painike on käytettävissä raportin määrityksestä.

Lisätietoja

Taloushallinnan raportointi

Raportin luominen