Enregistrer séparément les événements Showplan XML (SQL Server Profiler)

S’applique à : ouiSQL Server (toutes les versions prises en charge)

Cette rubrique explique comment enregistrer des événements Showplan XML qui sont capturés dans des traces dans des fichiers .SQLPlan différents avec le SQL Server Profiler. Vous pouvez ouvrir les fichiers d’événements Showplan XML dans SQL Server Management Studio, pour voir le plan d’exécution graphique de chaque événement.

Enregistrer séparément des événements Showplan XML

  1. Dans le menu Fichier, sélectionnez Nouvelle trace, puis connectez-vous à une instance de SQL Server.

    La boîte de dialogue Propriétés de la trace s'affiche.

    Notes

    Si vous cochez l’option Démarrer le suivi juste après avoir établi la connexion, la boîte de dialogue Propriétés de la trace ne s’affiche pas et le suivi est lancé. Pour désactiver ce paramètre, dans le menu Outils, sélectionnez Options, puis décochez la case Démarrer le suivi juste après avoir établi la connexion.

  2. Dans la zone Nom de la trace de la boîte de dialogue Propriétés de la trace , entrez le nom de la trace.

  3. Dans la liste Utiliser le modèle, sélectionnez un modèle de trace sur lequel baser le suivi. Si vous ne souhaitez pas utiliser de modèle, sélectionnez Vide.

  4. Effectuez l’une des actions suivantes :

    • Pour capturer la trace dans un fichier, cochez la case Enregistrer dans le fichier. Spécifiez une valeur dans Définir la taille de fichier maximale.

      Au besoin, activez les cases à cocher Activer la substitution de fichier et Le serveur traite les données de trace .

    • Pour capturer la trace dans une table de base de données, cochez la case Enregistrer dans la table.

      Au besoin, sélectionnez Définir le nombre de lignes maximal, puis spécifiez une valeur.

  5. Le cas échéant, activez la case à cocher Activer l'heure d'arrêt de la trace et indiquez une date et une heure d'arrêt.

  6. Sélectionnez l’onglet Sélection des événements.

  7. Dans la colonne de données Événements, développez la catégorie d’événements Performance, puis cochez la case Showplan XML. Si la catégorie d’événements Performance n’est pas visible, cochez la case Afficher tous les événements pour l’afficher.

    L’onglet Paramètres d’extraction des événements est ajouté à la boîte de dialogue Propriétés de la trace.

  8. Sous l’onglet Paramètres d’extraction des événements, sélectionnez Enregistrer les événements Showplan XML séparément.

  9. Dans la boîte de dialogue Enregistrer sous , entrez le nom du fichier dans lequel vous souhaitez stocker les événements Showplan XML .

  10. Sélectionnez Tous les lots Showplan XML dans un seul fichier pour enregistrer tous les événements Showplan XML dans un même fichier XML. Sinon, vous pouvez sélectionner l’option Chaque lot Showplan XML dans un fichier différent afin de créer un fichier XML pour chaque événement Showplan XML.

  11. Pour afficher le fichier d’événements Showplan XML dans SQL Server Management Studio, ouvrez le menu Fichier, pointez sur Ouvrir, puis sélectionnez Fichier. Parcourez le répertoire où vous avez enregistré le ou les fichiers d’événements Showplan XML pour en sélectionner un et l’ouvrir. Les fichiers d'événements Showplan XML ont l'extension .SQLPlan.

Voir aussi

Analyser des requêtes avec des résultats Showplan dans SQL Server Profiler