Remote DebuggingRemote Debugging

Vous pouvez déboguer une application Visual Studio qui a été déployée sur un autre ordinateur.You can debug a Visual Studio application that has been deployed on a different computer. Pour ce faire, utilisez le débogueur distant Visual Studio.To do so, you use the Visual Studio remote debugger.

Pour obtenir des instructions détaillées sur le débogage distant, consultez les rubriques suivantes.For in-depth instructions on remote debugging, see these topics.

ScénarioScenario LienLink
Azure App ServiceAzure App Service Débogueur de captures instantanées ou ASP.NET sur Azure de déboguer à distanceSnapshot Debugger or Remote debug ASP.NET on Azure
Machine virtuelle AzureAzure VM Déboguer à distance ASP.NET sur AzureRemote debug ASP.NET on Azure
Azure Service FabricAzure Service Fabric Déboguer une application Azure Service FabricDebug an Azure Service Fabric application
ASP.NETASP.NET ASP.NET Core de déboguer à distance ou ASP.NET de déboguer à distanceRemote debug ASP.NET Core or Remote Debug ASP.NET
C# ou Visual BasicC# or Visual Basic Débogage distant d’un projet C# ou Visual BasicRemote debug a C# or Visual Basic project
C++C++ Déboguer à distance un projet C++Remote debug a C++ project
Applications Windows universelle (UWP)Universal Windows Apps (UWP) Exécuter des applications UWP sur un ordinateur distant ou déboguer un package d’application installéRun UWP apps on a remote machine or Debug an installed app package

Si vous avez simplement à télécharger et installer le débogueur distant et que vous n’avez pas besoin des instructions supplémentaires pour votre scénario, suivez les étapes décrites dans cet article.If you just want to download and install the remote debugger and don't need any additional instructions for your scenario, follow the steps in this article.

Téléchargez et installez les outils à distanceDownload and Install the remote tools

  1. Sur l’appareil ou serveur machine que vous souhaitez déboguer (plutôt que l’ordinateur qui exécute Visual Studio), obtenir la version des outils à distance.On the device or server machine that you want to debug (rather than the machine running Visual Studio), get the correct version of the remote tools.

    VersionVersion LienLink NotesNotes
    Visual Studio 2017 (version la plus récente)Visual Studio 2017 (latest version) Outils à distanceRemote tools La dernière version des outils à distance est compatible avec toutes les versions de Visual Studio 2017.The latest version of the remote tools is compatible with all Visual Studio 2017 releases. Téléchargez toujours la version correspondant à votre système d’exploitation (x 86, x64 ou ARM64).Always download the version matching your device operating system (x86, x64, or ARM64). Sur Windows Server, consultez débloquer le téléchargement du fichier pour l’aide pour télécharger les outils à distance.On Windows Server, see Unblock the file download for help to download the remote tools.
    Visual Studio 2015Visual Studio 2015 Outils à distanceRemote tools Les outils à distance pour Visual Studio 2015 sont disponibles à partir de My.VisualStudio.com.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. Si vous y êtes invité, participez à la version gratuite Visual Studio Dev Essentials programme, ou connectez-vous avec votre ID d’abonnement Visual Studio.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. Sur Windows Server, consultez débloquer le téléchargement du fichier pour l’aide pour télécharger les outils à distance.On Windows Server, see Unblock the file download for help to download the remote tools.
    Visual Studio 2013Visual Studio 2013 Outils à distanceRemote tools Télécharger la page dans la documentation de Visual Studio 2013Download page in Visual Studio 2013 documentation
    Visual Studio 2012Visual Studio 2012 Outils à distanceRemote tools Télécharger la page dans la documentation de Visual Studio 2012Download page in Visual Studio 2012 documentation
  2. Sur la page de téléchargement, choisissez la version des outils qui correspond à votre système d’exploitation (x86, x64, ARM ou ARM64) et téléchargez les outils à distance.On the download page, choose the version of the tools that matches your operating system (x86, x64, ARM, or ARM64) and download the remote tools.

    Important

    Nous vous recommandons d’installer la version la plus récente des outils à distance pour votre version de Visual Studio.We recommend that you install the most recent version of the remote tools for your release of Visual Studio. La version la plus récente (par exemple, 15.8) est compatible avec les versions antérieures (par exemple, 15.0) ; Toutefois, les versions antérieures ne sont pas compatibles avec les versions ultérieures.The latest version (for example, 15.8) is compatible with earlier releases (for example, 15.0); however, earlier versions are not compatible with later releases. En outre, vous devez installer les outils à distance qui ont la même architecture que le système d’exploitation sur lequel vous souhaitez l’installer.In addition, you must install the remote tools that have the same architecture as the operating system on which you want to install it. En d’autres termes, si vous souhaitez déboguer une application 32 bits sur un ordinateur distant exécutant un système d’exploitation de 64 bits, vous devez installer la version 64 bits des outils à distance sur l’ordinateur distant.In other words, if you want to debug a 32-bit application on a remote computer running a 64-bit operating system, you must install the 64-bit version of the remote tools on the remote computer.

    Pour le débogage sur Windows 10 sur les appareils ARM, cliquez sur Télécharger ARM64 disponible avec la dernière version des outils à distance.For debugging on Windows 10 on ARM devices, choose the ARM64 download available with the latest version of the remote tools. Pour les appareils Windows RT, choisissez la version ARM, qui est uniquement disponible dans le téléchargement de Visual Studio 2015 RTW.For Windows RT devices, choose the ARM version, which is only available in the Visual Studio 2015 RTW download.

  3. Lorsque vous avez terminé de télécharger le fichier exécutable, accédez à la section suivante et suivez les instructions d’installation.When you have finished downloading the executable, go to the next section and follow setup instructions.

Si vous tentez de copier le débogueur distant (msvsmon.exe) sur l’ordinateur distant et l’exécuter, n’oubliez pas que le Assistant Configuration Remote Debugger (rdbgwiz.exe) est installé uniquement lorsque vous téléchargez le outils.If you try to copy the remote debugger (msvsmon.exe) to the remote computer and run it, be aware that the Remote Debugger Configuration Wizard (rdbgwiz.exe) is installed only when you download the tools. Vous devrez peut-être utiliser l’Assistant de configuration plus tard, en particulier si vous souhaitez que le débogueur distant s’exécute en tant que service.You may need to use the wizard for configuration later, especially if you want the remote debugger to run as a service. Pour plus d’informations, consultez (facultatif) configurer le débogueur distant en tant que service.For more information, see (Optional) Configure the remote debugger as a service.

SpécificationsRequirements

Supported Operating SystemsSupported Operating Systems

L’ordinateur distant doit exécuter l’un des systèmes d’exploitation suivants :The remote computer must be running one of the following operating systems:

  • Windows 10 (pas le téléphone)Windows 10 (not phone)

  • Windows 8 ou 8.1 (pas le téléphone)Windows 8 or 8.1 (not phone)

  • Windows 7 Service Pack 1Windows 7 Service Pack 1

  • Windows Server 2012 ou Windows Server 2012 R2Windows Server 2012 or Windows Server 2012 R2

  • Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1

Note

Windows Phone requiert une connexion USB pour déboguer (il ne nécessite pas les outils à distance).Windows Phone requires a USB connection to debug (it does not require the remote tools).

Configurations matérielles prises en chargeSupported Hardware Configurations

  • Processeur 1,6 GHz minimum1.6 GHz or faster processor

  • 1 Go de RAM (1,5 Go s’il s’agit d’une machine virtuelle)1 GB of RAM (1.5 GB if running on a virtual machine)

  • 1 Go d’espace disque disponible1 GB of available hard disk space

  • Disque dur 5400 tr/min5400-RPM hard drive

  • Carte vidéo DirectX 9 s’exécutant avec une résolution d’affichage de 1024 x 768 ou supérieureDirectX 9-capable video card running at 1024 x 768 or higher display resolution

Configuration réseauNetwork configuration

L’ordinateur distant et l’ordinateur Visual Studio doivent être connectés sur un réseau, un groupe de travail, un groupe résidentiel ou directement connectés à l’aide d’un câble Ethernet.The remote computer and the Visual Studio computer must be connected over a network, workgroup, or homegroup, or else connected directly through an Ethernet cable. Débogage entre deux ordinateurs connectés via un proxy n’est pas pris en charge.Debugging between two computers connected through a proxy is not supported. Débogage sur une latence élevée ou faible bande passante, telles que la numérotation Internet, ou via Internet entre les pays n’est pas recommandé et peut échouer ou être trop faibles.Debugging over a high latency or low bandwidth connection, such as dialup Internet, or over the Internet across countries is not recommended and may fail or be unacceptably slow.

(Facultatif) Pour exécuter le débogueur distant à partir d’un partage de fichiers(Optional) To run the remote debugger from a file share

Vous pouvez trouver le débogueur distant (msvsmon.exe) sur un ordinateur avec Visual Studio Community, Professional ou Enterprise déjà installé.You can find the remote debugger (msvsmon.exe) on a computer with Visual Studio Community, Professional, or Enterprise already installed. Dans certains scénarios, le plus simple à configurer le débogage à distance consiste à exécuter le débogueur distant (msvsmon.exe) à partir d’un partage de fichiers.For some scenarios, the easiest way to set up remote debugging is to run the remote debugger (msvsmon.exe) from a file share. Pour les restrictions d’utilisation, consultez la page d’aide du débogueur distant (aide > utilisation dans le débogueur distant).For usage limitations, see the remote debugger's Help page (Help > Usage in the remote debugger).

  1. Rechercher msvsmon.exe dans le répertoire correspondant à votre version de Visual Studio.Find msvsmon.exe in the directory matching your version of Visual Studio. Pour Visual Studio Enterprise 2017 :For Visual Studio Enterprise 2017:

    Programme fichiers (x86) \Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Programme fichiers (x86) \Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

  2. Partage le débogueur distant dossier sur l’ordinateur Visual Studio.Share the Remote Debugger folder on the Visual Studio computer.

  3. Sur l’ordinateur distant, exécutez msvsmon.exe à partir du dossier partagé.On the remote computer, run msvsmon.exe from the shared folder. Suivez le instructions d’installation.Follow the setup instructions.

Tip

Pour l’installation de ligne de commande et référence de ligne de commande, consultez la page d’aide msvsmon.exe en tapant msvsmon.exe /? dans la ligne de commande sur l’ordinateur avec Visual Studio est installé (ou accédez à aide > utilisationdans le débogueur distant).For command line installation and command line reference, see the Help page for msvsmon.exe by typing msvsmon.exe /? in the command line on the computer with Visual Studio installed (or go to Help > Usage in the remote debugger).

Configurer le débogueur distantSet up the remote debugger

Vous devez disposer des autorisations administratives sur l’ordinateur distant.You must have administrative permissions on the remote computer.

  1. Recherchez l’application du débogueur distant.Locate the Remote Debugger application. (Recherchez msvsmon.exe dans l’emplacement où il a été installé ou ouvrez le menu Démarrer et recherchez débogueur distant.)(Find msvsmon.exe in the location where it has been installed, or open the Start menu and search for Remote Debugger.)

    Si vous exécutez le débogueur distant sur un serveur distant, vous pouvez avec le bouton droit de l’application débogueur distant et choisissez exécuter en tant qu’administrateur.If you are running the remote debugger on a remote server, you can right-click the Remote Debugger app and choose Run as administrator. Si vous n’exécutez pas sur un serveur distant, seulement le démarrer normalement.If you are not running it on a remote server, just start it normally.

  2. Lorsque vous démarrez les outils à distance pour la première fois (ou avant que vous l’avez configuré), le Configuration du débogage distant boîte de dialogue s’affiche.When you start the remote tools for the first time (or before you have configured it), the Remote Debugging Configuration dialog box appears.

    RemoteDebuggerConfWizardPageRemoteDebuggerConfWizardPage

  3. Si l’API de Service Windows n’est pas installé (ce qui se produit uniquement sur Windows Server 2008 R2), choisissez le installer bouton.If the Windows Service API is not installed (which happens only on Windows Server 2008 R2), choose the Install button.

  4. Sélectionnez les types de réseau sur lesquels vous voulez utiliser les outils de contrôle à distance.Select the network types you want use the remote tools on. Au moins un type de réseau doit être sélectionné.At least one network type must be selected. Si les ordinateurs sont connectés à un domaine, vous devez choisir le premier élément.If the computers are connected through a domain, you must choose the first item. Si les ordinateurs sont connectés à un groupe de travail ou un groupe résidentiel, vous devez choisir le deuxième ou troisième élément, selon les besoins.If the computers are connected through a workgroup or homegroup, you need to choose the second or third item as appropriate.

  5. Choisissez configurer le débogage distant pour configurer le pare-feu et démarrer l’outil.Choose Configure remote debugging to configure the firewall and start the tool.

  6. Une fois la configuration terminée, la fenêtre du débogueur distant s’affiche.When configuration is complete, the Remote Debugger window appears.

    RemoteDebuggerWindowRemoteDebuggerWindow

    Le débogueur distant est maintenant en attente pour une connexion.The remote debugger is now waiting for a connection. Prenez note du nom du serveur et le port numéro qui s’affiche, car il doit correspondre à la configuration que vous utilisez plus tard dans Visual Studio.Make a note of the server name and port number that is displayed, because this must match the configuration you later use in Visual Studio.

    Lorsque vous avez terminé le débogage et vous devez arrêter le débogueur distant, cliquez sur fichier > sortie dans la fenêtre.When you are finished debugging and need to stop the remote debugger, click File > Exit on the window. Vous pouvez le redémarrer à partir de la Démarrer menu ou à partir de la ligne de commande :You can restart it from the Start menu or from the command line:

    <Répertoire d’installation de débogueur distant >\< x86, x64, ARM, ARM64 ou Appx > \msvsmon.exe.<Remote debugger installation directory>\<x86, x64, ARM, ARM64, or Appx>\msvsmon.exe.

Configurer le débogueur distantConfigure the remote debugger

Vous pouvez modifier certains aspects de la configuration du débogueur distant après l’avoir démarré pour la première fois.You can change some aspects of the configuration of the remote debugger after you have started it for the first time.

  • Si vous avez besoin ajouter des autorisations pour d’autres utilisateurs à se connecter au débogueur distant, choisissez Outils > autorisations.If you need to add permissions for other users to connect to the remote debugger, choose Tools > Permissions. Vous devez disposer de privilèges d’administrateur pour accorder ou refuser des autorisations.You must have administrator privileges to grant or deny permissions.

    Important

    Vous pouvez exécuter le débogueur distant sous un compte d’utilisateur différent à partir du compte d’utilisateur que vous utilisez sur l’ordinateur Visual Studio, mais vous devez ajouter le compte d’utilisateur différent pour les autorisations du débogueur distant.You can run the remote debugger under a user account that differs from the user account you are using on the Visual Studio computer, but you must add the different user account to the remote debugger's permissions.

    Vous pouvez également démarrer le débogueur distant à partir de la ligne de commande avec le / allow <nom d’utilisateur > paramètre : msvsmon /Allow < username@computer>.Alternatively, you can start the remote debugger from the command line with the /allow <username> parameter: msvsmon /allow <username@computer>.

  • Si vous avez besoin modifier le mode d’authentification ou le numéro de port, ou spécifiez une valeur de délai d’expiration pour les outils à distance : choisissez Outils > Options.If you need to change the Authentication mode or the port number, or specify a timeout value for the remote tools: choose Tools > Options.

    Pour obtenir la liste des numéros de port utilisés par défaut, consultez Remote Debugger Port Assignments.For a listing of the port numbers used by default, see Remote Debugger Port Assignments.

    Warning

    Vous pouvez choisir d’exécuter les outils de contrôle à distance en mode Aucune authentification, mais ce mode est fortement déconseillé.You can choose to run the remote tools in No Authentication mode, but this mode is strongly discouraged. Il n’existe aucune sécurité du réseau lorsque vous lancez l’exécution dans ce mode.There is no network security when you run in this mode. Sélectionnez le mode Aucune authentification uniquement si vous êtes sûr que le réseau n’est pas exposé à des failles de sécurité liées à des programmes malveillants ou du trafic dangereux.Choose the No Authentication mode only if you are sure that the network is not at risk from malicious or hostile traffic.

(Facultatif) Configurer le débogueur distant en tant que service(Optional) Configure the remote debugger as a service

Pour déboguer dans ASP.NET et d’autres environnements de serveur, vous devez exécuter le débogueur distant en tant qu’administrateur ou, si vous souhaitez qu’il est toujours en cours d’exécution, exécutez le débogueur distant en tant que service.For debugging in ASP.NET and other server environments, you must either run the remote debugger as an Administrator or, if you want it always running, run the remote debugger as a service.

Si vous souhaitez configurer le débogueur distant en tant que service, procédez comme suit.If you want to configure the remote debugger as a service, follow these steps.

  1. Recherchez l’ Assistant Configuration Remote Debugger (rdbgwiz.exe).Find the Remote Debugger Configuration Wizard (rdbgwiz.exe). (C’est une application distincte du débogueur distant). Il est disponible uniquement quand vous installez les outils de contrôle à distance.(This is a separate application from the Remote Debugger.) It is available only when you install the remote tools. Il n’est pas installé avec Visual Studio.It is not installed with Visual Studio.

  2. Démarrez l’Assistant Configuration.Start running the configuration wizard. Quand la première page s’affiche, cliquez sur Suivant.When the first page comes up, click Next.

  3. Cochez la case Exécuter le débogueur distant Visual Studio 2015 en tant que service .Check the Run the Visual Studio 2015 Remote Debugger as a service checkbox.

  4. Ajoutez le nom du compte d’utilisateur et le mot de passe.Add the name of the user account and password.

    Vous devrez peut-être ajouter le une session en tant que service utilisateur directement à ce compte (trouver stratégie de sécurité locale (secpol.msc) dans le Démarrer page ou la fenêtre (ou type secpol.msc à une invite de commandes).You may need to add the Log on as a service user right to this account (Find Local Security Policy (secpol.msc) in the Start page or window (or type secpol at a command prompt). Quand la fenêtre s’affiche, double-cliquez sur Attribution des droits utilisateur, puis recherchez Ouvrir une session en tant que service dans le volet droit.When the window appears, double-click User Rights Assignment, then find Log on as a service in the right pane. Double-cliquez dessus.Double-click it. Ajouter le compte d’utilisateur pour le propriétés fenêtre et cliquez sur OK).Add the user account to the Properties window and click OK). Cliquez sur Suivant.Click Next.

  5. Sélectionnez le type de réseau avec lesquel vous voulez que les outils de contrôle à distance communiquent.Select the type of network that you want the remote tools to communicate with. Au moins un type de réseau doit être sélectionné.At least one network type must be selected. Si les ordinateurs sont connectés à un domaine, vous devez choisir le premier élément.If the computers are connected through a domain, you should choose the first item. Si les ordinateurs sont connectés à un groupe de travail ou un groupe résidentiel, vous devez choisir le deuxième ou troisième élément.If the computers are connected through a workgroup or homegroup, you should choose the second or third items. Cliquez sur Suivant.Click Next.

  6. Si le service peut être démarré, le message suivant s’affiche : L’Assistant Configuration Visual Studio Remote Debugger est terminé.If the service can be started, you will see You have successfully completed the Visual Studio Remote Debugger Configuration Wizard. Si le service ne peut pas être démarré, le message suivant s’affiche : Échec de l’Assistant Configuration Débogueur distant Visual Studio.If the service cannot be started, you will see Failed to complete the Visual Studio Remote Debugger Configuration Wizard. La page fournit également des conseils à suivre pour faire démarrer le service.The page also gives some tips to follow to get the service to start.

  7. Cliquez sur Terminer.Click Finish.

    À ce stade, le débogueur distant s’exécute en tant que service.At this point the remote debugger is running as a service. Vous pouvez le vérifier en accédant à le panneau de configuration > Services et en recherchant débogueur distant Visual Studio 2015.You can verify this by going to Control Panel > Services and looking for Visual Studio 2015 Remote Debugger.

    Vous pouvez arrêter et démarrer le service débogueur distant à partir de le panneau de configuration > Services.You can stop and start the remote debugger service from Control Panel > Services.

Configurer le débogage avec des symboles distantsSet Up Debugging with Remote Symbols

Vous devez pouvoir déboguer votre code avec les symboles que vous générez sur l’ordinateur Visual Studio.You should be able to debug your code with the symbols you generate on the Visual Studio computer. Les performances du débogueur distant sont nettement meilleures quand vous utilisez des symboles locaux.The performance of the remote debugger is much better when you use local symbols. Si vous devez utiliser des symboles distants, vous devez indiquer au Remote Debugging Monitor de rechercher les symboles sur l’ordinateur distant.If you must use remote symbols, you need to tell the remote debugging monitor to look for symbols on the remote machine.

À partir de Visual Studio 2013 Update 2, vous pouvez utiliser le commutateur de ligne de commande msvsmon suivant pour utiliser des symboles distants pour le code managé : Msvsmon /FallbackLoadRemoteManagedPdbsStarting in Visual Studio 2013 Update 2, you can use the following msvsmon command-line switch to use remote symbols for managed code: Msvsmon /FallbackLoadRemoteManagedPdbs

Pour plus d’informations, consultez l’aide du débogage distant (appuyez sur F1 dans la fenêtre du débogueur distant, ou cliquez sur aide > utilisation).For more information, please see the remote debugging help (press F1 in the remote debugger window, or click Help > Usage). Vous trouverez plus d’informations sur modifications symboles distants .NET le chargement dans Visual Studio 2012 et 2013You can find more information at .NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013

Voir aussiSee also