Utiliser des solutions et des projetsWork with solutions and projects

Les projets regroupent tous les éléments dont vous avez besoin pour générer votre application dans Visual Studio, tels que les fichiers de code source, les bitmaps, les icônes, et les références de composant et de service.Projects hold the items needed to build your app in Visual Studio, such as source code files, bitmaps, icons, and component and service references. Quand vous créez un projet, Visual Studio crée une solution dans laquelle est placé votre projet.When you create a new project, Visual Studio creates a solution to contain the project. Vous pouvez ensuite ajouter d’autres projets nouveaux ou existants à la solution.You can then add other new or existing projects to the solution if you want. Les solutions peuvent également contenir des fichiers qui ne sont pas associés à un projet spécifique.Solutions can also contain files that aren't connected to any specific project.

Diagramme montrant la hiérarchie de la solution et du projet.

Notes

Cette rubrique s’applique à Visual Studio sur Windows.This topic applies to Visual Studio on Windows. Pour Visual Studio pour Mac, consultez Créer des projets dans Visual Studio pour Mac.For Visual Studio for Mac, see Create projects in Visual Studio for Mac.

Vous pouvez afficher vos solutions et projets dans une fenêtre Outil appelée Explorateur de solutions.You can view your solutions and projects in a tool window called Solution Explorer. La capture d’écran suivante montre un exemple de solution dans l’Explorateur de solutions (BikeSharing.Xamarin-UWP), qui contient deux projets : BikeSharing.Clients.Core et BikeSharing.Clients.Windows.The following screenshot shows an example solution in Solution Explorer (BikeSharing.Xamarin-UWP) that contains two projects: BikeSharing.Clients.Core and BikeSharing.Clients.Windows. Chaque projet contient plusieurs fichiers, dossiers et références.Each project contains multiple files, folders, and references. Le nom du projet en gras est le projet de démarrage, c’est-à-dire le projet qui démarre quand vous exécutez l’application.The project name in bold is the startup project; that is, the project that starts when you run the app. Vous pouvez spécifier le projet à utiliser comme projet de démarrage.You can specify which project is the startup project.

Capture d’écran de Explorateur de solutions avec deux projets.

Vous pouvez créer un projet vous-même en y ajoutant les fichiers nécessaires ou créer un projet à partir d’un des modèles de projet disponibles dans Visual Studio.While you can construct a project yourself by adding the necessary files to it, Visual Studio offers a selection of project templates to give you a head start. Quand vous créez un projet à partir d’un modèle, votre projet contient les éléments essentiels pour le type de projet choisi. Vous pouvez ensuite renommer les fichiers et ajouter du code nouveau ou existant et d’autres ressources selon vos besoins.Creating a new project from a template gives you a project with the essentials for that project type, and you can rename the files or add new or existing code and other resources to it as needed.

Cela étant dit, le développement d’applications dans Visual Studio peut se faire sans solutions ni projets.That being said, solutions and projects are not required to develop apps in Visual Studio. Vous pouvez simplement ouvrir du code que vous avez cloné à partir de Git ou téléchargé d’une source de votre choix.You can also just open code that you have cloned from Git or downloaded elsewhere. Pour plus d’informations, consultez Développer du code dans Visual Studio sans projets ni solutions.For more information, see Develop code in Visual Studio without projects or solutions.

Créer un projet à partir d'un modèle de projetCreate a project from a project template

Pour plus d’informations sur la façon de sélectionner un modèle pour créer un projet, consultez créer un nouveau projet dans Visual Studio.For information about how to select a template to create a new project, see Create a new project in Visual Studio. Et, pour obtenir un exemple d’un projet et d’une solution créés à partir de zéro, avec des instructions pas à pas et des exemples de code, consultez Présentation des projets et des solutions.And, for an example of a project and solution that's created from scratch, complete with step-by-step instructions and sample code, see Introduction to projects and solutions.

Créer un projet à partir de fichiers de code existantsCreate a project from existing code files

Si vous avez déjà une collection de fichiers de code source, vous pouvez facilement les ajouter à un projet.If you have a collection of code source files, you can easily add them to a project.

  1. Dans le menu, sélectionnez fichier > nouveau > projet à partir du code existant.On the menu, select File > New > Project From Existing Code.

  2. Dans l’Assistant créer un projet à partir de fichiers de code existants , sélectionnez le type de projet que vous souhaitez dans la zone de liste déroulante quel type de projet voulez-vous créer ? , puis sélectionnez le bouton suivant .In the Create Project from Existing Code Files wizard, select the project type you want in the What type of project would you like to create? drop-down list box, and then select the Next button.

  3. Dans l’Assistant, accédez à l’emplacement des fichiers, puis entrez le nom du nouveau projet dans la zone Nom.In the wizard, browse to the location of the files and then enter a name for the new project in the Name box. Lorsque vous avez terminé, sélectionnez le bouton Terminer .When you are done, select the Finish button.

Notes

Cette option est la plus appropriée pour une collection de fichiers relativement simple.This option works best for a relatively simple collection of files. Actuellement, seuls les types de projets C++, Apache Cordova, Visual Basic et C# sont pris en charge.Currently, only C++, Apache Cordova, Visual Basic, and C# project types are supported.

Ajouter des fichiers à une solutionAdd files to a solution

Si vous utilisez des fichiers qui s’appliquent à plusieurs projets, comme un fichier Lisezmoi pour la solution, ou d’autres fichiers qui sont logiquement associés à la solution globale plutôt qu’à un projet particulier, vous pouvez les ajouter directement à la solution.If you have a file that applies to multiple projects, such as a readme file for the solution, or other files that logically belong at the solution level rather than under a specific project, then you can add them to the solution itself. Pour ajouter un élément à une solution, dans le menu contextuel (clic droit) du nœud de la solution dans Explorateur de solutions, sélectionnez Ajouter un > nouvel élément ou Ajouter un > élément existant.To add an item to a solution, on the context (right-click) menu of the solution node in Solution Explorer, select Add > New Item, or Add > Existing Item.

Conseil

Un fichier solution est une structure d’organisation des projets dans Visual Studio.A solution file is a structure for organizing projects in Visual Studio. Elle contient l’état de ces informations dans deux fichiers : un fichier . sln (texte, partagé) et un fichier . suo (fichiers binaires, masqués, spécifiques à l’utilisateur).It contains the state of that information in two files: an .sln (text-based, shared) file, and an .suo (binary, hidden, user-specific solution options) file. Par conséquent, une solution n’est pas une solution qui doit être copiée et renommée ; au lieu de cela, il est préférable de créer une solution, puis d’y ajouter des éléments existants.Thus, a solution isn't something that should be copied and renamed; instead, it's best to create a new solution and then add existing items to it.

Créer un projet .NET qui cible une version spécifique du .NET FrameworkCreate a .NET project that targets a specific version of the .NET Framework

Quand vous créez un projet .NET Framework, vous pouvez spécifier une version spécifique du .NET Framework que votre projet doit utiliser.When you create a .NET Framework project, you can specify a specific version of the .NET Framework that you want the project to use. (Quand vous créez un projet .NET Core, vous ne spécifiez pas de version du framework.)(When you create a .NET Core project, you don't specify a framework version.)

Pour spécifier une version de .NET Framework, sélectionnez le menu déroulant Framework dans la boîte de dialogue nouveau projet .To specify a .NET Framework version, select the Framework drop-down menu in the New Project dialog box.

Capture d’écran de la liste déroulante Framework dans la boîte de dialogue Nouveau projet.

Notes

Vous devez avoir .NET Framework 3.5 installé sur votre système pour pouvoir accéder aux versions de .NET Framework antérieures à .NET Framework 4.You must have .NET Framework 3.5 installed on your system to access .NET Framework versions earlier than .NET Framework 4.

Pour spécifier une version de .NET Framework, sélectionnez le menu déroulant Framework sur la page créer un nouveau projet .To specify a .NET Framework version, select the Framework drop-down menu on the Create a new project page.

Capture d’écran du sélecteur d’infrastructure dans la boîte de dialogue « Configurer un nouveau projet ».

Créer des solutions videsCreate empty solutions

Vous pouvez également créer des solutions vides qui ne contiennent pas de projets.You can also create empty solutions that have no projects. Utilisez plutôt cette méthode si vous souhaitez créer vous-même entièrement votre solution et vos projets.This might be preferable in cases where you want to construct your solution and projects from scratch.

Pour créer une solution videTo create an empty solution

  1. Dans la barre de menus, sélectionnez fichier > nouveau > projet.On the menu bar, select File > New > Project.
  1. Dans le volet gauche (modèles), sélectionnez autres types de projets > solutions Visual Studio dans la liste développée.In the left (Templates) pane, select Other Project Types > Visual Studio Solutions in the expanded list.

  2. Dans le volet central, sélectionnez Nouvelle Solution.In the middle pane, select Blank Solution.

  3. Entrez les valeurs nom et emplacement de votre solution, puis sélectionnez OK.Enter Name and Location values for your solution, and then select OK.

  1. Dans la page Créer un projet, tapez solution dans la zone de recherche.On the Create a new project page, type solution into the search box.

  2. Sélectionnez le modèle Solution vide, puis cliquez sur Suivant.Select the Blank Solution template, and then click Next.

  3. Entrez les valeurs nom et emplacement de votre solution, puis sélectionnez créer.Enter Name and Location values for your solution, and then select Create.

Après avoir créé une solution vide, vous pouvez lui ajouter des projets ou éléments nouveaux ou existants en choisissant Ajouter un nouvel élément ou Ajouter un élément existant dans le menu Projet.After you create an empty solution, you can add new or existing projects or items to it by choosing Add New Item or Add Existing Item on the Project menu.

Comme mentionné plus haut, vous pouvez aussi ouvrir des fichiers de code sans avoir besoin d’un projet ou d’une solution.As mentioned earlier, you can also open code files without needing a project or solution. Pour en savoir plus sur le développement de code de cette façon, consultez Développer du code dans Visual Studio sans projets ni solutions.To learn about developing code in this way, see Develop code in Visual Studio without projects or solutions.

Créer un projet temporaireCreate a temporary project

(C# et Visual Basic uniquement)(C# and Visual Basic only)

Si vous créez un projet .NET sans spécifier un emplacement sur disque, le projet est considéré comme temporaire.If you create a .NET-based project without specifying a disk location, it is a temporary project. Les projets temporaires sont utiles pour faire des essais avec des projets .NET.Temporary projects enable you to experiment with .NET projects. Quand vous travaillez avec un projet temporaire, vous pouvez choisir de l’enregistrer ou de le supprimer à tout moment.At any time while you are working with a temporary project, you can choose to save it or discard it.

Pour créer un projet temporaire, accédez d’abord à Outils > options > projets et solutions > général, puis décochez la case enregistrer les nouveaux projets lors de leur création.To create a temporary project, first go to Tools > Options > Projects and Solutions > General, and uncheck the Save new projects when created checkbox. Ouvrez ensuite la boîte de dialogue Nouveau projet.Then open the New Project dialog box as usual.

Supprimer une solution, un projet ou un élémentDelete a solution, project, or item

Vous pouvez utiliser le menu contextuel en cliquant avec le bouton droit pour supprimer ou supprimer des solutions, des projets ou des éléments dans Visual Studio, mais qui les supprime uniquement de la solution ou du projet actuel.You can use the right-click context menu to either delete or remove solutions, projects, or items in Visual Studio, but that only removes them from the current solution or project.

Pour supprimer définitivement une solution ou d’autres composants de votre système, utilisez l' Explorateur de fichiers dans Windows pour supprimer le dossier qui contient les fichiers solution . sln et . suo .To permanently delete a solution or other components from your system, use File Explorer in Windows to delete the folder that contains the .sln and .suo solution files. (Avant de supprimer une solution, vous souhaiterez peut-être sauvegarder vos projets et vos fichiers si vous en avez besoin de nouveau.)(Before you delete a solution, you might want to back up your projects and files in case you need them again.)

Notes

Le fichier . suo est un fichier masqué qui n’est pas affiché sous les paramètres par défaut de l’Explorateur de fichiers.The .suo file is a hidden file that isn't displayed under the default File Explorer settings. Pour afficher les fichiers masqués, dans le menu Affichage de l’Explorateur de fichiers, cochez la case Éléments masqués.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

Pour supprimer définitivement une solutionPermanently delete a solution

Vous pouvez accéder à l’Explorateur de fichiers dans Windows à l’aide de Explorateur de solutions dans Visual Studio.You can access File Explorer in Windows by using Solution Explorer in Visual Studio. Voici comment faire.Here's how.

  1. Dans Explorateur de solutions, dans le menu contextuel (menu contextuel) de la solution que vous souhaitez supprimer, sélectionnez ouvrir le dossier dans l’Explorateur de fichiers.In Solution Explorer, on the right-click menu (context menu) of the solution you want to delete, select Open folder in File Explorer.

  2. Dans l'Explorateur de fichiers, remontez d'un niveau.In File Explorer, navigate up one level.

  3. Sélectionnez le dossier qui contient la solution, puis appuyez sur la touche Suppr .Select the folder that contains the solution, and then press the Delete key.

Voir aussiSee also