Guide pratique pour personnaliser des menus et des barres d’outils dans Visual StudioHow to: Customize menus and toolbars in Visual Studio

Vous pouvez personnaliser Visual Studio non seulement en ajoutant et en supprimant des barres d’outils et des menus dans la barre de menus, mais aussi en ajoutant et en supprimant des commandes dans une barre d’outils ou un menu.You can customize Visual Studio not only by adding and removing toolbars and menus on the menu bar, but also by adding and removing commands on any given toolbar or menu.

Warning

Après avoir personnalisé une barre d’outils ou un menu, veillez à ce que sa case demeure cochée dans la boîte de dialogue Personnaliser.After you customize a toolbar or menu, make sure that its check box remains selected in the Customize dialog box. Dans le cas contraire, vos modifications ne seront pas conservées une fois que vous aurez fermé et rouvert Visual Studio.Otherwise, your changes won't persist after you close and reopen Visual Studio.

Ajouter, supprimer ou déplacer un menu dans la barre de menusAdd, remove, or move a menu on the menu bar

  1. Dans la barre de menus, choisissez Outils > Personnaliser.On the menu bar, choose Tools > Customize.

    La boîte de dialogue Personnaliser s’affiche.The Customize dialog box opens.

  2. Sous l’onglet Commandes, laissez la case d’option Barre de menus sélectionnée, laissez l’option Barre de menus sélectionnée dans la liste située en regard de cette case d’option, puis exécutez l’une des procédures suivantes :On the Commands tab, leave the Menu bar option button selected, leave Menu Bar selected in the list next to that option, and then perform one of the following sets of steps:

    • Pour ajouter un menu, choisissez le bouton Ajouter un nouveau menu, choisissez le bouton Modifier la sélection, puis nommez le menu à ajouter.To add a menu, choose the Add New Menu button, choose the Modify Selection button, and then name the menu that you want to add.

      Boîte de dialogue Personnaliser montrant comment ajouter un menu

    • Pour supprimer un menu, choisissez-le dans la liste Contrôles, puis choisissez le bouton Supprimer.To remove a menu, choose it in the Controls list, and then choose the Delete button.

    • Pour déplacer un menu dans la barre de menus, choisissez le menu dans la liste Contrôles, puis choisissez le bouton Monter ou Descendre.To move a menu within the menu bar, choose the menu in the Controls list, and then choose the Move Up or Move Down button.

Ajouter, supprimer ou déplacer une barre d’outilsAdd, remove, or move a toolbar

  1. Dans la barre de menus, choisissez Outils > Personnaliser.On the menu bar, choose Tools > Customize.

    La boîte de dialogue Personnaliser s’affiche.The Customize dialog box opens.

  2. Sous l’onglet Barre d’outils, exécutez l’une des procédures suivantes :On the Toolbar tab, perform one of the following sets of steps:

    • Pour ajouter une barre d’outils, choisissez le bouton Nouveau, spécifiez le nom de la barre d’outils à ajouter, puis choisissez le bouton OK.To add a toolbar, choose the New button, specify a name for the toolbar that you want to add, and then choose the OK button.

      Boîte de dialogue Personnaliser montrant comment ajouter une barre d'outils

    • Pour supprimer une barre d’outils personnalisée, choisissez-la dans la liste Barres d’outils, puis choisissez le bouton Supprimer.To remove a custom toolbar, choose it in the Toolbars list, and then choose the Delete button.

      Important

      Vous pouvez supprimer les barres d'outils que vous créez mais pas les barres d'outils par défaut.You can delete toolbars that you create but not default toolbars.

    • Pour déplacer une barre d’outils vers un autre emplacement d’ancrage, choisissez-la dans la liste Barres d’outils, choisissez le bouton Modifier la sélection, puis choisissez un emplacement dans la liste qui s’affiche.To move a toolbar to a different docking location, choose it in the Toolbars list, choose the Modify Selection button, and then choose a location in the list that appears.

      Vous pouvez également faire glisser le bord gauche d'une barre d'outils pour placer cette dernière n'importe où dans la zone d'ancrage principale.You can also drag a toolbar by its left edge to move it anywhere in the main docking area.

      Note

      Pour plus d’informations sur l’amélioration de l’utilisation et de l’accessibilité des barres d’outils, consultez Guide pratique pour définir les options d’accessibilité IDE.For more information about how to improve the usability and accessibility of toolbars, see How to: Set IDE accessibility options.

Personnaliser un menu ou une barre d’outilsCustomize a menu or a toolbar

  1. Dans la barre de menus, choisissez Outils > Personnaliser.On the menu bar, choose Tools > Customize.

    La boîte de dialogue Personnaliser s’affiche.The Customize dialog box opens.

  2. Sous l’onglet Commandes, choisissez la case d’option correspondant au type d’élément que vous souhaitez personnaliser.On the Commands tab, choose the option button for the type of element that you want to customize.

  3. Dans la liste correspondant à ce type d'élément, choisissez le menu ou la barre d'outils que vous souhaitez personnaliser, puis exécutez l'une des procédures suivantes :In the list for that type of element, choose the menu or toolbar that you want to customize, and then perform one of the following sets of steps:

    • Pour ajouter une commande, choisissez le bouton Ajouter une commande.To add a command, choose the Add Command button.

      Dans la boîte de dialogue Ajouter une commande, choisissez un élément dans la liste Catégories, choisissez un élément dans la liste Commandes, puis choisissez le bouton OK.In the Add Command dialog box, choose an item in the Categories list, choose an item in the Commands list, and then choose the OK button.

      Boîte de dialogue Ajouter une commande de Visual Studio

    • Pour supprimer une commande, choisissez-la dans la liste Contrôles, puis choisissez le bouton Supprimer.To delete a command, choose it in the Controls list, and then choose the Delete button.

    • Pour réorganiser des commandes, choisissez une commande dans la liste Contrôles, puis choisissez le bouton Monter ou Descendre.To reorder commands, choose a command in the Controls list, and then choose the Move Up or Move Down button.

    • Pour regrouper des commandes en dessous d’une ligne horizontale, choisissez la première commande dans la liste Contrôles, choisissez le bouton Modifier la sélection, puis choisissez Nouveau groupe dans le menu qui s’affiche.To group commands under a horizontal line, choose the first command in the Controls list, choose the Modify Selection button, and then choose Begin a Group in the menu that appears.

Réinitialiser un menu ou une barre d’outilsReset a menu or a toolbar

  1. Dans la barre de menus, choisissez Outils > Personnaliser.On the menu bar, choose Tools > Customize.

    La boîte de dialogue Personnaliser s’affiche.The Customize dialog box opens.

  2. Sous l’onglet Commandes, choisissez la case d’option correspondant au type d’élément que vous souhaitez réinitialiser.On the Commands tab, choose the option button for the type of element that you want to reset.

  3. Dans la liste correspondant à ce type d'élément, choisissez le menu ou la barre d'outils à réinitialiser.In the list for that type of element, choose the menu or toolbar that you want to reset.

  4. Choisissez le bouton Modifier la sélection, puis choisissez Réinitialiser dans le menu qui s’affiche.Choose the Modify Selection button, and then choose Reset in the menu that appears.

    Vous pouvez également réinitialiser l’ensemble des menus et des barres d’outils en choisissant le bouton Réinitialiser tout.You can also reset all menus and toolbars by choosing the Reset All button.

Voir aussiSee also