Windows mostra un errore con schermata blu all'avvio di una macchina virtuale di Azure

Questo articolo descrive gli errori di schermata blu che si possono verificare quando si avvia una macchina virtuale (VM) Windows in Microsoft Azure. Fornisce passaggi per aiutarti a raccogliere i dati per un ticket di supporto.

Sintomi

Una macchina virtuale Windows non si avvia. Quando si controllano le schermate di avvio in Diagnostica di avvio, viene visualizzato uno dei seguenti messaggi di errore in una schermata blu:

Il tuo PC ha riscontrato un problema e deve essere riavviato. Stiamo solo raccogliendo alcune informazioni sull'errore, quindi puoi riavviare.

Il tuo PC ha riscontrato un problema e deve essere riavviato.

Causa

Potrebbero esserci molti motivi per cui si verifica un errore di arresto. Le cause più comuni sono i problemi seguenti:

  • Problema con un driver
  • File di sistema o memoria danneggiati
  • Un'applicazione accede a un settore proibito della memoria

Soluzione

Consiglio

Se disponi di un backup recente della VM, puoi provare a ripristinare la VM dal backup per risolvere il problema di avvio.

Per risolvere questo problema, è necessario raccogliere un file di dump dell'arresto anomalo prima di contattare il supporto tecnico. Per raccogliere il file dump, attenersi alla seguente procedura:

Passaggio 1: individuare il file di dump e inviare un ticket di supporto

Parte 1: collegare il disco del sistema operativo a una macchina virtuale di ripristino
  1. Eseguire uno snapshot del disco del sistema operativo della macchina virtuale interessata per creare un backup. Per altre informazioni, vedere Creare uno snapshot di un disco rigido virtuale.

  2.               Collegare il disco del sistema operativo a una macchina virtuale di ripristino.

  3. Utilizzare Remote Desktop Protocol (RDP) per connettersi da remoto alla macchina virtuale di ripristino.

  4. Se il disco del sistema operativo della macchina virtuale interessata è crittografato, disattivare la crittografia prima di andare al passaggio successivo. Per ulteriori informazioni, vedere Descrittografare il disco del sistema operativo crittografato.

Parte 2: individuare il file di dump e inviare un ticket di supporto
  1. Nella macchina virtuale di ripristino, accedere alla cartella Windows sul disco del sistema operativo collegato. Ad esempio, se la lettera di unità assegnata al disco del sistema operativo collegato è F, passare a F:\Windows.

  2. Individuare il file Memory.dmp, quindi inviare un ticket di supporto e allegare il file di dump.

Se non si riesce a trovare il file di dump, passare ai passaggi successivi per abilitare il registro dump e la console seriale, quindi riprodurre il problema.

Passaggio 2: attivare il registro dump e la console seriale

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Al fine di protezione, eseguire il backup del registro di sistema prima di modificarlo, in modo da poterlo ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire backup e ripristino del Registro di sistema, vedere Backup e ripristino del Registro di sistema in Windows.

Per attivare un registro dump e la console seriale, seguire questa procedura:

  1. Aprire una sessione del prompt dei comandi con privilegi elevati come amministratore.

  2. Eseguire i seguenti comandi BCDEdit utilizzando le opzioni /ems e /emssettings:

                  Attivare la console seriale:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Verificare che lo spazio libero sul disco del sistema operativo sia maggiore della dimensione della memoria (RAM) sulla macchina virtuale.

    Se lo spazio sul disco del sistema operativo non è sufficiente, è necessario modificare la posizione in cui viene creato il file di dump della memoria e fare riferimento a qualsiasi disco dati collegato alla macchina virtuale che disponga di spazio libero sufficiente. Per modificare la posizione, sostituisci %SystemRoot% con la lettera dell'unità del disco dati, ad esempio F:, nei seguenti comandi.

    Per abilitare il file di dump del sistema operativo, eseguire i seguenti comandi load, add e unload per implementare la configurazione suggerita utilizzando lo strumento reg:

                  Caricare l'hive del Registro di sistema dal disco del sistema operativo danneggiato:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

                  Abilitare su ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

                  Abilitare su ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

                  Scaricare il disco del sistema operativo danneggiato:

    reg unload HKLM\<broken-system>
    

Passaggio 3: riprodurre il problema

  1.               Scollegare il disco del sistema operativo e quindi ricollegarlo alla macchina virtuale interessata.

  2. Avviare la macchina virtuale per riprodurre il problema in modo da generare un file di dump.

  3. Ripetere le istruzioni nella sezione Passaggio 1: individuare il file di dump e inviare un ticket di supporto.

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