Compilazione e pulizia di progetti e soluzioni in Visual StudioBuild and clean projects and solutions in Visual Studio

Tramite le procedure descritte in questo argomento è possibile compilare, ricompilare o pulire tutti o alcuni progetti o elementi di progetto di una soluzione.By using the procedures in this topic, you can build, rebuild, or clean all or some of the projects or project items in a solution. Per un'esercitazione dettagliata, vedere Procedura dettagliata: Compilazione di un'applicazione.For a step-by-step tutorial, see Walkthrough: Building an application.

Note

Questo argomento si applica a Visual Studio in Windows.This topic applies to Visual Studio on Windows. Per Visual Studio per Mac, vedere Compilazione e pulizia di progetti e soluzioni in Visual Studio per Mac.For Visual Studio for Mac, see Build and clean projects and solutions in Visual Studio for Mac.

Note

L'interfaccia utente dell'edizione di Visual Studio in uso potrebbe essere diversa da quanto descritto in questo argomento, a seconda delle impostazioni attive.The UI in your edition of Visual Studio might differ from what this topic describes, depending on your active settings. Per modificare le impostazioni, ad esempio per implementare le impostazioni Generali o Visual C++ , scegliere Strumenti > Importa/Esporta impostazioni e quindi scegliere Reimposta tutte le impostazioni.To change your settings, for example to General or Visual C++ settings, choose Tools > Import and Export Settings, and then choose Reset all settings.

Per compilare, ricompilare o pulire un'intera soluzioneTo build, rebuild, or clean an entire solution

  1. In Esplora soluzioni scegliere una soluzione o aprire la soluzione voluta.In Solution Explorer, choose or open the solution.

  2. Nella barra dei menu, scegliere Compila e quindi scegliere uno dei comandi seguenti:On the menu bar, choose Build, and then choose one of the following commands:

    • Scegliere Compila o Compila soluzione per compilare solo i file e i componenti del progetto che sono stati modificati dalla compilazione più recente.Choose Build or Build Solution to compile only those project files and components that have changed since the most recent build.

      Note

      Il comando Compila diventa Compila soluzione se una soluzione include più progetti.The Build command becomes Build Solution when a solution includes more than one project.

    • Scegliere Ricompila soluzione per "pulire" la soluzione e quindi compilare tutti i componenti e i file dei progetti.Choose Rebuild Solution to "clean" the solution and then build all project files and components.

    • Scegliere Pulisci soluzione per eliminare eventuali file intermedi e di output.Choose Clean Solution to delete any intermediate and output files. Quando sono rimasti solo i file dei componenti e dei progetti, è possibile compilare nuove istanze di file intermedi e di output.With only the project and component files left, new instances of the intermediate and output files can then be built.

Per compilare o ricompilare un progetto singoloTo build or rebuild a single project

  1. In Esplora soluzioni scegliere un progetto o aprire il progetto voluto.In Solution Explorer, choose or open the project.

  2. Nella barra dei menu scegliere Compila e quindi scegliere Compila NomeProgetto o Ricompila NomeProgetto.On the menu bar, choose Build, and then choose either Build ProjectName or Rebuild ProjectName.

    • Scegliere Compila NomeProgetto per compilare solo i componenti del progetto che sono stati modificati dopo la build più recente.Choose Build ProjectName to build only those project components that have changed since the most recent build.

    • Scegliere Ricompila NomeProgetto per "pulire" il progetto e quindi compilare i file e tutti i componenti del progetto.Choose Rebuild ProjectName to "clean" the project and then build the project files and all project components.

Per compilare il progetto di avvio e le relative dipendenzeTo build only the startup project and its dependencies

  1. Nella barra dei menu scegliere Strumenti > Opzioni.On the menu bar, choose Tools > Options.

  2. Nella finestra di dialogo Opzioni espandere il nodo Progetti e soluzioni e quindi scegliere la pagina Compila ed esegui.In the Options dialog box, expand the Projects and Solutions node, and then choose the Build and Run page.

    Si apre la finestra di dialogo Compila ed esegui > Progetti e soluzioni > Opzioni.The Build and Run > Projects and Solutions > Options dialog box opens.

  3. Selezionare la casella di controllo Compila progetti di avvio e dipendenze solo in fase di esecuzione.Select the Only build startup projects and dependencies on Run check box.

    Se questa casella di controllo è selezionata, solo il progetto di avvio corrente e le relative dipendenze vengono compilati quando si esegue la procedura seguente:When this check box is selected, only the current startup project and its dependencies are built when you perform either of the following steps:

    • Nella barra dei menu scegliere Debug > Avvia (F5).On the menu bar, choose Debug > Start (F5).

    • Nella barra dei menu scegliere Compila > Compila soluzione (CTRL+MAIUSC+B).On the menu bar, choose Build > Build Solution (Ctrl+Shift+B).

    Quando questa casella di controllo è deselezionata e si eseguono i comandi precedenti vengono compilati tutti i progetti, le relative dipendenze e i file della soluzione.When this check box is cleared, all projects, their dependencies, and the solution files are built when you run either of the preceding commands. Per impostazione predefinita, questa casella di controllo è deselezionata.By default, this check box is cleared.

Per compilare solo il progetto di Visual C++ selezionatoTo build only the selected Visual C++ project

Scegliere un progetto di Visual C++Visual C++ e quindi nella barra dei menu scegliere Compila > Solo progetto e quindi uno dei comandi seguenti:Choose a Visual C++Visual C++ project, and then, on the menu bar, choose Build > Project Only, and one of the following commands:

  • Build Only (Compila solo) NomeProgettoBuild Only ProjectName

  • Rebuild Only (Ricompila solo) NomeProgettoRebuild Only ProjectName

  • Clean Only (Pulisci solo) NomeProgettoClean Only ProjectName

  • Link Only (Collega solo) NomeProgettoLink Only ProjectName

Questi comandi si applicano solo al progetto di Visual C++Visual C++ scelto. Non eseguono la compilazione, la ricompilazione, la pulizia o il collegamento di eventuali dipendenze del progetto o file di soluzione.These commands apply only to the Visual C++Visual C++ project that you chose, without building, rebuilding, cleaning, or linking any project dependencies or solution files. A seconda della versione di Visual StudioVisual Studio, il sottomenu Project Only (Solo progetto) potrebbe contenere altri comandi.Depending on your version of Visual StudioVisual Studio, the Project Only submenu might contain more commands.

Per compilare più elementi di un progetto C++To compile multiple C++ project items

In Esplora soluzioni scegliere più file che dispongono di azioni che possono essere compilate, aprire il menu di scelta rapida per uno di questi file e quindi scegliere Compila.In Solution Explorer, choose multiple files that have can be compiled actions, open the shortcut menu for one of those files, and then choose Compile.

Se i file hanno dipendenze, vengono compilati in ordine di dipendenza.If the files have dependencies, the files will be compiled in dependency order. L'operazione di compilazione non riesce se i file richiedono un'intestazione precompilata che non disponibile in fase di compilazione.The compile operation will fail if the files require a precompiled header that isn't available when you compile. L'operazione di compilazione usa la configurazione della soluzione attiva corrente.The compile operation uses the current active solution configuration.

Per interrompere una compilazioneTo stop a build

Effettuare uno dei passaggi seguenti:Perform either of the following steps:

  • Nella barra dei menu selezionare Compila > Annulla.On the menu bar, select Build > Cancel.

  • Premere CTRL+INTERR.Press Ctrl+Break.

Vedere ancheSee also