Note sulla versione di Visual Studio 2017 (versione 15.3) Visual Studio 2017 version 15.3 Release Notes

Community degli sviluppatori | Requisiti di sistema | Compatibilità | Codice distribuibile | Condizioni di licenza | Blog | Problemi notiDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues


Nota

Questa non è la versione più recente di Visual Studio 2017.This is not the latest version of Visual Studio 2017. Per informazioni sulla versione più recente di Visual Studio 2017, visitare la pagina delle Note sulla versione corrente.To see information on the latest version of Visual Studio 2017, please visit the current Release Notes page.

Suggerimento

È possibile cambiare la lingua della pagina nella parte inferiore della pagina.You can switch the page language at the bottom of this page. Fare clic sul pulsanteClick the e cercare la lingua oppure selezionarla dall'elenco delle lingue disponibili. icon, search for your language, or select from the list of available languages.


Questo articolo contiene informazioni relative a Visual Studio 2017 versione 15.3.This article contains information about releases for Visual Studio 2017 version 15.3.

Commenti e suggerimentiFeedback

Le opinioni dei nostri clienti sono molto importanti per noi.We’d love to hear from you! È possibile segnalare un problema tramite l'opzione Segnala un problema del programma di installazione o dell'IDE di Visual Studio.You can report a problem from the Report a Problem option in either the installer or the Visual Studio IDE itself. Alla classeThe Feedback Icon L'icona si trova nell'angolo superiore destro.icon is located in the upper right hand corner. È possibile tenere traccia dei commenti e dei suggerimenti inviati nel portale della community di sviluppatori.You can track your feedback in the Developer Community portal. Inviare eventuali suggerimenti tramite il sito UserVoice.For suggestions, let us know through the UserVoice site.

Cronologia dei rilasciRelease History

Suggerimento

Altre informazioni sulle modalità di rilascio sono disponibili nel documento Tempistica per i rilasci di Visual Studio 2017.You can learn more about how we ship our releases in the Visual Studio 2017 Release Rhythm document.

Scaricare la versione corrente di Visual Studio 2017Download the Current Release of Visual Studio 2017

Fare clic sul pulsante per scaricare la versione più recente di Visual Studio 2017.Click the button to download the latest version of Visual Studio 2017. Per istruzioni, vedere Installare Visual Studio 2017.For instructions, see Install Visual Studio 2017.

Nota: le dimensioni pacchetto di installazione variano a seconda della configurazione di Visual Studio corrente.Note: Installation package size will vary depending on your current Visual Studio configuration.


Data di rilascio: 19 settembre 2017 - Visual Studio 2017 versione 15.3.5Release Date: September 19, 2017 - Visual Studio 2017 version 15.3.5

Problemi risolti nella versione del 19 settembre 2017Issues Fixed in September 19, 2017 Release

Questi sono i problemi segnalati dai clienti risolti in questa versione:These are the customer-reported issues addressed in this version:

  • È stato introdotto il supporto per Apple Xcode 9, iOS, 11, tvOS 11 e watchOS 4Introduced support for Apple's Xcode 9, iOS 11, tvOS 11 and watchOS 4

Data di rilascio: 12 settembre 2017 - Visual Studio 2017 versione 15.3.4Release Date: September 12, 2017 - Visual Studio 2017 version 15.3.4

Problemi risolti nella versione del 12 settembre 2017Issues Fixed in September 12, 2017 Release

Questi sono i problemi segnalati dai clienti risolti in questa versione:These are the customer-reported issues addressed in this version:


Data di rilascio: 29 agosto 2017 - Visual Studio 2017 (versione 15.3.3)Release Date: August 29, 2017 - Visual Studio 2017 version 15.3.3

Problemi risolti nella versione del 29 agosto 2017Issues Fixed in August 29, 2017 Release

Questi sono i problemi segnalati dai clienti risolti in questa versione:These are the customer-reported issues addressed in this version:


Data di rilascio: 22 agosto 2017 - Visual Studio 2017 (versione 15.3.2)Release Date: August 22, 2017 - Visual Studio 2017 version 15.3.2

Problemi risolti nella versione del 22 agosto 2017Issues Fixed in August 22, 2017 Release

Questi sono i problemi segnalati dai clienti risolti in questa versione:These are the customer-reported issues addressed in this version:

Altre correzioni incluse in questa versione:Additional fixes included in this release:

  • Aggiornamento degli strumenti Service Fabric.Service Fabric tooling update.
  • L'aggiornamento di Visual Studio ha esito negativo con un errore AccessDenied durante l'installazione/disinstallazione di VSIX.Visual Studio upgrade fails with AccessDenied failure during VSIX install / uninstall.
  • Problema di generazione del progetto nella versione di Unity < = 5.5.Project generation issue on Unity version <= 5.5.
  • Acquisizione dump per file collegati.Dump capture for linked files.
  • Codegen errato invisibile all'utente a causa dell'ottimizzazione del ciclo.Silent bad codegen due to loop optimization.

Data di uscita: 18 agosto 2017 - Visual Studio 2017 15.3.1Release Date: August 18, 2017 - Visual Studio 2017 version 15.3.1

Problemi corretti in questa versioneIssues Fixed in this Release

Questi sono i problemi segnalati dai clienti risolti in questa versione:These are the customer-reported issues addressed in this version:


Data di rilascio: 14 agosto 2017 - Visual Studio 2017 versione 15.3Release Date: August 14, 2017 - Visual Studio 2017 version 15.3

Riepilogo: Novità di questa versioneSummary: What's New in this Release

  • I miglioramenti dell'accessibilità rendono Visual Studio più accessibile che mai.Accessibility Improvements make Visual Studio more accessible than ever.
  • Gli strumenti di Funzione di Azure sono inclusi nel carico di lavoro Sviluppo di Azure.Azure Function Tools are included in the Azure development workload. È possibile sviluppare applicazioni Funzione di Azure in locale e pubblicarle direttamente in Azure.You can develop Azure Function applications locally and publish directly to Azure.
  • È ora possibile compilare in Visual Studio 2017 applicazioni eseguibili in Azure Stack e cloud per enti pubblici, come Azure in Cina.You can now build applications in Visual Studio 2017 that run on Azure Stack and government clouds, like Azure in China.
  • È stato migliorato il supporto per Sviluppo .NET Core per .NET Core 2.0 e per i contenitori di Windows Nano Server.We improved .NET Core development support for .NET Core 2.0, and Windows Nano Server containers.
  • Nell'IDE di Visual Studio sono state migliorate le funzioni di accesso e identità, la pagina di avvio, Caricamento leggero soluzioni e l'interfaccia della riga di comando di configurazione.In Visual Studio IDE, we improved Sign In and Identity, the start page, Lightweight Solution Load, and setup CLI. Sono stati inoltre migliorati il refactoring, la generazione di codice e le azioni rapide.We also improved refactoring, code generation and Quick Actions.
  • L'Editor di Visual Studio ha una migliore accessibilità grazie al nuovo tema 'Blu (Massimo contrasto)' e al supporto migliorato per l'utilità per la lettura dello schermo.The Visual Studio Editor has better accessibility due to the new ‘Blue (Extra Contrast)’ theme and improved screen reader support.
  • È stata migliorata l'esperienza di debug e diagnostica.We improved the Debugger and diagnostics experience. Ciò include la possibilità di impostare l'istruzione successiva con un clic.This includes Point and Click to Set Next Statement. Sono stati aggiornati tutti i valori annidati nella finestra delle variabili e apportati miglioramenti al debug di Apri cartella.We've also refreshed all nested values in variable window, and made Open Folder debugging improvements.
  • Xamarin dispone di un nuovo editor autonomo per la modifica dei diritti delle app.Xamarin has a new standalone editor for editing app entitlements.
  • È stata aggiornata l'esperienza di Apri cartella e strumenti CMake.The Open Folder and CMake Tooling experience is updated. È ora possibile usare CMake 3.8.You can now use CMake 3.8.
  • Sono stati apportati miglioramenti al motore di IntelliSense e alle procedure guidate per il progetto e il codice per i Servizi di linguaggio C++.We made improvements to the IntelliSense engine, and to the project and the code wizards for C++ Language Services.
  • È stato aggiunto il supporto per l'inizializzazione di un ambiente di prompt dei comandi destinato al set di strumenti di Visual C++.Visual C++ Toolset supports command-prompt initialization targeting.
  • È stata aggiunta la possibilità di usare le funzionalità del linguaggio C# 7.1.We added the ability to use C# 7.1 Language features.
  • È possibile installare le versioni TypeScript indipendentemente dagli aggiornamenti di Visual Studio.You can install TypeScript versions independent of Visual Studio updates.
  • È stato aggiunto il supporto per il debug di Node 8.We added support for Node 8 debugging.
  • NuGet ha aggiunto il supporto per nuove TFM (netcoreapp2.0, netstandard2.0, Tizen), Versionamento Semantico 2.0.0, e l'integrazione in MSBuild di avvisi ed errori NuGet.NuGet has added support for new TFMs (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0, and MSBuild integration of NuGet warnings and errors.
  • Visual Studio offre ora gli strumenti di sviluppo di .NET Framework 4.7 per tutte le piattaforme supportate con runtime 4.7 incluso.Visual Studio now offers .NET Framework 4.7 development tools to supported platforms with 4.7 runtime included.
  • Sono stati aggiunti cluster di eventi correlati ai risultati delle query di ricerca nello strumento Ricerca di Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool.
  • È stato migliorato il supporto della sintassi per SQL Server 2016 in Redgate SQL Search.We improved syntax support for SQL Server 2016 in Redgate SQL Search.
  • È stato abilitato il supporto per le API Microsoft Graph in Servizi connessi.We enabled support for Microsoft Graph APIs in Connected Services.

Problemi principali corretti in questa versioneTop Issues Fixed in this Release

L'elenco seguente include i problemi più votati dalla Community degli sviluppatoriThe Developer Community spoke and we listened. L'elenco seguente include i 10 problemi più votati che sono stati risolti in questa versione.This list provides the 10 highest voted issues fixed in this release.

The Developer Community PortalAltre informazioni sui problemi segnalati dai clienti e risolti in Visual Studio 2017 versione 15.3. Learn more about customer-reported issues addressed in Visual Studio 2017 version 15.3.


Dettaglio: Novità di questa versioneDetails: What's New in this Release

Accessibilità Accessibility

In questa versione sono stati risolti oltre 1.700 problemi di accessibilità e reso Visual Studio più accessibile che mai.We addressed over 1,700 accessibility issues in this release and made Visual Studio more accessible than ever. È ora possibile accedere al tema "Blu (massimo contrasto)" (Figura 1).You have access to the new “Blue (Extra Contrast)” theme (Figure 1). Il tema offre un maggiore contrasto rispetto al tema "Blu" standard se non si vuole o non si ha bisogno di attivare la modalità contrasto elevato completa.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode.

Blue (Extra Contrast) theme
(Figura 1) Tema Blu (massimo contrasto)(Figure 1) Blue (Extra Contrast) theme

Con l'Editor di Visual Studio, è possibile individuare le aree di controllo e spostarsi tra di esse tramite il nuovo set di comandi "Mostra annotazioni riga".With Visual Studio Editor, you can discover and navigate between text adornments via the new "Show Line Annotations" command set. La nuova funzionalità è disponibile nel menu di scelta rapida dell'editor (Figura 2).You can find the new feature on the Editor context menu (Figure 2). Per altre informazioni, vedere la sezione Editor di Visual Studio.See the Visual Studio Editor section for more information.

Show Line Annotations
(Figura 2) Mostra annotazioni riga(Figure 2) Show Line Annotations

Per altre informazioni sull'accessibilità, visitare il post di blog sui miglioramenti dell'accessibilità di Visual Studio 2017 (versione 15.3).For more accessibility news, visit the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.


Azure Stack and cloud Azure per enti pubblici Azure Stack and Azure Government Clouds

Per connettere Azure Stack e i cloud per enti pubblici, usare gli stessi strumenti disponibili in Visual Studio — ad esempio Cloud Explorer, Servizi connessi e ASP.NET Publish —.Use all the same tools in Visual Studio — like Cloud Explorer, Connected Services and ASP.NET Publish — to connect Azure Stack and government clouds. Selezionare un cloud per enti pubblici esistente, ad esempio Azure in Cina (figura 3), oppure immettere l'endpoint di individuazione per lo stack di Azure dell'organizzazione.Pick an existing government cloud, like Azure in China (Figure 3), or enter the discovery endpoint for your organization’s Azure Stack.

Azure Stack
(Figura 3) Azure Stack(Figure 3) Azure Stack

Strumenti per le funzioni di AzureAzure Function Tools

  • Gli strumenti per lo sviluppo di funzioni di Azure in C# sono inclusi come parte del carico di lavoro "Sviluppo di Azure".Tools for developing C# Azure Functions are included as part of the “Azure development” workload.
  • È possibile sviluppare funzioni di Azure mediante librerie di classi C# precompilate e attributi per specificare i trigger.You can develop Azure functions by using pre-compiled C# class libraries, and attributes to specify triggers.
  • È possibile compilare, eseguire ed effettuare il debug nel computer di sviluppo locale.You can build, run, and debug on your local development machine.
  • È ora possibile pubblicare direttamente in Azure da Visual Studio.You can publish directly to Azure from Visual Studio.

Per altre informazioni, vedere il post di blog relativo agli strumenti di Visual Studio 2017 per Funzioni di Azure.For more details, see the Visual Studio 2017 Tools for Azure Functions blog post.


.NET Core e ASP.NET Core .NET Core and ASP.NET Core

  • È possibile installare l'SDK per .NET Core 2.0 tramite un download distinto per abilitare lo sviluppo per .NET Core 2.0 in Visual Studio 2017 (versione 15.3).You can install .NET Core 2.0 SDK via a separate download to enable .NET Core 2.0 development in Visual Studio 2017 version 15.3. Visual Studio offre ora il supporto side-by-side di più SDK per .NET Core.Visual Studio now provides side-by-side support of multiple .NET Core SDKs. È possibile provare a usare la build giornaliera più recente di .NET Core SDK e al tempo stesso eseguire attività di sviluppo con la versione pubblica più recente dell'SDK.You can experiment with the latest daily build of the .NET Core SDK while you develop with the latest public release of the SDK. Per informazioni dettagliate, vedere il post del blog .NET.See .NET blog for details.
  • Il supporto per Visual Basic permette di creare applicazioni console .NET Core e librerie di classi .NET Core e .NET Standard in Visual Basic.With Visual Basic support, you now have the ability to create .NET Core console applications, and .NET Core, and .NET Standard class libraries in Visual Basic.
  • L'interoperabilità tra .NET Framework e .NET Standard/Core permette di fare riferimento alle librerie di .NET Core/.NET Standard da progetti .NET Framework e viceversa..NET Framework and .NET Standard/Core interop allows you to refer to .NET Core/.NET Standard libraries from .NET Framework projects and vice versa. Non è necessario aggiungere manualmente i pacchetti NuGet di interoperabilità: Visual Studio esegue automaticamente questa operazione.No need to manually add interop NuGet packages – Visual Studio does this for you automatically.
  • Il miglioramento al supporto per più framework di destinazione consente di compilare il progetto per più framework di destinazione (TFM) e di usare il selettore TFM in Debug/Esegui per selezionare il TFM per l'esecuzione.Multiple target framework support enhancement allows you to build your project for multiple target frameworks (TFM), and use the TFM picker in Debug/Run to pick the TFM to run.
  • È stato aggiunto il supporto per le immagini Windows Nano Server per l'inserimento nei contenitori delle app ASP.NET Core come immagini Windows Nano Server.We added Windows Nano Server image support for containerizing ASP.NET Core apps as Windows Nano Server images. È ora possibile selezionare Windows Nano Server come piattaforma del contenitore.You can now select Windows Nano Server as the container platform. È possibile eseguire questa operazione in File->Nuovo progetto per i progetti ASP.NET Core.You can do this under File->New Project for ASP.NET Core projects. Per i progetti esistenti, può essere aggiunto usando il menu di scelta rapida del progetto.For your existing projects, it can be added using the Project Context Menu.
  • Supporto per IIS locale: ora è possibile sviluppare ed eseguire il debug usando IIS da Visual Studio.Local IIS support: You can now develop and debug using IIS from Visual Studio.
  • ASP.NET Core in .NET Framework - Per creare un progetto ASP.NET Core destinato alla versione completa di .NET Framework (solo Windows), usare l'elenco a discesa nella finestra di dialogo One ASP.NET.ASP.NET Core on .NET Framework – When you create an ASP.NET Core project targeting the full .NET Framework (Windows only), you will use the dropdown on the One ASP.NET dialog.
  • È possibile abilitare la funzionalità Live Unit Testing per i progetti .NET Standard, .NET Core e ASP.NET Core.The Live Unit Testing feature can be enabled for your .NET Standard, .NET Core, and ASP.NET Core projects.

Strumenti di Service FabricService Fabric Tools

In questa versione sono disponibili un nuovo modello di progetto ASP.NET Core con stato, il supporto per gli SDK 2.5 e 2.6 (e i runtime corrispondenti) di Service Fabric, nonché diverse correzioni di bug.This release provides a new stateful ASP.NET Core project template, support for both 2.5 and 2.6 SDK's (and corresponding runtimes) of Service Fabric, as well as several bug fixes.

Strumenti di recapito continuoContinuous Delivery Tools

Queste funzionalità sono state spostate dall'estensione CD4VS (Strumenti di recapito continuo Microsoft per Visual Studio) in Visual Studio:We moved these features from the CD4VS (Microsoft Continuous Delivery Tools for Visual Studio) extension into Visual Studio:

  • Configurare il recapito continuo per le soluzioni che contengono progetti ASP.NET che hanno come destinazione un servizio app di Azure.Configure continuous delivery for solutions that contain ASP.NET projects targeting an Azure App Service.
  • Configurare il recapito continuo per le soluzioni che contengono progetti ASP.NET Core che hanno come destinazione un servizio app di Azure.Configure continuous delivery for solutions that contain ASP.NET Core projects targeting an Azure App Service.

IDE di Visual Studio Visual Studio IDE

  • È stato aggiunto il comando Accessibilità tastiera nel menu "?".We added the Keyboard Accessibility menu command under the "Help" menu. Questo comando fornisce un collegamento alla documentazione online sui suggerimenti sull'accessibilità.This provides you with a shortcut to online documention about Accessibility Tips and Tricks.
  • Il sistema di diagnostica segnala nella barra informazioni le estensioni che potrebbero essere state coinvolte in una chiusura imprevista di Visual Studio (Figura 4).The diagnostic system informs you via the InfoBar about extensions that might have been involved in an unexpected termination of Visual Studio (Figure 4). La barra informazioni visualizza queste informazioni sulla chiusura e chiede se disabilitare l'estensione sospetta.The InfoBar provides this information about the termination and asks if you would like to disable the suspected extension.
InfoBar notification
(Figura 4) Notifica nella barra informazioni(Figure 4) InfoBar notification
  • Negli scenari che prevedono l'apertura di cartelle, è possibile selezionare il debugger desiderato tramite un'interfaccia utente dedicata.In open folder scenarios, you can select your desired debugger via dedicated UI.
  • È stata arrestata la condivisione di alcune impostazioni, ad esempio il layout delle finestre degli strumenti, tra diverse installazioni side-by-side di Visual Studio 2017.We’ve stopped sharing certain settings, like tool window layout, between different side-by-side installations of Visual Studio 2017. Per altre informazioni, vedere la documentazione Sincronizzare le impostazioni in Visual Studio.For more information, see the Synchronize your settings in Visual Studio documentation.
  • È stato risolto il bug della "finestra nascosta", per cui Visual Studio sembrava bloccarsi prima della visualizzazione della finestra principale.We fixed the "hidden window" bug that made Visual Studio appear to hang before its main window appeared.
  • È stata aumentata l'area di destinazione selezionabile per rendere più semplice ignorare i suggerimenti delle notifiche.We increased the clickable target area to make it easier to dismiss notification tips.

IDE di .NET.NET IDE

  • Sono stati aggiunti diversi nuovi refactoring e correzioni rapide, ad esempio per la risoluzione dei conflitti di unione, l'aggiunta di controlli null, l'aggiunta di parametri e molti altri.We added several new refactorings and quick fixes, like "Resolve merge conflicts", "Add null checks", "Add parameter", and many more. Visitare la pagina Refactoring, generazione di codice e azioni rapide in Visual Studio per visualizzare l'elenco completo.Take a look at our Refactoring, Code Generation and Quick Actions in Visual Studio page to see the full list.
  • Vengono suggeriti i nomi delle variabili in IntelliSense per velocizzare l'assegnazione dei nomi alle variabili, ad esempio Person person.We suggest variable names in IntelliSense to help you name your variables quickly, for example, Person person.
  • Modifica e continuazione supporta le funzionalità di C# 7.0 (ad eccezione delle funzioni locali).Edit and Continue supports C# 7.0 features (except local functions).
  • È stato aggiunto il supporto per il glob dei file all'esterno della cartella del progetto per .NET Core.We added support for file globbing outside of your project folder for .NET Core.

Accesso e identitàSign In and Identity

È stato corretto il controllo per la selezione dell'account in modo da rendere più affidabile il funzionamento dell'opzione "Immettere di nuovo le credenziali".We fixed the account picker control so "Re-enter credentials" works more reliably. In alcuni casi, la selezione dell'account cancellava gli account quando venivano immesse di nuovo le credenziali.In some cases, the account picker would clear accounts upon re-entering credentials.

Pagina inizialeStart Page

È stata aumentata l'area di destinazione selezionabile negli elementi da aggiungere nell'elenco degli ultimi elementi usati nella pagina iniziale.We increased the clickable target area on Start Page MRU “pins”. In questo modo è più semplice aggiungere elementi a cui si è interessati all'inizio dell'elenco.It's easier to pin items you care about to the top of the MRU.

Caricamento leggero soluzioniLightweight Solution Load

  • Sono state aumentate la velocità e la stabilità di compilazione.We increased build speed and stability.
  • È stato ridotto il numero di progetti caricati.We reduced the number of loaded projects.
  • È stata aggiunta una nuova opzione (figura 5) per consentire a Visual Studio di effettuare la scelta ottimale per la soluzione.We added a new option (Figure 5) that allows Visual Studio to decide what’s best for your solution.
Lightweight Solution Load Options
(Figura 5) Opzioni di caricamento leggero delle soluzioni(Figure 5) Lightweight Solution Load Options
  • Sono state aggiunte soluzioni per i risultati della ricerca di file per i progetti posticipati, invece che solo per i progetti caricati.We added file search results solutions to search for deferred projects, instead of just loaded projects.
    • Quando si carica un progetto, tutte le ricerche esistenti vengono aggiornate per aggiungere i risultati relativi all'avanzamento.When you load a project, all existing searches are refreshed to add progression results.
    • Esistono alcune limitazioni per questa funzionalità:There are limits to this:
      • La ricerca non comprende il contenuto del file e non include risultati progressivi, ad esempio classi, metodi e così via.Search does not extend within the file and does not include progressive results, i.e. classes, methods, etc.
      • I file che appartengono a un progetto vengono visualizzati come un elenco semplice.Files that belong to a project are shown as a flat list. Quando i file appartengono a una cartella, viene visualizzato il percorso relativo anziché il nome del file.When files belong to a folder, the relative path is shown instead of just the file name.
      • Non sono disponibili menu di scelta rapida per le voci relative ai file nella visualizzazione di ricerca.There are no context menus for the file items in the search view.
  • Le opzioni Vai a tutti e Vai al file mostrano il contenuto degli elementi esterni nell'area di lavoro.GoTo All and GoTo Files show content from external items in the workspace.
  • È stata migliorata la compilazione batch nei progetti che usano Caricamento leggero soluzioni.We improved Batch build in projects that use Lightweight Solution Load.

ConfigurazioneSetup

  • Il programma di installazione di Visual Studio ora supporta il ridimensionamento ad alta risoluzione a livelli inferiori a 150%.Visual Studio Installer now supports high-DPI scaling at levels less than 150%.
  • Il file eseguibile vswhere.exe è stato aggiornato per escludere le istanze di anteprima per impostazione predefinita, ma vengono incluse quando si include --prerelease nella riga di comando.The vswhere.exe executable file has been updated to exclude preview instances by default, and includes them when --prerelease is included on the command line.
  • L'interfaccia della riga di comando è in grado di gestire --verify, --fix e --clean.CLI is able to handle --verify, --fix and --clean.
    • --verify verifica il layout e segnala i payload mancanti o non validi.--verify verifies layout and informs you of missing and invalid payloads.
    • --fix verifica il layout e scarica di nuovo i pacchetti mancanti o non validi.--fix verifies the layout and re-downloads packages that are either missing or invalid.
    • --clean elimina i pacchetti obsoleti e consente di tagliare il layout in base a un intervallo di versioni specifico.--clean deletes obsolete packages and allows you to trim layout to a specific version range.
  • Sono state aggiunge informazioni che mostrano l'impatto della dimensione netta dell'unità nella pagina dei dettagli di installazione.We added details that show the net size impact per drive to the installation details page. (Figura 6).(Figure 6).
Drive Sizes listed in the Installer
(Figura 6) Dimensioni delle unità elencate nel programma di installazione(Figure 6) Drive Sizes listed in the Installer

Editor di Visual Studio Visual Studio Editor

  • È stato risolto il problema che rendeva più complesso effettuare lo scorrimento e la selezione manuali quando erano presenti numerosi errori.Manual scroll and selection are no longer difficult when a large numbers of errors are being added.
  • È stata aggiunta una nuova variante del tema "Blu", progettata in modo specifico per gli utenti che hanno l'esigenza di aumentare il contrasto nell'editor di Visual Studio.We added a new variant of the "Blue" theme, which caters specifically to users who need more contrast in the Visual Studio Editor. Il tema offre un maggiore contrasto rispetto al tema "Blu" standard se non si vuole o non si ha bisogno di attivare la modalità contrasto elevato completa.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode. È possibile provarlo tramite Strumenti -> Opzioni -> Ambiente -> Generale.You can try it out via Tools -> Options -> Environment -> General.
  • Se si usa un'utilità per la lettura dello schermo, è ora possibile spostarsi tra le aree di controllo usando il nuovo comando "Mostra annotazioni riga".If you use a screen-reader, you can now navigate between adornments by using the new "Show Line Annotations" command.
    • Per attivare la funzionalità, scegliere "Mostra annotazioni riga" (Ctrl+K, Ctrl+M) dal menu di scelta rapida dell'editor.To activate, select "Show Line Annotations" (Ctrl+K, Ctrl+M) on the Editor context menu. Viene visualizzato un popup nell'editor che descrive le aree di controllo per tale riga.A popup will appear in the editor describing the adornments on that line.
    • Per spostarsi tra più annotazioni in una riga, usare Ctrl+K, Ctrl+ Right/Left Arrow.Navigate through multiple annotations on the line using Ctrl+K, Ctrl+ Right/Left Arrow.
    • È anche possibile trovare facilmente il contesto nel codice usando il comando "Mostra struttura" Ctrl+K, Ctrl+G.You can also easily find context in code through the "Show Structure" command Ctrl+K, Ctrl+G. Verrà mostrato il contesto strutturale della riga di codice nel popup quando viene individuato il punto di inserimento, che potrà essere letto dall'utilità per la lettura dello schermo.This shows the structural context of the line of code in the popup where the caret is located, and can be read by the screen reader.

Debug e diagnostica Debugging and Diagnostics

Supporto del debugger per i server di simboli di Visual Studio Team ServicesDebugger Support for Visual Studio Team Services Symbol Servers

  • È possibile eseguire query e scaricare i simboli (figura 7) dai server di simboli di Visual Studio Team Services.You can query and download symbols (Figure 7) from Visual Studio Team Services Symbol Servers. È possibile selezionare i percorsi dei simboli di Visual Studio Team Services e aggiungerli all'ambiente di Visual Studio tramite la pagina Strumenti -> Opzioni -> Debugger -> Simboli.You can select and add Visual Studio Team Services symbol paths to your Visual Studio environment using the Tools->Options->Debugger->Symbols page. Per configurare server di simboli di Visual Studio Team Services, vedere la pagina relativa all'uso del server di simboli di Visual Studio Team Services.To set up a Visual Studio Team Services Symbol Server, see the Use Symbol Server in Team Services page.
Add VSTS Symbol Server
(Figura 7) Aggiungere un server di simboli di Visual Studio Team Services(Figure 7) Add VSTS Symbol Server
  • L'API SetThreadDescription è supportata durante il debug quando si usa Avvia debug (F5) o Connetti a processo (Ctrl+Alt+P).The SetThreadDescription API is supported while debugging when you use Start Debugging (F5) or Attach to Process (Ctrl+Alt+P). I nomi dei thread impostati tramite questa API ora vengono visualizzati nella finestra Thread e nell'elenco a discesa Thread nella barra degli strumenti Posizione di debug.The thread names that are set via this API now show up in the Threads window and in the Thread dropdown in the Debug Location toolbar. Questa funzionalità non è attualmente supportata durante il debug di dump.This is not currently supported while dump debugging.
  • La finestra di output ora visualizza l'output della console di un'applicazione in esecuzione all'interno di un contenitore di Windows durante il debug.The Output Window now shows you the console output of an application running inside a Windows Container while debugging.
  • È stato aggiunto il supporto per il debug di applicazioni .NET Core eseguite all'interno di contenitori di Windows basati su Windows Nano Server.We added new support for debugging .NET Core apps you run inside Windows Containers based on Windows Nano Server.

Impostare l'istruzione successiva con un clicPoint and Click to Set Next Statement

È possibile tenere premuto il tasto Ctrl mentre l'esecuzione è interrotta in corrispondenza di un punto di interruzione durante il debug.You can hold down the Ctrl key while stopped at a breakpoint when debugging. L'icona Run to Click (Continua l'esecuzione fino a qui) accanto alla riga di codice diventa "Imposta istruzione successiva" (Figura 8).The Run to Click (Run execution to here) icon next to your line of code changes to “Set Next Statement” functionality (Figure 8). Fare clic su di essa per spostare il puntatore dell'istruzione giallo in tale riga e impostare l'istruzione successiva per l'esecuzione da parte del debugger.Click the icon to move the yellow instruction pointer to that line and set the next statement for the debugger to execute.

Click to set Next Statement
(Figura 8) Fare clic per impostare l'istruzione successiva(Figure 8) Click to set Next Statement

Il collegamento all'origine ora è supportato per il formato file PDB Windows (oltre ai PDB portatili).Source Link is now supported for Windows PDB file format (in addition to Portable PDBs). I compilatori che lo supportano possono inserire le informazioni necessarie nel formato file PDB Windows e il debugger può recuperare i file di origine in base a tali informazioni.Compilers that support it can put the necessary information in the Windows PDB file format and the debugger can retrieve source files based on that information.

Debug di Apri cartellaOpen Folder Debugging

È stata semplificata l'esperienza di debug quando si usano i nuovi modelli disponibili per Apri cartella.We have made your debugging experience easier when you use our new templates for Open Folder. Se è installato il debugger Core, i nuovi modelli consentono di scegliere il tipo di debugger da usare.If you have the core debugger installed, our new templates allow you to choose the type of debugger you want to use. È possibile scegliere Gestito, Nativo o Misto nella finestra di dialogo "Seleziona un debugger", accessibile tramite l'opzione di menu "Impostazioni per debug e avvio" in Esplora soluzioni.Managed, Native, or Mixed can be chosen from the "Select a Debugger" dialog in the "Debug and Launch Settings" menu option in Solution Explorer. Se è installata un'esperienza C++ MDD (Android C++, debug di Linux e così via), nella stessa opzione di menu ora verranno visualizzate le opzioni per il supporto di MinGW e Cygwin usando GDB per il collegamento e l'avvio.If you have a C++ MDD experience installed (Android C++, Linux Debugging, etc.), you now see options for MinGW and Cygwin support by using GDB for attach and launch within the same menu option.

Aggiornare tutti i valori annidati nelle finestre delle variabiliRefresh All Nested Values in Variable Windows

Quando si fa clic sul pulsante Aggiorna per il nodo padre di una variabile o un'espressione nelle finestre Espressioni di controllo, Auto e Variabili locali, vengono aggiornate e rivalutate anche tutte le variabili e le espressioni visibili che sono elementi figlio di tale nodo.When you click the refresh button for the parent node of a variable or expression in the Watch, Autos, and Locals windows, all visible variables and expressions that are children of that node also refresh and re-evaluate. Non è più necessario fare clic sul pulsante Aggiorna per ognuno degli elementi figlio.You no longer need to click on the refresh button for each of the children.

Supporto di Live Unit Testing per .NET CoreLive Unit Testing Support for .NET Core

È possibile abilitare la funzionalità Live Unit Testing per i progetti .NET Standard, .NET Core e ASP.NET Core.You can enable the Live Unit Testing feature for .NET Standard, .NET Core, and ASP.NET Core projects.


Xamarin Xamarin

  • Riprogettazione delle pagine delle proprietà e del manifesto dell'app - È stato semplificato l'uso delle pagine delle proprietà per i progetti iOS e Android.Property Pages & App Manifest Redesigns - We have continued our work on making property pages for iOS and Android projects easier to use.
  • Nuovo editor per i diritti - È stato aggiunto un editor autonomo per la modifica dei diritti delle app.New Entitlements Editor - We added a standalone editor for editing app entitlements.

Per una panoramica completa delle modifiche, assicurarsi di visitare developer.xamarin.com per altri dettagli.For a complete overview of changes, be sure to check out developer.xamarin.com for more details.


Apri cartella e strumenti CMake Open Folder and CMake Tools

  • È stata migliorata la stabilità per lo spostamento tra la cartella e la soluzione.We improved stability for toggling between folder and solution.
  • I controlli Extender di Apri cartella possono aggiungere alle cartelle un'icona del controllo del codice sorgente.Open folder extenders can add a source control icon to your folders. In questo modo è possibile visualizzare rapidamente lo stato del controllo del codice sorgente dei file in Esplora soluzioni, attualmente implementato da SVN.This allows you to quickly see the source control state of your files in Solution Explorer, which is currently implemented by SVN.
  • L'esperienza CMake in Visual Studio è stata aggiornata ed è ora possibile usare CMake 3.8.The CMake experience in Visual Studio is upgraded to CMake 3.8.
  • È stato migliorato il supporto per la modifica, la compilazione e il debug in "Apri cartella" per i progetti C++ che usano MinGW o Cygwin.We improved editing, building, and debugging support in "Open Folder" for C++ projects that use MinGW or Cygwin.
  • È stato aggiunto il supporto per la definizione di variabili di ambiente globali e specifiche della configurazione in "CppProperties.json" e "CMakeSettings.json".We added support to define global and configuration-specific environment variables in "CppProperties.json" and "CMakeSettings.json". Queste variabili di ambiente possono essere usate dalle configurazioni di debug definite in "launch.vs.json" e dalle attività in "tasks.vs.json".These environment variables can be consumed by debug configurations defined in "launch.vs.json" and tasks in "tasks.vs.json".
  • Sono stati migliorati gli strumenti CMake per Visual Studio per fornire il supporto per l'integrazione di CTest.We enhanced CMake tools for Visual Studio to provide you with support for CTest integration.
  • È ora possibile usare il generatore Ninja di CMake per creare facilmente codice destinato alle piattaforme a 64 bit, nonché compilare, eseguire il debug e modificare il codice con IntelliSense.You can now use the CMake's Ninja generator to easily target 64-bit platforms, build, debug, and edit with IntelliSense.

Servizi di linguaggio C++ C++ Language Services

L'opzione "Abilita caricamento più rapido del progetto" in Opzioni sperimentali è stata rinominata "Abilita memorizzazione progetti nella cache" e spostata nelle impostazioni del progetto VC++.The “Enable Faster Project Load” option under Experimental options has been renamed “Enable Project Caching” and moved under VC++ Project Settings. Il valore della proprietà precedente non viene propagato alla nuova opzione.The old property value is not propagated to the new option.

Motore IntelliSenseIntelliSense Engine

  • IntelliSense per C++ supporta le nuove funzionalità di CC++17 per la versione del compilatore batch corrispondente.C++ IntelliSense supports new C++17 features matching the batch compiler release.
  • Nel menu di scelta rapida dell'editor di C++ è stata aggiunta l'opzione Ripeti analisi file, che può essere usata se IntelliSense non funziona correttamente.Added context menu option in C++ editor to Rescan File, which can be used if IntelliSense is not working correctly.
  • È stato ridotto l'uso della CPU quando si esegue Trova tutti i riferimenti o Gerarchia di chiamata per il codice C++.Reduced CPU usage when running Find All References or Call Hierarchy for C++ code.
  • È stata migliorata l'esperienza complessiva del motore IntelliSense per C++.We've improved the overall C++ IntelliSense engine experience.

Procedure guidate per il progetto e il codiceProject and Code Wizard

  • Sono state riscritte diverse procedure guidate per il progetto e il codice nello stile basato su finestre di dialogo.We have rewritten several project and code wizards in the signature dialogue style.
  • Aggiungi classe avvia direttamente la procedura guidata Aggiungi classe.Add Class launches the Add Class wizard directly. Tutti gli altri elementi che in precedenza erano disponibili in questa posizione sono disponibili in "Aggiungi > Nuovo elemento".All of the other items that were previously here are available under "Add > New Item".
  • I progetti Win32 sono inclusi nella categoria Desktop di Windows, nella finestra di dialogo Nuovo progetto.Win32 projects are under the Windows Desktop category in the New Project dialog.
  • I modelli Applicazione console di Windows e Applicazione desktop di Windows ora creano i progetti senza visualizzare una procedura guidata.The Windows Console and Desktop Application templates now create the projects without displaying a wizard. Nella stessa categoria è presente una nuova Creazione guidata applicazione desktop di Windows, che visualizza le stesse opzioni disponibili in precedenza.There's a new Windows Desktop Wizard under the same category that displays the same options as before.

Set di strumenti e librerie di Visual C++Visual C++ Toolset and Libraries

  • Nel prompt dei comandi per gli sviluppatori per Visual Studio (e nel prompt dei comandi di Visual C++) è stato aggiunto il supporto per l'inizializzazione di un ambiente di prompt dei comandi destinato al set di strumenti di Visual C++ 2015 (v140) tramite l'argomento -vcvars_ver=14.0.The Developer Command Prompt for Visual Studio (and the Visual C++ Command Prompt) have added support for initializing a command-prompt environment targeting the Visual C++ 2015 Toolset (v140) via the -vcvars_ver=14.0 argument.
  • Le directory di file Redist di Visual C++ sono state rinominate Microsoft.VC141.* per garantire la corrispondenza della versione con il set di strumenti (14.1 x).Visual C++ Redist file directories have been renamed to Microsoft.VC141.* to match versioning with the toolset (14.1x). In Visual Studio 2017 RTM queste directory erano denominate in modo errato Microsoft.VC150.*.In Visual Studio 2017 RTM, these directories were incorrectly named Microsoft.VC150.*.
  • Versione del file e directory di Visual C++ (Visual Studio 2017 15.3):Visual C++ File Version and Directories (Visual Studio 2017 15.3) :
    • Versione del file del set di strumenti di VC++: 14.11.25506.0 o 19.11.25506.0VC++ Toolset File Version : 14.11.25506.0 or 19.11.25506.0
    • Directory degli strumenti di VC++: VC\Tools\MSVC\14.11.25503 (il percorso della directory era bloccato in una versione di anteprima)VC++ Tools Directory : VC\Tools\MSVC\14.11.25503 (directory location was locked in a Preview release)
    • Directory Redist di VC++ [a]: VC\Redist\MSVC\14.11.25325 (tutti i runtime, ad eccezione di MFC e OneCore)VC++ Redist Directory [a] : VC\Redist\MSVC\14.11.25325 (All runtimes except for MFC and OneCore)
    • Directory Redist di VC++ [b]: VC\Redist\MSVC\14.11.25415 (runtime MFC e OneCore)VC++ Redist Directory [b] : VC\Redist\MSVC\14.11.25415 (MFC and OneCore runtimes)

Supporto per il linguaggio C# 7.1C# 7.1 Language Support


JavaScript e TypeScriptJavaScript & TypeScript

  • È stato eseguito il passaggio dal nodo a 64 bit al nodo a 32 bit per l'avvio di tsserver e il dimezzamento dell'utilizzo della memoria del servizio di linguaggio.We switched from 64-bit node to 32 bit-node when launching tsserver and cut language service memory consumption in half.
  • Il percorso del file IntelliSense nelle istruzioni di importazione è ora più veloce.File path IntelliSense in import statements is now faster.
  • Le versioni di TypeScript possono essere installate in modo indipendente dagli aggiornamenti di Visual Studio e selezionate a livello di singolo progetto.TypeScript versions can be installed independent of Visual Studio updates and selected on a per project basis. Per altre informazioni, vedere la documentazione relativa all'Aggiornamento di TypeScript in Visual Studio 2017.For more information see the Updating TypeScript in Visual Studio 2017 documentation.

Node.jsNode.js

  • È stato aggiunto il supporto per il debug di Node 8.We added support for Node 8 debugging.
  • Sono stati apportati miglioramenti delle prestazioni dei test runner per gli unit test.We made unit test runner performance enhancements.
  • È stata semplificata l'interfaccia utente del programma di installazione dei pacchetti npm.We simplified the npm package installer UI.

NuGet NuGet

  • È stato aggiunto supporto per le TFM seguenti - netcoreapp2.0, netstandard2.0 e Tizen.We have added support for the following TFMs - netcoreapp2.0, netstandard2.0, and Tizen.
  • Sono stati integrati in MSBuild gli errori e gli avvisi di NuGet; è quindi possibile usare le proprietà esistenti di MSBuild per eliminare specifici avvisi oppure per innalzarli di livello a errori.We have integrated NuGet warnings and errors with MSBuild so you can use existing MSBuild properties to suppress certain warnings or elevate them to errors.
  • È stato aggiunto il supporto per Versionamento Semantico 2.0.0.We have added support for Semantic Versioning 2.0.0.

Altre informazioni su questi miglioramenti e l'elenco completo delle correzioni sono disponibili nelle Note di rilascio di NuGet .You can find more details about these improvements and the complete list of bug fixes in the NuGet release notes.


.NET Framework 4.7 .NET Framework 4.7

Visual Studio 2017 versione 15.3 ora offre gli strumenti di sviluppo di .NET Framework 4.7 per tutte le piattaforme supportate con il runtime 4.7 incluso.Visual Studio 2017 version 15.3 now offers the .NET Framework 4.7 development tools to all supported platforms with the 4.7 runtime included. .NET Framework 4.7 include diverse nuove funzionalità e miglioramenti, oltre a numerose correzioni relative ad affidabilità, stabilità, sicurezza e prestazioni.The .NET Framework 4.7 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes.

È possibile trovare altre informazioni dettagliate su .NET 4.7 in questi articoli:You can find more details about .NET 4.7 in these articles:

Strumenti di sviluppo contenitoriContainer Development Tools

Visual Studio 2017 versione 15.3 ora supporta un'ampia varietà di strumenti di sviluppo dei contenitori per le app .NET Framework esistenti con i contenitori di Windows, .NET Core con Windows e il supporto per Linux.Visual Studio 2017 version 15.3 now supports the breadth of container development across existing .NET Framework apps with Windows Containers, to .NET Core with Windows, and Linux Support. Le aggiunte più recenti includono il supporto per le applicazioni .NET Core nei contenitori che eseguono Windows Nano Server, nonché miglioramenti del debug per le applicazioni .NET Framework nei contenitori.Recent additions include support for your .NET Core applications in containers running Windows Nano Server, as well as debugging improvements for .NET Framework applications in containers.


Sono stati aggiunti cluster di eventi correlati ai risultati delle query di ricerca nello strumento Ricerca di Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool. Questi cluster consentono di individuare modelli insoliti nel comportamento di un'applicazione, ad esempio un volume elevato di eccezioni generate da un singolo paese, una singola versione o un singolo utente.These clusters can help you discover surprising patterns in your application's behavior, like a large volume of exceptions coming from a single country, version, or user.


SQL Server Data Tools (SSDT) SQL Server Data Tools (SSDT)

Visual Studio 2017 (versione 15.3) è ora disponibile con SQL Server Data Tools che supporta completamente SQL Server 2017 in esecuzione su Windows, Linux e Docker in macOS.Visual Studio 2017 version 15.3 now ships with SQL Server Data Tools that fully supports SQL Server 2017 running on Windows, Linux and Docker in macOS. SSDT supporta ora tutte le versioni di SQL Server, SQLDB e Azure Data Warehouse.SSDT now supports all versions of SQL Server, SQLDB and DW on Azure.

Correzioni per i problemi più segnalati dai clienti:Fixes for top customer reported issues:

  • È stata aggiunta l'opzione Ignora ordine colonne per evitare lo spostamento non necessario dei dati di una tabella a causa di una modifica nell'ordine della colonna.We added Ignore Column Order option to prevent unnecessary table data movement due to a column order change.
  • È stato risolto l'errore di compilazione ESENT e aumentata la stabilità e le prestazioni di compilazione del progetto di database in Visual Studio 2017.We fixed ESENT build error and increased the database project build stability and performance in Visual Studio 2017.
  • Sono stati presi in considerazione molti altri problemi segnati dai clienti.We addressed many more customer reported issues. Vedere il Log delle modifiche per SQL Server Data Tools (SSDT) per altre informazioni sui problemi risolti.See SSDT changelog for more details of fixed issues.

Redgate Data Tools Redgate Data Tools

Tutti gli strumenti dati RedgateAll Redgate Data Tools

È stata eliminata la finestra di dialogo introduttiva visualizzata al primo utilizzo di Redgate Data Tools.We removed the introduction dialog that appeared upon first use of Redgate Data Tools.

Redgate SQL PromptRedgate SQL Prompt

Sono stati apportati miglioramenti alla formattazione.We made formatting improvements.

Redgate ReadyRollRedgate ReadyRoll

  • La finestra Apri progetto ReadyRoll è stata ridisegnata.The ReadyRoll open project window has been redesigned.
  • È stato migliorato il tempo di caricamento delle proprietà del progetto.We improved the loading time of Project Properties.
  • Il widget di stato dello script è stato sostituito con una barra delle azioni.We replaced the script status widget with an action bar.
  • Sono stati corretti i problemi di connettività con Azure.We fixed the connectivity problems with Azure.
  • È stato migliorato il supporto della sintassi per SQL Server 2016.We improved the syntax support for SQL Server 2016.

PythonPython

  • È stata migliorata l'accessibilità nelle utilità per la lettura dello schermo, la navigazione da tastiera e il contrasto elevato.We improved accessibility in screen readers, keyboard navigation and high contrast.
  • È stata migliorata la localizzazione, in modo che gli utenti non di lingua inglese possano visualizzare meno testo in inglese nell'interfaccia utente.We improved localization so that non-English users will see less English text in the UI.

R ToolsR Tools

  • È stata migliorata l'esperienza IntelliSense.The IntelliSense experience is improved.
  • È stata migliorata la connettività di Azure ai computer che bloccano il ping.You have better Azure connectivity to your machines that are blocking ping.
  • Quando si esegue un'installazione di servizi in modalità remota, non è più necessario disporre dei diritti di gestione del servizio.When you perform a remote services install, you are no longer required to have service management rights.
  • Sono stati apportati miglioramenti generici ad accessibilità e localizzazione.We improved overall accessibility, and localization.

Provider Microsoft Graph in Servizi connessiMicrosoft Graph Provider in Connected Services

È stato abilitato il supporto per le API Microsoft Graph abilitato in Servizi connessi.We have enabled support for Microsoft Graph APIs in Connected Services. L'installazione è stata semplificata.We've made Installation easier. È sufficiente aprire la finestra di dialogo Servizi connessi per eseguire accesso e installazione (figura 9).Just open the Connected Services dialog to access and install (Figure 9).

Install Microsoft Graph provider
(Figura 9) Installare il provider di Microsoft Graph(Figure 9) Install Microsoft Graph provider

Problemi notiKnown Issues

Visual Studio 2017 Known Issues Vedere tutti i problemi noti esistenti e le soluzioni alternative disponibili in Visual Studio 2017 versione 15.3. See all existing known issues and available workarounds in Visual Studio 2017 version 15.3.

Microsoft presta la massima attenzione ai commenti e suggerimenti degli utenti.We are fully committed to listening to your feedback. Visitare il sito della community degli sviluppatori per conoscere i problemi più recenti, registrare nuovi problemi e votare a favore dei problemi esistenti.Visit the Developer Community site to find the latest issues, log new issues, and upvote existing issues.


Cronologia delle note sulla versione di Visual Studio 2017Visual Studio 2017 Release Notes History

Vedere la pagina Cronologia delle note sulla versione di Visual Studio 2017.Please see the Visual Studio 2017 Release Notes History page.


Inizio pagina
Top of Page