PowerApps でデータを折れ線グラフ、円グラフ、棒グラフで表示するShow data in a line, pie, or bar chart in PowerApps

折れ線グラフ、円グラフ、棒グラフを使ってデータを表示することができます。Use line charts, pie charts, and bar charts to display your data. グラフを扱うとき、インポートするデータは次のような構造になっている必要があります。When working with charts, the data that you import should be structured like the following:

  • 各系列が先頭行に入力されていること。Each series should be in the first row.
  • ラベルが左端の列に入力されていること。Labels should be in the leftmost column.

たとえば、データは次のようになっている必要があります。For example, your data should look similar to the following:

これらのグラフは PowerApps 内で作成し、使用することができます。You can create and use these charts within PowerApps. それでは、始めましょう。Let's get started.

前提条件Prerequisites

  • PowerApps にサインアップして PowerApps をインストールします。Sign up for PowerApps, and then install PowerApps. PowerApps を開く際に、サインアップに使用した同じ資格情報でサインインします。When you open PowerApps, sign in using the same credentials that you used to sign up.
  • テンプレートデータ、またはゼロからアプリを作成します。Create an app from a template, from data, or from scratch.
  • PowerApps でコントロールを構成する方法について確認します。Learn how to configure a control in PowerApps.
  • ChartData.zip をダウンロードします。このファイルには、サンプル データが XML ファイルとして格納されています。Download ChartData.zip, which contains sample data as an XML file. このトピックの手順に従って直接アプリにインポートしてください。Follow the steps in this topic to import it directly into your app. または .zip ファイルを展開し、XML ファイルを Excel で開いて、クラウド ストレージ アカウントに保存します。As an alternative, decompress the .zip file, open the XML file in Excel, and save it to a cloud-storage account.

サンプル データをインポートするImport the sample data

以降の手順では、ProductRevenue という名前のコレクションにサンプル データをインポートします。In these steps, we import the sample data into a collection, named ProductRevenue.

  1. [挿入] タブで [コントロール] を選択し、[インポート] を選択します。On the Insert tab, select Controls, and then select Import:

  2. このコントロールの OnSelect プロパティを次の関数に設定します。Set the control's OnSelect property to the following function:
    Collect(ProductRevenue, Import1.Data)
  3. F5 を押してプレビュー モードで開き、[データのインポート] ボタンを選択します。Press F5 to open Preview mode, and then select the Import Data button.
  4. [開く] ダイアログ ボックスで ChartData.zip を選択し、[開く] を選択して Esc キーを押します。In the Open dialog box, select ChartData.zip, select Open, and then press Esc.
  5. [ファイル] メニューの [コレクション] を選択します。On the File menu, select Collections.

    ProductRevenue コレクションが、インポートしたグラフ データと共に表示されます。The ProductRevenue collection is listed with the chart data you imported:

    注意

    インポート コントロールの目的は、Excel と同様のデータをインポートしてコレクションを作成することです。The import control is used to import Excel-like data and create the collection. インポート コントロールによってデータがインポートされるのは、アプリの作成時とアプリのプレビュー時です。The import control imports data when you are creating your app, and previewing your app. 現在、アプリの発行時には、データはインポートされません。Currently, the import control does not import data when you publish your app.

  6. Esc キーを押して既定のワークスペースに戻ります。Press Esc to return to the default workspace.

円グラフを追加するAdd a pie chart

  1. [挿入] タブの [グラフ] を選択し、[円グラフ] を選択します。On the Insert tab, select Charts, and then select Pie Chart.
  2. [データのインポート] ボタンの下に円グラフを移動します。Move the pie chart under the Import data button.
  3. 円グラフ コントロールで、円グラフの中心を選択します。In the pie-chart control, select the middle of the pie chart:

  4. 円グラフの Items プロパティを次の式に設定します。Set the Items property of the pie chart to this expression:

    
     ![][2]  
    
     <span data-ttu-id="f0233-136">円グラフに、2014 年の売上データが表示されます。</span><span class="sxs-lookup"><span data-stu-id="f0233-136">The pie chart shows the revenue data from 2014.</span></span>
    
     ![][3]  
    
    
    

棒グラフを追加してデータを表示するAdd a bar chart to display your data

今度は、この ProductRevenue コレクションを棒グラフで表示してみましょう。Now, let's use this ProductRevenue collection in a bar chart:

  1. [ホーム] タブでスクリーンを追加します。On the Home tab, add a screen.
  2. [挿入] タブの [グラフ] を選択し、[縦棒グラフ] を選択します。On the Insert tab, select Charts, and then select Column Chart.
  3. 縦棒グラフの中心を選択します。Select the middle of the column chart. 縦棒グラフの Items プロパティを ProductRevenue に設定します。Set the Items property of the column chart to ProductRevenue:

    縦棒グラフに、2012 年の売上データが表示されます。The column chart shows the revenue data from 2012:

  4. 縦棒グラフの中央の正方形を選択します。In the column chart, select the center square:

  5. [グラフ] タブで [系列の数] を選択し、数式バーに「3」と入力します。On the Chart tab, select Number of Series, and then enter 3 in the formula bar:

    縦棒グラフに、3 年間にわたる各製品の売上データが表示されます。The column chart shows revenue data for each product over three years: