Xamarin 環境を検証するVerify your Xamarin environment

インストーラーが完了したら (「セットアップとインストール」を参照)、数分をかけて、Xamarin 開発を実行するための準備ができているかどうかを確認します。Once the installers have completed (see Setup and install), spend a few minutes to verify that everything is ready to experience Xamarin development.

これらの確認が終わったら、次のチュートリアルの一方または両方を実行できます。Once you have completed these verifications, you can do either or both of the following walkthroughs:

すべてのプラットフォームAll platforms

最初に、[ツール] > [オプション] を選択し、[Xamarin] > [その他] を展開して、[今すぐ確認] リンクをクリックして更新プログラムを確認します。First, select Tools > Options, expand Xamarin > Other, and click the Check now link for updates. 以前のライセンスの問題を回避するには、Xamarin 4.0.3.214 以降を使用する必要があります。You need to be using Xamarin 4.0.3.214 or later to avoid previous licensing issues.

その後、[ファイル] > [新しいプロジェクト] を使って Visual Studio で新しい Xamarin ソリューションを作成し、ダイアログで [テンプレート] > [他の言語] > [Visual C#] > [クロスプラットフォーム] の順に展開して、[空のアプリ (ネイティブ ポータブル)] を選び、[OK] をクリックします。Then create a new Xamarin solution in Visual Studio using File > New Project, then in the dialog expand Templates > Other Languages > Visual C# > Cross-Platform, select Blank App (Native Portable), and click OK. これによって、共有ポータブル クラス ライブラリ プロジェクトと Android、iOS、Windows の個々のプロジェクトを含むソリューションが作成されます。This creates a solution with a shared portable class library project and individual projects for Android, iOS, and Windows:

空のアプリ (ネイティブ ポータブル) テンプレートから新しいプロジェクトを作成した結果Results of creating a new project from the Blank App (Native Portable) template

注意

テンプレートが表示されない場合は、「Xamarin のプロジェクト テンプレートが見当たりませんか?」を参照してください。次の操作を試してみてください」をこのページの下部でご覧ください。If the templates are not there, see Are the Xamarin project templates missing? Try this at the bottom of this page.

AndroidAndroid

  1. 最新の Android SDK ツールがインストールされていることを確認するには、[ツール] > [Android] > [Android SDK Manager] に移動し、最新バージョンの Android SDK ツール、Android SDK プラットフォーム ツール、Android SDK ビルド ツール コンポーネントがインストールされていることをご確認ください。Check that you have the latest Android SDK tools installed by going to Tools > Android > Android SDK Manager and installing the newest version of the Android SDK Tools, Android SDK Platform-tools, and Android SDK Build-tools components. 最新の Android API レベルを必ずインストールする必要はないことにご注意ください。必要な API は、対象となるプラットフォームのレベルによって異なります。Note that it is not necessary to always install the latest Android API level; the API you need depends on the platform level you want to target. 通常、Xamarin をインストールすると、必要なプラットフォームのレベルがインストールされます。In general, installing Xamarin will install the platform level it requires.

  2. Android デザイナーの検証: Android プロジェクトのソリューション エクスプローラーで、[リソース] > [レイアウト] > [Main.axml] ファイルを開きます Validate the Android designer: in the Android project in Solution Explorer, open the Resources > Layout > Main.axml file. (このファイルが直接参照されない場合、ソリューション エクスプローラーで検索してください。Android プロジェクトにのみ存在し、iOS プロジェクトには存在しません)。(If you aren't seeing this file directly, try searching for it in Solution Explorer; it exists in the Android project only and not in the iOS project.)

    • 「インストールされている Android SDK が古すぎます」というエラーが発生した場合は、そのメッセージ内の [Android SDK を開く] をクリックして、上記の手順 1 に従って利用可能な最新の SDK バージョンを選んでインストールします。If you receive an error saying "The installed Android SDK is too old", click Open Android SDK in that message to select and install the newest SDK version tools available as in step 1 above.
  3. エミュレーター (またはデバイス) でのビルドとデバッグの検証:Validate building and debugging in the emulator (or device):

    • ソリューション エクスプローラーで Android プロジェクトを右クリックして [スタートアップ プロジェクトに設定]をクリックします。Right-click the Android project in Solution Explorer and select Set as Startup Project.

      Visual Studio はスタートアップ プロジェクト オプションとして設定されていますVisual Studio Set as Startup project option

    • 対象の Android バージョンに基づき、適切なエミュレーターを選びます。コンピューターに Android 開発デバイスが接続されている場合は、エミュレーターと共にそれもここに一覧表示されます。Select an appropriate emulator based on your target Android version; if you have an Android development device attached to your computer, you will also see it listed here alongside the emulators:

      • Windows 8+: 次に示すように、Visual Studio のデバッグ ドロップダウン リストで VS エミュレーター のターゲットを選び、F5 キーを押してデバッガーを開始します。Windows 8+: select a VS Emulator target in Visual Studio's debug drop-down as shown below and start the debugger by pressing F5. 詳細については、「Introducing Visual Studio's Emulator for Android」 (Visual Studio ALM ブログ) をご覧ください。For more details, see Introducing Visual Studio's Emulator for Android (Visual Studio ALM blog). エミュレーターを機能させるときに問題が発生する場合は、「 Troubleshooting the Visual Studio Emulator for Android」を参照してください。If you encounter problems getting the emulator to work, see Troubleshooting the Visual Studio Emulator for Android. [ツール] > [Visual Studio Emulator for Android...] を選択して、エミュレーターの新しいデバイス プロファイルを作成することもできます。You can also create new device profiles for the emulator by selecting Tools > Visual Studio Emulator for Android....

        デバッグ ターゲットとして Visual Studio Emulator for Android を選択していますSelecting the Visual Studio Emulator for Android as a debug target

        注: [ツール] > [Visual Studio Emulator for Android...] メニュー オプションが表示されない場合、エミュレーター自体がインストールされていない可能性があります。Note: if you do not see the Tools > Visual Studio Emulator for Android... menu option, you may not have the emulator itself installed. [コントロール パネル] > [プログラムと機能] に移動し、[Microsoft Visual Studio] を選択して、[変更] をクリックすると、インストーラーを再実行できます。Go to Control Panel > Programs and Features, select Microsoft Visual Studio, and click Change to rerun the installer. インストーラーで [変更] をクリックし、[Cross Platform Mobile Development] > [Microsoft Visual Studio Emulator for Android] のボックスにチェックマークを付け、[更新] をクリックします。Click Modify in the installer, check the box for Cross Platform Mobile Development > Microsoft Visual Studio Emulator for Android, and click Update.

      • Windows 7 以前: ドロップダウン リストで Xamarin Player for Android を代わりに選び、F5 キーを押して実行します。For Windows 7 and earlier: select the Xamarin Player for Android in the drop-down instead and press F5 to run. Xamarin プレーヤー、そのデバイス マネージャー、トラブルシューティングのヒントについて詳しくは、「 Xamarin Android Player 」(xamarin.com) をご覧ください。For details on the Xamarin Player, its device manager, and troubleshooting tips, read Xamarin Android Player (xamarin.com).

注意

Visual Studio では、ツール バーに Android エミュレーター マネージャー (AVD) ボタンが表示される場合があります (以下に示します)。これは、特に Google Android エミュレーターを構成するために使用されるデバイス マネージャーを開くものです。In Visual Studio, you may notice the presence of the Android Emulator Manager (AVD) button in the toolbar (show below), which opens the device manager that is specifically used for configuring the Google Android emulator. これは、Visual Studio Emulator for Android と Xamarin Player のどちらにも影響しません。それぞれプロファイルを構成するための独自のデバイス マネージャーを持ちます。This has no impact on either the Visual Studio Emulator for Android or the Xamarin Player, each of which has their own device manager for configuring profiles. 詳しくは、「Introducing Visual Studio's Emulator for Android 」 (Visual Studio ALM ブログ) と「Xamarin Android Player (xamarin.com) の概要」をご覧ください。See Introducing Visual Studio's Emulator for Android (Visual Studio ALM blog) and Xamarin Android Player (xamarin.com) for details.
CrossPlat Xamarin Verify 7CrossPlat Xamarin Verify 7

Windows PhoneWindows Phone

  1. Windows Phone デザイナーの検証: ソリューション エクスプローラーの Windows Phone プロジェクトで、 MainPage.xaml ファイルを開きます。Validate the Windows Phone designer: in the Windows Phone project in Solution Explorer, open the MainPage.xaml file.

  2. エミュレーターまたはデバイスでのビルドとデバッグの検証 (注: このステップでは、Visual Studio セットアップでインストールされた Windows Phone エミュレーターか、テザリングされたデバイスが必要です):Validate building and debugging in the emulator or on a device (note: you will need to have the Windows Phone emulator installed through Visual Studio setup for this step, or a tethered device):

    • ソリューション エクスプローラーで Windows Phone プロジェクトを右クリックして [スタートアップ プロジェクトに設定]をクリックします。Right-click the Windows Phone project in Solution Explorer and select Set as Startup Project.

    • 次に示すように、Visual Studio のデバッグ ドロップダウンで エミュレーター 8.1 のターゲットまたは接続されたデバイスを選び、F5 キーを押してデバッガーを開始します。Select an Emulator 8.1 target or an attached device in Visual Studio's debug drop-down as shown below and start the debugger by pressing F5.

      デバッグ ターゲットとして Windows Phone エミュレーターを選択していますSelecting a Windows Phone emulator as a debug target

    • エミュレーターを機能させる際に問題が発生した場合は、「 Windows Phone 8 エミュレーターのトラブルシューティング」をご覧ください。If you encounter problems getting the emulator to work, read Troubleshooting the Windows Phone 8 Emulator.

iOSiOS

  1. Connecting to the Mac 」(xamarin.com) で説明されているように、ネットワーク上で Mac が利用でき、Visual Studio とペアになっていることを確認してください。Make sure your Mac is available on the network and paired with Visual Studio as described on Connecting to the Mac (xamarin.com).

  2. ストーリーボード デザイナーの検証: ソリューション エクスプローラーの iOS プロジェクトで、 Main.storyboard ファイルを開きます。Validate the storyboard designer: in the iOS project in Solution Explorer, open the Main.storyboard file. ここでは、Visual Studio が Mac でリモート実行されているデザイナーをホストしています。Here, Visual Studio is hosting the designer that's running remotely on the Mac.

  3. ビルドとデバッグの検証:Validate building and debugging:

    1. ソリューション エクスプローラーで iOS プロジェクトを右クリックして [スタートアップ プロジェクトに設定]を選択します。Right-click the iOS project in Solution Explorer and select Set as Startup Project.

    2. 次に示すように、Visual Studio のビルド ドロップダウン リストで iPhoneSimulator のターゲットを選ぶか、テザリングされたデバイスがある場合には、iPhone のターゲットを選びます。Select the iPhoneSimulator target from Visual Studio's build drop-down as shown below, or the iPhone target if you have a tethered device. シミュレーターが表示されていない場合は、Mac で Xcode を起動し、[Xcode] > [ユーザー設定] の順に選び、[ダウンロード] をクリックします。If no simulators are listed, launch Xcode on your Mac, select Xcode->Preferences, and click Download. [コンポーネント] の下に、ダウンロード可能なシミュレーターのバージョンが表示されます。Under Components you should see the simulator versions that are available to download. デバッグに関する詳しい説明については、Xamarin の「デバッグ」ページ (xamarin.com) を参照してください。Additional instructions for debugging can be found on the Xamarin's Debugging page (xamarin.com).

      iPhoneSimulator ビルド ターゲットを選択していますSelecting the iPhoneSimulator build target

    3. 次に示すように、Visual Studio のデバッグ ドロップダウン リストで iPhone のターゲットを選び、F5 キーを押してデバッガーを開始します。Select an iPhone target from Visual Studio's debug drop-down as shown below and start the debugger by pressing F5. これによって、Mac 上のシミュレーターが起動し、Visual Studio でのデバッグ中にアプリを操作できるようになります。This launches the simulator on the Mac where you'll interact with the app, while debugging happens in Visual Studio. iPhone または iPad の実機を Mac に接続した場合は、ここに表示され、代わりに選択できます。If you have a physical iPhone or iPad connected to the Mac, it will appear here and you can select it instead. いずれかのデバイスまたはシミュレーターが一覧に表示されない場合は、上記の手順 1 にあるリンク先のトピックを参照するか、 [ツール] >iOS >[Xamarin Mac エージェント]If you do not see any devices or simulators listed, check the connection to the Mac by reviewing the topic linked in step 1 above, or by going to Tools >iOS >Xamarin Mac Agent

      iPhone デバッグ ターゲットを選択していますSelecting an iPhone debug target

    4. Mac に接続する際に問題が発生した場合は、「 接続のトラブルシューティング 」(xamarin.com) をご覧ください。If you encounter problems connecting to the Mac, read Connection Troubleshooting (xamarin.com).

    5. "インストールされている iOS の署名キーに一致するプロビジョニング プロファイルがインストールされていません" というエラーが表示された場合は、次の操作を行います。If you see an error saying "No installed provisioning profiles match the installed iOS signing keys, do the following:

      • Xcode にアカウントを追加する 」(apple.com) の説明に従って、Mac 上の Xcode に Apple ID アカウントが追加されていることを確認します。Check that your Apple Id account is added in Xcode on your Mac as described on Adding Your Account to Xcode (apple.com). アカウントの追加後、必ず Visual Studio と Xcode の両方を再起動します。After adding your account, be sure to restart both Visual Studio and Xcode.

        CrossPlat Xamarin Verify 8CrossPlat Xamarin Verify 8

      • iOS バンドル署名タブの iOS プロジェクト プロパティで、アクティブなデバッグ構成のカスタム権利フィールドが空であることを確認します。Verify that in your iOS project properties in the iOS bundle signing tab, that the Custom entitlement field is empty for the active debug configuration. 注: 上記のエラー メッセージが表示された場合は、この設定の削除だけを試してみる必要があります。Note: you should only try removing this setting if you've encountered the above error message.

Xamarin プロジェクト テンプレートが見当たりませんか?Are the Xamarin project templates missing? 次の操作を試してみてくださいTry this

Xamarin の Web サイトから直接 Xamarin をインストールして、Visual Studio 2013 と Visual Studio 2015 が同時にインストールされていると、テンプレートが見つからないことがあります。Templates might be missing if you install Xamarin directly from the Xamarin website and you have Visual Studio 2013 and Visual Studio 2015 installed side-by-side. 直すのは簡単: Xamarin セットアップ プログラムで [Xamarin for Visual Studio 2015] 機能を有効にするだけです。It's easy to fix, though: just enable the Xamarin for Visual Studio 2015 feature in the Xamarin setup program.

  1. コントロール パネルで [プログラムと機能]を開き、 [Xamarin] の項目を選択してから [変更]をクリックします。In Control Panel, open Programs and Features, choose the Xamarin item, and click Change.

  2. 表示される Xamarin のセットアップ ウィザードで、 [次へ] をクリックしてから、 [変更]をクリックします。In the setup wizard for Xamarin that appears, click Next and then Change.

  3. インストールするオプション機能の一覧で、 [Xamarin for Visual Studio 2015]を展開し、 [ローカル ドライブにインストールする]を選択し、 [次へ] をクリックして機能の追加に進みます。In the list of optional features to install, expand Xamarin for Visual Studio 2015, choose will be installed on local drive, and click Next to proceed with adding the feature.