セッションに手動で参加するJoin a session manually

コラボレーションセッションに参加するために、ブラウザーでリンクを開くだけでなく、既に実行中のツールにリンクを貼り付けることによって、手動で参加させることができます。In addition to opening a link in a browser to join a collaboration session, you can manually join by pasting the link into an already running tool. これは、通常とは異なるツールを使用する場合や、何らかの理由で、招待リンクの取得に問題がある場合に便利です。This can be useful if you want to use a different tool than you usually do or if you are having trouble with getting invite links to work for some reason.

正確な手順はVisual StudioVisual Studio Codeによって異なります。そのため、詳細については、使用するツールを選択してください。The exact instructions vary between Visual Studio and Visual Studio Code, so pick the tool you intend to use for more information.

Visual Studio Code からの結合Join from Visual Studio Code

1. サインイン1. Sign in

注: コラボレーションセッションを読み取り専用の guesasdsat として参加させる場合は、サインインをスキップできます。Note: If you want to join a collaboration session as a read-only guesasdsat, you can skip signing in. 共有されているが編集できないコードを表示および移動するためのアクセス権があります。You will have access to viewing and navigating around the code that is shared but not be able to make edits.

Web ブラウザーを使用してサインインを求めるトースト通知

共同作業するためには、他のすべてのユーザーに認識されるように、Visual Studio Live Share にサインインする必要があります。In order to collaborate, you'll need sign into Visual Studio Live Share so everyone knows who you are. ステータスバーの [Live Share] をクリックするか、 Ctrl + shift + p/Cmd + shift + pキーを押して、"Live Share: ブラウザーでのサインイン" コマンドを選択します。Click on the "Live Share" status bar item or press Ctrl+Shift+P / Cmd+Shift+P and select the "Live Share: Sign In With Browser" command.

VS Code のサインイン ボタン

サインインを求める通知が表示されている間、ブラウザーが起動します。Your browser will launch while a notification will appear launch asking you to sign in. ブラウザーでのサインイン プロセスが完了したら、ブラウザーを閉じるだけです。Complete the sign in process in your browser, then simply close the browser when done.

成功したサインインを選択せずに VS Code の問題が発生した場合は、ブラウザーの [成功] 画面にある [問題がある] リンクをクリックし、指示に従います。If you are running into problems with VS Code not picking up a successful sign-in, click on the "Having trouble" link on the success screen in the browser and follow the directions. 詳細については、「トラブルシューティング」を参照してください。Check out troubleshooting for more tips.

2. join コマンドを使用する2. Use the join command

VS Code アクティビティバーで Live Share viewlet を開き、[コラボレーションセッションに参加...] を選択します。アイコンまたはエントリ。Open the Live Share viewlet in the VS Code activity bar, and select the "Join collaboration session..." icon or entry.

参加 Viewlet アイコン

注: 読み取り専用のゲストとして参加している場合は、セッションで参加者を識別するのに役立つ表示名を入力するように求められます。Note: If you are joining as a read-only guest, you will then be asked to enter a display name to help participants identify you in the session.

送信した招待 URL を貼り付けて、確認のために Enter キーを押します。Paste in the invite URL you were sent and hit 'Enter' to confirm.

これで完了です。That's it! すぐにコラボレーション セッションに接続されるはずです。You should be connected to the collaboration session momentarily.

Visual Studio からの参加Join from Visual Studio

1. サインイン1. Sign in

インストールが完了したら、Visual Studio を起動してサインインします (まだサインインしていない場合)。Once installed, start Visual Studio and sign in if you have not already. 個人用設定アカウントよりも Visual Studio 用の別のサインインを使用する必要がある場合は、[ツール] > [オプション] > Live Share > ユーザーアカウント]にアクセスしてください。If you need to use a different sign-in for Visual Studio than your personalization account, go to Tools > Options > Live Share > User account.

VS サインイン

まだ問題が解決していませんか?Still having trouble? トラブルシューティング」を参照してください。See troubleshooting.

2. join コマンドを使用する2. Use the join command

[ファイル] > にアクセスしてコラボレーションセッションに参加するだけです。Simply go to File > Join Collaboration Session.

VS 参加メニュー

送信した招待 URL を貼り付けて、確認のために Enter キーを押します。Paste in the invite URL you were sent and hit 'Enter' to confirm.

これで完了です。That's it! すぐにコラボレーション セッションに接続されるはずです。You should be connected to the collaboration session momentarily.

関連項目See also

クイックスタートQuickstarts

方法How-tos

辞書/辞典/その他Reference

問題が発生していますか?Having problems? トラブルシューティングまたはフィードバックの送信に関するページをご覧ください。See troubleshooting or provide feedback.