WinDbg プレビューを使用したデバッグDebugging Using WinDbg Preview

WinDbg プレビューの小さなロゴ

WinDbg プレビューは、最新の外観、高速なウィンドウ、本格的なスクリプトの操作性を備え、拡張可能なデバッガー データ モデルを中心に構築された WinDbg の最新バージョンです。WinDbg Preview is the latest version of WinDbg with more modern visuals, faster windows, a full-fledged scripting experience, built with the extensible debugger data model front and center. WinDbg プレビューは、現行の WinDbg と同じ基本エンジンを使用しているため、使い慣れたすべてのコマンド、拡張機能、ワークフローがこれまでどおり動作します。WinDbg Preview is using the same underlying engine as WinDbg today, so all the commands, extensions, and workflows you're used to will still work as they did before.

WinDbg プレビューの主な機能Major Features of WinDbg Preview

WinDbg プレビューの変更された、または新しい最も重要なものをいくつか以下に示します。Here's some of the most notable things that have changed or are new in WinDbg Preview.

デバッガーのメイン画面

全般的な機能General features

  • より簡単になった接続設定と呼び出し - WinDbg プレビューは、前のセッション構成情報を呼び出す機能を備えています。Easier Connection Setup and Recall - The WinDbg Preview includes the ability to recall previous session configuration information.

デバッガーのメイン画面のスクリーン ショット

  • 簡単なフィードバック チャネル - お客様からのフィードバックは、開発を進める助けになります。Easy feedback channel - Your feedback will guide the development effort going forward. 詳細については、「フィードバックの提供」を参照してくださいFor more information, see Providing Feedback

  • ダンプ ファイル プロセッサ検出 - プロセッサ アーキテクチャを自動検出できるので、デバッグの管理が容易になります。Dump file processor detection -Auto-detects processor architecture for easier managed debugging.

  • パフォーマンスの向上 ウィンドウが非同期で読み込まれるようになり、キャンセルできるようになりました - ユーザーが別のコマンドを実行すると、WinDbg プレビューはローカル、ウォッチ、またはその他のウィンドウの読み込みを停止します。Performance Improvements Windows now load asynchronously and can be canceled - When you run another command, WinDbg Preview will stop the loading of your locals, watch, or other windows.

ウィンドウの機能強化Windowing improvements

  • 逆アセンブリ ウィンドウの機能強化 - 逆アセンブリ ウィンドウも改善されました。現在の命令の強調表示は、スクロールしても元の位置のままになります。Disassembly Window Improvements - The disassembly window is also improved, the highlight of the current instruction remains where it is when you scroll.

    デバッガーの逆アセンブリ ウィンドウ

  • メモリ ウィンドウの機能強化 - メモリ ウィンドウに強調表示機能が加わり、スクロールも改善されました。Memory window improvements - The memory window has highlighting and improved scrolling.

  • ローカルおよびウォッチのデータ モデルの視覚化 - ローカル ウィンドウとウォッチ ウィンドウは、どちらも dx コマンドによって使用されるデータ モデルに基づいて表示されます。Locals and watch data model visualization - The locals and watch windows are both based off of the data model that is used by the dx command. このため、ローカル ウィンドウとウォッチ ウィンドウは、dx コマンドと同様に、ユーザーが読み込んだ任意の NatVis 拡張機能や JavaScript 拡張機能を利用でき、完全な LINQ クエリをサポートすることもできます。This means the locals and watch windows will benefit from any NatVis or JavaScript extensions you have loaded, and can even support full LINQ queries, just like the dx command.

  • ログ - これは、WinDbg プレビュー内部の内部ログです。Logs - This is a under the covers log of the WinDbg Preview internals. これは、トラブルシューティングや長時間実行されるプロセスを監視する目的で表示できます。It can be viewed for troubleshooting or to monitor long running processes.

詳細については、「WinDbg プレビュー - [表示] メニュー」を参照してください。For more information, see WinDbg Preview - View menu.

  • コマンド ウィンドウ - コマンド ウィンドウを使用すると、DML の切り替えや、デバッガー コマンド ウィンドウのクリアを簡単に実行できます。Command window - Use the command window provides easy access to toggle DML and clear the debugger command window. 現在のすべてのデバッガー コマンドは WinDbg プレビューと互換性があり、引き続き WinDbg Preview で動作します。All current debugger commands are compatible with and continue to work in WinDbg Preview.

濃色テーマDark theme

濃色テーマを有効にするには、ファイル > 設定 を使用します。Use File > Settings to enable the dark theme.

濃色テーマを示すスクリーン ショット

リボン クイック アクセスRibbon Quick Access

最もよく使用するボタンをピン留めすることにより、リボンを折りたたんで画面領域を節約できます。Just pin the buttons you use the most and you can collapse the ribbon to save screen real estate.

ピン留めされた項目を含むリボンを示すスクリーンショット

ソース コードSource code

最新のエディターに合うように、ソース コード ウィンドウが更新されました。The source code window has been updated to be much more in line with modern editors.

デバッガーでのソース コード ウィンドウのスクリーンショット

強調表示Highlighting

コマンド ウィンドウに、2 つの新しい強調表示機能が追加されました。The command window has two new highlighting features. 任意のテキストを選択すると、そのテキストの他のすべてのインスタンスがわずかに強調表示されます。Selecting any text will give a subtle highlight to any other instances of that text. 次に、[Highlight/Un-highlight (強調表示/強調表示解除)] または Ctrl + Alt + H を押すと、強調表示を保持できます。You can then hit "Highlight/Un-highlight" or Ctrl+Alt+H to persist the highlighting.

列が黄色で強調表示されていることを示すスクリーン ショット

改善されたキーボード ナビゲーションBetter keyboard navigation

Ctrl + Tab を押すだけで、キーボードだけでウィンドウ間を簡単に移動できます。Just hit Ctrl+Tab and you can easily navigate between windows with just your keyboard.

Ctrl Tab メニューを示すスクリーン ショット

統合された Time Travel Debugging (TTD)Integrated Time Travel Debugging (TTD)

アプリケーションの TTD トレースが必要な場合は、起動時またはアタッチ時に、[Record with Time Travel Debugging](タイム トラベル デバッグで記録) ボックスをオンにするだけです。If you need a TTD trace of your application, just check the "Record with Time Travel Debugging" box when launching or attaching. WinDbgNext がこれを TTD に設定し、記録が完了するとトレースを開きます。WinDbgNext will set it up for TTD and open the trace when you're done recording.

記録するための Notepad プロセスが選択されている、プロセスのレコード メニューを示すスクリーン ショット

詳細については、「Time Travel Debugging - 概要」を参照してください。For more information, see Time Travel Debugging - Overview.

アプリ パッケージのデバッグDebugging App packages

ユニバーサル アプリやバックグラウンド タスクのデバッグを、シングル クリックまたは 1 回の選択操作で実行できるようになりました。Debugging your universal app or background task is now a single click or select.

検索ボックスに「cal」と入力され 3 つのアプリが一覧表示されている [Launch App Package (アプリ パッケージの起動)] の [アプリケーション] タブ

詳細については、「アプリ パッケージの起動」を参照してください。For more information, see Launch App Package.

プロセスへのアタッチAttach to a process

アタッチ ダイアログには詳細が示され、検索ダイアログが含まれており、使いやすくなっています。The attach dialog provides more detail, includes a search dialog and is easier to use.

プロセスへのアタッチのダイアログ

強化されたブレークポイント追跡Enhanced breakpoint tracking

  • ブレークポイントの有効化/無効化 - ブレークポイント ウィンドウに現在のすべてのブレークポイントが表示され、それらを簡単に有効化または無効化できます。Enable/Disable breakpoints - The breakpoints window shows all your current breakpoints and provides easy access to enabling and disabling them.
  • ヒット カウント - ブレークポイント ウィンドウには、ブレークポイントにヒットするたびにそれまでの合計が表示されます。Hit count - The breakpoint window keeps a running total of each time the breakpoint is hit.

詳細については、「ブレークポイント」を参照してください。For more information, see Breakpoints.

強化されたデータ モデルのサポートEnhanced data model support

  • 組み込みデータ モデルのサポート - WinDbg プレビューは、組み込みのデータ モデルがサポートされて作成されており、そのデータ モデルをデバッガーを通じて利用できます。Built in data model support - WinDbg Preview is written with built in data model support and the data model is available through out the debugger.
  • モデル ウィンドウ - モデル ウィンドウを使用すると、dx や dx -g を展開表示することができ、NatVis、JavaScript、LINQ のクエリを基に強力なテーブルを作成できます。Model window - The model window gives you an expandable and browsable version of ‘dx’ and ‘dx -g’, letting you create powerful tables on-top of your NatVis, JavaScript, and LINQ queries.

詳細については、「WinDbg プレビュー - データ モデル」を参照してください。For more information, see WinDbg Preview - Data model.

デバッガーのデータ モデル メニューのスクリーン ショット

新しいスクリプト開発 UINew scripting development UI

  • スクリプト開発 UI - エラーの強調表示と IntelliSense により JavaScript スクリプトや NatVis スクリプトの開発を簡単にする、専用のスクリプト作成ウィンドウが用意されました。Script development UI - There is now a purpose built scripting window to make developing JavaScript and NatVis scripts easier, with error highlighting and IntelliSense.

IntelliSense を表示している、デバッガーのスクリプト作成メニューのスクリーン ショット

詳細については、「WinDbg プレビュー - スクリプト」を参照してください。For more information, see WinDbg Preview - Scripting.

下位互換性Backwards compatibility

基になるデバッガー エンジンは同じなので、従来のデバッガー コマンドやデバッガー拡張機能はすべて引き続き動作します。Because the underling debugger engine is the same, all of the previous debugger commands and debugger extensions continue to work.

フィードバックの提供Providing feedback

お客様からのフィードバックは、WinDbg の開発を進める助けになります。Your feedback will help guide WinDbg's development going forward.

  • 実現を希望される機能や問題の原因となっているバグなどのフィードバックがある場合は、フィードバック Hub をご利用ください。If you have feedback such as a feature that you really want to see or a bug that makes something difficult, use the Feedback Hub.

[新しいフィードバックの追加] ボタンを含むフィードバック オプションを示すフィードバック Hub のスクリーンショット

チーム ブログTeam Blog

デバッガー チームのブログは、現在、非アクティブになっていますが、ヒントとテクニックが含まれています。The debugger team blog, although now inactive, includes tips and tricks. /archive/blogs/windbg//archive/blogs/windbg/

ビデオVideos

デフラグ ツール ショーの次のエピソードから、Windbg プレビューの実際の動作をご覧いただけます。Watch these episodes of the Defrag Tools show to see Windbg Preview in action.

次のステップNext Steps

最新リリースの新機能については、「WinDbg プレビュー - 新機能」を参照してください。For information on what's new in the most recent release, see WinDbg Preview - What's New.

WinDbg プレビューをインストールして構成するには、次のトピックをご確認ください。Review these topics to install and configure WinDbg Preview.

デバッグする環境に接続する方法については、以下のトピックで説明されています。These topics describe how to get connected to the environment that you want to debug.

いくつかの一般的なタスクについては、メニュー タブ別に以下のトピックで説明されています。These topics describe some common tasks, organized by the menu tabs.