Queryoverzicht in Power BI DesktopQuery overview in Power BI Desktop

Met Power BI Desktop kunt u verbinding maken met de wereld van gegevens, overtuigende en gefundeerde rapporten maken en uw resultaten delen met anderen, die verder kunnen bouwen op uw werk en hun business intelligence-activiteiten kunnen uitbreiden.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

U kunt kiezen uit drie weergaven in Power BI Desktop:Power BI Desktop has three views:

  • Rapport: gebruik query's om overtuigende visualisaties te maken, gerangschikt zoals u dat wilt, met meerdere pagina's die u met anderen kunt delenReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Gegevens: bekijk de gegevens in uw rapport in de indeling van een gegevensmodel waarmee u metingen kunt toevoegen, nieuwe kolommen kunt maken en relaties kunt beherenData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Relaties: maak een grafische weergave van de relaties die zijn vastgelegd in uw gegevensmodel, en beheer of wijzig deze zo nodig.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Open deze weergaven door een van de drie pictogrammen aan de linkerkant van Power BI Desktop te selecteren.Access these views by selecting one of the three icons along the left side of Power BI Desktop. In de volgende afbeelding is de weergave Rapport geselecteerd. Dit is te zien aan de gele band naast het pictogram.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Schermopname van Power BI Desktop waarbij de weergave Rapport is geselecteerd.

Power BI Desktop wordt ook geleverd bij Power Query-editor.Power BI Desktop also comes with Power Query Editor. Gebruik Power Query-editor om verbinding te maken met een of meer gegevensbronnen, de gegevens naar behoefte vorm te geven en te transformeren, en dat model vervolgens in Power BI Desktop te laden.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Dit document geeft een overzicht van het werken met gegevens in de Power Query-editor, maar er is meer te leren.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. U vindt aan het einde van dit document koppelingen naar gedetailleerde richtlijnen over ondersteunde gegevenstypen.At the end of this document, you'll find links to detailed guidance about supported data types. Ook vindt u hier informatie over het maken van verbinding met gegevens, het vormgeven van gegevens, het maken van relaties en hoe u kunt beginnen.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Maar laten we eerst kennismaken met Power Query-editor.But first, let's see get acquainted with Power Query Editor.

Power Query-editorPower Query Editor

Selecteer Query's bewerken op het tabblad Start van Power BI Desktop om Power BI-editor te openen.To get to Power Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Schermopname van Power BI Desktop met het tabblad Start van de Power Query-editor.

Zonder gegevensverbindingen wordt Power Query-editor weergegeven als een leeg venster dat gereed is voor gegevens.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Schermopname van Power BI Desktop met de Power Query-editor zonder gegevensverbindingen.

Nadat een query is geladen, wordt het venster van Power Query-editor een stuk interessanter.Once a query is loaded, Power Query Editor view becomes more interesting. Als we verbinding maken met de volgende webgegevensbron, wordt er in Power Query-Editor informatie over de gegevens geladen. Vervolgens kunt u deze gaan vormgeven:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Power Query-editor ziet er ongeveer als volgt uit zodra een gegevensverbinding tot stand is gebracht:Here's how Power Query Editor appears once a data connection is established:

  1. In het lint zijn veel knoppen actief om de gegevens in de query te gebruiken.In the ribbon, many buttons are now active to interact with the data in the query.

  2. In het linkerdeelvenster worden query's vermeld die beschikbaar zijn om te worden geselecteerd, weergegeven en vormgegeven.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. In het middelste deelvenster worden gegevens uit de geselecteerde query weergegeven en geactiveerd voor weergave.In the center pane, data from the selected query is displayed and available for shaping.

  4. Het deelvenster Queryinstellingen wordt weergegeven, waarin de eigenschappen van de query en de toegepaste stappen worden weergegeven.The Query Settings pane appears, listing the query's properties and applied steps.

    Schermopname van Power BI Desktop met waarin het deelvenster Queryinstellingen in de Power Query-editor wordt weergegeven.

We kijken naar elk van deze vier gebieden: het lint, het deelvenster Query's, de weergave Gegevens en het deelvenster Queryinstellingen.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Het lint in Query-editorThe query ribbon

Het lint in Power Query-editor bestaat uit vier tabbladen: Start, Transformeren, Kolom toevoegen en Weergave.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

Het tabblad Start bevat de algemene querytaken.The Home tab contains the common query tasks.

Schermopname van Power BI Desktop met het querylint van de Power Query-editor.

Selecteer Nieuwe bron om een verbinding met gegevens te maken en te beginnen met het opbouwen van een query.To connect to data and begin the query building process, select New Source. Er verschijnt een menu met de meestvoorkomende gegevensbronnen.A menu appears, providing the most common data sources.

Schermopname van Power BI Desktop met de knop Nieuwe bron.

Zie Gegevensbronnen voor meer informatie over beschikbare gegevensbronnen.For more information about available data sources, see Data Sources. Zie Verbinding maken met gegevens voor meer informatie over het maken van verbindingen met gegevens, inclusief voorbeelden en stappen.For information about connecting to data, including examples and steps, see Connect to Data.

Het tabblad Transformeren biedt toegang tot algemene taken voor gegevenstransformatie, zoals:The Transform tab provides access to common data transformation tasks, such as:

  • Kolommen toevoegen of verwijderenAdding or removing columns
  • Gegevenstypen wijzigenChanging data types
  • Kolommen splitsenSplitting columns
  • Andere gegevensgestuurde takenOther data-driven tasks

Schermopname van Power BI Desktop met de knop Start.

Zie voor meer informatie over het transformeren van gegevens, inclusief voorbeelden, Zelfstudie: Gegevens vormgeven en combineren in Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

Het tabblad Kolom toevoegen bevat aanvullende taken die zijn gekoppeld aan het toevoegen van een kolom, het opmaken van kolomgegevens en het toevoegen van aangepaste kolommen.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. De volgende afbeelding toont het tabblad Kolom toevoegen.The following image shows the Add Column tab.

Schermopname van Power BI Desktop met het tabblad Kolom toevoegen.

Het tabblad Weergeven van het lint wordt gebruikt om te bepalen of bepaalde deelvensters of vensters worden weergegeven.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Het wordt ook gebruikt om de geavanceerde editor weer te geven.It's also used to display the Advanced Editor. De volgende afbeelding toont het tabblad Weergeven.The following image shows the View tab.

Schermopname van Power BI Desktop met het tabblad Weergeven.

Veel taken in het lint zijn overigens ook beschikbaar door met de rechtermuisknop te klikken op een kolom, of andere gegevens, in het middelste deelvenster.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Het linkerdeelvenster (Query's)The left (Queries) pane

In het linkerdeelvenster of het deelvenster Query's wordt het aantal actieve query's en de naam van de query weergegeven.The left pane, or Queries pane, displays the number of active queries and the name of the query. Wanneer u een query selecteert in het linkerdeelvenster, worden de bijbehorende gegevens weergegeven in het middelste deelvenster, waar u de gegevens naar behoefte kunt vormgeven en transformeren.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. De volgende afbeelding toont het linkerdeelvenster met een query.The following image shows the left pane with a query.

Schermopname van Power BI Desktop waarin Query's in het linkerdeelvenster wordt weergegeven.

Het middelste deelvenster (Gegevens)The center (Data) pane

In het middelste deelvenster, het deelvenster Gegevens, worden de gegevens van de geselecteerde query weergegeven.In the center pane, or Data pane, data from the selected query is displayed. In dit deelvenster worden veel taken van de queryweergave uitgevoerd.This pane is where much of the work of the Query view is accomplished.

In de volgende afbeelding ziet u de verbinding met de webgegevens die eerder tot stand is gebracht.In the following image shows the Web data connection established earlier. De kolom Product is geselecteerd en er is met de rechtermuisknop op de kolomkop geklikt om de beschikbare menu-items weer te geven.The Product column is selected, and its header is right-clicked to show the available menu items. U ziet dat veel van deze snelmenu-items hetzelfde zijn als knoppen in de linttabbladen.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Schermopname van Power BI Desktop waarin het item Gegevens in het middelste deelvenster wordt weergegeven.

Als u een snelmenu-item (of een knop op het lint) selecteert, past de query de stap toe op de gegevens.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Ook wordt de stap opgeslagen als onderdeel van de query zelf.It also saves step as part of the query itself. De stappen worden vastgelegd in het deelvenster Query-instellingen in sequentiële volgorde, zoals beschreven in de volgende sectie.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Het rechterdeelvenster (Query-instellingen)The right (Query Settings) pane

In het rechterdeelvenster, of het deelvenster Query-instellingen, worden alle stappen weergegeven die zijn gekoppeld aan een query.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Zo ziet u in de volgende afbeelding van de sectie Toegepaste stappen van het deelvenster Query-instellingen dat we zojuist het type van de kolom Totale score hebben gewijzigd.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Schermopname van Power BI Desktop waarin het item Queryinstellingen in het rechterdeelvenster wordt weergegeven.

Als u aanvullende vormgevingsstappen toepast op de query, worden deze vastgelegd in de sectie Toegepaste stappen.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Het is belangrijk te weten dat de onderliggende gegevens niet zijn gewijzigd.It's important to know that the underlying data isn't changed. In plaats daarvan wordt de weergave van de gegevens in Power Query-editor aangepast en beïnvloed.Rather, Power Query Editor adjusts and shapes its view of the data. Ook wordt de weergave van elke interactie met de onderliggende gegevens die plaatsvinden op basis van de gewijzigde en aangepaste weergave van Power Query-editor van die gegevens beïnvloed en aangepast.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

In het deelvenster Query-instellingen kunt u de namen van stappen wijzigen, stappen verwijderen of de volgorde van de stappen naar wens aanpassen.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Hiertoe klikt u met de rechtermuisknop op een stap in de sectie Toegepaste stappen en kiest u een optie in het snelmenu.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. De querystappen worden uitgevoerd in de volgorde waarin ze worden weergegeven in het deelvenster Toegepaste stappen.All query steps are carried out in the order they appear in the Applied Steps pane.

Schermopname van Power BI Desktop met de filters Eigenschappen en Toegepaste stappen van queryinstellingen.

Geavanceerde editorAdvanced Editor

Met de Geavanceerde editor kunt u de code zien die Power Query-editor maakt bij elke stap.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. U kunt ook uw eigen bepalende code maken.It also lets you create your own shaping code. Om de geavanceerde editor te starten, selecteert u Weergave in het lint en vervolgens Geavanceerde Editor.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Er verschijnt een venster met de bestaande querycode.A window appears, showing the existing query code.
Schermopname van Power BI Desktop met het dialoogvenster Geavanceerde editor.Screenshot of Power B I Desktop showing Advanced Editor dialog box.

U kunt de code rechtstreeks bewerken in het venster Geavanceerde editor.You can directly edit the code in the Advanced Editor window. Om het venster te sluiten, selecteert u knop Gereed of Annuleren.To close the window, select the Done or Cancel button.

Uw werk opslaanSaving your work

Als uw query zich op de gewenste plek bevindt, selecteert u Sluiten en toepassen in het menu Bestand in Power Query-editor.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Met deze actie worden de wijzigingen toegepast en wordt de editor gesloten.This action applies the changes and closes the editor.
Schermopname van Power BI Desktop met de optie Sluiten en toepassen onder het tabblad Bestand.Screenshot of Power B I Desktop showing Close and Apply option under File tab.

In Power BI Desktop wordt de voortgangsstatus in een dialoogvenster aangegeven.As progress is made, Power BI Desktop provides a dialog to display its status.
Schermopname van Power BI Desktop met het bevestigingsvenster Toegepaste querywijzigingen.

Als u klaar bent, kan Power BI Desktop uw werk opslaan in de vorm van een pbix-bestand.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Als u uw werk wilt opslaan, kiest u Bestand > Opslaan (of Bestand > Opslaan als), zoals wordt weergegeven in de volgende afbeelding.To save your work, select File > Save (or File > Save As), as shown in the following image.
Schermopname van Power BI Desktop met het tabblad Bestand van de Power Query-editor.Screenshot of Power B I Desktop showing Power Query Editor File tab.

Volgende stappenNext steps

U kunt allerlei handelingen uitvoeren met Power BI Desktop.There are all sorts of things you can do with Power BI Desktop. Bekijk de volgende bronnen voor meer informatie over de vele mogelijkheden:For more information on its capabilities, check out the following resources: