Skrypty po stronie klienta nie działają już w Microsoft Dynamics CRM Online po aktualizacji usługi z grudnia 2012 r.

Ten artykuł pomaga naprawić błędy skryptów po zaktualizowaniu organizacji Microsoft Dynamics CRM Online do aktualizacji usługi z grudnia 2012 r.

Dotyczy: Microsoft Dynamics CRM Online
Oryginalny numer KB: 2804561

Symptomy

Jeśli formularze korzystają z interfejsu API klienta w wersji 4.0 (crmForm), po zaktualizowaniu organizacji Microsoft Dynamics CRM Online do aktualizacji usługi z grudnia 2012 r. mogą wystąpić błędy skryptów. Może zostać wyświetlone okno dialogowe z komunikatem "Niezdefiniowane" lub może zostać wyświetlony błąd w lewym dolnym rogu formularza z komunikatem "Błąd na stronie". Mogą pojawić się inne różne błędy skryptu.

Przyczyna

Aktualizacja usługi dla Microsoft Dynamics CRM z grudnia 2012 r. wprowadziła nowe ustawienie systemowe, które określa, czy składniki HTML (HTC) są zawarte w formularzach Microsoft Dynamics CRM. To ustawienie jest domyślnie wyłączone w Microsoft Dynamics CRM Online.

Następujące właściwości crmForm wymagają aplikacji HTC:

Właściwości programu CrmForm
. Zapisz(
. SaveAndClose(
. Typ formularza
. ObjectTypeCode
. Objectid
. ObjectTypeName
. RequiredLevel
. SetFocus(
. FireOnChange
. Min
. Max
. Datavalue
.Isdirty
. Wyłączone
. SelectedOption
. Selectedtext
. SortingEnum
. Sortowania
. Selectedindex
. Innertext
. OptionsXml
. Precyzji
. DataXml
. Tekst
. Wartość
. DisplayValue
. WillSubmit
. DataChangeHandler
. BypassValidation
. AllowFormFocus
._bSaving
._htcInitCompleted
. SubmitFormId
.NO_DATA
. RefreshOnSave
. Widoczne
. ForceSubmit
. Formularza
. TimeControl
.Isinitialized
.allowblankdate
. IsMoney
. IsBaseCurrency
. CurrencySymbol
. WalutaPrecision
. IgnoreCurrencySymbol
. IgnoreRange
. PrecisionChangeHandler
. TrimValue
. Maxlength
Moduł wyliczający

Rozwiązanie

  1. Zaloguj się do aplikacji internetowej Microsoft Dynamics CRM jako administrator systemu.
  2. Kliknij pozycję Ustawienia, kliknij pozycję Administracja, a następnie kliknij pozycję Ustawienia systemowe.
  3. Kliknij kartę Dostosowywanie .
  4. Kliknij pole wyboru obok ustawienia Dołącz obsługę aplikacji HTC w formularzach Microsoft Dynamics CRM.
  5. Kliknij przycisk OK.

Więcej informacji

Interfejs API crmForm został przestarzały w wersji Microsoft Dynamics CRM 2011. Aby uzyskać więcej informacji na temat tego tematu i innych potencjalnych przyczyn błędów skryptu po aktualizacji usługi z grudnia 2012 r., zobacz następujące wpisy w blogu: