2022Logoinformacje o wersji 17.2 Visual Studio 2022


Porada

Obejrzyj nagrania wydarzenia startowego Visual Studio 2022, aby dowiedzieć się, co nowego, usłyszeć wskazówki dotyczące porad & i pobrać bezpłatny cyfrowy swag.

| Developer Community Visual Studio 2022 Plan | wymagania systemowe Wymagania | systemoweZgodnośćKod | dystrybucyjny | Postanowienia | licencyjneBlogi | najnowsze znane problemy | Whats New w Visual Studio Docs


Kliknij przycisk, aby pobrać najnowszą wersję Visual Studio 2022. Aby uzyskać instrukcje dotyczące instalowania i aktualizowania Visual Studio 2022, zobacz Update Visual Studio 2022 do najnowszej wersji. Ponadto zobacz instrukcje na temat sposobu instalowania w trybie offline.

Download Community ButtonDownload Professional ButtonDownload Enterprise Button

Odwiedź stronę visualstudio.microsoft.com/downloads, aby pobrać inne produkty Visual Studio 2022.


Visual Studio 2022 w wersji 17.2

wydania Visual Studio 2022 w wersji 17.2


17.2.5Visual Studio 2022 w wersji 17.2.5

wydany 22 czerwca 2022 r.

Problemy rozwiązane w tej wersji 17.2.5

  • Usunięto usterkę w środowisku uruchomieniowym VC++ z uszkodzonymi linkami dla kontenerów MFC OLE Linking/Embedding
  • Rozwiązano problem polegający na tym, że instalacja programu SxS w programach VS2022 i VS2015 (lub starszych) powodowała niepowodzenie skanowania rozszerzeń w programie VS.
  • Ulepszona walidacja nazw kontenerów podczas aprowizacji usługi Azure Container Apps.

Zgłaszane na forum Developer Community

17.2.4Visual Studio 2022 w wersji 17.2.4

wydany 14 czerwca 2022 r.

Problemy rozwiązane w tej wersji 17.2.4

  • Zaktualizowano zestaw narzędzi Dewelopera 16.11 C++ do wersji 14.29.30145.00. Najnowsza wersja zestawu narzędzi Dewelopera 16.11 języka C++ zawiera ważne poprawki błędów, w tym naprawianie wszystkich pozostałych raportów o usterkach języka C++20. Aby uzyskać informacje o poprawkach błędów, w tym raportach o błędach języka C++20 w programie Dev 16.11, zobacz https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes#16.11.14
  • Rozwiązano problem polegający na tym, że potencjalne zawieszenie przy pierwszym ładowaniu pakietu (po zastosowaniu ustawień tego pakietu za pośrednictwem usługi DTE). Właściwości) lub w innych scenariuszach korzystających z DTE. Właściwości

Zgłaszane na forum Developer Community

Porady dotyczące zabezpieczeń


17.2.3Visual Studio 2022 w wersji 17.2.3

wydany 31 maja 2022 r.

Problemy rozwiązane w tej wersji 17.2.3

  • Dodaje zestaw SDK Windows (10.0.22621) dla Windows 11 w wersji 22H2 jako składnik opcjonalny w instalatorze Visual Studio.
  • Rozwiązano problem polegający na tym, że kliknięcie przycisku "Utwórz żądanie ściągnięcia" nie powodowało otwarcia przeglądarki na stronie tworzenia żądania ściągnięcia dostawcy hostingu.
  • Dodaje powiadomienie, gdy usługa Git wykryje niebezpieczne repozytorium i umożliwia oznaczenie repozytorium jako bezpieczne.

Zgłaszane na forum Developer Community


17.2.2Visual Studio 2022 w wersji 17.2.2

wydany 24 maja 2022 r.

Problemy rozwiązane w tej wersji 17.2.2

  • Naprawiono awarię kreatora pakietów i publikowania podczas pracy z projektami WinUI przeznaczonymi dla wersji 1.1.0 Windows App SDK.

Zgłaszane na forum Developer Community


17.2.1Visual Studio 2022 w wersji 17.2.1

wydany 17 maja 2022 r.

Problemy rozwiązane w tej wersji 17.2.1

  • Naprawiono ostrzeżenia fałszywie dodatnie C26828 w typach wyliczenia języka C++ z nakładającymi się wartościami.
  • Naprawiono niepoprawne raportowanie błędów narzędzia AddressSanitizer podczas scenariuszy, w których pamięć jest przydzielana przed zainicjowaniem usługi ASAN.

Zgłaszane na forum Developer Community


Co nowego w programie Visual Studio 2022 w wersji 17.2.0

blog Visual Studio 2022

Blog Visual Studio 2022 jest oficjalnym źródłem szczegółowych informacji o produkcie od zespołu inżynierów Visual Studio. Szczegółowe informacje na temat wydań Visual Studio 2022 można znaleźć w następujących wpisach:

Ramy czasowe pomocy technicznej

Visual Studio 2022 w wersji 17.2 jest drugim obsługiwanym długoterminowym kanałem obsługi dla Visual Studio 2022 r. Zachęcamy klientów korzystających z wersji Enterprise i Professional, którzy muszą wdrożyć długoterminowe, stabilne i bezpieczne środowisko programistyczne do standaryzacji do tej wersji.  Jak wyjaśniono bardziej szczegółowo w naszych zasadach cyklu życia i pomocy technicznej, wersja 17.2 będzie obsługiwana z poprawkami i aktualizacjami zabezpieczeń przez 18 miesięcy do stycznia 2024 r.

Najnowszą najbezpieczniejszą wersję programu Visual Studio 2022 w wersji 17.2 można uzyskać w sekcji pobierania my.visualstudio.com lub katalogu Microsoft. Aby uzyskać więcej informacji na temat Visual Studio obsługiwanych kanałów, zapoznaj się z zasadami pomocy technicznej dotyczącymi Visual Studio 2022 r.

Visual Studio 2022 — zarchiwizowane informacje o wersji


Instalator

  • W wersji 17.2 rozwiązano problem uniemożliwiający klientom instalowanie Visual Studio z powodu ustawienia zasad obiektu zasad grupy w rejestrze systemowym. Visual Studio będzie teraz działać tak samo, jak funkcja WebView2 w odniesieniu do tej instalacji.

Edytor

  • Visual Studio można teraz automatycznie zapisywać dokumenty kodu za każdym razem, gdy aplikacja traci fokus. Dostęp do tej funkcji można uzyskać za pośrednictwem dokumentu środowiska > Opcji > narzędzi>. Jeśli jest zaznaczona opcja "Automatyczne zapisywanie", Visual Studio spróbuje zapisać wszystkie brudne dokumenty kodu za każdym razem, gdy aplikacja Visual Studio utraci fokus (np. podczas przełączania do innej aplikacji w Windows).

C++

  • W wersji 17.1 wprowadziliśmy widoki rejestracji urządzeń peryferyjnych i rtos dla deweloperów osadzonych. Nadal ulepszamy możliwości tych widoków dzięki ulepszeniom użyteczności w wersji 17.2. Użytkownicy mogą teraz kliknąć ikonę pinezki obok urządzeń peryferyjnych, rejestrów lub pól, aby przypiąć je w górnej części widoku peryferyjnego.
  • Dodano obsługę kompilatora dla funkcji języka C++23, która jest dostępna pod flagą /std:c++latest .
  • Dodano nazwę parametru wbudowanego i obsługę wskazówek typów, przełączane przez naciśnięcie klawiszy Alt+F1 lub dwukrotne naciśnięcie klawiszy Ctrl. To zachowanie można dostosować w obszarze Narzędzia > Opcje Edytory > tekstów C/C++ >> IntelliSense. Inline parameter name and type hints
  • Dodano obsługę eksperymentalną modułów języka C++20 w projektach CMake. Jest to obecnie dostępne tylko w przypadku generatora Visual Studio (MSBuild).
  • Dodano obsługę IntelliSense dla funkcji języka C++23, które deducing to i w przypadku ograniczenia.
  • W wersji 17.1 wprowadziliśmy widoki rejestrowania urządzeń peryferyjnych i RTOS dla deweloperów osadzonych. Nadal ulepszamy możliwości tych widoków dzięki ulepszeniom użyteczności w wersji 17.2:
    • Okno narzędzia RTOS jest teraz domyślnie ukryte. Zapobiega to wyświetlaniu okna narzędzia z komunikatami o błędach, które nie są istotne, gdy system RTOS nie jest używany.
    • Gdy użytkownik dwukrotnie kliknie obiekt RTOS w oknie narzędzia, doda zegarek dla obiektu.
    • Gdy użytkownik wybierze wartości początkowe/końcowe wskaźnika stosu w oknie narzędzia RTOS, zostanie otwarty w oknie pamięci.
    • Dodano rozpoznawanie wątków dla elementów docelowych urządzeń w oknie stosu wywołań.
  • Dodano implementację pozostałych raportów błędów C++20 (a.k.a. backports). Wszystkie funkcje języka C++20 są teraz dostępne w przełączniku /std:c++20. Aby uzyskać więcej informacji na temat wdrożonych backportów, zobacz projekt C++20 Defect Reports w repozytorium microsoft/STL GitHub i ten wpis w blogu
  • Dodano różne wyczyny biblioteki C++23 dostępne pod flagą /std:c++latest . Aby uzyskać szczegółowe informacje o nowych funkcjach, zobacz dziennik zmian repozytorium STL
  • Zwiększona wydajność początkowego indeksowania języka C++ przez maksymalnie 20%, w zależności od głębokości wykresu dołączania.

Narzędzia git

  • Ulepszone środowisko przemieszczania liniowego, umożliwiając pracę linii etapowej w różnych trybach różnic (obok siebie, śródwierszowy, lewy, prawy widok).
  • Polecenia etapu i cofania na pasku narzędzi podglądu działają teraz na docelowym fragmentie.
  • Dodano możliwość włączenia funkcji Git commit-graph w celu uzyskania lepszej historii i wydajności operacji usługi Git.
  • Ulepszono interaktywne przemieszczanie przez dodanie obsługi przemieszczania poszczególnych wierszy kodu bezpośrednio z poziomu edytora i widoku różnic.
  • Ulepszono środowisko wyewidencjonowania gałęzi, czyli przełączanie gałęzi, dodając więcej opcji i kontekstu, gdy zmiany nie zostały zatwierdzone.
  • Ulepszono odłączone środowisko HEAD, zapewniając opcję przechowywania lub odrzucania zatwierdzeń podczas przełączania do gałęzi.
  • Dodano opcję dołączania szablonu licencji podczas tworzenia nowego repozytorium.
  • Obsługa przemieszczania liniowego, czyli interaktywnego przemieszczania z możliwością etapowania określonych wierszy i/lub fragmentów kodu bezpośrednio z poziomu edytora i widoku różnic.
  • Azure DevOps ulepszenia wykrywania połączeń ułatwiają powiązane elementy robocze do zatwierdzeń.
  • Visual Studio teraz używa 64-bitowego narzędzia Git dla Windows.

Narzędzia do testowania

  • Teraz możesz użyć szybszego okna pokrycia kodu z bardziej elastycznymi kolumnami w celu organizowania i zapisywania widoku. Ulepszenia środowiska pokrycia kodu można włączyć w obszarze Narzędzia > Opcje > środowiska > w wersji zapoznawczej funkcji.
  • Testowanie zdalne obsługuje teraz przebiegi testowe w środowiskach zdalnego systemu Windows arm64.
  • Znaczące ulepszenia pełnej funkcjonalności testów jednostkowych na żywo są dostępne w ramach flagi funkcji w wersji zapoznawczej, w tym:
    • Obsługa większej liczby rozwiązań poza urządzeniem niż wcześniej
    • Lepsza obsługa dużych rozwiązań
    • Lepsze domyślne zachowanie pracy z dużymi zestawami testów
    • Lepsze możliwości anulowania przebiegów testów w toku
    • Więcej opcji konfiguracji za pomocą nowego kreatora testów jednostkowych na żywo i pliku Lutignore
    • Włącz to nowe środowisko kompilacji live Unit Testing w obszarze Narzędzia > Opcje > środowiska > w wersji zapoznawczej i przeczytaj nasz wpis w blogu , aby dowiedzieć się więcej.
  • Zapoznamy się również z bardziej zaawansowanym paskiem postępu testu, który zawiera więcej szczegółów na temat tego, gdzie eksplorator testów znajduje się w procesie wykonywania testów z aktualizacjami na żywo.

Produktywność platformy .NET

  • Teraz udostępniamy osadzone źródło i Source Link w ramach funkcji Przejdź do implementacji, jeśli przywołyny zestaw ma osadzone źródło lub Source Link. Umożliwia to przejście do oryginalnych plików źródłowych, które implementują symbol docelowy.
  • Na platformie .NET 7 dodaliśmy nowy atrybut o nazwie StringSyntaxAttribute , który umożliwi nam określenie, jakiego rodzaju dane reprezentuje ciąg, taki jak JSON, Regex lub DateTime. Dodaliśmy obsługę tego atrybutu, aby uzyskać wyróżnianie składni dla nowego elementu StringSyntaxAttribute dla formatu JSON.
  • Dodaliśmy komunikat diagnostyczny dla nowego ciągu JSON StringSyntaxAttribute, gdy w literału obiektu występuje niewłaściwy literał ciągu, aby powiedzieć, że dwukropek jest oczekiwany.
  • Teraz mamy refaktoryzację, która opakowuje kolekcję inicjatorów zarówno dla Visual Basic, jak i C#.
  • Teraz obsługujemy języki osadzone dla nowych literałów nieprzetworzonych ciągów języka C# 11. Aby użyć literałów nieprzetworzonych ciągów, ustaw wersję języka w pliku projektu na podgląd: <LangVersion>preview</LangVersion>.
  • Code Analysis w tle ma teraz więcej opcji konfiguracji w obszarze Opcje narzędzi>, dzięki czemu można ustawić zakres diagnostyczny tak, None aby wyłączyć Code Analysis w tle.
  • Oczyszczanie kodu obsługuje teraz wszystkie opcje stylu kodu.
  • Szybkie informacje będą teraz wyświetlane podpisy anonimowych delegatów.
  • Istnieje nowa zmiana w kompilatorze, która nie zezwala na konstruktory bez parametrów wewnątrz struktur. Dodaliśmy nową poprawkę kodu, która spowoduje automatyczne naprawienie tego problemu.
  • Na platformie .NET 7.0 dodaliśmy nowy atrybut o nazwie StringSyntaxAttribute , który umożliwi nam określenie, jakiego rodzaju dane reprezentuje ciąg, taki jak JSON, Regex lub DateTime. Dodaliśmy obsługę tej funkcji, aby uzyskać wyróżnianie składni w Visual Studio na podstawie typu danych, które reprezentuje ciąg.
  • Dwukrotne kliknięcie wbudowanego parametru lub wskazówek typu spowoduje teraz wstawienie nazw parametrów lub typów.
  • Dodaliśmy nową refaktoryzację, która usuwa niepotrzebne wyrażenia lambda i bezpośrednio wywołuje grupę metod. Umieść kursor na niepotrzebnej lambda. Naciśnij klawisze Ctrl+. aby wyzwolić menu Szybkie akcje i refaktoryzacje. Wybierz pozycję Usuń niepotrzebne wyrażenie lambda.
  • W języku C# 11 dodajemy nową funkcję języka o nazwie nieprzetworzone literały ciągów. Teraz mamy refaktoryzację, aby przekonwertować zwykły lub dosłowny literał ciągu na nieprzetworzone literał ciągu. Aby użyć literałów nieprzetworzonych ciągów, ustaw wersję języka w pliku projektu na podgląd: <LangVersion>preview</LangVersion>. Umieść kursor na normalnym lub dosłownym ciągu. Naciśnij klawisze Ctrl+. aby wyzwolić menu Szybkie akcje i refaktoryzacje. Wybierz pozycję Konwertuj na nieprzetworzone ciągi. Convert to raw string

Edytor Razor (ASP.NET Core)

  • Nowy edytor Razor wyświetla teraz kolory wbudowane dla kolorów dokumentu tekstowego.
  • Nowy edytor Razor obsługuje teraz możliwość zwijania regionów.
  • Nowy edytor Razor obsługuje teraz skrót "zawijanie div" Shift+Alt+W.

IntelliCode

  • W przypadku wersji 17.1 funkcja IntelliCode zaczęła sugerować szybkie akcje dla języka C# na podstawie intencji użytkownika na liście IntelliSense. W przypadku wersji 17.2 są one teraz wyświetlane jako automatycznie sugerowany kod wyświetlany w edytorze podczas wpisywania.
  • W przypadku wersji 17.2 sugestie funkcji IntelliCode dotyczące powtarzających się edycji są również wyświetlane jako kod sugerowany automatycznie, gdy sugerowana edycja obejmuje tylko dodawanie kodu. Dotyczy to zarówno edycji obejmujących pojedyncze wiersze, jak i wiele wierszy.

Narzędzia kontenerów

  • Teraz można dodać obsługę orkiestracji kontenerów Docker Compose do projektu Azure Functions i debugować go lokalnie.
  • Dodaliśmy obsługę platformy .NET 7.

Debugowanie platformy .NET za pomocą programu WSL

  • Ulepszone rozwiązywanie problemów z konfiguracją, w tym automatyczna instalacja programu WSL.

Service Fabric

  • Dodaliśmy obsługę platformy .NET 7.

narzędzia SQL Server Data Tools

Narzędzia internetowe

  • Tworzenie nowych projektów funkcji platformy Azure jest teraz w pełni zintegrowane z ogólnym oknom dialogowym Nowy Project umożliwiającym wybranie i skonfigurowanie wyzwalaczy funkcji platformy Azure bez konieczności korzystania z dodatkowego okna dialogowego. Uzyskasz również opcję utworzenia pliku dockerfile w ramach tworzenia projektu. Gdy potrzebna jest dalsza konfiguracja za pośrednictwem usług połączonych, środowisko nawiguje po Tobie i prowadzi Cię przez pozostałe kroki.
  • Teraz możesz połączyć aplikację z usługą PostgreSQL (Postgres — oficjalny obraz | Docker Hub), MongoDB (Mongo — oficjalny obraz | Docker Hub) i SQLite (źródło danych=Sqllite.db) za pośrednictwem środowiska połączonych usług
  • Ostrzeżenia pochodzące z szkieletu zakodowane i jego właściwości nienależące do wartości null będą domyślnie ukryte przez dodanie właściwości "Nullable" z wartością "adnotacje" w odpowiednim pliku csproj.
  • Okno dialogowe Dodawanie zależności w usługach połączonych oferuje teraz środowisko wyszukiwania.

Ogólne

  • Ulepszona obsługa serwera proxy dzięki wykrywaniu, gdy użytkownicy znajdują się za serwerem proxy i proaktywnie monitują o poświadczenia, gdy Visual Studio musi uzyskać dostęp do zasobów online

narzędzia programistyczne Microsoft Teams

  • Szablon projektu aplikacji Microsoft Teams został ulepszony i teraz tworzy pliki konfiguracji spójne z interfejsem wiersza polecenia teamsfx, w tym folderem .fx.
    • Zalecamy utworzenie nowego projektu przy użyciu zaktualizowanego szablonu dla wszystkich istniejących aplikacji Teams utworzonych przy użyciu poprzednich wersji zestawu narzędzi Teams Toolkit.
  • Usunęliśmy wybór konta i automatyczną rejestrację zasobów Teams z szablonu projektu aplikacji Microsoft Teams.
    • Teraz możesz wybrać, kiedy zalogować się przy użyciu tożsamości usługi M365 i zarejestrować zasoby aplikacji przy użyciu opcji menu Project Teams > Toolkit Configure Microsoft Teams App (Konfigurowanie menu aplikacji Microsoft Teams).>
    • Aktualizacje do plików manifest.*.template.json można zsynchronizować z Teams Portal deweloperów, wybierając ten element menu ponownie w dowolnym momencie.
  • Teraz możesz tworzyć i debugować boty dla Microsoft Teams.
    • Utwórz nowy projekt przy użyciu szablonu projektu aplikacji Microsoft Teams i wybierz pozycję Możliwości bota.
    • Użyj menu Project Teams > Toolkit > Configure Microsoft Teams app (Konfigurowanie aplikacji Microsoft Teams), aby zarejestrować aplikację i bota.
  • Teraz możesz tworzyć zasoby dla kart i botów w ramach subskrypcji platformy Azure.
    • Użyj Project Teams > Toolkit > Provision w menu Chmura, aby utworzyć zasoby w subskrypcji.
    • Użyj menu Project Teams Toolkit Deploy to the Cloud (Wdrażanie zestawu narzędzi > Project > w chmurze), aby opublikować kod w tych zasobach.
  • Zasoby hostowane zdalnie można otwierać w przeglądarce utworzonej z menu Aprowizuj przy użyciu menu Podgląd Teams aplikacji.

Debugowania &Diagnostyka debugowania & diagnostyki

  • Teraz obsługujemy nowy wizualizator danych w celu oceny implementacji interfejsu IEnumerable.
  • Wizualizator IEnumerable pomoże eksplorować większe obiekty kolekcji w widoku tabelarycznym.
  • Dodaliśmy obsługę zależnego punktu śledzenia.
  • Teraz można ustawić dowolny punkt przerwania zależny od punktu śledzenia i na odwrót.
  • Jeśli punkt przerwania jest zależny od punktu śledzenia, trafi dopiero po trafieniu punktu śledzenia. (tj. po wydrukowaniu komunikatu śledzenia/dziennika w oknie danych wyjściowych)

Diagnostyka debugowania &

  • Wizualizator IEnumerable pomoże eksplorować większe obiekty kolekcji w bardziej usprawniony sposób w widoku siatki tabelarycznej/danych. Obsługuje kolekcje IEnumerable, w których język T może być prostymi typami lub typami złożonymi, takimi jak słowniki, hermetyzowane.

Convert to raw string

  • Za każdym razem, gdy masz implementację kodu IEnumerable, zobaczysz ikonę lupy w kolumnie Wartość okna Locals/ Watch. Po umieszczeniu wskaźnika myszy na zmiennej zostanie również wyświetlona ikona. Kliknij ikonę i możesz uzyskać dostęp do wizualizatora IEnumerable.

  • Możesz użyć opcji Ukryj kolumny, aby ukryć zduplikowane dane lub rozwinąć kolumny, aby wyświetlić bardziej szczegółowe elementy w złożonych danych. Na koniec możesz ukryć dzieci, aby uzyskać bardziej zwięzły widok danych.

Convert to raw string

Problemy rozwiązane w wersji 17.2

  • Rozwiązano problem polegający na tym, że selektor konta w obszarze "Uwierzytelnianie usługi platformy Azure" został przerwany i powodował ponowne uruchomienie programu VS, a osoby korzystające z języków innych niż angielskie nie mogły wybrać innego konta/dodać nowego dla uwierzytelniania usługi platformy Azure.
  • Ta wersja Visual Studio zawiera zestaw Win App SDK 1.0.3— Windows App SDK kanały wydania — Windows aplikacje | Microsoft Docs, aby uzyskać więcej informacji.
  • Rozwiązano problem polegający na tym, że rozwiązania zawierające projekty WiX ulegały awarii podczas otwierania.
  • Rozwiązano problem polegający na tym, że etykietki narzędzi nie były poprawnie wyświetlane w kontrolkach Daytona.
  • Zaktualizowano punkt odniesienia webview2 w usłudze Daytona.
  • Rozwiązano problem polegający na tym, że "Gałąź synchronizacji" nie powiodła się w scenariuszu polegającym na tym, że "gałęzie lokalne i zdalne rozeszły się" i "pull.rebase" nie zostały zdenerwowane.
  • Rozwiązano problem polegający na tym, że użytkownik tworzący natywną aplikację języka C++ przeznaczoną dla platformy Android napotkał błędy kompilacji, jeśli jest również zainstalowane obciążenie "Programowanie mobilne za pomocą platformy .NET".
  • Naprawiono opóźnienie interfejsu użytkownika po załadowaniu projektu platformy .NET lub kompilacji Windows Forms, gdy przybornik nie został jeszcze zainicjowany.
  • Naprawiono brakujące ostrzeżenia wyliczenia bitowego dla niektórych danych wejściowych.
  • Wybranie pozycji "Załaduj wszystkie symbole" w narzędziu procesora CPU nie powoduje już wyświetlania pustych wierszy w analizie.
  • IntelliSense nie jest już bardzo powolne (trwa prawie minutę odpowiedzi) na wzorzec używany w nagłówkach języka C++ zestawu Vulkan SDK.
  • Rozwiązano problem, który mógł pojawić się w oknie dialogowym "Integracja narzędzia CMake" i prowadzić do zatrzymania działania narzędzia CMake po zapisaniu zmian w CMakeLists.txt.
  • Zwiększona wydajność przełączania konfiguracji kompilacji przy użyciu projektów CMake
  • Zwiększona wydajność podczas edytowania dużych plików źródłowych Razor.
  • Rozwiązano problem w widokach narzędzia użycie procesora CPU, w którym tekst został obcięty przez niebieskie paski użycia
  • Usunięto niepoprawny komunikat z informacją, że nie ma najlepszych szczegółowych informacji w narzędziu Użycie procesora CPU, nawet jeśli istnieją najważniejsze szczegółowe informacje.
  • Usunięto usterkę polegającą na tym, że komunikat "Nie znaleziono szczegółowych informacji" w narzędziu Użycie procesora CPU nie został poprawnie zlokalizowany
  • Rozwiązano problem uniemożliwiający niektórym klientom instalowanie Visual Studio z powodu ustawienia zasad obiektu zasad grupy w rejestrze systemowym. Visual Studio będzie teraz działać tak samo, jak funkcja WebView2 w odniesieniu do tej instalacji.
  • Rozwiązano problem "Nie można zainstalować dowolnego rozszerzenia (vsix) dla Visual Studio na maszynie w trybie offline".
  • Naprawiono manifest instalacji obciążenia MonoToolchain i emsdk.

Zgłaszane na forum Developer Community


Znane problemy

Zobacz wszystkie otwarte problemy i dostępne obejścia w Visual Studio 2022 r., korzystając z poniższego linku.


Opinie i sugestie

Chcemy poznać Twoją opinię! Możesz zgłosić problem lub zasugerować funkcjęFeedback Icon przy użyciu ikony Wyślij opinię w prawym górnym rogu instalatora lub środowiska IDE Visual Studio albo z obszaru Wyślij opinię w pomocy>. Problemy można śledzić przy użyciu Visual Studio Developer Community, gdzie dodasz komentarze lub znajdziesz rozwiązania. Możesz też uzyskać bezpłatną pomoc dotyczącą instalacji za pośrednictwem naszej pomocy technicznej przez czat na żywo.


Blogi

Skorzystaj ze szczegółowych informacji i zaleceń dostępnych w witrynie blogów dotyczących narzędzi programistycznych, aby być na bieżąco ze wszystkimi nowymi wersjami i zyskać dostęp do szczegółowych wpisów dotyczących szerokiego zakresu funkcji.


Początek strony