Rozwiązywanie problemów z pobieraniem szczegółowych danych użycia rezerwacji platformy Azure

Ten artykuł ułatwia zrozumienie i rozwiązywanie problemów z pobieraniem szczegółowych danych użycia wystąpienia zarezerwowanego wyświetlanych w witrynie Azure Portal jako niedostępne.

Objawy

  1. Zaloguj się do witryny Azure Portal i przejdź do obszaru Rezerwacje.
  2. Wybierz rezerwację.
  3. Na stronie przeglądu rezerwacji w widoku domyślnym są wyświetlane dane użycia z co najmniej ostatnich siedmiu dni. Możesz wybrać opcję Pobierz jako plik CSV, aby pobrać szczegóły użycia rezerwacji.
  4. Gdy zmienisz zakres czasu, opcja Pobierz jako plik CSV stanie się niedostępna. Zrzut ekranu przedstawiający właściwości rezerwacji, w których pobieranie jako plik CSV jest niedostępne.

Przyczyna

Ze względu na ograniczenia techniczne platforma Azure nie obsługuje pobierania danych z przedziału czasu dłuższego niż siedem dni. W przypadku klientów mających dużą liczbę rezerwacji dłuższe okresy generują duże ilości danych. Zwracanie danych za pomocą interfejsów API powoduje ograniczenie zasobów platformy Azure.

Rozwiązanie

Zdajemy sobie sprawę, że klienci chcą pobierać dane z dłuższych przedziałów czasu. Obecnie jednak nie ma możliwości pobierania danych użycia rezerwacji z długich okresów.

Następne kroki