Konfigurowanie bfd za pośrednictwem usługi ExpressRoute

Usługa ExpressRoute obsługuje dwukierunkowe wykrywanie przekazywania (BFD) zarówno za pośrednictwem prywatnej komunikacji równorzędnej, jak i komunikacji równorzędnej firmy Microsoft. Po włączeniu usługi BFD za pośrednictwem usługi ExpressRoute można przyspieszyć wykrywanie awarii łącza między urządzeniami microsoft Enterprise Edge (MSEE) i routerami konfigurowany przez obwód usługi ExpressRoute (CE/PE). Usługę ExpressRoute można skonfigurować za pośrednictwem urządzeń routingu brzegowego lub urządzeń routingu Partner Edge (jeśli usługa ta jest zarządzana w warstwie 3). Ten dokument zawiera informacje na temat konieczności obsługi bfd i sposobu włączania bfd za pośrednictwem expressRoute.

Need for BFD

Na poniższym diagramie przedstawiono korzyści z włączenia bfd za pośrednictwem obwodu expressRoute: 1

Obwód usługi ExpressRoute można włączyć za pomocą połączeń warstwy 2 lub zarządzanych połączeń warstwy 3. W obu przypadkach, jeśli w ścieżce połączenia usługi ExpressRoute znajduje się więcej niż jedno urządzenie warstwy 2, odpowiedzialność za wykrywanie błędów łącza w ścieżce spoczywa na nakładaniu się na sesję protokołu BGP.

Na urządzeniach MSEE zachowanie aktywności protokołu BGP i czas przechowywania są zwykle skonfigurowane odpowiednio na 60 i 180 sekund. Z tego powodu w przypadku awarii łącza wykrycie awarii łącza i przełączenie ruchu na połączenie alternatywne może potrwać do trzech minut.

Czasomierze protokołu BGP można kontrolować, konfigurując niższą podtrzymanie aktywności i czas wstrzymywania protokołu BGP na urządzeniu brzegowej komunikacji równorzędnej. Jeśli czasomierze protokołu BGP nie są takie same między dwoma urządzeniami komunikacji równorzędnej, sesja protokołu BGP zostanie nawiątana przy użyciu niższej wartości czasu. Utrzymanie aktywności protokołu BGP można ustawić na 3 sekundy, a czas przechowywania — nawet 10 sekund. Jednak ustawienie bardzo agresywnego czasomierza protokołu BGP nie jest zalecane, ponieważ protokół intensywnie przetwarza.

W tym scenariuszu może pomóc BFD. BfD zapewnia wykrywanie niepowodzeń łącza o niskim narzucie w interwałach czasu poniżej sekund.

Włączanie BFD

BfD jest konfigurowany domyślnie we wszystkich nowo utworzonych interfejsach prywatnej komunikacji równorzędnej Usługi ExpressRoute na urządzeniach MIEM. W związku z tym, aby włączyć usługę BFD, wystarczy skonfigurować BFD zarówno na urządzeniach podstawowych, jak i pomocniczych. Konfigurowanie bfd jest proces dwuetapowy. Należy skonfigurować bfd w interfejsie, a następnie połączyć go z sesją protokołu BGP.

Poniżej przedstawiono przykładową konfigurację CE/PE (przy użyciu oprogramowania Cisco IOS XE).

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Uwaga

Aby włączyć bfd w ramach istniejącej prywatnej komunikacji równorzędnej; należy zresetować komunikacja równorzędna. Zobacz Resetowanie komunikacji równorzędnej expressRoute

Negocjacja czasomierza BFD

Między rówieśnikami BFD szybkość transmisji jest określana przez wolniejsze z dwóch elementów równorzędnych. Interwały transmisji/odbierania (BFD) są ustawione na 300 milisekund. W niektórych scenariuszach interwał może być ustawiony na wyższą wartość 750 milisekund. Konfigurując wyższą wartość, można wymusić, aby interwały były dłuższe, ale nie można ich skrócić.

Uwaga

Jeśli skonfigurowano geograficznie nadmiarowe obwody usługi ExpressRoute lub użyj połączenia sieci VPN typu lokacja-lokacja protokołu IPSec jako kopii zapasowej. Włączenie bfd może pomóc w szybszym trybie failover po awarii łączności usługi ExpressRoute.

Następne kroki

Aby uzyskać więcej informacji lub pomoc, zapoznaj się z następującymi linkami: