Nieaktywna skrzynka pocztowa nie jest automatycznie ponownie połączona z kontem lokalna usługa Active Directory

Oryginalny numer KB: 4337973

Symptomy

Gdy konto lokalna usługa Active Directory zostanie przywrócone do zakresu Microsoft Entra Connect, nieaktywna skrzynka pocztowa nie zostanie ponownie połączona automatycznie w Exchange Online. Ponadto nowo aprowizowana skrzynka pocztowa jest tworzona w Exchange Online.

Uwaga

W przypadku Office 365 dedykowanych/ITAR klienci programu Microsoft Managed Services Service Provisioning Provider (MMSSPP) zapisują atrybuty msExchMailboxGUID i ExchangeGUID z dedykowanego środowiska do lokalna usługa Active Directory klienta w fazie współistnienia. Zamiast nowo aprowizowanej skrzynki pocztowej w Exchange Online tworzony jest użytkownik z obsługą poczty.

Przyczyna

Po usunięciu obiektów skrzynki pocztowej z zakresu Microsoft Entra Connect pozostają one w koszu Tożsamość Microsoft Entra przez 30 dni. Musisz wykonać dodatkowe kroki, aby ponownie połączyć lokalne konto usługi AD z nieaktywną skrzynką pocztową, gdy konto zostanie usunięte z Kosza.

Rozwiązanie

Aby rozwiązać ten problem, użyj następujących procesów.

Przenoszenie zawartości z oryginalnej skrzynki pocztowej

Przywróć zawartość z nieaktywnej skrzynki pocztowej do nowo aprowizowanej skrzynki pocztowej przy użyciu polecenia cmdlet New-MailboxRestoreRequest . Umożliwia to dalsze korzystanie z nowej skrzynki pocztowej i kopiowanie oryginalnej zawartości.

Ponowne łączenie oryginalnej nieaktywnej skrzynki pocztowej

Uwaga

Ten proces działa również w przypadku nietrwałych skrzynek pocztowych, jeśli łączą się z nowym lokalnym kontem usługi AD. Parametr SoftDeletedMailbox powinien zostać użyty do zastąpienia parametru InactiveMailboxOnly .

  1. Uruchom następujące polecenie, aby uzyskać nieaktywne atrybuty skrzynki pocztowej z programu Exchange Online programu PowerShell:

    $InactiveMailbox = Get-Mailbox -InactiveMailboxOnly -Identity <identity of inactive mailbox>
    
  2. Uruchom następujące polecenie, aby tymczasowo skojarzyć nieaktywną skrzynkę pocztową z kontem w chmurze:

    New-Mailbox -InactiveMailbox $InactiveMailbox.DistinguishedName -Name "<name of inactive mailbox>" -DisplayName "<DisplayName of inactive mailbox>" -MicrosoftOnlineServicesID <alias@*.onmicrosoft.com> -Password (ConvertTo-SecureString -String <PasswordString> -AsPlainText -Force) -ResetPasswordOnNextLogon $true
    
  3. Połącz się z modułem programu PowerShell usługi Azure Active Directory, a następnie uruchom następujące polecenie, aby uzyskać ObjectGUID atrybut:

     Get-ADUser -Identity <ADUser> -Properties "ObjectGUID"
    
  4. Uzyskaj wartość parametru ImmutableID , która jest domyślnie atrybutem lokalnym ObjectGUID . Na wartość można przekonwertować ObjectGUIDImmutableID za pomocą następującego polecenia w Windows PowerShell:

    [system.convert]::ToBase64String(([GUID]"<ObjectGUID>").tobytearray())
    
  5. ImmutableID Ustaw parametr w Tożsamość Microsoft Entra:

    Set-MsolUser -UserPrincipalName <UPN> -ImmutableId <ImmutableId>
    

    Uwaga

    Moduły programu PowerShell Azure AD i MSOnline są przestarzałe od 30 marca 2024 r. Aby dowiedzieć się więcej, przeczytaj aktualizację wycofania. Po tej dacie obsługa tych modułów jest ograniczona do pomocy w migracji do zestawu Microsoft Graph PowerShell SDK i poprawek zabezpieczeń. Przestarzałe moduły będą nadal działać do 30 marca 2025 r.

    Zalecamy migrację do programu Microsoft Graph PowerShell w celu interakcji z Tożsamość Microsoft Entra (dawniej Azure AD). Aby uzyskać typowe pytania dotyczące migracji, zapoznaj się z często zadawanymi pytaniami dotyczącymi migracji. Uwaga: W wersjach 1.0.x usługi MSOnline mogą wystąpić zakłócenia po 30 czerwca 2024 r.

  6. Uruchom synchronizację różnicową Microsoft Entra Connect. Spowoduje to przełączenie oryginalnego konta Microsoft Entra do zakresu programu Microsoft Entra Connect.

  7. Sprawdź obiekt skrzynki pocztowej i sprawdź, czy podstawowy adres SMTP został zaktualizowany z tymczasowej wartości głównej nazwy użytkownika (UPN) do poprawnego adresu podstawowego.

    Uwaga

    Nowa skrzynka pocztowa nie jest włączona dla blokady postępowania sądowego. Ponadto zostanie wyświetlony następujący komunikat ostrzegawczy:
    OSTRZEŻENIE: Nieaktywna skrzynka pocztowa została odzyskana. Aby zachować dane do czasu uzyskania ważnej licencji, włączyliśmy odzyskiwanie pojedynczego elementu przez 30 dni. Ponadto włączyliśmy również blokadę przechowywania przez 30 dni. Po przypisaniu prawidłowej licencji dla tej skrzynki pocztowej możesz wyłączyć te ustawienia i użyć opcji Spory sądowe lub In-Place Hold, aby zachować dane.

  8. Zastosuj licencję Exchange Server i odpowiednie ustawienia blokady do nowej skrzynki pocztowej.

Więcej informacji

Kroki opisane w sekcji Rozwiązywanie są dostosowane na podstawie instrukcji dotyczących skrzynki pocztowej w chmurze w temacie Przywracanie nieaktywnej skrzynki pocztowej na platformie Microsoft 365.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.