"550 5.1.10 RESOLVER. ADR. RecipientNotFound", gdy użytkownicy platformy Microsoft 365 wysyłają wiadomości e-mail do użytkowników lokalnych w ramach wdrożenia hybrydowego

Oryginalny numer KB: 3197393

Problem

Użytkownik platformy Microsoft 365 nie może wysyłać wiadomości e-mail do lokalnych użytkowników programu Exchange w ramach wdrożenia hybrydowego programu Exchange. Użytkownik platformy Microsoft 365 otrzymuje następujący raport niedelicyjny (NDR):

Nie można dostarczyć User@contoso.com twojej wiadomości.

Użytkownik nie został znaleziony w <contoso.com>

NDR zawiera następujący kod błędu:

550 5.1.10 RESOLVER. ADR. AdresatNotFound; Adresat nie został znaleziony przez wyszukiwanie adresu SMTP

Przyczyna

Ten problem występuje, jeśli użytkownik został utworzony na platformie Microsoft 365. W tym scenariuszu lokalne środowisko programu Exchange nie ma obiektu do odwołania dla użytkownika. W związku z tym wszystkie zapytania dotyczące tego adresu SMTP nie powiodły się.

Rozwiązanie

Aby rozwiązać ten problem, utwórz zdalną skrzynkę pocztową w środowisku lokalnym, a następnie poczekaj na wystąpienie synchronizacji katalogów lub wymuś synchronizację katalogów. Aby to zrobić, wykonaj następujące kroki.

  1. Utwórz obiekt lokalny dla skrzynki pocztowej w chmurze przy użyciu polecenia cmdlet New-RemoteMailbox w usłudze Exchange Management Shell.

    Uwaga

    Ten obiekt musi mieć taką samą nazwę, alias i główną nazwę użytkownika (UPN) co skrzynka pocztowa w chmurze. Aby uzyskać więcej informacji, zobacz New-RemoteMailbox.

  2. Ustaw właściwość ExchangeGuid dla nowego obiektu lokalnego utworzonego w kroku 1, aby dopasować ją do skrzynki pocztowej w chmurze. Aby to zrobić, wykonaj następujące kroki.

    1. Nawiązywanie połączenia z Exchange Online przy użyciu zdalnego programu PowerShell.

      Aby uzyskać więcej informacji, zobacz Nawiązywanie połączenia z usługą Exchange Online przy użyciu programu PowerShell.

    2. Użyj polecenia cmdlet Get-Mailbox, aby pobrać wartość ExchangeGuid właściwości skrzynki pocztowej w chmurze. Na przykład uruchom następujące polecenie:

      Get-Mailbox <MailboxName>| FL ExchangeGuid
      

      Aby uzyskać więcej informacji, zobacz Get-Mailbox.

    3. Otwórz powłokę zarządzania programu Exchange na lokalnym serwerze Exchange.

    4. Set-RemoteMailbox Użyj polecenia cmdlet, aby ustawić wartość ExchangeGuid właściwości w obiekcie lokalnym na wartość pobraną w kroku 2b. Na przykład uruchom następujące polecenie:

      Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
      

      Aby uzyskać więcej informacji, zobacz Set-RemoteMailbox.

  3. Poczekaj na synchronizację katalogów. Możesz też wymusić synchronizację katalogów.

    Aby uzyskać więcej informacji, zobacz Synchronizowanie katalogów.

  4. Upewnij się, że obiekt użytkownika platformy Microsoft 365 jest wyświetlany jako Synchronizowany z usługą Active Directory.

Więcej informacji

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.