Błąd MigrationPermanentException podczas przenoszenia skrzynek pocztowych z Exchange Online do Exchange Server 2010 r.

Oryginalny numer KB: 2932443

Uwaga

Kreator konfiguracji hybrydowej dołączony do konsoli zarządzania programu Exchange w Microsoft Exchange Server 2010 r. nie jest już obsługiwany. W związku z tym nie należy już używać starego kreatora konfiguracji hybrydowej. Zamiast tego użyj kreatora konfiguracji hybrydowej platformy Microsoft 365. Aby uzyskać więcej informacji, zobacz Kreator konfiguracji hybrydowej platformy Microsoft 365 dla programu Exchange 2010.

Symptomy

Załóżmy, że masz wdrożenie hybrydowe programu Exchange, które obejmuje lokalne serwery programu Exchange 2010. Podczas próby odłączenia lub przeniesienia skrzynki pocztowej z Exchange Online na serwer programu Exchange 2010 w środowisku lokalnym zostanie wyświetlony następujący komunikat o błędzie:

Błąd: MigrationPermanentException:

Nie należy migrować "nazwy użytkownika>" skrzynki pocztowej< do programu Exchange 2010 lub starszej wersji, gdy lista kontaktów wiadomości błyskawicznych użytkownika jest przechowywana w programie Exchange. Jeśli to zrobisz, użytkownik może trwale utracić dostęp do swojej listy kontaktów wiadomości błyskawicznych, co spowoduje poważną utratę danych. Kopia programu Exchange może być jedyną kopią listy kontaktów tego użytkownika. Aby kontynuować, skontaktuj się z administratorem wiadomości błyskawicznych i upewnij się, że lista kontaktów użytkownika została przeniesiona z powrotem na serwer wiadomości błyskawicznych. Po zakończeniu tej migracji powinno być możliwe ukończenie tej migracji. Jeśli musisz przeprowadzić migrację skrzynki pocztowej pomimo potencjalnej utraty danych, możesz to zrobić, uruchamiając polecenie "Set-UMMailbox mailboxID -ImListMigrationCompleted $false".

Jednak po uruchomieniu Set-UMMailbox mailboxID -ImListMigrationCompleted $false polecenia cmdlet zgodnie z komunikatem o błędzie zostanie wyświetlony następujący komunikat o błędzie:

Nazwa użytkownika> skrzynki pocztowej<@contoso.com nie jest włączona na potrzeby ujednoliconej obsługi wiadomości.

Przyczyna

Dzieje się tak, jeśli kontakty programu Lync 2013 użytkownika skojarzonego ze skrzynką pocztową są przechowywane w ujednoliconym magazynie kontaktów w programie Exchange. Domyślnie, jeśli użytkownik zalogował się do programu Lync 2013, dla tego użytkownika jest włączony ujednolicony magazyn kontaktów. Ponadto kontakty użytkownika programu Lync są migrowane z serwera programu Lync do programu Exchange.

Rozwiązanie

Ważna

ImListMigrationCompleted Obecnie parametr jest dostępny tylko w Exchange Server (lokalnie). Aby uzyskać więcej informacji na temat importowania plików PST do Exchange Online skrzynek pocztowych, zobacz omówienie importowania plików PST organizacji.

Użyj polecenia cmdlet Set-Mailbox razem z parametrem ImListMigrationCompleted zamiast Set-UMMailbox polecenia cmdlet. Na przykład uruchom następujące polecenie cmdlet:

Set-Mailbox John@contoso.com -ImListMigrationCompleted $false

Po uruchomieniu polecenia cmdlet wykonaj żądanie przeniesienia skrzynki pocztowej.

Uwaga

Ustawienie $false w parametrze ImListMigrationCompleted wskazuje, że kontakty użytkownika nie zostały zmigrowane do programu Lync w celu zachowania listy kontaktów. Należy pamiętać, że rozwiązanie w tej sekcji może spowodować utratę danych. Exchange Server 2010 r. nie obsługuje funkcji ujednoliconego magazynu kontaktów w programie Lync 2013. W związku z tym w przypadku przeniesienia skrzynki pocztowej z powrotem do Exchange Server 2010 r., gdy kontakty użytkownika programu Lync są przechowywane w ujednoliconym magazynie kontaktów, użytkownik może utracić dostęp do kontaktów programu Lync. Przed przeniesieniem skrzynki pocztowej do Exchange Server 2010 r. należy najpierw upewnić się, że kontakty użytkownika programu Lync zostaną przeniesione z powrotem na serwer programu Lync.

Więcej informacji

Jeśli podczas przenoszenia skrzynek pocztowych do Exchange Online na platformie Microsoft 365 występują problemy, możesz uruchomić narzędzie Rozwiązywanie problemów z migracją skrzynki pocztowej platformy Microsoft 365. Ta diagnostyka jest zautomatyzowanym narzędziem do rozwiązywania problemów. Jeśli występuje znany problem, zostanie wyświetlony komunikat z informacją o tym, co poszło nie tak. Komunikat zawiera link do artykułu zawierającego rozwiązanie. Obecnie narzędzie jest obsługiwane tylko w programie Internet Explorer.

Nadal potrzebujesz pomocy? Przejdź do witryny Społeczność Microsoft lub forów Microsoft Q&A.