Błąd podczas tworzenia punktu końcowego migracji folderu publicznego

Oryginalny numer KB: 4052729

Symptomy

Po uruchomieniu New-MigrationEndpoint polecenia cmdlet w celu utworzenia punktu końcowego migracji typu PublicFolder lub PublicFolderToGroups w Microsoft Exchange Online jest wyświetlany jeden z następujących komunikatów o błędach:

Dostawca MAPI nie jest obsługiwany w przypadku skrzynki pocztowej z wersją <VersionNumber> na serwerze <ServerName>.

Write-ErrorMessage : |Microsoft.Exchange.Data.Storage.Management.MigrationTransientException|

Przyczyna

Te błędy występują, ponieważ następujące skrzynki pocztowe nie znajdują się na tym samym serwerze:

  • Skrzynka pocztowa folderu publicznego hierarchii podstawowej.
  • Skrzynka pocztowa organizacji o nazwie SystemMailbox{MailboxID}. (Jest to typ skrzynki pocztowej arbitrażu).

Rozwiązanie

Aby rozwiązać ten problem, upewnij się, że bazy danych hostujące te dwie skrzynki pocztowe znajdują się na tym samym serwerze. Aby to zrobić, wykonaj następujące kroki.

  1. Znajdź bazę danych hostującą skrzynkę pocztową folderu publicznego hierarchii podstawowej, uruchamiając jedną z następujących opcji polecenia cmdlet:

    Opcja 1

    Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq $true} | ft name,database
    Get-MailboxDatabaseCopyStatus <database returned from the first cmdlet>
    

    Opcja 2

    Get-MailboxDatabase (Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq $true}).database | Get-MailboxDatabaseCopyStatus
    
  2. Znajdź bazę danych hostującą skrzynkę pocztową folderu publicznego hierarchii podstawowej, uruchamiając jedną z następujących opcji polecenia cmdlet:

    Opcja 1

    Get-Mailbox -Arbitration | ?{$_.name -like "SystemMailbox{MailboxID}"} | ft database
    Get-MailboxDatabaseCopyStatus <database returned from the first cmdlet>
    

    Opcja 2

    Get-MailboxDatabase (Get-Mailbox -Arbitration | ?{$_.name -like "SystemMailbox{MailboxID}"}).database | Get-MailboxDatabaseCopyStatus
    
  3. Jeśli bazy danych hostujące skrzynkę pocztową folderu publicznego hierarchii podstawowej i skrzynkę pocztową arbitrażu mają kopię na tym samym serwerze, aktywuj obie kopie bazy danych na tym samym serwerze.

    W przeciwnym razie przenieś skrzynkę pocztową arbitrażu lub skrzynkę pocztową folderu publicznego hierarchii podstawowej, tak aby obie skrzynki pocztowe były na tym samym serwerze.