Program Access może przestać odpowiadać podczas próby utworzenia pliku MDE, ACCDE lub ADE

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Umiarkowany. Wymaga podstawowych umiejętności makr, kodowania i współdziałania.

Ten artykuł dotyczy bazy danych programu Microsoft Access (mdb lub accdb) i projektu programu Microsoft Access (adp).

Oryginalny numer KB:   814858

Symptomy

Podczas próby zapisania pliku bazy danych programu Access (mdb lub accdb) jako pliku MDE (mde) lub ACCDE (accde) albo podczas próby zapisania pliku projektu programu Access (adp) jako pliku ADE (ade) program Access może przestać odpowiadać. Może zostać wyświetlony następujący komunikat o błędzie:

Program Microsoft Access napotkał problem i musi go zamknąć. Przepraszamy za niedogodności.
Powiedz firmie Microsoft o tym problemie.
Utworzono raport o błędach, który możesz wysłać, aby pomóc nam w ulepszaniu programu Microsoft Access. Ten raport zostanie potraktowany jako poufny i anonimowy.
Aby sprawdzić, jakie dane zawierają ten raport o błędach, kliknij tutaj.

Przyczyna

Ten problem może wystąpić, gdy skompilowany projekt języka Visual Basic for Applications (VBA) pliku mdb lub plik adp jest uszkodzony.

Obejście problemu

Aby rozwiązać ten problem, możesz ponownie załadować projekt VBA bazy danych programu Access z tekstu, a następnie utworzyć plik MDE, ACCDE lub ADE. Aby to zrobić, wykonaj następujące kroki.

Uwaga

Przed rozpoczęciem tych czynności zrób kopię zapasową bazy danych.

  1. Na pasku zadań kliknij pozycję start, a następnie kliknij pozycję Uruchom.

  2. Wpisz <Microsoft_Access_Path>\msaccess.exe /dekompilowanie, a następnie kliknij przycisk OK.

    Uwaga

    <Microsoft_Access_Path> to ścieżka folderu, w którym jest zainstalowany program Access.

  3. Otwórz oryginalny plik mdb, oryginalny plik accdb lub oryginalny plik adp, który chcesz zapisać jako nowy plik MDE, plik ACCDE lub plik ADE. Aby to zrobić, wykonaj następujące kroki.

    1. Naciśnij klawisze ALT+F11, aby otworzyć Edytor Visual Basic.
    2. W menu Debugowanie kliknij polecenie Kompilowanie. <DatabaseName>
    3. W menu Plik kliknij polecenie Zapisz <DatabaseName>, a następnie zamknij Edytor Visual Basic.
  4. W najnowszych wersjach programu Access kliknij pozycję Zapisz plik jako zapisz bazę danych jako, a następnie kliknij pozycję Make > > ACCDE File (Zapisz plik ACCDE) lub make ADE (Make ADE).

    W programach Access 2010 i Access 2007 kliknij kartę Narzędzia bazy danych, a następnie kliknij pozycję Nabłęd plik ACCDE lub pozycję Nastawianie ADE w grupie Narzędzia bazy danych.

    W programie Microsoft Office Access 2003 lub we wcześniejszych wersjach programu Access kliknij polecenie Narzędzia bazy danych w menu Narzędzia, a następnie kliknij polecenie Nabłęd plik MDE lub kliknij polecenie Make ADE File (Nabłęd plik ADE).

  5. W oknie dialogowym Zapisywanie mde jako w oknie dialogowym Zapisywanie jako lub w oknie dialogowym Zapisywanie ADE jako zlokalizuj folder, w którym chcesz zapisać plik MDE, ACCDE lub ADE, wpisz nazwę pliku w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.