Adres e-mail usługi Office 365 zawiera znak podkreślenia po synchronizacji katalogów

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Symptomy

Gdy narzędzie do synchronizacji usługi Microsoft Azure Active Directory zostanie uruchomiony w celu zsynchronizowania lokalnego środowiska usługi Active Directory z usługą Azure Active Directory, adres e-mail użytkownika w usłudze Office 365 nieoczekiwanie będzie zawierał znak podkreślenia "_".

Przyczyna

Dzieje się tak, jeśli konto użytkownika w środowisku lokalnym ma atrybut proxyaddresses lub atrybut mail, który zawiera co najmniej jeden z następujących znaków specjalnych przed częścią " @domain.com adresu:

Znak Name (Nazwa)
znak spacji
` apostrof
( otwierający nawias
) nawias zamykający
' pojedynczy cudzysłów
& "i"
| rura
= znak równości
? znak zapytania
/ ukośnik
% procent

W tym scenariuszu po uruchomieniu synchronizacji katalogów znak specjalny zostanie zastąpiony znakiem podkreślenia. Dlatego adres e-mail użytkownika w usłudze Office 365 zawiera znak podkreślenia zamiast znaku specjalnego.

Rozwiązanie

Usuń znaki specjalne z atrybutu proxyaddresses konta użytkownika w środowisku lokalnym.

Więcej informacji

Znaki wymienione w sekcji Przyczyna są w usłudze Office 365 traktowane jako znaki specjalne. Użycie dowolnego z tych znaków może spowodować problemy, takie jak zakłócenia w działaniu usługi.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.