"Nie można zresetować hasła tego użytkownika", gdy administrator resetuje hasło użytkownika będącego członkiem domeny

Problem

Rozważmy następujący scenariusz: użytkownik nie może zalogować się do usługi w chmurze firmy Microsoft, takiej jak Microsoft 365, Microsoft Azure lub Microsoft Intune przy użyciu identyfikatora użytkownika, który jest członkiem domeny usługi w chmurze, która była wcześniej skonfigurowana na potrzeby logowania jednokrotnego. W tym scenariuszu, gdy administrator usługi w chmurze próbuje zresetować hasło użytkownika przy użyciu portalu usługi w chmurze lub modułu usługi Azure Active Directory dla Windows PowerShell, administrator otrzymuje następujący komunikat o błędzie:

Nie można zresetować hasła tego użytkownika. Spróbuj ponownie później.

Przyczyna

Ten problem występuje, jeśli użytkownik jest członkiem domeny usługi w chmurze, która była wcześniej włączona do logowania jednokrotnego i jeśli identyfikator użytkownika nie został przekonwertowany na użycie uwierzytelniania standardowego.

Na przykład ten problem może wystąpić, jeśli użyto następującego polecenia cmdlet Windows PowerShell:

convert-MSOLDomainToStandard –skipuserconversion:$true 

Uwaga

Moduły programu PowerShell Azure AD i MSOnline są przestarzałe od 30 marca 2024 r. Aby dowiedzieć się więcej, przeczytaj aktualizację wycofania. Po tej dacie obsługa tych modułów jest ograniczona do pomocy w migracji do zestawu Microsoft Graph PowerShell SDK i poprawek zabezpieczeń. Przestarzałe moduły będą nadal działać do 30 marca 2025 r.

Zalecamy migrację do programu Microsoft Graph PowerShell w celu interakcji z Tożsamość Microsoft Entra (dawniej Azure AD). Aby uzyskać typowe pytania dotyczące migracji, zapoznaj się z często zadawanymi pytaniami dotyczącymi migracji. Uwaga: W wersjach 1.0.x usługi MSOnline mogą wystąpić zakłócenia po 30 czerwca 2024 r.

Rozwiązanie

Aby rozwiązać ten problem, przekonwertuj identyfikator użytkownika na typ standardowy (niefederacyjny). Aby to zrobić, wykonaj następujące kroki.

  1. W tej samej konsoli Windows PowerShell, która została użyta do zweryfikowania problemu, wpisz następujące polecenie cmdlet, a następnie naciśnij klawisz Enter:
    Convert-MsolFederatedUser -userprincipalname < user ID > 
    

    Uwaga

    W tym poleceniu cmdlet identyfikator użytkownika> symbolu zastępczego < reprezentuje identyfikator użytkownika.

  2. Nadaj użytkownikowi hasło tymczasowe. Następnym razem, gdy użytkownik zaloguje się do usługi w chmurze, musi zmienić swoje tymczasowe hasło, zanim będzie mógł uzyskać dostęp do zasobów usługi w chmurze.

Więcej informacji

Uwaga

Polecenia cmdlet Windows PowerShell w tym artykule wymagają modułu usługi Azure Active Directory dla Windows PowerShell.

Nadal potrzebujesz pomocy? Przejdź do witryny microsoft community lub witryny internetowej forów Microsoft Entra.