Niektóre reguły są wyłączone i podczas próby utworzenia lub włączenia reguł w programie Outlook jest wyświetlany komunikat o błędzie

Oryginalny numer artykułu KB:   886616

Symptomy

Po uaktualnieniu do programu Office Outlook 2003 (lub nowszego) możesz zauważyć, że niektóre reguły są wyłączone i nie można ich włączyć. Inne reguły działają poprawnie. Jeśli spróbujesz włączyć wyłączone reguły, zostanie wyświetlony następujący komunikat o błędzie:

Nie można przekazać jednej lub większej liczby reguł na serwer Exchange i zostały one dezaktywowane. Może to być spowodowane tym, że niektóre parametry nie są obsługiwane lub brakuje miejsca do przechowywania wszystkich reguł.

Przyczyna

  • Skrzynki pocztowe na programach Microsoft Exchange Server 2007, Exchange Server 2010 lub Exchange Server 2013

    To zachowanie występuje, jeśli reguły w skrzynce pocztowej przekroczą limit przydziału określony dla skrzynki pocztowej. Limit rozmiaru reguł dla skrzynek pocztowych w programie Exchange Server 2007 (i nowszych) ma domyślny rozmiar 64 KB na skrzynkę pocztową. Limit rozmiaru wszystkich reguł można również dostosować do 256 KB na skrzynkę pocztową.

  • Skrzynki pocztowe na serwerze Exchange 2003

    To zachowanie występuje, jeśli reguły w skrzynce pocztowej przekroczą rozmiar 32 kilobajtów (KB). Całkowity limit rozmiaru reguł dla skrzynek pocztowych w programie Exchange Server 2003 to 32 KB. Nie można zmienić limitu reguł dla programu Exchange 2003.

W programie Outlook 2003 lub nowszym rozmiar reguł wzrósł głównie, aby zapewnić obsługę formatu Unicode.

Obejście problemu

Jeśli skrzynka pocztowa znajduje się na serwerze programu Exchange Server 2007 lub nowszej wersji, możesz poprosić administratora programu Exchange o zwiększenie przydziału reguł dla skrzynki pocztowej.

Poniższe polecenie przykładowe ustawia przydział reguł do wartości maksymalnej 256 KB.

Set-Mailbox john@contoso.com -RulesQuota:256kb

Poniższe polecenie przykładowe umożliwia wyświetlenie aktualnego przydziału dla skrzynki pocztowej.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Jeśli administrator serwera Exchange nie może zwiększyć przydziału reguł dla skrzynki pocztowej, Wypróbuj jedno z poniższych obejść dotyczących wszystkich wersji programu Exchange.

W celu obejścia tego problemu, aby przywrócić reguły, użyj jednej lub kilku z poniższych metod w celu zmniejszenia rozmiaru istniejących reguł.

Metoda 1

Zmień nazwy reguł na krótszą nazwę. Aby zmienić nazwę reguły w programie Outlook, wykonaj następujące czynności.

W przypadku programu Outlook 2010 i nowszych wersji:

  1. Na karcie plik kliknij pozycję informacje.
  2. Kliknij pozycję Zarządzaj regułami i alertami.
  3. Na karcie reguły wiadomości E-mail kliknij regułę, której nazwę chcesz zmienić.
  4. Kliknij pozycję Zmień reguły, a następnie kliknij pozycję Zmień nazwę reguły.
  5. Wpisz nową, krótszą nazwę reguły, a następnie kliknij przycisk OK.
  6. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

W przypadku programów Outlook 2007 i Outlook 2003:

  1. W menu Narzędzia kliknij polecenie reguły i alerty.
  2. Na karcie reguły wiadomości E-mail kliknij regułę, której nazwę chcesz zmienić.
  3. Na liście Zmień regułę kliknij pozycję Zmień nazwę reguły.
  4. Wpisz nową, krótszą nazwę reguły, a następnie kliknij przycisk OK.
  5. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

Metoda 2

Usuń wszystkie stare reguły. Aby usunąć regułę w programie Outlook, wykonaj następujące czynności:

W przypadku programu Outlook 2010 i nowszych wersji:

  1. Na karcie plik kliknij pozycję informacje.
  2. Kliknij pozycję Zarządzaj regułami i alertami.
  3. Na karcie reguły wiadomości E-mail kliknij regułę, której nazwę chcesz zmienić.
  4. Kliknij przycisk Usuń , a następnie kliknij przycisk tak , aby potwierdzić usunięcie.
  5. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

W przypadku programów Outlook 2007 i Outlook 2003:

  1. W menu Narzędzia kliknij polecenie reguły i alerty.
  2. Na karcie reguły wiadomości E-mail kliknij regułę, którą chcesz usunąć.
  3. Kliknij pozycję Usuń, a następnie kliknij przycisk tak , aby potwierdzić usunięcie.
  4. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

Metoda 3

Połącz podobne reguły, aby zmniejszyć ogólny rozmiar reguł. Jeśli to możliwe, Połącz podobne reguły, aby zmniejszyć ogólny rozmiar reguł. Po połączeniu podobnych reguł Usuń reguły, które nie są już potrzebne. Aby edytować istniejącą regułę w programie Outlook, wykonaj następujące czynności.

W przypadku programu Outlook 2010 i nowszych wersji:

  1. Na karcie plik kliknij pozycję informacje.
  2. Kliknij pozycję Zarządzaj regułami i alertami.
  3. Na karcie reguły wiadomości E-mail kliknij regułę, której nazwę chcesz zmienić.
  4. Kliknij pozycję Zmień regułę, a następnie kliknij pozycję Edytuj ustawienia reguły.
  5. Zmodyfikuj odpowiednią regułę.
  6. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

W przypadku programów Outlook 2007 i Outlook 2003:

  1. W menu Narzędzia kliknij polecenie reguły i alerty.

  2. Na karcie reguły wiadomości E-mail kliknij regułę, którą chcesz edytować.

  3. Na liście Zmień regułę kliknij pozycję Edytuj ustawienia reguły.

    Zmodyfikuj odpowiednią regułę.

  4. Po zakończeniu kliknij przycisk Zakończ, a następnie kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

Uwaga

Jeśli reguła jest regułą klienta, należy kliknąć przycisk OK dwa razy, aby zamknąć okno dialogowe reguły i alerty .

Metoda 4

Przenieś plik folderów osobistych (pst) do lokalizacji o najkrótszej nazwie ścieżki. Jeśli masz reguły, które przenoszą wiadomości e-mail do pliku pst, Przenieś plik PST do lokalizacji o najkrótszej nazwie ścieżki. Na przykład Przenieś plik PST do lokalizacji, na przykład C: \<file_name>. pst. Aby przenieść plik pst w programie Outlook, wykonaj następujące czynności:

  1. W okienku nawigacji kliknij prawym przyciskiem myszy pozycję Foldery osobiste lub nazwę folderu, który jest wyświetlany dla pliku pst, a następnie kliknij polecenie właściwości <folder_name>.

    Uwaga

    Ten folder będzie zawsze folderem najwyższego poziomu w okienku nawigacji w folderze poczta.

  2. Na karcie Ogólne kliknij pozycję Zaawansowane.

  3. W polu tekstowym Nazwa pliku Zanotuj pełną ścieżkę i nazwę pliku pst.

  4. Kliknij przycisk OK dwa razy, aby zamknąć okno dialogowe ** właściwości<folder_name>** .

  5. Zamknij program Outlook.

  6. Przenieś plik PST do nowej lokalizacji za pomocą Eksploratora Microsoft Windows.

    Domyślnie lokalizacja pliku pst to dysk: \ Documents and Settings \<user_name> \Ustawienia Lokalne\dane aplikacji\Microsoft\Outlook. Domyślną lokalizacją jest folder ukryty. Aby zlokalizować ten folder za pomocą Eksploratora Windows, należy najpierw włączyć wyświetlanie folderów ukrytych. Aby to zrobić, wykonaj następujące kroki.

    1. W Eksploratorze Windows kliknij pozycję Opcje folderów w menu Narzędzia .

    2. Kliknij kartę Widok .

    3. W sekcji Ustawienia zaawansowane kliknij pozycję Pokaż ukryte pliki i foldery w obszarze ukryte pliki i foldery.

    4. Jeśli chcesz wyświetlić wszystkie rozszerzenia nazw plików, kliknij pole wyboru Ukryj rozszerzenia znanych typów plików w obszarze pliki i foldery, aby je wyczyścić.

      Uwaga

      Foldery ukryte są wyświetlane jako wygaszone, co wskazuje, że nie są typowymi folderami.

    5. Kliknij przycisk OK.

  7. Aby otworzyć element poczta w panelu sterowania, użyj jednej z następujących metod:

    • Aby wykonać tę czynność na komputerze z systemem Windows XP lub Windows Server 2003, kliknij przycisk Start, kliknij polecenie Panel sterowania, kliknij pozycję konta użytkowników, a następnie kliknij pozycję poczta.

      Uwaga

      Jeśli korzystasz z widoku klasycznego, kliknij przycisk Start, kliknij polecenie Panel sterowania, a następnie kliknij dwukrotnie pozycję poczta.

    • Aby to zrobić na komputerze z systemem Microsoft Windows 2000, kliknij przycisk Start, wskaż polecenie Ustawienia, kliknij polecenie Panel sterowania, a następnie kliknij dwukrotnie pozycję poczta.

  8. Kliknij pozycję Pokaż profile, a następnie kliknij profil, który zawiera plik pst.

  9. Kliknij pozycję Właściwości, a następnie kliknij pozycję pliki danych.

  10. Kliknij przeniesiony plik danych PST, a następnie kliknij pozycję Ustawienia.

  11. Gdy zostanie wyświetlony monit o znalezienie pliku danych w starej lokalizacji, kliknij przycisk OK.

  12. Zlokalizuj, a następnie kliknij plik pst w lokalizacji nowy folder, a następnie kliknij przycisk Otwórz.

  13. Kliknij przycisk OK, a następnie kliknij przycisk Zamknij dwa razy.

  14. Kliknij przycisk OK.

  15. Zamknij Panel sterowania.

  16. Uruchom ponownie program Outlook.

Metoda 5

Wyczyść pole wyboru tylko na tym komputerze . Jeśli użyjesz reguły, aby przenieść wiadomości e-mail do pliku pst, kliknij, aby wyczyścić pole wyboru na tym komputerze tylko wtedy, gdy nie masz dostępu do poczty E-mail programu Exchange Server z różnych komputerów klienckich. Aby to zrobić w programie Outlook, wykonaj następujące czynności:

W przypadku programu Outlook 2010 i nowszych wersji:

  1. Na karcie plik kliknij pozycję informacje.
  2. Kliknij pozycję Zarządzaj regułami i alertami.
  3. Na karcie reguły wiadomości E-mail kliknij regułę, której nazwę chcesz zmienić.
  4. Kliknij pozycję Zmień regułę, a następnie kliknij pozycję Edytuj ustawienia reguły.
  5. Kliknij, aby wyczyścić pole wyboru tylko na tym komputerze , jeśli to pole wyboru jest zaznaczone.
  6. Ukończ pracę z kreatorem reguł. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

W przypadku programów Outlook 2007 i Outlook 2003:

  1. W menu Narzędzia kliknij polecenie reguły i alerty.

  2. Na karcie reguły wiadomości E-mail kliknij regułę, którą chcesz edytować.

  3. Na liście Zmień regułę kliknij pozycję Edytuj ustawienia reguły.

  4. Jeśli ta opcja jest zaznaczona, kliknij, aby wyczyścić pole wyboru tylko na tym komputerze .

  5. Ukończ pracę z kreatorem reguł.

  6. Kliknij przycisk OK , aby zamknąć okno dialogowe reguły i alerty .

    Uwaga

    Jeśli korzystasz z reguł klienta, które wskazują lokalne pliki zasobów, na przykład przenoszenie elementów do folderu w pliku PST i używasz wielu komputerów do uzyskiwania dostępu do programu Microsoft Outlook, mogą wystąpić konflikty reguł. Z tego powodu niektóre reguły klienta mogą być wyłączone.