Nie można utworzyć profilu programu Outlook po migracji za pomocą zdarzenia 1098 w dzienniku Tożsamość Microsoft Entra

Oryginalny numer KB: 4499299

Symptomy

Podczas próby utworzenia profilu programu Microsoft Outlook po migracji domeny zostanie wyświetlony komunikat o błędzie wskazujący, że nie można uruchomić programu Outlook lub wystąpił problem. Zostanie również wyświetlony monit o zalogowanie.

Zrzut ekranu przedstawiający komunikaty o błędach programu Outlook.

Ponadto w dzienniku operacyjnym Microsoft Entra może zostać wyświetlone zdarzenie 1098 podobne do następującego błędu:

Błąd: 2147943712

ErrorMessage: Określona sesja logowania nie istnieje. Być może została ona już zakończona. Określona sesja logowania nie istnieje. Być może została ona już zakończona.

AdditionalInformation: Wyjątek typu "klasa WinRTException" w webaccountprocessor.cpp, wiersz: 190, metoda:
Tożsamość Microsoft Entra::Core::WebAccountProcessor::P rocessBrokerRequest::<lambda_>::operator (). Dziennik: operacja brokera tokenów 0xcaa5001c nie powiodła się. Nazwa operacji: RequestToken Logged at webaccountprocessor.cpp, line: 520, method: Tożsamość Microsoft Entra::Core::WebAccountProcessor::ReportException.

Aby znaleźć dziennik operacyjny Microsoft Entra w Podgląd zdarzeń, znajdź dzienniki> aplikacji i usługMicrosoft>Windows>Tożsamość Microsoft Entra>Operational.

Zrzut ekranu przedstawiający lokalizację Microsoft Entra w Podgląd zdarzeń.

Przyczyna

Istnieje wiele scenariuszy, które mogą spowodować zmianę identyfikatora zabezpieczeń użytkownika (SID), na przykład migrację użytkownika do nowej domeny. Jednak profil użytkownika nie został zmieniony, a pliki danych, które mają stary identyfikator SID, są teraz buforowane w starym profilu. W takim przypadku może wystąpić problem z połączeniem pakietu Office lub pętle uwierzytelniania, które skutkują tym błędem.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki:

  1. Usuń wszystkie pliki z folderu Konta w następującej lokalizacji:

    %LOCALAPPDATA%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\TokenBroker\Accounts

    Uwaga

    Skopiuj i wklej powyższą lokalizację w polu Wyszukiwania w systemie Windows, aby znaleźć folder.

  2. Uruchom ponownie i ponownie utwórz profil programu Outlook.