Nie można utworzyć profil programu Outlook po migracji z zdarzeniem 1098 w dzienniku AAD

Oryginalny numer KB:   4499299

Symptomy

Podczas próby utworzenia konta microsoft profil programu Outlook migracji domeny pojawia się komunikat o błędzie z informacjami, że nie można uruchomić programu Outlook lub wystąpił problem. Zostanie również wyświetlony monit o zalogowanie się.

zrzut ekranu przedstawiający komunikaty o błędach

Ponadto w dzienniku operacyjnym usługi Azure Active Directory (AAD) może zostać wyświetlony dziennik zdarzeń 1098 podobny do następującego błędu:

Błąd: 2147943712

ErrorMessage: Określona sesja logowania nie istnieje. Być może już została zakończona. Określona sesja logowania nie istnieje. Być może już została zakończona.

Dodatkoweinformacje: Wyjątek typu "klasa WinRTException" w pliku webaccountprocessor.cpp, wiersz: 190, metoda:
AAD::Core::WebAccountProcessor::P rocessBrokerRequest::<lambda_>::operator (). Dziennik: 0xcaa5001c tokenu ma nieudane. Nazwa operacji: RequestToken Logged at webaccountprocessor.cpp, wiersz: 520, metoda: AAD::Core::WebAccountProcessor::ReportException.

Aby znaleźć dziennik operacyjny AAD w podglądzie zdarzeń, odszukaj dzienniki aplikacji i usług > systemu Microsoft > Windows > AAD > Operacyjne.

Lokalizacja usługi Azure Active Directory w podglądzie zdarzeń

Przyczyna

Istnieje wiele scenariuszy, które mogą doprowadzić do zmiany identyfikatora zabezpieczeń użytkownika (SID), na przykład migrowania użytkownika do nowej domeny. Profil użytkownika nie jest jednak zmieniany, a pliki danych, które mają stary identyfikator SID, są teraz buforowane w starym profilu. W takim przypadku może wystąpić problem z połączeniem pakietu Office lub pętle uwierzytelniania, które powoduje ten błąd.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Usuń wszystkie pliki z folderu Konta w następującej lokalizacji:

    %LOCALAPPDATA%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\TokenBroker\Accounts

    Uwaga

    Skopiuj i wklej powyższe miejsce w polu wyszukiwania systemu Windows, aby znaleźć ten folder.

  2. Uruchom ponownie i utwórz ponownie profil programu Outlook.