Niektóre funkcje klienta wiadomości błyskawicznych nie są dostępne w programie Outlook

Oryginalny numer KB: 2859256

Symptomy

Niektóre funkcje wiadomości błyskawicznych, które są współużytkowane między klientem wiadomości błyskawicznych i programem Microsoft Outlook, mogą być niedostępne. Na przykład w Microsoft Outlook 2010 elementy Szybkich kontaktów z programu Microsoft Lync nie są dostępne na pasku To-Do programu Outlook lub informacje o obecności i zdjęcia kontaktów nie są wyświetlane w programie Outlook.

Przyczyna

Ten problem może wystąpić, gdy nieprawidłowy lub niezgodny klient wiadomości błyskawicznych jest wymieniony jako wartość DefaultIMApp w rejestrze.

W jednym przypadku pomoc techniczna firmy Microsoft zespoły zobaczyły problem opisany w sekcji Objawy, zauważając, że wartość parametru DefaultIMApp została ustawiona na Cisco Jabber. Cisco Jabber jest produkowany przez Cisco Systems.

Rozwiązanie

[ ! WAŻNE] Uważnie wykonaj kroki opisane w tej sekcji. Niepoprawne zmodyfikowanie rejestru może być przyczyną poważnych problemów. Przed zmodyfikowaniem rejestru należy utworzyć jego kopię zapasową, aby móc przywrócić rejestr na wypadek problemów.

Aby rozwiązać ten problem, upewnij się, że DefaultIMApp wartość ciągu jest ustawiona na odpowiednią wartość dla zainstalowanego klienta wiadomości błyskawicznych. W poniższej tabeli wymieniono wartości do użycia dla różnych klientów wiadomości błyskawicznych od firmy Microsoft.

Zainstalowany klient wiadomości błyskawicznych Wartość dla defaultIMApp
Microsoft Office Communicator Communicator
Microsoft Lync 2010 Communicator
Microsoft Lync 2013 (Skype dla firm) Lync
Skype dla firm 2016
Skype (konsument)
Lync
Skype
Microsoft Teams Teams

Aby to zrobić, wykonaj następujące kroki.

  1. Zamknij program Outlook i klienta wiadomości błyskawicznych.

  2. Uruchom Edytor rejestru. W tym celu — zależnie od posiadanej wersji systemu Windows — zastosuj jedną z następujących procedur:

    • Windows 10, Windows 8.1 i Windows 8: naciśnij klawisz Windows+R, aby otworzyć okno dialogowe Uruchamianie. Wpisz regedit.exe, a następnie wybierz przycisk OK.
    • Windows 7: Wybierz pozycję Start, wpisz regedit.exe w polu Wyszukaj , a następnie naciśnij klawisz Enter.
  3. Odszukaj i wybierz następujący podklucz rejestru:

    HKEY_CURRENT_USER\SOFTWARE\IM Providers

  4. DefaultIMApp Wybierz wartość ciągu.

    Uwaga

    DefaultIMApp Jeśli wartość nie znajduje się w kluczu dostawcy wiadomości błyskawicznych, musi zostać utworzona ręcznie. Aby to zrobić, wykonaj następujące kroki.

    1. Kliknij prawym przyciskiem myszy pozycję Dostawcy wiadomości błyskawicznych, wskaż pozycję Nowy, a następnie wybierz pozycję Wartość ciągu.
    2. Kliknij prawym przyciskiem myszy nową wartość ciągu, a następnie wybierz pozycję Zmień nazwę.
    3. Zmień nazwę wartości ciągu na DefaultIMApp, a następnie naciśnij klawisz Enter.
  5. W menu Edycja wybierz polecenie Modyfikuj.

  6. Wpisz nazwę klienta wiadomości błyskawicznych, a następnie wybierz przycisk OK.

  7. Zakończ edytor rejestru.

  8. Uruchom klienta wiadomości błyskawicznych.

  9. Uruchom program Outlook.

Wyłączenie odpowiedzialności za kontakty z osobami trzecimi

Firma Microsoft udostępnia informacje dotyczące sposobów kontaktowania się z innymi firmami, aby ułatwić uzyskanie niezbędnej pomocy technicznej. Informacje te mogą zostać zmienione bez powiadomienia. Firma Microsoft nie gwarantuje dokładności informacji dotyczących innych firm.