Wprowadzenie do programu Power BI DesktopGetting started with Power BI Desktop

Witamy przewodniku Wprowadzenie do programu Power BI Desktop.Welcome to the Power BI Desktop Getting Started Guide. Ten krótki przewodnik po programie Power BI Desktop umożliwia zapoznanie się z działaniem programu, demonstruje jego możliwości i przyspiesza tworzenie niezawodnych modeli danych — wraz z zachwycającymi raportami — które uzupełniają działania w zakresie analizy biznesowej.This short tour of Power BI Desktop gets you acquainted with how it works, demonstrates what it can do, and accelerates your ability to build robust data models — along with amazing reports — that amplify your business intelligence efforts.

Wolisz oglądać zamiast czytać?Prefer to watch instead of read? Możesz też obejrzeć nasz wprowadzający film wideo.Feel free to take a look at our getting started video. A jeśli chcesz używać przykładowych danych podczas oglądania filmu, możesz pobrać ten przykładowy skoroszyt programu Excel.And if you want to follow along with the video with matching sample data, you can download this sample Excel workbook.

Program Power BI Desktop umożliwia tworzenie kolekcji zapytań, połączeń danych i raportów, które z łatwością można udostępniać innym osobom.Power BI Desktop lets you create a collection of queries, data connections, and reports that can easily be shared with others. Program Power BI Desktop integruje sprawdzone technologie firmy Microsoft — zaawansowany aparat zapytań, modelowanie danych i wizualizacje — i współpracuje bezproblemowo z usługą internetową Power BI.Power BI Desktop integrates proven Microsoft technologies – the powerful Query engine, data modeling, and visualizations – and works seamlessly with the online Power BI service.

Dzięki połączeniu programu Power BI Desktop (w którym analitycy i inne osoby mogą tworzyć zaawansowane połączenia danych, modele i raporty) z usługą Power BI (w której raporty programu Power BI Desktop można udostępniać innym użytkownikom w celu ich wyświetlania lub wchodzenia z nimi w interakcje) nowe szczegółowe informacje ze świata danych można jeszcze łatwiej modelować, tworzyć, udostępniać i rozszerzać.With the combination of Power BI Desktop (where analysts and others can create powerful data connections, models and reports) and the Power BI service (where Power BI Desktop reports can be shared so users can view and interact with them), new insights from the world of data are easier to model, build, share, and extend.

Dla analityków danych program Power BI Desktop to zaawansowane, elastyczne i wysoce dostępne narzędzie do łączenia i kształtowania danych, tworzenia niezawodnych modeli i opracowywania raportów o odpowiedniej strukturze.Data analysts will find Power BI Desktop a powerful, flexible, and a highly accessible tool to connect with and shape the world of data, build robust models, and craft well-structured reports.

Jak używać tego przewodnikaHow to use this guide

Możesz użyć tego przewodnika na kilka sposobów — przeskanować go, aby uzyskać szybki przegląd informacji lub przeczytać uważnie każdą sekcję, aby dobrze zrozumieć sposób działania programu Power BI Desktop.You can use this guide in a couple of ways – scan it for a quick overview, or read through each section for a strong understanding of how Power BI Desktop works.

Jeśli nie masz czasu, możesz pobieżnie przejrzeć ten przewodnik w ciągu kilku minut, aby zrozumieć, jak działa program Power BI Desktop i jak go używać.If you’re in a hurry you can do a visual sweep of this guide in just a couple minutes, and come away with a good sense of how Power BI Desktop operates, and how to use it. Większą część tego przewodnika stanowią zrzuty ekranu, które wizualnie pokazują sposób działania programu Power BI Desktop.Most of this guide consists of screens that visually show how Power BI Desktop works.

Aby zapewnić bardziej dokładne zrozumienie, możesz przeczytać każdą sekcję, wykonać kroki i odejść z własnym plikiem programu Power BI Desktop gotowym do opublikowania w usłudze Power BI i udostępnienia innym osobom.For a more thorough understanding you can read through each section, perform the steps, and walk away with your own Power BI Desktop file that’s ready to post onto the Power BI service, and share with others.

Uwaga

Istnieje również osobna, wyspecjalizowana wersja usługi Power BI o nazwie Serwer raportów usługi Power BI przeznaczona dla klientów, którzy chcą lokalnie obsługiwać swoje dane i raporty.There is also a separate and specialized version of Power BI called Power BI Report Server, which is for customers who need their data and reporting to remain on-premises. Istnieje również przeznaczona do użycia z tą specjalną wersją oddzielna, wyspecjalizowana wersja programu Power BI Desktop o nazwie Power BI Desktop dla serwera raportów usługi Power BI, która działa tylko w przypadku wersji serwera raportów dla usługi Power BI.For use with that specialized version, there's also a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. W tym artykule opisano standardowy program Power BI Desktop.This article describes the standard Power BI Desktop.

Jak działa program Power BI DesktopHow Power BI Desktop works

Przy użyciu programu Power BI Desktop możesz łączyć się z danymi (zazwyczaj wieloma źródłami danych), kształtować dane (przy użyciu zapytań tworzących interesujące, szczegółowe modele danych) oraz używać modeli do tworzenia raportów (do używania, rozwijania i współdzielenia przez inne osoby).With Power BI Desktop, you connect to data (usually multiple data sources), shape that data (with queries that build insightful, compelling data models), and use that model to create reports (which others can leverage, build upon, and share).

Po wykonaniu kroków zgodnie z oczekiwaniami — nawiązaniu połączenia, ukształtowaniu danych i utworzeniu raportu — możesz zapisać pracę w pliku programu Power BI Desktop, który ma rozszerzenie pbix.When the steps are completed to your satisfaction – connect, shape, and report – you can save that work in Power BI Desktop file format, which is the .pbix extension. Pliki Power BI Desktop można udostępniać tak jak dowolne inne formaty plików, ale najbardziej atrakcyjnym sposobem udostępniania plików programu Power BI Desktop jest ich przekazanie (udostępnienie) w usłudze Power BI.Power BI Desktop files can be shared like any other file, but the most compelling way to share Power BI Desktop files is to upload them (share them) on the Power BI service.

Program Power BI Desktop centralizuje, upraszcza i ułatwia proces projektowania i tworzenia repozytoriów i raportów analizy biznesowej, który może być w innym przypadku odłączony, rozproszony i uciążliwy.Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports.

Chcesz spróbować?Ready to give it a try? Zaczynajmy.Let’s get started.

Instalowanie i uruchamianie programu Power BI DesktopInstall and run Power BI Desktop

Możesz pobrać program Power BI Desktop z usługi Power BI, wybierając ikonę koła zębatego i opcję Power BI Desktop.You can download Power BI Desktop from the Power BI service, by selecting the gear icon, then select Power BI Desktop.

Program Power BI Desktop jest instalowany jako aplikacja i jest uruchamiany na pulpicie.Power BI Desktop is installed as an application, and runs on your desktop.

Po uruchomieniu programu Power BI Desktop zostanie wyświetlony ekran powitalny.When you run Power BI Desktop, a Welcome screen is displayed.

Możesz użyć opcji Pobierz dane, zobaczyć Ostatnio używane źródła lub skorzystać z opcji Otwórz inne Raporty bezpośrednio z ekranu powitalnego (przy użyciu linków w okienku po lewej stronie).You can Get Data, see Recent Sources, or Open Other Reports directly from the Welcome screen (from the links in the left pane). Jeśli zamkniesz ekran (ikona x w prawym górnym rogu), zostanie wyświetlony widok Raport programu Power BI Desktop.If you close the screen (select the x in the top right corner), the Report view of Power BI Desktop is displayed.

W programie Power BI Desktop istnieją trzy widoki: widok Raport, widok Dane i widok Relacje.There are three views in Power BI Desktop: Report view, Data view, and Relationships view. Program Power BI Desktop zawiera również Edytor zapytań, który jest otwierany w osobnym oknie.Power BI Desktop also includes Query Editor, which opens in a separate window. W Edytorze zapytań możesz tworzyć zapytania i przekształcać dane, a następnie załadować dostosowany model danych do programu Power BI Desktop i tworzyć raporty.In Query Editor, you can build queries and transform data, then load that refined data model into Power BI Desktop, and create reports.

Następujący ekran pokazuje trzy ikony widoków po lewej stronie programu Power BI Desktop: Raport, Dane i Relacje, od góry do dołu.The following screen shows the three view icons along the left of Power BI Desktop: Report, Data, and Relationships, from top to bottom. Obecnie wyświetlany widok jest wskazywany przez żółty pasek wzdłuż lewej strony.The currently displayed view is indicated by the yellow bar along the left. W tym przypadku obecnie wyświetlany jest widok Raport.In this case, Report view is currently displayed. Możesz zmienić widoki, wybierając dowolną z tych trzech ikon.You can change views by selecting any of those three icons.

Po zainstalowaniu programu Power BI Desktop masz wszystko gotowe, aby nawiązywać połączenia z danymi, kształtować dane i tworzyć raporty (zazwyczaj w tej kolejności).With Power BI Desktop installed you’re ready to connect to data, shape data, and build reports (usually in that order). W kolejnych sekcjach omówimy każdy z tych kroków.In the next few sections, we take a tour through each in turn.

Łączenie się z danymiConnect to data

Po zainstalowaniu programu Power BI Desktop możesz połączyć się z nieustannie rozszerzającym się światem danych.With Power BI Desktop installed, you’re ready to connect to the ever expanding world of data. W oknie zapytania są dostępne źródła danych wielu typów.There are all sorts of data sources available in the Query window. Na poniższej ilustracji pokazano sposób łączenia z danymi przez wybranie wstążki Narzędzia główne, a następnie pozycji Pobierz dane > Więcej.The following image shows how to connect to data, by selecting the Home ribbon, then Get Data > More.

W tym szybkim przewodniku nawiążemy połączenie z kilkoma różnymi internetowymi źródłami danych.For this quick tour, we'll connect to a couple different Web data sources.

Wyobraź sobie, że przechodzisz na emeryturę — chcesz mieszkać w miejscu o dużym nasłonecznieniu, w którym stosuje się preferencyjne podatki i zapewnia się dobrą opiekę zdrowotną. A może jesteś analitykiem danych i potrzebujesz tych informacji, aby pomóc swoim klientom.Imagine you’re retiring – you want to live where there’s lots of sunshine, preferable taxes, and good health care – or perhaps you’re a data analyst, and you want that information to help your customers. Przykładowo chcesz pomóc sprzedawcy okularów przeciwsłonecznych w nakierowaniu sprzedaży na miejsca, w których słońce świeci najczęściej.For example, perhaps you want to help your sunglasses retailer target sales where the sun shines most frequently.

Tak czy siak, poniższy zasób internetowy zawiera interesujące dane dotyczące tych tematów i nie tylko:Either way, the following Web resource has interesting data about those topics, and more:

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Wybierz pozycję Pobierz dane > Internet i wklej adres.Select Get Data > Web and paste the address.

Po wybraniu przycisku OK funkcja Zapytanie programu Power BI Desktop przystępuje do pracy.When you select OK, the Query functionality of Power BI Desktop goes to work. Zapytanie łączy się z zasobem internetowym i w oknie Nawigator zwracane są wyniki znalezione na stronie internetowej.Query contacts the Web resource, and the Navigator window returns what it found on that Web page. W tym przypadku została znaleziona tabela (Table 0) i cały dokument internetowy (Web Document).In this case, it found a table (Table 0) and the overall Web Document. Interesuje nas tabela, więc wybieramy ją z listy.We’re interested in the table, so we select it from the list. W oknie Nawigator pojawia się podgląd.The Navigator window displays a preview.

Na tym etapie możemy poddać edycji zapytanie przed załadowaniem tabeli, wybierając pozycję Edytuj u dołu okna, albo załadować tabelę.At this point we can edit the query before loading the table, by selecting Edit from the bottom of the window, or we can load the table.

Gdy wybierzemy opcję Edytuj, zostanie uruchomiony Edytor zapytań oraz zostanie wyświetlony reprezentatywny widok tabeli.When we select Edit, Query Editor launches and a representative view of the table is presented. Zostanie wyświetlone okienko Ustawienia zapytania. Jeśli tak się nie stanie, możesz wybrać pozycję Wyświetl ze wstążki, a następnie pozycje Pokaż > Ustawienia zapytania w celu wyświetlenia okienka Ustawienia zapytania.The Query Settings pane is displayed (if it’s not, you can select View from the ribbon, then Show > Query Settings to display the Query Settings pane). Oto jak to wygląda.Here’s what that looks like.

Aby uzyskać więcej informacji o łączeniu się z danymi, zobacz Nawiązywanie połączenia z danymi w programie Power BI Desktop.For more information about connecting to data, see Connect to Data in Power BI Desktop.

W następnej sekcji dostosujemy dane do naszych potrzeb.In the next section, we adjust the data so it meets our needs. Proces dostosowania podłączonych danych nazywa się kształtowaniem danych.The process of adjusting connected data is called shaping data.

Kształtowanie i łączenie danychShape and combine data

Teraz po nawiązaniu połączenia ze źródłem danych musimy dostosować dane do naszych potrzeb.Now that we’ve connected to a data source, we need to adjust the data to meet our needs. Czasami dostosowywanie oznacza przekształcanie danych, np. zmienianie nazw kolumn lub tabel, zmienianie tekstu na liczby, usuwanie wierszy, ustawianie pierwszego wiersza jako nagłówków i tak dalej.Sometimes adjusting means transforming the data – such as renaming columns or tables, changing text to numbers, removing rows, setting the first row as headers, and so on.

W Edytorze zapytań programu Power BI Desktop bardzo często używane są menu dostępne po kliknięciu prawym przyciskiem myszy oraz zadania dostępne we wstążce.The Query editor in Power BI Desktop makes ample use of right-click menus, in addition to having tasks available on the ribbon. Większość opcji, które można wybrać we wstążce Przekształć, jest również dostępna po kliknięciu prawym przyciskiem myszy elementu (takiego jak kolumna) i wybraniu z menu, które zostanie wyświetlone.Most of what you can select in the Transform ribbon is also available by right-clicking an item (such as a column) and choosing from the menu that appears.

Kształtowanie danychShape data

Kształtując dane w Edytorze zapytań, udostępniasz instrukcje krok po kroku (wykonywane przez Edytor zapytań), aby dostosować dane, które Edytor zapytań ładuje i prezentuje.When you shape data in the Query Editor, you’re providing step-by-step instructions (that Query Editor carries out for you) to adjust the data as Query Editor loads and presents it. Nie wpływa to na oryginalne źródło danych. Dostosowywanie, czyli kształtowanie, dotyczy tylko tego konkretnego widoku danych.The original data source is not affected; only this particular view of the data is adjusted, or shaped.

Określone kroki (takie jak zmiana nazwy tabeli, przekształcenie typu danych lub usunięcie kolumn) są rejestrowane przez Edytor zapytań, a następnie wykonywane za każdym razem, gdy to zapytanie połączy się ze źródłem danych. Dzięki temu dane są zawsze kształtowane zgodnie z Twoimi instrukcjami.The steps you specify (such as rename a table, transform a data type, or delete columns) are recorded by Query Editor, and each time this query connects to the data source those steps are carried out so that the data is always shaped the way you specify. Ten proces odbywa się za każdym, gdy użyjesz zapytania w programie Power BI Desktop lub gdy dowolny użytkownik użyje Twojego udostępnionego zapytania, na przykład w usłudze Power BI.This process occurs whenever you use the query in Power BI Desktop, or for anyone who uses your shared query, such as in the Power BI service. Kroki są przechwytywane sekwencyjnie w okienku Ustawienia zapytania w obszarze Zastosowane kroki.Those steps are captured, sequentially, in the Query Settings pane under Applied Steps.

Poniższy obraz przedstawia okienko Ustawienia zapytania dla zapytania, które zostało ukształtowane — w kilku następnych akapitach przyjrzymy się każdemu z tych kroków.The following image shows the Query Settings pane for a query that has been shaped – we’ll go through each of those steps in the next few paragraphs.

Wróćmy do naszych danych dotyczących emerytury, które znaleźliśmy po nawiązaniu połączenia z internetowym źródłem danych, i ukształtujmy te dane zgodnie z naszymi potrzebami.Let’s get back to our retirement data, which we found by connecting to a Web data source, and shape that data to fit our needs.

Po pierwsze większość klasyfikacji zostało przeniesionych do Edytora zapytań jako liczby całkowite, ale nie wszystkie z nich (jedna kolumna zawierała tekst i liczby, więc nie została automatycznie skonwertowana).For starters, most ratings were brought into Query Editor as whole numbers, but not all of them (one column contained text and numbers, so it wasn't automatically converted). Potrzebne nam są dane w formie liczb.We need the data to be numbers. Żaden problem — po prostu kliknij nagłówek kolumny prawym przyciskiem myszy i wybierz pozycje Zmień typ > Liczba całkowita w celu zmiany typu danych.No problem – just right-click the column header, and select Change Type > Whole Number to change the data type. Aby w razie potrzeby zaznaczyć więcej niż jedną kolumnę, zaznacz kolumnę, naciśnij i przytrzymaj klawisz SHIFT, wybierz kolejne przyległe kolumny, a następnie kliknij prawym przyciskiem myszy nagłówek kolumny w celu zmienienia wszystkich zaznaczonych kolumn.If we needed to choose more than one column, we could first select a column then hold down SHIFT, select additional adjacent columns, and then right-click a column header to change all selected columns. Możesz też użyć klawisza CTRL, aby wybrać kolumny, które ze sobą nie sąsiadują.You can also use CTRL to select non-adjacent columns.

Ponadto możesz zmienić lub przekształcić te kolumny z tekstu na nagłówek, korzystając ze wstążki Przekształć.You can also change, or transform, those columns from text to header by using the Transform ribbon. Oto wstążka Przekształć i strzałka wskazująca przycisk Typ danych, który umożliwia przekształcenie bieżącego typu danych na inny.Here’s the Transform ribbon, with an arrow pointing toward the Data Type button, which lets you transform the current data type to another.

Zauważ, że w okienku Ustawienia zapytania sekcja Zastosowane kroki odzwierciedla wprowadzone zmiany.Note that in Query Settings, the Applied Steps reflect the changes that were made. Aby usunąć dowolny krok z procesu kształtowania, po prostu wybierz ten krok, a następnie wybierz symbol X po lewej stronie kroku.If I want to remove any step from the shaping process, I simply select that step, and then select the X to the left of the step.

Aby zapytanie było zgodne z naszymi oczekiwaniami, musimy wprowadzić jeszcze kilka zmian:We need to make a few more changes to get the query where we want it:

  • Usuniemy pierwszą kolumnę — nie potrzebujemy jej. Zawiera tylko zbędne wiersze z tekstem „Check out how your state ranks for retirement”, co jest pozostałością po tym, że jest tabelą internetową.Remove the first column – we don’t need it, it just includes redundant rows that say “Check out how your state ranks for retirement” which is an artifact of this being a Web based table
  • Naprawimy kilka błędów — na stronie internetowej jedna z kolumn zawierała tekst i liczby (niektóre stany powiązane w jednej kategorii).Fix a few Errors – on the Web page, one column had text mixed in with the numbers (some states tied in one category). Dane działają nieźle na stronie internetowej, ale niezbyt dobrze w przypadku naszej analizy danych.That works well in the website, but not for our data analysis. Naprawienie tego błędu jest proste (w tym przypadku) i zademonstruje nam ciekawe funkcje i możliwości Edytora zapytań i opcji Zastosowane kroki.It's easy (in this case) to fix, and shows some cool features and capabilities of Query Editor and its Applied Steps
  • Zmienimy nazwę tabeliTable 0 nie jest przydatną nazwą, ale jej zmiana jest prosta.Change the Table Name – that Table 0 is not a useful descriptor, but changing it simple

Każdy z tych kroków został zaprezentowany w sekcji Kształtowanie i łączenie danych w programie Power BI Desktop.Each of these steps is demonstrated in Shape and Combine Data in Power BI Desktop. Możesz sprawdzić tę stronę lub kontynuować pracę z tym dokumentem, aby zobaczyć, co możesz zrobić dalej.Feel free to check out that page, or keep going in this document to see what you would do next. Następna sekcja rozpoczyna się od momentu wprowadzenia powyższych zmian.The next section picks up after the changes above are applied.

Łączenie danychCombine data

Dane dotyczące różnych stanów są interesujące i będą użyteczne podczas tworzenia dodatkowych zapytań i analizowania.That data about various states is interesting, and will be useful for building additional analysis efforts and queries. Jest jednak jeden problem: w większości istniejących danych używane są dwuliterowe skróty kodów stanów, a nie pełne nazwy.But there’s one problem: most data out there uses a two-letter abbreviation for state codes, not the full name of the state. Potrzebujemy sposobu na skojarzenie nazw stanów z ich skrótami.We need some way to associate state names with their abbreviations.

Mamy szczęście: istnieje inne publiczne źródło danych, które właśnie to robi, ale zanim połączymy je z naszą tabelą dotyczącą emerytur, konieczna będzie znaczna ilość operacji w celu ukształtowania danych.We’re in luck: there’s another public data source that does just that, but it needs a fair amount of shaping before we can connect it to our retirement table. Oto zasób internetowy zawierający skróty nazw stanów:Here’s the Web resource for state abbreviations:

http://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations

Ze wstążki Narzędzia główne w Edytorze zapytań wybieramy polecenie Pobierz dane> Internet i wpisujemy adres. Następnie wybieramy przycisk OK, a Nawigator wyświetli to, co znalazł na tej stronie internetowej.From the Home ribbon in Query Editor, we select Get Data > Web and type the address, select OK, and the Navigator window shows what it found on that Web page.

Wybieramy tabelę Table[edit], ponieważ zawiera ona dane, których potrzebujemy, ale dostosowanie danych z tej tabeli będzie wymagało znacznej liczby operacji kształtowania.We select Table[edit] because it includes the data we want, but it’s going to take quite a bit of shaping to pare that table’s data down. Każdy z tych kroków został zaprezentowany również w sekcji Kształtowanie i łączenie danych w programie Power BI Desktop.Each of these steps is also demonstrated in Shape and Combine Data in Power BI Desktop. Podsumujmy te kroki:To summarize those steps, here's what we do:

Wybierzemy opcję Edytuj, a następnie:We select Edit, then:

  • Usuniemy dwa pierwsze wiersze — są one wynikiem sposobu utworzenia tabeli na stronie internetowej i nie są nam potrzebne.Remove the top two rows – they’re a result of the way that Web page’s table was created, and we don’t need them.
  • Usuniemy 26 ostatnich wierszy — wszystkie one dotyczą terytoriów i nie musimy ich uwzględniać.Remove the bottom 26 rows – they’re all the territories, which we don’t need to include.
  • Odfiltrujemy Waszyngton DC — tabela statystyk dotyczących emerytury nie obejmuje regionu DC, więc wykluczymy go z naszej listy.Filter out Washington DC – the retirement stats table doesn't include DC, so we'll exclude it from our list.
  • Usuniemy kilka niepotrzebnych kolumn — potrzebujemy tylko odwzorowania nazwy stanu na jej oficjalny dwuliterowy skrót, dlatego możemy usunąć inne kolumny.Remove a few unneeded columns – we only need the mapping of state to its official two-letter abbreviation, so we can remove the other columns.
  • Użyjemy pierwszego wiersza jako nagłówków — usunęliśmy trzy pierwsze wiersze i obecny pierwszy wiersz jest nagłówkiem, którego potrzebujemy.Use the first row as headers – since we removed the top three rows, the current top row is the header we want.

    Uwaga

    To dobry moment na to, aby wspomnieć, że kolejność zastosowanych kroków w Edytorze zapytań jest istotna i może wpłynąć na kształt danych.This is a good time to point out that the sequence of applied steps in Query Editor is important, and can affect how the data is shaped. Należy również pamiętać o tym, że jeden krok może wpłynąć na kolejne kroki. Jeśli usuniesz krok z obszaru Zastosowane kroki, kolejne kroki mogą zachowywać się inaczej niż oczekiwano z powodu wpływu sekwencji kroków w zapytaniu.It’s also important to consider how one step may impact another subsequent step; if you remove a step from the Applied Steps, subsequent steps may not behave as originally intended, because of the impact of the query’s sequence of steps.

  • Zmienimy nazwy kolumn oraz samej tabeli — jak zwykle istnieje kilka sposobów na zmianę nazwy kolumny. Możesz wybrać dowolny z nich.Rename the columns, and the table itself – as usual, there are a couple ways to rename a column, you can choose whichever you prefer.

Ukształtowaliśmy tabelę StateCodes, a teraz możemy połączyć te dwie tabele (zapytania) w jedną. Obecne tabele są wynikiem zapytań zastosowanych względem danych, dlatego często są nazywane zapytaniami.With the StateCodes table shaped, we can combine these two tables, or queries, into one; since the tables we now have are a result of the queries we applied to the data, they’re often referred to as queries.

Istnieją dwa podstawowe sposoby łączenia zapytań — scalanie i dołączanie.There are two primary ways of combining queries – merging and appending.

Jeśli masz co najmniej jedną kolumnę, którą chcesz dodać do innego zapytania, scalasz zapytania.When you have one or more columns that you’d like to add to another query, you merge the queries. Jeśli masz dodatkowe wiersze danych, które chcesz dodać do istniejącego zapytania, wówczas dołączasz zapytanie.When you have additional rows of data that you’d like to add to an existing query, you append the query.

W tym przypadku chcemy scalić zapytania.In this case we want to merge queries. Aby rozpocząć, możemy wybrać zapytanie, z którym chcemy scalić inne zapytanie, a następnie wybrać opcję Scal zapytania na karcie Narzędzia główne na wstążce.To get started, we select the query into which we want the other query to merge, then select Merge Queries from the Home tab on the ribbon.

Zostanie wyświetlone okno Scalanie z prośbą o wybranie tabeli, która ma zostać scalona z wybraną tabelą, oraz pasujących kolumn na potrzeby scalania.The Merge window appears, prompting us to select which table we’d like merged into the selected table, and then, the matching columns to use for the merge. Wybierz kolumnę State z tabeli (zapytania) RetirementStats, a następnie zapytanie StateCodes (w tym przypadku jest łatwo, ponieważ istnieje tylko jedno inne zapytanie — w przypadku nawiązania połączenia z wieloma źródłami danych istnieje wiele zapytań do wyboru).Select State from the RetirementStats table (query), then select the StateCodes query (easy in this case, since there’s only one other query – when you connect to many data sources, there are many queries to choose from). Gdy wybierzemy poprawne pasujące kolumny — State z zapytania RetirementStats i State Name z zapytania StateCodes — wówczas okno Scalanie będzie wyglądać podobnie, jak poniższe, a przycisk OK będzie włączony.When we select the correct matching columns – State from RetirementStats, and State Name from StateCodes – the Merge window looks like the following, and the OK button is enabled.

Na końcu zapytania zostanie utworzona kolumna Nowa kolumna, w której znajduje się zawartość tabeli (zapytania) scalonej z istniejącym zapytaniem.A NewColumn is created at the end of the query, which is the contents of the table (query) that was merged with the existing query. Wszystkie kolumny ze scalonego zapytania są zmniejszone do kolumny Nowa kolumna, ale można wybrać opcję Rozwiń, aby rozwinąć tabelę i dołączyć dowolne kolumny.All columns from the merged query are condensed into the NewColumn, but you can select to Expand the table, and include whichever columns you want. Aby rozwinąć scaloną tabelę i wybrać kolumny do dołączenia, wybierz ikonę Rozwiń ().To expand the merged table, and select which columns to include, select the expand icon (). Zostanie wyświetlone okno Rozwijanie.The Expand window appears.

W tym przypadku potrzebujemy tylko kolumny State Code, dlatego wybieramy tylko ją, a następnie przycisk OK.In this case, we only want the State Code column, so we select only that column and then select OK. Usuwamy zaznaczenie pola wyboru Użyj oryginalnej nazwy kolumny jako prefiksu, ponieważ nie potrzebujemy tej opcji. Jeśli to pole pozostanie zaznaczone, scalona kolumna będzie miała nazwę Nowa kolumna.State Code (oryginalna nazwa kolumny, czyli Nowa kolumna, kropka, a następnie nazwa kolumny wprowadzanej do zapytania).We clear the checkbox from Use original column name as prefix because we don’t need or want that; if we leave that selected, the merged column would be named NewColumn.State Code (the original column name, or NewColumn, then a dot, then the name of the column being brought into the query).

Uwaga

Chcesz wypróbować wprowadzanie tej tabeli Nowa kolumna?Want to play around with how to bring in that NewColumn table? Możesz trochę poeksperymentować, a jeśli nie spodobają Ci się wyniki, po prostu usuń ten krok z listy Zastosowane kroki w okienku Ustawienia zapytania. Zapytanie wróci do stanu sprzed zastosowania kroku Rozwiń.You can experiment a bit, and if you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane; your query returns to the state prior to applying that Expand step. Możesz powtarzać te czynności dowolną liczbę razy, aż dostosujesz proces rozwijania do swoich potrzeb.It’s like a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

Teraz mamy pojedyncze zapytanie (tabelę), które łączy w sobie dwa źródła danych, a każde z nich zostało ukształtowane zgodnie z naszymi potrzebami.We now have a single query (table) that combined two data sources, each of which has been shaped to meet our needs. To zapytanie może służyć jako podstawa dla wielu dodatkowych, interesujących połączeń danych, takich jak statystyki wydatków na mieszkania, dane demograficzne lub oferty pracy w dowolnym stanie.This query can serve as a basis for lots of additional, interesting data connections – such as housing cost statistics, demographics, or job opportunities in any state.

Aby uzyskać bardziej szczegółowy opis każdego z tych kroków kształtowania i łączenia danych, zobacz Kształtowanie i łączenie danych w programie Power BI Desktop.For a more complete description of each of these shape and combine data steps, see Shape and Combine Data in Power BI Desktop.

Na razie mamy dość danych, aby utworzyć kilka interesujących raportów w programie Power BI Desktop.For now, we have enough data to create a few interesting reports, all within Power BI Desktop. Ponieważ jest to ważny etap, zapiszemy ten plik programu Power BI Desktop — nazwijmy go Wprowadzenie do programu Power BI Desktop.Since this is a milestone let’s save this Power BI Desktop file – we’ll call it Getting Started with Power BI Desktop. Aby zastosować zmiany w Edytorze zapytań i załadować je do programu Power BI Desktop, użyj opcji Zamknij i zastosuj na wstążce Narzędzia główne.To apply the changes in Query Editor and load them into Power BI Desktop, select Close & Apply from the Home ribbon.

Tworzenie raportówBuild reports

Po załadowaniu tabeli można wprowadzić dodatkowe zmiany. Możesz też ponownie załadować model, aby zastosować wszelkie wprowadzone zmiany.Additional changes can be made after the table is loaded, and you can reload a model to apply any changes you make. Jednak chwilowo wystarczy to, co mamy.But for now this will do. W widoku Raport programu Power BI Desktop możesz rozpocząć tworzenie raportów.In Power BI Desktop Report view, you can begin to build reports.

Widok Raport ma pięć głównych obszarów:The Report view has five main areas:

  1. Wstążka, która wyświetla typowe zadania związane z raportami i wizualizacjami.The ribbon, which displays common tasks associated with reports and visualizations

  2. Widok Raport (czyli kanwa), w którym tworzy się i rozmieszcza wizualizacje.The Report view, or canvas, where visualizations are created and arranged

  3. Obszar karty Strony u dołu, który umożliwia wybranie lub dodanie strony raportu.The Pages tab area along the bottom, which lets you select or add a report page

  4. Okienko Wizualizacje, w którym można zmieniać wizualizacje, dostosowywać kolory lub osie, stosować filtry, przeciągać pola i wykonywać inne czynności.The Visualizations pane, where you can change visualizations, customize colors or axes, apply filters, drag fields, and more

  5. Okienko Pola, w którym można przeciągać elementy zapytania i filtry do widoku Raport lub obszaru Filtry okienka Wizualizacje.The Fields pane, where query elements and filters can be dragged onto the Report view, or dragged to the Filters area of the Visualizations pane

Okienka Wizualizacje i Pola można zwinąć, wybierając małą strzałkę wzdłuż krawędzi, co daje więcej miejsca w widoku Raport na tworzenie atrakcyjnych wizualizacji.The Visualizations and Fields pane can be collapsed by selecting the small arrow along the edge, providing more space in the Report view to build cool visualizations. Podczas modyfikowania wizualizacji te strzałki będą wskazywać w górę lub w dół, co oznacza, że odpowiednio można rozwinąć lub zwinąć tę sekcję.When modifying visualizations, you'll also see these arrows pointing up or down, which means you can expand or collapse that section, accordingly.

Aby utworzyć wizualizację, po prostu przeciągnij pole z listy Pola do widoku Raport.To create a visualization, just drag a field from the Fields list onto the Report view. W takim razie przeciągnijmy pole Stan z obszaru RetirementStats i zobaczmy, co się stanie.In this case, let’s drag the State field from RetirementStats, and see what happens.

Popatrz... Program Power BI Desktop automatycznie utworzył wizualizację opartą na mapie, ponieważ rozpoznał, że pole Stan zawiera dane geolokalizacji.Look at that... Power BI Desktop automatically created a map-based visualization, because it recognized that the State field contained geolocation data.

Zwróć uwagę, że w okienku Wizualizacje mogę wybrać różne rodzaje wizualizacji, a w obszarze poniżej tych ikon mogę przeciągnąć pola do innych obszarów, aby zastosować legendę lub w inny sposób zmodyfikować wizualizację.Notice that in the Visualizations pane, I can select different types of visualizations, and in the area below those icons, I can drag fields to different areas to apply a Legend, or otherwise modify the visualization.

Przyspieszmy nieco bieg wypadków i zobaczmy, jak widok Raport będzie wyglądać po dodaniu kilku wizualizacji oraz kilku nowych stron raportu.Let’s fast-forward a bit, and see what the Report view looks like after a handful of visualizations have been added, as well as a few new Report pages. Aby uzyskać więcej informacji o raportach, zobacz Widok raportu w programie Power BI Desktop.For more information about reports, see Report View in Power BI Desktop.

Pierwsza strona raportu zapewnia perspektywę danych w oparciu o Klasyfikację ogólną.The first Report page provides a perspective of the data based on Overall rank. Gdy wybierzemy jedną z wizualizacji, okienko Pola i filtry wskaże wybrane pola i strukturę wizualizacji (które pola są zastosowane do pozycji Udostępniona oś, Wartości kolumny i Wartości wiersza).When we select one of the visualizations, the Fields and Filters pane shows which fields are selected, and the structure of the visualization (which fields are applied to the Shared Axis, Column Values, and Line Values).

Ten raport zawiera sześć stron. Każda strona wizualizuje wybrane elementy danych.There are six Pages in this Report, each visualizing certain elements of our data.

  1. Pierwsza strona, pokazana powyżej, przedstawia wszystkie stany w oparciu o Klasyfikację ogólną.The first page, shown above, shows all states based on Overall rank.
  2. Druga strona skupia się na dziesięciu najpopularniejszych stanach w oparciu o Klasyfikację ogólną.The second page focuses on the top ten states based on Overall rank.
  3. Trzecia strona zawiera wizualizację najlepszych 10 stanów pod kątem kosztów utrzymania (i skojarzone dane).For the third page, the best 10 states for cost of living (and associated data) are visualized.
  4. Na czwartej stronie skupiono się na pogodzie z filtrowaniem do 15 najbardziej nasłonecznionych stanów.Weather is the focus of the fourth page, filtered to the 15 sunniest states.
  5. Na piątej stronie opracowano wykresy i wizualizację dobrobytu społeczności dla 15 najlepszych stanów.On the fifth page, Community well-being is charted and visualized for the top 15 states.
  6. W końcu opracowano wizualizację statystyk dotyczących przestępczości, aby przedstawić najlepsze (oraz najgorsze) dziesięć stanów.Lastly, crime statistics are visualized, showing the best (and well, the last) ten states.

Oto jak wygląda strona raportu skupiająca się na kosztach utrzymania.Here’s what the cost of living-focused Report page looks like.

Istnieją różnego rodzaju interesujące raporty i wizualizacje, które możesz utworzyć.There are all sorts of interesting reports and visualizations you can create.

Udostępnianie wyników pracyShare your work

Teraz, skoro mamy już względnie ukończony raport programu Power BI Desktop, możemy udostępnić go innym osobom w usłudze Power BI.Now that we have a Power BI Desktop report that’s reasonably complete, we can share it with others on the Power BI service. Istnieje kilka sposobów na udostępnianie pracy w programie Power BI Desktop.There are a few ways to share your work in Power BI Desktop. Możesz opublikować w usłudze Power BI, przekazać plik pbix bezpośrednio z usługi Power BI lub zapisać plik pbix i wysłać go tak jak każdy inny plik.You can publish to the Power BI service, you can upload the .pbix file directly from the Power BI service, or you can save the .pbix file and send it like any other file.

Najpierw przyjrzyjmy się opcji publikowania w usłudze Power BI bezpośrednio z programu Power BI Desktop.First, let's look at publishing to the Power BI service directly from Power BI Desktop. Na wstążce Narzędzia główne wybierz opcję Publikuj.On the Home ribbon, select Publish.

Może zostać wyświetlony monit logowania do usługi Power BI.You may be prompted to sign in to Power BI.

Po zalogowaniu i zakończeniu procesu publikowania zostanie wyświetlone następujące okno dialogowe.When you've signed in and the publish process is complete, you see the following dialog.

Po zalogowaniu się do usługi Power BI zobaczysz załadowany plik programu Power BI Desktop w sekcjach Pulpity nawigacyjne, Raporty i Zestawy danych w usłudze.When you sign in to Power BI, you'll see Power BI Desktop file you just loaded in the Dashboards, Reports, and Datasets sections of the service.

Innym sposobem udostępnienia pracy jest załadowanie pliku z poziomu usług Power BI.Another way to share your work is to load it from within the Power BI service. Poniższy link otworzy usługę Power BI w przeglądarce:The following link brings up the Power BI service in a browser:

https://app.powerbi.com

Wybierz opcję Pobierz dane, aby rozpocząć proces ładowania raportu programu Power BI Desktop.Select Get Data to start the process of loading your Power BI Desktop report.

Pojawi się strona Pobieranie danych, na której możesz wybrać, skąd chcesz pobrać dane.The Get Data page appears, from which you can select where to get your data from. W tym przypadku wybieramy opcję Pobierz w polu Pliki.In this case, we select Get from the Files box.

Zostanie wyświetlony widok Pliki.The Files view appears. W tym przypadku wybieramy opcję Plik lokalny.In this case, we select Local File.

Po wybraniu pliku usługa Power BI przekazuje plik.When you select the file, Power BI uploads the file.

Po przekazaniu pliku można wybrać plik w sekcji Raporty w okienku po lewej stornie w usłudze Power BI.Once the file is uploaded, you can select the file from the Reports in the left pane of the Power BI service.

Usługa Power BI wyświetli pierwszą stronę raportu.The Power BI service displays the first page of the report. Wzdłuż dolnej części strony możesz wybrać dowolną kartę, aby wybrać tę stronę raportu.Along the bottom of the page, you can select any tab to display that page of the report.

Możesz wprowadzić zmiany w raporcie w usłudze Power BI, wybierając opcję Edytuj raport w górnej części kanwy raportu.You can make changes to a report in the Power BI service by selecting Edit Report from the top of the report canvas.

Aby zapisać raport, wybierz opcję Plik > Zapisz jako w usłudze.To save your report, select File > Save As from the service. Istnieją różnego rodzaju interesujące wizualizacje, które możesz utworzyć w usłudze Power BI z raportu, a następnie przypiąć je do pulpitu nawigacyjnego.There are all sorts of interesting visuals you can create in the Power BI service from your report, which you can pin to a dashboard. Aby dowiedzieć się więcej o pulpitach nawigacyjnych w usłudze Power BI, zobacz Porady dotyczące projektowania doskonałych pulpitów nawigacyjnych.To learn about dashboards in the Power BI service, see Tips for designing a great dashboard.

Po zapisaniu wybierz ikonę Udostępnij na stronie głównej.Once saved, select the Share icon on the main page.

W tym miejscu możesz wysłać wiadomość e-mail do współpracowników, którym chcesz udostępnić pulpit nawigacyjny.From here, you can send an email to colleagues with whom you’d like to share the dashboard.

Aby uzyskać więcej informacji o tworzeniu, udostępnianiu i modyfikowaniu pulpitów nawigacyjnych, zobacz Udostępnianie pulpitu nawigacyjnego.For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

Istnieją różne rodzaje interesujących kombinacji i wizualizacji związanych z danymi, które możesz wykonać przy użyciu programu Power BI Desktop i usługi Power BI.There are all sorts of compelling data-related mash-ups and visualizations you can do with Power BI Desktop, and with the Power BI service. Zapoznaj się z następną sekcją, aby uzyskać więcej informacji.Check out the next section for more information.

DiagnostykaDiagnostics

Program Power BI Desktop obsługuje nawiązywanie połączenia z portem diagnostycznym.Power BI desktop supports connecting to a diagnostics port. Port diagnostyczny umożliwia innym narzędziom nawiązywanie połączenia i przeprowadzanie śledzeń w celach diagnostycznych.The diagnostic port allows for other tools to connect to and perform traces for diagnostic purposes. Wprowadzanie jakichkolwiek zmian w modelu nie jest obsługiwane! Zmiany w modelu mogą prowadzić do uszkodzenia i utraty danych.Making any changes to the model is not supported! Changes to the model may lead to corruption and data loss.

Następne krokiNext steps

Przy użyciu programu Power BI Desktop można wykonywać różnorodne zadania.There are all sorts of things you can do with Power BI Desktop. Aby uzyskać więcej informacji na temat jego możliwości, skorzystaj z następujących zasobów:For more information on its capabilities, check out the following resources: