Configuration Manager klienci nie otrzymują aktualizacji oprogramowania

W tym artykule rozwiązano problem polegający na tym, że klienci Configuration Manager nie mogą pobierać aktualizacji z punktu aktualizacji oprogramowania.

Oryginalna wersja produktu: Configuration Manager (bieżąca gałąź — wersja 1702)
Oryginalny numer KB: 4041012

Objaw

Po zainstalowaniu Configuration Manager bieżącej wersji gałęzi 1702 mogą wystąpić następujące objawy:

  • Nowo zainstalowani klienci nie mogą pobierać aktualizacji z punktu aktualizacji oprogramowania. Może to również wystąpić, jeśli punkt aktualizacji oprogramowania zostanie przeniesiony na inny serwer po zainstalowaniu wersji 1702. Po włączeniu pełnego rejestrowania klienta plik LocationServices.log zawiera pustą wartość wpisu WSUSLocationReply .
  • Niektóre komputery są wyświetlane w konsoli jako Nieznany stan.

Przyczyna

Począwszy od Configuration Manager bieżącej wersji gałęzi 1702, klienci używają grup granic do znalezienia nowego punktu aktualizacji oprogramowania oraz do powrotu i znalezienia nowego punktu aktualizacji oprogramowania, jeśli ich bieżący punkt nie jest już dostępny. Jeśli zainstalujesz nową lokację z wersją 1702 lub nowszą, musisz przypisać punkty aktualizacji oprogramowania do grupy granic, aby klienci mogli ich znaleźć i z nich korzystać.

Rozwiązanie

Dodaj serwer z uruchomionym punktem aktualizacji oprogramowania do domyślnej grupy granic lokacji dla klientów. Możesz dodać pojedyncze punkty aktualizacji oprogramowania do różnych grup granic, aby kontrolować serwery, które klient może znaleźć. Aby uzyskać więcej informacji, zobacz punkty aktualizacji oprogramowania.

Aby dodać punkt aktualizacji oprogramowania do grupy granic, wykonaj następujące kroki:

  1. Utwórz grupę granic, jeśli nie istnieje, i dodaj wszystkie maszyny klienckie do grupy granic z punktem aktualizacji oprogramowania jako serwerem lokacji.
  2. Uruchom cykl oceny & pobierania zasad maszyny na Configuration Manager.
  3. Sprawdź LocationServices.log na maszynie klienckiej, aby potwierdzić, że klient może nawiązać połączenie z serwerem Windows Server Update Services (WSUS).

Uwaga

Po wykonaniu tej czynności mogą wystąpić tymczasowe przekroczenia limitu czasu, jeśli duża liczba klientów próbuje nawiązać połączenie z serwerem WSUS. Może to również powodować wysokie użycie procesora CPU na serwerze WSUS. Ponieważ klienci łączą użycie procesora CPU, powinno powrócić do normy. Jeśli wysokie użycie procesora CPU będzie się powtarzać po połączeniu wszystkich klientów, zobacz Rozwiązywanie problemów z wysokim użyciem procesora CPU na serwerze WSUS.