Zasób dysku fizycznego może nie być w trybie online w węźle klastra

Ten artykuł pomaga rozwiązać problem polegający na tym, że zasób dysku fizycznego nie jest w trybie online w węźle klastra.

Dotyczy: Windows Server 2012 R2
Oryginalny numer KB: 981475

Symptomy

W węźle klastra z systemem Windows Server zasób dysku fizycznego może wprowadzić stan Niepowodzenie podczas próby przeniesienia grupy zawierającej zasób dysku fizycznego. Jeśli ponownie uruchomisz węzeł klastra, który ma zasób dysku fizycznego, który nie przeszedł do trybu online, problem zostanie tymczasowo rozwiązany.

W przypadku wystąpienia tego problemu następujące wpisy są rejestrowane w dzienniku klastra dla zasobu dysku fizycznego, który wprowadził stan niepowodzenia :

000020cc.000014d0::<DateTime> ERR Dysk fizyczny <Q:>:
DiskspCheckPath: Funkcja GetFileAttrs(Q:) zwróciła stan 87.
000020cc.000014d0::<DateTime> WARN Dysk fizyczny <Q:>:
DiskspCheckDriveLetter: sprawdzanie nazwy dysku (Q:) zwraca wartość 87

Ponadto następujące zdarzenia są rejestrowane w dzienniku zdarzeń systemowych:

Typ zdarzenia: błąd
Źródło zdarzenia: ClusSvc
Kategoria zdarzenia: zasób dysku fizycznego
Identyfikator zdarzenia: 1066
Data: <data>
Czas: <czas>
Użytkownik: N/A
Komputer: <nazwa węzła>
Opis: Zasób dysku klastra "Dysk Q:" jest uszkodzony. Uruchom polecenie "ChkDsk /F", aby naprawić problemy. Nazwa woluminu dla tego zasobu to "<\?\Volume{4323d41e-1379-11dd-9538-001e0b20dfe6}>". Jeśli jest dostępna, dane wyjściowe ChkDsk będą znajdować się w pliku "C:\WINDOWS\Cluster\ChkDsk_Disk2_SigB05E593B.log". Program ChkDsk może zapisywać informacje w dzienniku zdarzeń aplikacji o identyfikatorze zdarzenia 26180.

Typ zdarzenia: błąd
Źródło zdarzenia: ClusSvc
Kategoria zdarzenia: zasób dysku fizycznego
Identyfikator zdarzenia: 1035
Data: <data>
Czas: <czas>
Użytkownik: N/A
Komputer: <nazwa węzła>
Opis: Nie można zainstalować zasobu dysku klastra "Dysk Q:".

Podobnie w węźle klastra systemu Windows Server w dzienniku klastra mogą być widoczne następujące wpisy:

00000db0.00000868::<DateTime> WARN [RES] Dysk klastra dysków <fizycznych 1>: OnlineThread: Nie można uzyskać identyfikatora GUID woluminu dla urządzenia \?\GLOBALROOT\Device\Harddisk15\Partition1. Błąd 3
00000db0.00000868::<DateTime> WARN [RES] Dysk klastra dysków <fizycznych 1>: OnlineThread: Nie można ustawić volguid?? \Volume{3cb36133-0d0b-11df-afcf-005056ab58b9}. Błąd: 183.
00000db0.00000868::<DateTime> INFO [RES] Dysk klastra dysków <fizycznych 1>: VolumeIsNtfs: Volume \?\GLOBALROOT\Device\Harddisk15\Partition1\ ma typ systemu plików NTFS

Przyczyna

Wiadomo, że ten problem występuje, gdy oprogramowanie antywirusowe, które nie jest świadome klastra, jest zainstalowane, uaktualnione lub ponownie skonfigurowane. Wiadomo na przykład, że ten problem występuje po zainstalowaniu lub przeprowadzeniu migracji do programu Symantec Endpoint Protection 11.0 Release Update 5 (RU5) w węzłach klastra.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Sprawdź, czy ten problem jest spowodowany przez program Symantec Endpoint Protection (SEP) 11.0 Release Update 5 (RU5). W tym celu uruchom narzędzie Handle.exe natychmiast po wystąpieniu problemu w węźle klastra, w którym zasób dysku fizycznego nie został przełączany do trybu online.

    W wierszu polecenia z podwyższonym poziomem uprawnień wpisz następujące polecenie, a następnie naciśnij klawisz ENTER: Handle.exe -a -u drive_letter.

    Uwaga

    Symbol zastępczy drive_letter jest oznaczeniem dysku klastra, który nie został wprowadzony w tryb online.

    Załóżmy na przykład, że oznaczenie dysku dla dysku klastra, który nie jest dostępny w trybie online, to dysk Q. Aby uruchomić narzędzie Handle.exe w tym scenariuszu, wpisz następujące polecenie, a następnie naciśnij klawisz ENTER: Handle.exe -a -u Q:.

    Problem jest spowodowany przez aplikację firmy Symantec, jeśli zostanie wyświetlony następujący komunikat, który identyfikuje proces Smc.exe jako proces będący właścicielem dojścia:

    Obsługa wersji 3.42
    Prawa autorskie (C) 1997-2008 Mark Russinovich
    Sysinternals — www.sysinternals.com

    Smc.exe pid: 856 NT AUTHORITY\SYSTEM 66C: Q:

  2. Jeśli problem jest spowodowany przez aplikację firmy Symantec, skontaktuj się z firmą Symantec w celu uzyskania programu Symantec Endpoint Protection 11 Release Update 6 (RU6), który został wydany w celu rozwiązania tego problemu.

Więcej informacji

Aby uzyskać więcej informacji na temat narzędzia Handle.exe, zobacz Handle v4.22 (Obsługa wersji 4.22).

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.