Visual Studio Icon Notas sobre o lançamento do Visual Studio 2019 versão 16.6Visual Studio 2019 version 16.6 Release Notes


| Developer Community | Requisitos do Sistema | Compatibilidade | Código Distribuível | Termos da Licença | Blogs | Problemas Conhecidos da Última Versão || Developer Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Latest Release Known Issues |


Clique no botão para baixar a versão mais recente do Visual Studio 2019.Click a button to download the latest version of Visual Studio 2019. Para conferir instruções sobre a instalação e a atualização do Visual Studio 2019, consulte Atualizar o Visual Studio 2019 para a versão mais recente.For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. Além disso, consulte as instruções em como instalar offline.Also, see instructions on how to install offline.


Novidades no Visual Studio 2019 versão 16.6What's New in Visual Studio 2019 version 16.6

Lançamentos do Visual Studio 2019 versão 16.6Visual Studio 2019 version 16.6 Releases

Notas sobre a versão arquivadas do Visual Studio 2019Visual Studio 2019 Archived Release Notes

Blog do Visual Studio 2019Visual Studio 2019 Blog

O Blog do Visual Studio 2019 é a fonte oficial de insights do produto da equipe de engenharia do Visual Studio.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. É possível encontrar informações detalhadas sobre as versões do Visual Studio 2019 nas seguintes postagens:You can find in-depth information about the Visual Studio 2019 releases in the following posts:

Participe da discussão das notas sobre a versãoJoin the Release Note Discussion


Release Notes Icon Visual Studio 2019 versão 16.6.1Visual Studio 2019 version 16.6.1New release icon

lançado em 1º de junho de 2020released June 1, 2020

Principais problemas corrigidos no Visual Studio 2019 versão 16.6.1Top Issues Fixed in Visual Studio 2019 version 16.6.1


Release Notes Icon Visual Studio 2019 versão 16.6.0Visual Studio 2019 version 16.6.0

lançado em 19 de maio de 2020released May 19, 2020

Aviso de Consultoria de Segurança da versão 16.6Security Advisory Notice for 16.6

CVE-2020-1108 Vulnerabilidade de negação de serviço do .NET Core CVE-2020-1108 .NET Core Denial of Service Vulnerability

Um invasor não autenticado remoto pode explorar essa vulnerabilidade emitindo solicitações especialmente criadas para o aplicativo .NET Core.A remote unauthenticated attacker could exploit this vulnerability by issuing specially crafted requests to the .NET Core application. A atualização de segurança aborda a vulnerabilidade corrigindo como o aplicativo Web .NET Core lida com solicitações da Web.The security update addresses the vulnerability by correcting how the .NET Core web application handles web requests.

CVE-2020-1161 Vulnerabilidade de negação de serviço do .NET Core CVE-2020-1161 .NET Core Denial of Service Vulnerability

Um invasor não autenticado remoto pode explorar essa vulnerabilidade emitindo solicitações especialmente criadas para um aplicativo ASP.NET Core.A remote unauthenticated attacker could exploit this vulnerability by issuing specially crafted requests to the ASP.NET Core application. A atualização de segurança resolve a vulnerabilidade corrigindo como o aplicativo Web ASP.NET Core manipula solicitações da Web.The security update addresses the vulnerability by correcting how the ASP.NET Core web application handles web requests.

Neste lançamento do Visual Studio 2019 versão 16.6.0In This Release of Visual Studio 2019 version 16.6.0


C++C++

Geração aprimorada de comentários de Doxygen/XML: Gere automaticamente stubs de comentário da documentação XML ou Doxygen digitando as funções "///" ou "/**" acima.Improved Doxygen/XML comment generation: Automatically generate Doxygen or XML doc comment stubs by typing "///" or "/**" above functions. Eles agora são exibidos em dicas de ferramentas de Informações Rápidas também.These are now displayed in Quick Info tooltips as well.

Generate and consume Doxygen-style comments
Gerar e consumir comentários de estilo DoxygenGenerate and consume Doxygen-style comments

Suporte do Ninja para CMake para Linux/WSL: use o Ninja como o gerador subjacente ao criar projetos do CMake no WSL ou em um sistema remoto.Ninja support for CMake for Linux/WSL: Use Ninja as the underlying generator when building CMake projects on WSL or a remote system. O Ninja agora é o gerador padrão ao adicionar uma nova configuração do Linux ou do WSL.Ninja is now the default generator when adding a new Linux or WSL configuration.

Modelos de depuração para depuração remota de CMake: simplificamos os modelos de depuração de projetos CMake em um sistema Linux remoto ou WSL com o gdb.Debug templates for remote CMake debugging: We've simplified the templates for debugging CMake projects on a remote Linux system or WSL with gdb.

Suporte inicial para conceitos do C++20: O IntelliSense agora reconhece conceitos do C++ 20 e sugere o uso deles na lista de membros.Initial support for C++20 concepts: IntelliSense now recognizes C++20 concepts and suggests them in the member list.

DepuraçãoDebugging

Habilitar a anexação do Depurador de Instantâneos sem a necessidade de uma reinicialização: agora, o Depurador de Instantâneos pode ser instalado nos Serviços de Aplicativos do Azure (ASP.NET Core 3.1) sem a necessidade de uma reinicialização, permitindo que você depure e diagnostique problemas em tempo real sem interromper seu serviço!Enable attaching the Snapshot Debugger without requiring a restart: Snapshot Debugger can now be installed on Azure App Services (ASP.NET Core 3.1) without requiring a restart, allowing you to debug and diagnose live issues without interruption to your service! Anexar ao Depurador de Instantâneos pela primeira vez solicitaria uma instalação da extensão de site do Depurador de Instantâneos em sua implantação do Serviço de Aplicativo do Azure, que exigiria uma reinicialização.Attaching to Snapshot Debugger for the first time would prompt an install of the Snapshot Debugger site extension on your Azure App Service deployment, which required a restart.

Aprimoramentos na experiência do usuário para descompilação: o processo de descompilação usará PDBs existentes para produzir nomes melhores para variáveis locais.User experience improvements for Decompilation: The decompilation process will use existing PDBs to produce better names for local variables.

Produtividade do GitGit Productivity

  • Clone um repositório que contém somente uma solução que será carregada automaticamente após a conclusão da clonagem.Clone a repository that contains only one solution, and that solution is automatically loaded after clone completes.

JavaScript/TypeScriptJavaScript/TypeScript

  • Barra de progresso TSServer: Quando um serviço de linguagem abrir um projeto TypeScript, o usuário poderá ver o progresso do projeto configurado que estará sendo aberto, no widget Tarefas em Segundo Plano.TSServer Progress Bar: As language service opens a TypeScript project, the user will be able to see the progress of the configured project being opened up, in the Background Tasks Widget.

  • Nova depuração de JavaScript/TypeScript multidirecional e Suporte a trabalho de serviço: agora o depurador de JavaScript/TypeScript dá suporte a trabalhos de serviço de depuração, funções de trabalho, iFrames e à sua página JavaScript, tudo ao mesmo tempo!New Multi-target JavaScript/TypeScript debugging and Service Worker Support: The JavaScript/TypeScript debugger now supports debugging service workers, web workers, iFrames, and your page JavaScript all at the same time! Além disso, a nova experiência de depuração adiciona o suporte para a depuração de seus aplicativos de servidor de nó de back-end e para JavaScript do lado do cliente no navegador ao mesmo tempo.In addition, the new debugging experience adds support for debugging your back-end node server applications and client-side JavaScript in the browser simultaneously. Esse recurso ainda é experimental.This feature is still experimental. Você pode habilitar a nova experiência de depuração no menu de opções DepuraçãoYou can enable the new debugging experience in the Debugging options menu

  • As implementações de Ajuda de Assinatura e Ir Para Definição foram atualizadas para melhorar o suporte a cenários LiveShare.The implementations of Signature Help and Go To Definition have been updated to better support LiveShare scenarios.

Microsoft Fakes para projetos do .NET Core e projetos no estilo de SDKMicrosoft Fakes for .NET Core and SDK-style projects

O Microsoft Fakes agora dá suporte ao .NET Core!Microsoft Fakes now supports .NET Core! Muitos usuários desejam migrar aplicativos e conjuntos de teste para o .NET Core e, agora, uma grande parte desse processo é possível com o suporte do Fakes ao .NET Core.Many users want to migrate their apps and testing suites to .NET Core and now a huge part of that process is possible with Fakes support for .NET Core. Você pode habilitar esse recurso em Ferramentas > Opções > Versão Prévia do Recurso.You can enable this feature in Tools > Options > Preview Features. O Fakes é uma estrutura fictícia que ajuda a isolar seus testes simulando determinadas partes do código do produto com stubs ou shims.Fakes is a mocking framework that helps isolate your tests by mocking certain parts of your product code with stubs or shims. Essa simulação ajuda a desenrolar um teste do código do produto para que ele possa se concentrar em testar apenas o que é relevante para um determinado teste.This mocking helps untangle a test from your product code so it can focus on testing only what it is relevant to a given test.

EditorEditor

Exibição de lista: com a nova experiência Localizar nos Arquivos, recebemos comentários de que o formato de resultado anterior (texto simples sem formatação) era útil em determinados usos.List View: With the new Find in Files experience, we got feedback that the previous result format (flat text without formatting) was useful for certain uses. Agora, a Exibição de lista está disponível no painel de resultados para acessar os resultados no formato anterior.The List View is now available in the results panel to access the results in the previous format.

Repetir Localização: a janela de resultados da operação Localizar nos Arquivos agora tem o botão "Repetir Localização".Repeat Find: The results window from a Find in Files operation now has a "Repeat Find" button. Esse botão considera todas as opções usadas em uma pesquisa e preenche novamente o painel Localizar nos Arquivos com elas.This button will take all the options used for a search and re-populate the Find in Files panel with them. Assim, é mais fácil repetir uma pesquisa depois de fazer algumas alterações ou ajustar uma pesquisa para restringir os resultados.This makes it easier to repeat a search after making some changes or to tweak a search to help narrow down the results. Enquanto o foco estiver na janela Resultados, digite Alt+R e pressione ENTER para repetir a pesquisa imediatamente.While focus is in the Results window, type Alt+R then hit Enter to immediately repeat the search.

Produtividade do .NET.NET Productivity

Adicionar correção de código de conversão explícita: agora há uma correção de código para adicionar uma conversão explícita quando uma expressão não pode ser convertida implicitamente.Add explicit cast code fix: There is now a code fix to add an explicit cast when an expression cannot be implicitly cast. Coloque o cursor no erro e pressione (Ctrl+ . ) para disparar o menu Ações Rápidas e Refatorações.Place your cursor on the error and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Adicionar conversão explícita.Select Add explicit cast. Add explicit cast

Simplificar a refatoração das expressões condicionais: simplifique as expressões condicionais removendo código desnecessário.Simplify conditional expressions refactoring: Simplify conditional expressions by removing unnecessary code. Coloque o cursor na expressão condicional.Place your cursor on the conditional expression. Pressione (Ctrl+ . ) para acionar o menu Ações Rápidas e Refatorações.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Simplificar a expressão condicional.Select Simplify conditional expression. Simplify conditional expressions

Converter literais de cadeia de caracteres regulares para refatoração de literais de cadeia de caracteres verbatim: coloque o cursor sobre o literal de cadeia de caracteres regular.Convert regular string literals to verbatim string literals refactoring: Place your cursor on the regular string literal. Pressione (Ctrl+ . ) para acionar o menu Ações Rápidas e Refatorações.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Converter em cadeia de caracteres verbatim.Select Convert to verbatim string. Convert to verbatim string

Converter literais de cadeia de caracteres verbatim para refatoração de literais de cadeia de caracteres regular: coloque o cursor sobre o literal de cadeia de caracteres verbatim.Convert verbatim string literals to regular string literals refactoring: Place your cursor on the verbatim string literal. Pressione (Ctrl+ . ) para acionar o menu Ações Rápidas e Refatorações.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Converter em cadeia de caracteres regular.Select Convert to regular string. Convert to regular string

Configurar em massa o nível de severidade das categorias do analisador diretamente usando o editor: coloque o cursor sobre o erro, o aviso ou a sugestão e digite (Ctrl+ . ) para disparar o menu Ações Rápidas e Refatorações.Bulk configure the severity level of analyzer categories directly through the editor: Place your cursor on the error, warning, or suggestion and type (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Suprimir ou Configurar os problemas.Select suppress or Configure issues. Em seguida, selecione Configurar severidade para todos os analisadores {category name} .Then select Configure severity for all {category name} analyzers. Isso atualizará o arquivo EditorConfig existente com a nova severidade da categoria.This will update your existing EditorConfig file with the category’s new severity. Bulk configure analyzer categories

Suporte ao estilo de informações rápidas para comentários XML que contêm marcas de retorno e valor: passe o cursor sobre o elemento.Quick Info style support for XML comments that contain returns and value tags: Hover your cursor over the element. As Informações Rápidas exibirão os estilos compatíveis dos comentários XML acima do código.Quick Info will then display the supported styles from the XML comments above your code. XML style support for returns and value tags

Adicionar cabeçalhos de arquivo a arquivos, projetos e soluções existentes com EditorConfig: primeiro, você precisará adicionar a regra file_header_template ao arquivo EditorConfig.Add file headers to existing files, projects, and solutions with EditorConfig: You will first need to add the file_header_template rule to your EditorConfig file. Em seguida, será necessário definir o valor como igual ao texto do cabeçalho que você deseja aplicar.You will then need to set the value to equal the header text you would like applied. Add file header rule

Em seguida, coloque o cursor na primeira linha de qualquer arquivo do C# ou do Visual Basic e digite (Ctrl+ . ) para disparar o menu Ações Rápidas e Refatorações.Next, place your cursor on the first line of any C# or Visual Basic file and type (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Adicionar faixa de arquivo.Select Add file banner. Se você quiser aplicar o cabeçalho de arquivo a todos os arquivos de um projeto ou solução existente, selecione Projeto ou Solução na opção Corrigir todas as ocorrências em: .If you would like to apply the file header to all files of an existing project or solution, select Project or Solution under the Fix all occurrences in: option. Add file header

Ferramentas da WebWeb Tooling

Nova experiência para configurar os serviços e emuladores do Azure: A guia Serviços Conectados agora oferece uma nova experiência para conectar seu aplicativo aos serviços do Azure, como o SQL do Azure, o Armazenamento, o Key Vault e muitos outros.New experience for configuring Azure services and emulators: The Connected Services tab now offers a new experience for connecting your application to Azure services such as Azure SQL, Storage, Key Vault and many others. Ele ajuda você a provisionar novas instâncias (ou selecionar as existentes) e garante que seu código tenha os pacotes NuGet mais atualizados e o código de configuração de inicialização correto.It helps you provision new instances (or select existing ones) and ensures your code has the most update to date NuGet packages and the right startup configuration code. Sempre que possível, opções de emulação local também estão disponíveis.Wherever possible local emulation options are also available.

Atualizações para a experiência de publicação: A publicação agora oferece uma experiência semelhante à de um assistente para a criação de novos perfis de publicação que orientam você pelas suas opções.Updates to the Publish experience: Publishing now offers a new wizard-like expierence for creating new publish profiles that guides you through your options. Mesmo que alguns componentes do Visual Studio estejam ausentes em sua instalação, você ainda terá acesso ao conjunto completo de destinos e opções de publicação. Os componentes ausentes serão identificados e será solicitado que eles sejam instalados sob demanda.Even if some Visual Studio components are missing from your installation you will still have access to the full set of publishing targets and options; any missing components will be identified and requested to be installed on demand. A página de resumo do perfil de publicação também foi atualizada para corresponder à experiência disponível na guia Serviços Conectados para configurar dependências para os serviços do Azure.The publish profile summary page has also been updated to match the experience available under the Connected Services tab for configuring dependencies to Azure services.

Windows FormsWindows Forms

Designer de Formulários do Windows para .NET CoreWindows Forms Designer for .NET Core

Agora está disponível o Designer de Formulários do Windows para projetos do .NET Core.The Windows Forms designer for .NET Core projects is now available. Para habilitar o designer no Visual Studio, acesse Ferramentas > Opções > Ambiente > Recursos de Visualização e selecione a opção Usar a visualização do Designer de Formulários do Windows em aplicativos .NET Core.To enable the designer in Visual Studio, go to Tools > Options > Environment > Preview Features and select the Use the preview Windows Forms designer for .NET Core apps option.

Windows Forms Designer for .NET Core

Nessa versão, fizemos as seguintes melhorias, incluindo o suporte para controles adicionais:In this release we have made the following improvements, including support for additional controls:

  • Suporte para os controles de todos os diálogos, PropertyGrid, HScrollBar, VScrollBar, DomainUpDown e TrackBarSupport for all Dialogs controls, PropertyGrid, HScrollBar, VScrollBar, DomainUpDown and TrackBar
  • Aprimoramentos do tipo "arrastar e soltar"Drag-and-drop improvements
  • Melhorias na seleçãoSelection improvements
  • Correções de bugs e na estabilidadeStability and bug fixes

Ferramentas do WPF/UWPWPF/UWP Tooling

Azure Key Vault no assistente de empacotamento: os desenvolvedores da UWP agora podem assinar pacotes de aplicativos com certificados de assinatura de código diretamente no Azure Key Vault no assistente de empacotamento.Azure Key Vault in the Packaging Wizard: UWP developers can now sign their app packages with code signing certificates directly from Azure Key Vault in the packaging wizard. Você só precisará do URI do Key Vault e das permissões corretas de sua conta Microsoft.All that is required is the URI of the Key Vault and the correct permissions for your Microsoft account. O certificado escolhido será importado para o repositório de certificados local do usuário, no qual ele poderá ser usado para assinatura.The chosen certificate will be imported to the user’s local certificate store where it can be used for signing. Os certificados locais protegidos por senha agora também podem ser descriptografados com segredos de um Key Vault.Local password protected certificates can also now be decrypted with secrets from a Key Vault.

A Recarga Dinâmica de XAML e a árvore visual dinâmica agora dão suporte à anexação simultânea a vários processos.XAML Hot Reload and the Live Visual Tree now support attaching to multiple processes at the same time. Isso ajuda cenários como quando uma solução inicia vários projetos do WPF/da UWP simultaneamente ou quando o aplicativo UWP está usando várias instâncias.This helps scenarios such as when a solution starts multiple WPF/UWP projects at the same time or if you’re UWP app is using multi-instancing. Para fazer esse trabalho, atualizamos a árvore visual dinâmica com um novo nó de processo de nível superior para agrupar elementos do mesmo processo.To make this work we’ve updated the Live Visual Tree with a new top-level process node to group elements from the same process together. Live Visual Tree with multiple processes attached

A Caixa de Ferramentas agora dá suporte a pacotes NuGet com vários arquivos VisualStudioToolsManifest.xml: Isso permite que os autores do pacote NuGet alterem quais controles são mostrados na Caixa de Ferramentas com base na versão da estrutura/plataforma do projeto de referência.Toolbox now supports NuGet packages with multiple VisualStudioToolsManifest.xml files: This enables NuGet package authors to change which controls are shown in the Toolbox based on the framework/platform version of the referencing project. A Caixa de Ferramentas mostrará os itens do manifesto cujo subdiretório de ferramentas TFM (Moniker da Estrutura de Destino) melhor corresponda à plataforma/estrutura de destino do projeto.Toolbox will show the items from the manifest whose tools subdirectory Target Framework Moniker (TFM) best matches the project’s target framework/platform. Ele voltará ao manifesto na raiz do diretório de ferramentas se nenhuma correspondência de TFM for encontrada.It will fall back to the manifest in the root of the tools directory if no TFM match is found. Esse manifesto raiz também é necessário para compatibilidade com versões mais antigas do Visual Studio.This root manifest is also needed for compatibility with older versions of Visual Studio.

Nova configuração: Recarga Dinâmica de XAML ao Salvar.New Setting: XAML Hot Reload on Save. A Recarga Dinâmica de XAML envia por padrão todas as alterações de XAML em tempo real ao seu aplicativo em execução.XAML Hot Reload by default sends all valid XAML changes in real-time to your running app. Nesta versão, adicionamos uma nova configuração (Depurar > Opções > Geral > Habilitar Ferramentas de Depuração de Interface do Usuário para XAML > Aplicar a Recarga Dinâmica de XAML ao salvar documento), que oferece aos desenvolvedores uma escolha sobre como esse comportamento funciona.In this release we've added a new setting (Debug > Options > General > Enable UI Debugging Tools for XAML > Apply XAML Hot Reload on document save) that gives developers a choice in how this behavior works. Quando essa configuração é habilitada, as alterações na Recarga Dinâmica de XAML não são aplicadas até que o arquivo que está sendo editado seja salvo.When this setting is enabled XAML Hot Reload changes will not apply until the file that is being edited is saved.

O suporte a temas escuros para designer de classe foi adicionado.Dark theme support for Class Designer has been added.

Class Designer now supports dark theme

XamarinXamarin

A Recarga Dinâmica de XAML agora pode recarregar o que acabou de ser mudado em sua página, em vez de toda a página.XAML Hot Reload can now reload just what changed on your page, instead of the whole page. Teste isso alterando a configuração "Opções de Recarga" em Ferramentas > Opções > Xamarin > Recarga Dinâmica.Try it out by changing the "Reload Options" setting in Tools > Options > Xamarin > Hot Reload.

Exibir uma Árvore Visual Dinâmica de elementos na página em seu aplicativo em execução.View a Live Visual Tree of elements on the page in your running application. Abra a árvore visual dinâmica durante uma sessão de depuração de Recarga Dinâmica de XAML por meio de Depurar > Windows > Árvore Visual Dinâmica.Open the Live Visual Tree during a XAML Hot Reload debug session through Debug > Windows > Live Visual Tree.

Substituir as configurações do emulador, como modo escuro/claro, tamanhos da fonte e mais usando o painel Configurações de Ambiente.Override your emulator's settings like dark/light mode, font sizes, and more using the Environment Settings pad. Abra-o durante uma sessão de Recarga Dinâmica de XAML em Depurar > Windows > Configurações de Ambiente.Open it during a XAML Hot Reload session via Debug > Windows > Environment Settings.

Você pode usar um arquivo de configuração Lint e selecionar ainda mais sugestões do IntelliSense ao editar seu XML do Android.You can use a Lint configuration file and select from even more IntelliSense suggestions when editing your Android XML.


Correções de bugBug Fixes

Principais problemas corrigidos no Visual Studio 2019 versão 16.6.0Top Issues Fixed in Visual Studio 2019 version 16.6.0

  • Quando um novo sinalizador de recurso de experiência Git estiver habilitado, uma mensagem será exibida no Team Explorer, orientando os usuários para a nova janela de ferramentas Git.When New Git experience feature flag is enabled, a message will appear in Team Explorer guiding users to the new Git tool window.
  • Correção do atraso intermitente da interface do usuário ao fechar o VS quando o designer do WinForms .NET Core está no estado aberto.Fix for intermittent UI delay while closing VS when WinForms .NET Core designer is in open state.
  • Problemas corrigidos na criação de projetos usando provedores de tipos, lançando a exceção de método ausente no runtime.Fixed issues creating projects using type providers, throwing missing method exception at runtime.
  • Correção da criação de projeto para projetos do .NET Framework.Fixed project creation for .NET framework projects.
  • A nova experiência de Localizar nos arquivos respeita as opções no painel Ferramentas – Opções – Localizar e Substituir.New find in files experience respects options in Tools-Options-Find and Replace pane.
  • Corrigido um bug devido ao qual o repositório Git não é alterado ao fechar uma Pasta e abrir uma Solução.Fixed a bug where Git repository does not change when closing a Folder and opening a Solution.
  • Corrigido o bug de compilação do aplicativo iOS usando símbolos de depuração completos.Fixed bug when building iOS app using full debug symbols.
  • Adicionada a navegação regressiva dos perfis e certificados de provisionamento do Mac Distribution por meio do Windows.Added back browing of Mac Distribution provisioning profiles and certificates from Windows.
  • Corrigido um bug que fazia com que o Visual Studio 2019 parasse de responder ao trabalhar com projetos Xamarin em determinados cenários.Fixed a bug causing Visual Studio 2019 to stop responding when working with Xamarin projects on certain scenarios.
  • Adicionado o atalho de teclado para a opção "Copiar com Cabeçalhos" na Grade de Resultados de Script do SQLAdded keyboard shortcut for "Copy with Headers" option in SQL Script Results Grid
  • Agora, os usuários do SSDT poderão definir e exibir propriedades de confidencialidade para todas as versões superiores ao SQL Server 2008SSDT users will now be able to set and view sensitivity properties for all version above SQL Server 2008
  • Aprimorada a caixa de diálogo Propriedades de Conexão para usuários de acessibilidade.Improve Connection Properties dialog for accessibility users.
  • Corrigidas as falhas ocasionais ao usar o indicador Testado pelo CodeLens.Fixed occasional crashes when using Tested By Code Lens indicator.
  • Verifique se o texto foi populado automaticamente em Localizar nos arquivos, de acordo com o comportamento herdado.Ensure auto population of text in Find in files is as per legacy behavior.
  • Verifique se o comportamento da tecla de seta para a esquerda em Localizar nos arquivos está correto.Ensure left arrow key behavior in find in files is correct.
  • Um problema que impede os usuários do C++ na Biblioteca de intervalos do C++20 de usar algoritmos.An issue blocking C++ users of the C++20 Ranges library from using algorithms.

Da Developer CommunityFrom Developer Community


Problemas conhecidosKnown Issues

Veja todos os problemas em aberto e as soluções alternativas disponíveis no Visual Studio 2019, seguindo o link abaixo.See all open issues and available workarounds in Visual Studio 2019 by following the below link.


ComentáriosFeedback

Adoraríamos ouvir sua opinião!We would love to hear from you! Em caso de problemas, informe-nos por meio da opção Relatar um Problema no canto superior direito do Instalador ou do próprio IDE do Visual Studio.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. OThe Feedback Icon está localizado no canto superior direito.icon is located in the upper right-hand corner. Você pode fazer uma sugestão de produto ou acompanhar os problemas na Comunidade de Desenvolvedores do Visual Studio, em que você pode fazer perguntas, encontrar respostas e propor novos recursos.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. Você também pode obter ajuda gratuita com a instalação por meio de nosso suporte via chat ao vivo.You can also get free installation help through our Live Chat support.


BlogsBlogs

Aproveite as informações e recomendações disponíveis no site Blogs de Ferramentas de Desenvolvedor para ficar em dia com as novas versões e conferir postagens detalhadas sobre uma grande variedade de recursos.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Histórico de notas sobre a versão do Visual Studio 2019Visual Studio 2019 Release Notes History

Para obter mais informações sobre versões anteriores do Visual Studio 2019, consulte a página Histórico de notas sobre a versão do Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Início da página

Top of Page