Visual Studio Icon Notas sobre a versão do Visual Studio 2019 versão 16.3Visual Studio 2019 version 16.3 Release Notes



Developer Community | Requisitos do Sistema | Compatibilidade | Código Distribuível | Termos da Licença | Blogs | Problemas Conhecidos da Última VersãoDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Latest Release Known Issues


Clique no botão para baixar a versão mais recente do Visual Studio 2019.Click a button to download the latest version of Visual Studio 2019. Para conferir instruções sobre a instalação e a atualização do Visual Studio 2019, consulte Atualizar o Visual Studio 2019 para a versão mais recente.For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. Além disso, consulte as instruções em como instalar offline.Also, see instructions on how to install offline.

Community Download Button Professional Download Button Enterprise Download Button


Novidades no Visual Studio 2019 versão 16.3What's New in Visual Studio 2019 version 16.3

Lançamento das versões do Visual Studio 2019 versão 16.3Visual Studio 2019 version 16.3 Releases

Notas de versão arquivadasArchived Release Notes

Blog do Visual Studio 2019Visual Studio 2019 Blog

O Blog do Visual Studio 2019 é a fonte oficial de insights do produto da equipe de engenharia do Visual Studio.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. É possível encontrar informações detalhadas sobre as versões do Visual Studio 2019 nas seguintes postagens:You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019 versão 16.3.10Visual Studio 2019 version 16.3.10 New release icon

lançado em 20 de novembro de 2019released November 20, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.10Top Issues Fixed in Visual Studio 2019 version 16.3.10


Release Notes Icon Visual Studio 2019 versão 16.3.9Visual Studio 2019 version 16.3.9

lançado em 12 de novembro de 2019released November 12, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.9Top Issues Fixed in Visual Studio 2019 version 16.3.9


Release Notes Icon Visual Studio 2019 versão 16.3.8Visual Studio 2019 version 16.3.8

lançado em 5 de novembro de 2019released November 5, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.8Top Issues Fixed in Visual Studio 2019 version 16.3.8


Release Notes Icon Visual Studio 2019 versão 16.3.7Visual Studio 2019 version 16.3.7

lançado em 29 de outubro de 2019released October 29, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.7Top Issues Fixed in Visual Studio 2019 version 16.3.7


Release Notes Icon Visual Studio 2019 versão 16.3.6Visual Studio 2019 version 16.3.6

lançado em 22 de outubro de 2019released October 22, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.6Top Issues Fixed in Visual Studio 2019 version 16.3.6


Release Notes Icon Visual Studio 2019 versão 16.3.5Visual Studio 2019 version 16.3.5

lançado em 15 de outubro de 2019released October 15, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.5Top Issues Fixed in Visual Studio 2019 version 16.3.5


Release Notes Icon Visual Studio 2019 versão 16.3.4Visual Studio 2019 version 16.3.4

lançado em 10 de outubro de 2019released October 10, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.4Top Issues Fixed in Visual Studio 2019 version 16.3.4


Release Notes Icon Visual Studio 2019 versão 16.3.3Visual Studio 2019 version 16.3.3

lançado em 8 de outubro de 2019released October 8, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.3Top Issues Fixed in Visual Studio 2019 version 16.3.3


Release Notes Icon Visual Studio 2019 versão 16.3.2Visual Studio 2019 version 16.3.2

lançado em 1º de outubro de 2019released October 1, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.2Top Issues Fixed in Visual Studio 2019 version 16.3.2

  • Corrigido um problema com o suporte do Xcode 11.Corrected an issue with Xcode 11 support.

Release Notes Icon Visual Studio 2019 versão 16.3.1Visual Studio 2019 version 16.3.1

lançado em 25 de setembro de 2019released September 25, 2019

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.1Top Issues Fixed in Visual Studio 2019 version 16.3.1


Release Notes Icon Visual Studio 2019 versão 16.3.0Visual Studio 2019 version 16.3.0

lançado em 23 de setembro de 2019released September 23, 2019

Resumo das novidades do Visual Studio 2019 versão 16.3Summary of What's New in Visual Studio 2019 version 16.3

Principais problemas corrigidos no Visual Studio 2019 versão 16.3.0Top Issues Fixed in Visual Studio 2019 version 16.3.0


Detalhes das novidades do Visual Studio 2019 versão 16.3.0Details of What's new in Visual Studio 2019 version 16.3.0

.NET Framework 4.8.NET Framework 4.8

As ferramentas de desenvolvimento .NET Framework 4.8 foram adicionadas para dar suporte de direcionamento ao .NET Framework 4,8.The .NET Framework 4.8 development tools have been added to support targeting .NET Framework 4.8. O .NET Framework 4.8 oferece diversos novos recursos e melhorias, bem como várias correções de confiabilidade, estabilidade, segurança e desempenho.The .NET Framework 4.8 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes. Encontre mais detalhes sobre o .NET Framework 4.8 no anúncio do blog sobre o .NET Framework 4.8Find more details about the .NET Framework 4.8 in the .NET Framework 4.8 blog announcement

Produtividade do .NET.NET productivity

  • Os desenvolvedores agora podem renomear um arquivo ao renomear uma interface, enumeração ou classe.Developers can now rename a file when renaming an interface, enum, or class. Coloque o cursor no nome da classe e digite (Ctrl + R, R) para abrir a caixa de diálogo Renomear e marque a caixa 'Renomear arquivo'.Place the cursor in the class name and type (Ctrl + R,R) to open the Rename dialogue and check the ‘Rename file’ box.
Rename containing file when renaming a class
Renomear o arquivo contentor ao renomear uma classeRename containing file when renaming a class
  • Agora há suporte para Editar e Continuar para projetos multiplataforma, que inclui módulos carregados várias vezes no mesmo processo em contextos de carga ou domínios diferentes.You can now Edit and Continue support for multi-targeted projects which includes modules loaded multiple times in the same process on different domains or load contexts. Além disso, os desenvolvedores podem editar arquivos de origem mesmo quando o projeto contentor não está carregado ou o aplicativo está em execução.In addition, developers can edit source files even when the containing project is not loaded or the application is running.
  • Agora você pode encapsular cadeias de chamadas fluentes com uma refatoração.You can now wrap chains of fluent calls with a refactoring. Coloque o cursor em uma cadeia de chamadas e pressione (Ctrl + .) para disparar o menu Ações Rápidas e Refatorações.Place your cursor on a call chain and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione Encapsular cadeia de chamadas ou Encapsular e alinhar a cadeia de chamadas.Select either Wrap call chain or Wrap and align call chain.
Wrap call chain
Encapsular Cadeia de ChamadasWrap Call Chain
  • Os usuários agora podem introduzir uma variável local imediatamente após gravarem o inicializador.Users can now introduce a local variable immediately after writing its initializer. Primeiro, escreva uma expressão.First, write an expression. Em seguida, coloque o cursor no nome da expressão e pressione (Ctrl+. ) para disparar o menu Ações Rápidas e Refatoração.Then place the cursor in the expression name and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selecione a opção para introduzir uma variável local.Select the option to introduce a local variable.
Introduce a local variable
Introduzir Variável Local Após Gravar InicializadorIntroduce Local Variable After Writing Initializer
  • Agora há suporte para ferramentas do .NET Core para analisadores.There is now .NET Core tooling support for analyzers. Os usuários podem adicionar o pacote de analisador mais recomendado clicando com o botão direito do mouse no nome do projeto no Gerenciador de Soluções e selecionando Propriedades.Users can add the most recommended analyzer package by right clicking on the project name within the solution explorer and select properties. Selecione Análise de Código para instalar o pacote do analisador e configurar quando executar a análise de código.Select Code Analysis to install the analyzer package and to configure when to run code analysis.
.NET Core Tooling Analyzer Support
Suporte do Analisador de Ferramentas do .NET Core.NET Core Tooling Analyzer Support
  • Anteriormente, adicionamos o preenchimento do IntelliSense para tipos não importados.Previously, we added IntelliSense completion for unimported types. Esse recurso veio com a opção de desativá-lo para os usuários que não desejam que os tipos não importados sempre preencham o IntelliSense.This feature came with the option to turn it off for users who did not want unimported types always populating their IntelliSense. Agora, para os usuários que desativam a conclusão de tipos não importados, é muito mais fácil recolocá-los na lista de conclusão com o novo filtro de tipo importado adicionado às alternâncias do IntelliSense.Now, for users who turn off the completion for unimported types, it's much easier to get it back in the completion list with the new imported type filter added to the IntelliSense toggles.
IntelliSense completion list expander
Expansor da lista de conclusão do IntelliSenseIntelliSense completion list expander
IntelliSense completion list expander triggered
Expansor da Lista de Conclusão do IntelliSense DisparadoIntelliSense Completion List Expander Triggered
  • Agora há suporte ao estilo de Informações Rápidas para comentários XML.There is now Quick Info style support for XML comments. Coloque o cursor sobre o nome do método.Place the cursor over the method name. As Informações Rápidas exibirão os estilos com suporte dos comentários XML acima do código.Quick Info will then display the supported styles from the XML comments above the code.
Quick info style support for XML comments
Suporte ao estilo de informações rápidas para comentários XMLQuick Info style support for XML comments

Ferramentas do WPF/UWPWPF/UWP Tooling

Os clientes que criam aplicativos WPF/UWP verão os seguintes aprimoramentos nas ferramentas XAML do Visual Studio:Customers building WPF/UWP applications will see the following improvements in Visual Studio XAML tooling:

Designer:Designer:

  • Designer do WPF agora totalmente disponível (GA) para projetos do WPF .NET Core: O Designer XAML para aplicativos WPF .NET Core agora está disponível para todos os clientes, sem a necessidade de sinalizador de versão prévia do recurso.WPF Designer now fully available (GA) for WPF .NET Core Projects: The XAML Designer for WPF .NET Core applications is now generally available (GA) to all customers without the need for preview feature flag. O Designer XAML para aplicativos WPF .NET Core é um pouco diferente do WPF .NET Framework Designer em alguns de seus comportamentos e funcionalidades, observe que isso ocorre por questão de design.The XAML Designer for WPF .NET Core applications is slightly different in some behaviors and functionality then WPF .NET Framework Designer, please note this is by design. Devido a essa diferença, gostaríamos de encorajar os clientes a reportar todos os problemas ou limitações que encontrem por meio do recurso de comentários do Visual Studio.Given the difference we’d like to encourage customers to report any problems or limitations that you might be running into using Visual Studio feedback feature.
WPF .NET Core XAML Designer
Designer XAML WPF .NET CoreWPF .NET Core XAML Designer

Ferramentas de depuração de XAML:XAML Debugging Tools:

  • Suporte à Recarga Dinâmica de XAML adicionada para alterações de dicionários de recursos do WPF: A Recarga Dinâmica de XAML agora oferece suporte à atualização de dicionários de recursos do WPF para atualizações em tempo real no aplicativo.XAML Hot Reload support added for WPF resource dictionaries changes: XAML Hot Reload now supports updating WPF Resource Dictionaries for real-time updates in the application. Anteriormente, esse recurso estava disponível apenas para a UWP (Plataforma Universal do Windows), mas agora ele é compatível com aplicativos WPF .NET Framework, WPF .NET Core e UWP.Previously this feature was only available to Universal Windows Platform (UWP), but is now supported for WPF .NET Framework, WPF .NET Core and UWP apps. As ações compatíveis incluem a adição de uma nova definição da seção Recursos e a adição, exclusão e atualização de recursos em seções novas/existentes.Supported actions include adding a new Resources section definition and adding, deleting and updating resources new/existing sections.
  • Agora, a barra de ferramentas no aplicativo pode ser movida: A barra de ferramentas no aplicativo foi aprimorada para que ela possa ser movida no aplicativo WPF/UWP em execução, permitindo que os desenvolvedores a arrastem para a esquerda ou para a direita dentro do aplicativo para desbloquear a interface do usuário do aplicativo.In-app toolbar now movable: The in-app toolbar has been enhanced so that it is movable within the running WPF/UWP application, enabling developers to drag it left or right within the app to unblock app UI. Observe que a posição para a qual a barra de ferramentas é movida não é armazenada entre as sessões e ela voltará à posição padrão quando o aplicativo for reiniciado.Note that position to which the toolbar is moved is not stored between sessions and will go back to the default position when your app is restarted.
In-app toolbar movable
Barra de ferramentas móvel no aplicativoIn-app toolbar movable

Assinatura do Pacote UWP.UWP Package Signing.

  • Reintrodução da capacidade de criar e importar arquivos de certificado de autenticação (.pfx) por meio do Designer de Manifesto.Brought back the ability to create and import signing certificate files (.pfx) through the Manifest Designer.
UWP signing
  • Introdução da capacidade de criar e importar certificados de autenticação por meio do Assistente de Empacotamento para simplificar o processo de assinatura.Introduced the ability to create and import signing certificates through the Packaging Wizard to streamline the signing process.
UWP signing packaging wizard

Ferramentas do .NET.NET tools

  • Suporte para adicionar novas referências de serviço GRPC e Open API para projetos do .NET Core 3.0.Support for adding new Open API & GRPC service references to .NET Core 3.0 projects.
  • Publicar projetos de trabalho do .NET Core 3.0 no Registro de Contêiner do Azure, DockerHub, etc.Publish .NET Core 3.0 worker projects Azure Container Registry, DockerHub, etc.
  • Os modelos do .NET Core 3.0 para trabalho, gRPC, biblioteca de classes do Razor e Blazor são apresentados na caixa de diálogo Novo Projeto..NET Core 3.0 templates for Worker, gRPC, Razor Class library & Blazor are surfaced in the New Project Dialog.
  • Todas as atualizações feitas nos modelos do .NET Core 3.0 por meio da CLI do .NET também são apresentadas no Visual Studio.Any updates made to the .NET Core 3.0 templates via the .NET CLI are also surfaced in Visual Studio.

C++C++

  • Desenvolvedores do C++ agora podem alternar comentários de linha usando o atalho de teclado Ctrl + K, Ctrl + / .C++ developers can now toggle line comments using the keyboard shortcut Ctrl + K, Ctrl + /.
  • As listas de membros do IntelliSense agora são filtradas com base em qualificadores de tipo, por exemplo, const std::vector agora filtrará métodos como push_back.IntelliSense member lists are now filtered based on type qualifiers, e.g. const std::vector will now filter out methods such as push_back.
  • Adicionamos as seguintes versões prévias do recurso da Biblioteca Padrão C++20 (com /std:c++latest):Added the following C++20 Standard Library preview features (with /std:c++latest):
    • P0487R1: Resolvendo operator>>(basic_istream&, CharT*)P0487R1: Fixing operator>>(basic_istream&, CharT*)
    • P0616R0: Usando move() em <numeric>P0616R0: Using move() In <numeric>
    • P0758R1: is_nothrow_convertibleP0758R1: is_nothrow_convertible
    • P0734R0: Extensões C++ para ConceitosP0734R0: C++ extensions for Concepts
    • P0898R3: Conceitos da Biblioteca PadrãoP0898R3: Standard Library Concepts
    • P0919R3: Pesquisa Heterogênea por Contêineres Não OrdenadosP0919R3: Heterogeneous Lookup For Unordered Containers
  • Novas verificações de Diretriz do C++ Core, incluindo o novo conjunto de regras "Regras de Enumeração" e as regras const, emum e type adicionais.New C++ Core Guideline checks, including the new "Enum Rules" rule set, and additional const, enum, and type rules.
  • Um novo esquema de colorização semântico padrão permite que os usuários entendam melhor seu código em um relance, a janela pilha de chamadas pode ser configurada para ocultar argumentos de modelo e o IntelliCode C++ é ativado por padrão.A new default semantic colorization scheme allows users to better understand their code at a glance, the call-stack window can be configured to hide template arguments, and C++ IntelliCode is on-by-default.
  • Configure destinos de depuração e tarefas personalizadas com variáveis de ambiente usando CMakeSettings.json ou CppProperties.json ou a nova marca "env" em destinos e tarefas individuais em launch.vs.json e tasks.vs.json.Configure debug targets and custom tasks with environment variables using CMakeSettings.json or CppProperties.json or the new "env" tag on individual targets and tasks in launch.vs.json and tasks.vs.json.
  • Os usuários agora podem usar uma ação rápida nos pacotes vcpkg ausentes para abrir automaticamente um console e instalar na instalação padrão do vcpkg.Users can now use a quick action on missing vcpkg packages to automatically open a console and install to the default vcpkg installation.
  • A cópia de cabeçalho remoto feita por projetos do Linux (CMake e MSBuild) foi otimizada e agora é executada em paralelo.The remote header copy done by Linux projects (CMake and MSBuild) has been optimized and now runs in parallel.
  • O suporte nativo do Visual Studio para WSL agora dá suporte a builds paralelos para projetos do Linux baseados em MSBuild.Visual Studio's native support for WSL now supports parallel builds for MSBuild-based Linux projects.
  • Os usuários agora podem especificar uma lista de saídas de build locais para implantar em um sistema remoto com projetos Makefile do Linux.Users can now specify a list of local build outputs to deploy to a remote system with Linux Makefile projects.
  • A definição de descrições no Editor de Configurações do CMake agora contém mais contexto e links para a documentação útil.Setting descriptions in the CMake Settings Editor now contain more context and links to helpful documentation.

Ferramentas de ContêinerContainer Tools

  • Os desenvolvedores que criam o Azure Functions (v2) agora podem adicionar suporte ao contêiner do Docker (somente C# para Linux) a seus projetos.Developers building Azure Functions (v2) can now add Docker container support (Linux only) to their C# projects. Isso pode ser feito clicando com o botão direito do mouse no nome do projeto em Gerenciador de Soluções e selecionando "Adicionar"--> "Suporte ao Docker".This can be done by right clicking the project name in Solution Explorer and selecting "Add" --> "Docker Support". Além de adicionar um Dockerfile a seu projeto, o destino de depuração será definido como "Docker".In addition to adding a Dockerfile to your project the debug target will be set to "Docker". Isso significa que a depuração do código de funções ocorrerá dentro do contêiner em execução.What this means is debugging of Functions code will happen inside of the running container. Os usuários poderão clicar em pontos de interrupção, inspecionar variáveis e usar todos os recursos de depuração avançados fornecidos pelo Visual Studio.Users will be able to hit breakpoints, inspect variables, and use all the powerful debugging features Visual Studio provides.
Debug Azure Functions running in Linux containers.
Depurar o Azure Functions em execução em contêineres do LinuxDebug Azure Functions running in Linux containers

Criação de Perfil de Banco de Dados para projetos .Net CoreDatabase Profiling for .Net Core projects

Esta versão inclui uma nova ferramenta no conjunto de ferramentas de desempenho e diagnóstico disponível por meio do Criador de Perfil de Desempenho (ALT-F2).This release includes a new tool in the suite of performance and diagnostics tools available via the Performance Profiler (ALT-F2). A nova ferramenta de banco de dados fornecerá detalhes sobre consultas de projetos .Net Core que utilizam o ADO.Net ou o Entity Framework.The new database tool will provide details about queries from .Net Core projects which utilize ADO.Net or Entity Framework. A ferramenta fornece uma opção "ir para a origem" para vinculação ao código-fonte e fornece detalhes de tempo para cada consulta executada durante uma sessão de criação de perfil.The tool provides a "go to source" option for linking to source code and provides timing details for each query executed during a profiling session. Essa ferramenta pode funcionar simultaneamente com outras no Criador de Perfil de Desempenho.This tool can work simultaneously with other tools in the Performance Profiler. Quando usada em conjunto com a ferramenta de Uso da CPU, obtêm-se informações detalhadas sobre as características de desempenho do código do .Net Core que usa um banco de dados.When used in conjunction with the CPU Usage tool, one gains detailed information about the performance characteristics of .Net Core code which uses a database.

DepuradorDebugger

  • A Janela de Pilhas Paralelas melhorou a visualização de tarefas e suas dependências em um processo para facilitar o diagnóstico de problemas no código assíncrono.The Parallel Stacks Window has improved the visualization of tasks and their dependencies in a process to make it easier to diagnose problems in asynchronous code.
Tasks visualization in parallel stacks window
Visualização de tarefa aprimorada na Janela de Pilhas ParalelasImproved task visualization in the Parallel Stacks Window

F# e ferramentas do F#F# and F# tools

Esta versão inclui o suporte para o F# 4.7, a versão mais recente da linguagem F#.This release includes support for F# 4.7, the newest version of the F# language!

Grande parte do F# 4.7 era dedicada a alterações de infraestrutura subjacentes que nos permitem fornecer uma visualização da funcionalidade da linguagem F# com mais eficiência.Much of F# 4.7 was dedicated to underlying infrastructural changes that allow us to deliver preview of F# language functionality more effectively. Dito isso, ainda há alguns bons novos recursos fornecidos.That said, there are still some nice new features delivered as well.

Linguagem F# e biblioteca principalF# language and core library

Adicionamos suporte para o F# 4.7, uma versão secundária da linguagem que vem com uma infraestrutura de compilador para habilitar a versão prévia de recursos, de modo que possamos obter comentários sobre designs de recursos antecipadamente no processo de desenvolvimento.We added support for F# 4.7, a minor language release that comes with compiler infrastructure to enable preview features so that we can get feedback on feature designs earlier in the development process.

O conjunto completo de recursos de F# 4.7 inclui:The full F# 4.7 feature set is:

Além do conjunto de recursos do F# 4.7, esta versão inclui o suporte para os seguintes recursos da linguagem F# de versão prévia:In addition to the F# 4.7 feature set, this release includes support for the following preview F# language features:

  • Suporte para expressões nameofSupport for nameof expressions
  • Suporte para a abertura de classes estáticasSupport for opening of static classes

Você pode habilitar isso definindo <LangVersion>preview</LangVersion> no arquivo de projeto.You can enable this by seeting <LangVersion>preview</LangVersion> in your project file.

Esta versão também contém as seguintes correções de bug e melhorias no compilador F#:This release also contains the following bug fixes and improvements to the F# compiler:

  • Foi resolvido um problema antigo em que o compilador F# podia ter excedente de pilha com uma quantidade imensa de registros, structs ou outros tipos (#7070)A longstanding issue where the F# compiler could stack overflow with massive records, structs, or other types has been resolved (#7070)
  • Foi solucionado um problema em que uma linha inválida IL podia travar o Visual Studio (#7164)An issue where specifying invalid inline IL could crash Visual Studio has been resolved (#7164
  • Resolvido o problema em que a cópia de um struct não poderia ocorrer se estivesse definida em C# e fosse modificada em uma chamada de membro (#7406)Resolution of an issue where copying of a struct would not occur if it was defined in C# and mutated in a member call (#7406)
  • Um hash criptografado do conteúdo portátil PDB criado pelo compilador não era incluído no diretório de depuração PE, com um hash configurável definido como SHA-256 por padrão (#4259, #1223)A crypto hash of the portable PDB content created by the compiler is not included in the PE debug directory, with a configurable hash set to SHA-256 by default (#4259, #1223)
  • Um bug em que LeafExpressionConverter ignorava ValueType e assumia System.Tuple foi corrigido (#6515) por Kevin MalenfantA bug where LeafExpressionConverter ignored ValueType and assumed System.Tuple has been fixed (#6515) by Kevin Malenfant
  • Um bug em que List.transpose descartava dados em vez de acionar uma exceção foi solucionado (#6908) por Patrick McDonaldA bug where List.transpose discaded data instead of throwing an exception has been resolved (#6908) by Patrick McDonald
  • Um bug em que List.map3 fornecia um erro equivocado quando usado em listas de diferentes comprimentos foi resolvido (#6897) por reacheightA bug where List.map3 gave a misleading error when used on lists of different lengths has been resolved (#6897) by reacheight

Ferramentas F#F# tools

Essa versão também inclui algumas melhorias para as ferramentas do F# para Visual Studio:This release also includes a few improvements to the F# tools for Visual Studio:

  • Os registros são formatados para se parecerem mais com valores e declarações canônicos em dicas de ferramentas e F# interativo (#7163)Records are formatted more to look more like canonical declarations and values in tooltips and F# interactive (#7163)
  • Agora as propriedades em dicas de ferramentas especificam se é para usar ou não get-only, set-only ou get e set (#7007)Properties in tooltips now specify whether or not that are get-only, set-only, or get and set (#7007)
  • Um problema em que o recurso Ir para Definição e outros nem sempre funcionavam entre projetos quando os arquivos usavam barras duplas (#4446, #5521, #4016) foi corrigido com o auxílio de chadunitAn issue where Go to Definition and other features could not always work across projects when files use forward slashes (#4446, #5521, #4016) has been fixed, with help from chadunit
  • Foram solucionados problemas com depurações e registros anônimos (#6728, #6512)Issues with anonymous records and debugging have been resolved (#6728, #6512)
  • Foi corrigido um bug em que diretivas de hash vazias na origem poderiam colorir o texto de origem de forma aleatória (#6400, #7000)A bug where empty hash directives in source could make source text coloring seem random has been resolved (#6400, #7000)

IDEIDE

  • Uma caixa de pesquisa na janela de início permite a você localizar rapidamente projetos, soluções e pastas usados recentemente.A search box in the start window allows you quick location of recently used projects, solutions, and folders. Além disso, estes contêineres de código MRU se integram com a pesquisa global do Visual Studio para que os desenvolvedores possam encontrá-los por meio da caixa de pesquisa do Visual Studio.In addition, these MRU code containers integrate with Visual Studio global search so developers can find them through the Visual Studio search box.
Start window MRU search
Pesquisar na lista de projetos recentes na janela de inícioSearch in recent projects list on start window
  • Melhorias à interface da caixa de diálogo do Instalador no IDE do Visual Studio facilita a identificação de cargas de trabalho específicas que estão sendo adicionadas ao Visual Studio.Improvements to the Installer dialog interface within the Visual Studio IDE makes it easier to identify specific workloads being added to Visual Studio.
  • O VS Search dará suporte à capacidade de pesquisar tipos e membros com C# o e o VB, bem como à pesquisa de arquivos em todos os idiomas.VS Search will support the ability to search for types and members with C# and VB, as well as file search for all languages. Os resultados aparecerão à medida que os usuários digitarem sua consulta de pesquisa, bem como em um grupo de "Código" dedicado, acessível por meio de atalho de teclado ou clique com o mouse.Results will show up as users type their search query, as well as in a dedicated ‘Code’ group accessible via keyboard shortcut or mouse click.
  • Os modelos de projeto recém-instalados são indicados com um rótulo "Novo" para permitir a identificação rápida e os filtros mostram os valores selecionados na caixa de diálogo Novo Projeto.Newly installed project templates are indicated with a "New" label to allow quick identification, and filters show selected values in the New Project Dialog. Além disso, os desenvolvedores podem organizar os modelos usados recentemente fixando, desafixando e removendo-os da lista.In addition, developers can organize recently used templates by pinning, unpinning, and removing them from the list.
New Project Dialog
Veja projetos recém-instalados e filtros selecionados e fixe modelos na caixa de diálogo Novo ProjetoSee newly installed projects and selected filters, and pin templates in the New Project Dialog
  • Pesquise modelos na caixa de diálogo Novo Projeto por meio de uma pesquisa difusa mais robusta, que se adapta a erros de digitação e plurais para realçar os resultados de palavra-chave e classificação correspondentes com base na relevância de pesquisa e de filtro.Search for templates in the New Project Dialog through a more robust fuzzy search which adapts with typos and plurals to highlighting matching keyword and rank results based on search and filter relevance.
New Project Dialog template search
Melhoria na precisão da pesquisa e no realce na pesquisa de modelos de projetoImproved search accuracy and highlighting in project templates search

InstaladorInstaller

  • O Visual Studio agora atualiza o IDE e o Instalador do Visual Studio com um único clique para aumentar a produtividade.Visual Studio now updates both the Visual Studio IDE and the Installer with a single click for increased productivity.
  • Os componentes do instalador do Visual Studio para .NET Core 2.1 e 2.2 usados para carregar apenas o runtime.The Visual Studio installer components for .NET Core 2.1 and 2.2 used to only carry the runtime. Dessa versão prévia em diante, os componentes também carregarão os modelos, bem como o runtime.From this preview onwards the components will also carry the templates as well as the runtime.
  • Uma caixa de pesquisa na guia de componentes Individuais do Instalador do Visual Studio permite a localização rápida de todos os componentes disponíveis para instalação.A search box in the Visual Studio Installer's Individual components tab allows for quick location of all available components for installation.
Installer components search
Pesquisar componentes individuais no Instalador do Visual StudioSearch individual components in the Visual Studio Installer

IntelliCodeIntelliCode

  • O modelo de base de C++ foi ativado por padrão.The C++ base model has been turned on by default.
    • É possível alterar essa configuração em Ferramentas > Opções > IntelliCode.You can change this setting by going to Tools > Options > IntelliCode.
  • Incluímos Edições Repetidas para C#, que analisa se há alterações repetíveis em edições locais e determina outros locais em que talvez você precise dessa alteração dentro do mesmo arquivo.We've included Repeated Edits for C#, which analyzes local edits for repeatable changes and determines other places you may need this change within the same file.
    • As sugestões de edições repetidas serão exibidas na Lista de Erros e como avisos dentro do arquivo de código.Suggested repeated edits will appear in the Error List and as warnings within the code file.

JavaScript/TypeScriptJavaScript/TypeScript

  • A classificação de JavaScript e TypeScript (normalmente chamada de "coloração de sintaxe") será aplicada a arquivos grandes mais rapidamente.JavaScript and TypeScript classification (commonly called “syntax coloring”) will be applied to large files more quickly. A lista de correções e refatorações de código JavaScript e TypeScript (ou seja, a lâmpada) também será exibida mais rapidamente.The list of JavaScript and TypeScript code fixes and refactorings (i.e. the lightbulb) will also be displayed more quickly.
  • Agora, há suporte do editor do TypeScript 3.6.There is now editor support for TypeScript 3.6.
  • Quando um arquivo tsconfig.json for editado ou alterado, agora o Visual Studio atualizará o projeto de forma mais responsiva.When a tsconfig.json file is edited or changed, Visual Studio will now refresh the project more responsively.

Testes do PythonPython Tests

  • Os Desenvolvedores do Python agora podem executar testes usando a popular estrutura do Python pytest em cenários de workspace de Pasta Aberta e projetos do Python.Python Developers can now run tests using the popular Python framework pytest in both Python projects and Open Folder workspace scenarios.
  • Para habilitar pytest e unittest para projetos do Python, clique com o botão direito do mouse no nome da solução do projeto e selecione Propriedades.To enable pytest and unittest for Python projects, right-click on the project solution name and select Properties. De lá, selecione a guia Teste para selecionar opções de teste.From there, select the Test tab to select testing options. Observe que, para unittest, você deve especificar o diretório para os testes (o diretório raiz é o padrão), bem como o padrão para os nomes de arquivo de teste.Note that for unittest, you must specify the directory for the tests (root directory is the default) as well as the pattern for the test filenames. A Detecção de Testes é iniciada assim que as alterações são salvas na guia Teste. Test Discovery is intitiated as soon as changes are saved in the Test tab.
pythontest_project
Configuração de um projeto do Python para descobrir pytests ou testes escritos com unittest. Observe que, selecionando "Mostrar saída de: Testes" na Janela de Saída, os usuários podem ver informações de log associadas a execuções de teste para testes reprovados e aprovados.Configuring a Python project to discover pytests or tests written with unittest. Notice that by selecting 'Show output from: Tests' in the Output Window, users are able to see logging information associated with test runs, for both failed and passed tests.
  • A experiência de teste do unittest foi retrabalhada de modo que um usuário agora precisa configurar manualmente os testes para os projetos do Python e os workspaces de Pasta Aberta, pois esses testes não são mais descobertos automaticamente:The unittest testing experience has been reworked such that a user now needs to manually configure tests for both Python projects and Open Folder workspaces as these tests are no longer automatically discovered:
  • Para habilitar testes para pastas do Python, clique noTo enable tests for Python folders, click on the Show All Files ícone para Mostrar Todos os Arquivos no Gerenciador de Soluções.icon to Show All Files in the Solution Explorer. De lá, clique no arquivo PythonSettings.json localizado na pasta ' "Configurações Locais" (se não houver um arquivo, crie um).From there, click on the PythonSettings.json file located within your 'Local Settings' folder (if there isn't a file there, create one). Nesse arquivo, você pode especificar a 'TestFramework' que deseja usar, bem como os padrões de nome de arquivo de teste e o diretório que contém os testes (ambas as opções se aplicam a unittest): Within this file, you can specify the 'TestFramework' you wish to use as well as the test filename patterns and the directory that contains your tests (both options apply to unittest):
pythontest_folder
  • A depuração de teste é atualizada para usar o PTVSD 4, mas se os usuários quiserem continuar usando o 'Depurador Herdado' ou se houver problemas com o uso do novo depurador, eles poderão habilitá-lo acessando Ferramentas > Opções > Python > Depuração > Usar Depurador Herdado e marcar a caixa para habilitá-lo.Test debugging is updated to use PTVSD 4, but if users wish to continue using the 'Legacy Debugger' or run into any issues with using the new debugger, they can enable it by going to Tools > Options > Python > Debugging > Use Legacy Debugger and check the box to enable it.
  • Também tornamos simples para os usuários com projetos preexistentes e em workspaces de pasta aberta que contêm arquivos de teste continuar trabalhando rapidamente com o código no Visual Studio 2019.We have also made it simple for users with pre-existing projects and in open folder workspaces that contain test files to quickly continue working with their code in Visual Studio 2019. Quando os usuários abrem um projeto que contém arquivos de configuração de teste (por exemplo, um arquivo .ini para pytest), mas não instalaram nem habilitaram o pytest, eles são solicitados a instalar os pacotes necessários e configurá-los para o ambiente Python que estão trabalhando: When users open a project that contains testing configuration files (e.g. a .ini file for pytest), but they have not installed or enabled pytest, they will be prompted to install the necessary packages and configure them for the Python environment they are working:
pytest infobar
Sempre que um projeto ou uma pasta Python é aberta contendo arquivos de teste que não estão configurados, os usuários são solicitados a fazer isso, além de instalar o pacote de teste necessário, que, neste exemplo, é pytest.Whenever a Python project or folder is opened that contains test files that aren't configured, users are prompted to do so as well as install the necessary test package, which in this example, is pytest.
  • Da mesma forma que para arquivos de teste unittest dentro de um projeto ou workspace de pasta aberta, os usuários serão solicitados a instalar e/ou habilitar a estrutura de teste.Similarly for unittest test files within a project or open folder workspace, users will be prompted to install and/or enable the testing framework. Para ambos os cenários, os desenvolvedores têm a opção de ignorar a mensagem e configurar manualmente a estrutura.For both scenarios, developers have the option to ignore the message and to manually configure the framework.

Criador de Perfil de Desempenho do Visual StudioVisual Studio Performance Profiler

  • A ferramenta de Uso da CPU no Criador de Perfil de Desempenho exibe automaticamente o indicador de Afunilamento com um ícone de chama vermelha ao exibir a Árvore de Chamadas.The CPU Usage tool in the Performance Profiler automatically displays the "hot path" indicator with a red flame icon when displaying the Call Tree. Isso economiza um clique em investigações de desempenho comuns de Uso da CPU.This saves a click on common CPU Usage performance investigations. As ferramentas de uso da CPU podem ser acessadas usando Alt-F2 ou no menu Depurar.The CPU Usage tools is accessible by using Alt-F2 or from the Debug menu.
  • O Criador de Perfil de Desempenho agora participa da navegação posterior/regressiva no IDE do Visual Studio.The Performance Profiler now participates in forward/backward navigation in the Visual Studio IDE. À medida que os desenvolvedores navegam para várias exibições de ferramentas no criador de perfil de desempenho, os pontos de navegação são salvos junto com outros itens de navegação.As developers navigate to various views of tools in the Performance Profiler, navigation points are saved along with other navigation items. Eles podem ser empregados clicando nos botões de navegação ou usando comandos de navegação no Visual Studio.They can be employed by clicking the navigation buttons or using navigation commands in Visual Studio.
Forward/Backward Navigation Image
Navegação para frente/trás no Criador de PerfilForward/Backward Navigation in the Profiler

Ferramentas da WebWeb Tools

  • Configure facilmente as dependências dos aplicativos em perfis de publicação usando o novo assistente para Adicionar Dependência.Easily configure applications' dependencies in publish profiles using the new Add Dependency wizard. Atualmente, dá suporte à adição de dependências ao Serviço do Azure SignalR, ao Azure SQL Server e ao Armazenamento do Azure, permitindo que os usuários provisionem novas instâncias ou selecionem as existentes sem sair do IDE.It currently supports adding dependencies to Azure SignalR Service, Azure SQL Server, Azure Storage allowing users to either provision new instances or select existing ones without leaving the IDE.
  • A equipe do ASP.NET Runtime habilitou o suporte para o fornecimento de conteúdo estático em bibliotecas de classes do Razor devido à demanda popular.The ASP.NET runtime team has enabled support for serving static content from within Razor class libraries due to popular demand. Nesta versão prévia do Visual Studio, a equipe adicionou suporte de ferramentas para esse cenário.In this preview of Visual Studio, the team has added tooling support for this scenario.

XamarinXamarin

Esta versão inclui as seguintes atualizações do SDK do Xamarin:This release includes the following Xamarin SDK updates:

  • Xamarin.iOS 13Xamarin.iOS 13
    • Adiciona suporte ao Xcode 11 para compilar e depurar aplicativos para o iOS 13, o tvOS 13 e o watchOS 6.Adds support for Xcode 11 to build and debug apps for iOS 13, tvOS 13, and watchOS 6. Confira nossa Introdução ao iOS 13 para obter mais detalhes sobre os novos recursos disponíveis.See our Introduction to iOS 13 for more details on the new features available.
  • Xamarin.Android 10Xamarin.Android 10
    • Os aplicativos Android agora podem ser direcionados ao Android 10 definindo Compilar usando a versão do Android: (Estrutura de Destino) como Android 10.0 (Q) na guia Aplicativo da página de propriedades do projeto.Android apps can now target Android 10 by setting Compile using Android version: (Target Framework) to Android 10.0 (Q) under the Application tab of the project property page. O Android 10 apresenta recursos como tema escuro, navegação gestual e otimizações para dispositivos dobráveis.Android 10 introduces features such as dark theme, gestural navigation, and optimizations for foldable devices. Confira nossa página do Android 10 com Xamarin para obter mais informações sobre esses novos recursos.See our Android 10 with Xamarin page for more information on these new features.
android q
Defina Compilar usando a versão do Android: (Estrutura de Destino) para Android 10.0 (Q).Set the Compile using Android version: (Target Framework) to Android 10.0 (Q).

Esta versão também inclui vários novos recursos de ferramentas e melhorias:This release also includes several new tooling features and enhancements:

  • Uma versão prévia pública da Recarga Dinâmica de XAML do Xamarin.Forms está disponível nesta versão.A public preview of XAML Hot Reload for Xamarin.Forms is available in this release. A Recarga Dinâmica de XAML permite que você itere rapidamente na interface do usuário enquanto depura seu aplicativo em um emulador, um simulador ou um dispositivo físico.XAML Hot Reload lets you rapidly iterate on your UI while debugging your app on an emulator, simulator, or physical device. Basta editar o XAML e, em seguida, salvar o arquivo para ver as alterações refletidas imediatamente no aplicativo em execução.Simply edit your XAML then save the file to see the changes immediately reflected on the running app. Para habilitar a Recarga Dinâmica de XAML, acesse Ferramentas > Opções > Xamarin > Recarga Dinâmica.To enable XAML Hot Reload, go to Tools > Options > Xamarin > Hot Reload.
xaml hot reload
Recarga Frequente de XAML para Xamarin.Forms.XAML Hot Reload for Xamarin.Forms.
  • O Pré-visualizador de XAML do Xamarin.Forms agora renderiza o Design de material para iOS e Android ao usar o Visual do Xamarin.Forms.The XAML Previewer for Xamarin.Forms now renders Material design for both iOS and Android when using Xamarin.Forms Visual.
  • O Xamarin Designer para iOS apresenta uma nova maneira de trabalhar com restrições.The Xamarin Designer for iOS has a new way to work with constraints. Quando você seleciona uma exibição restrita, reticências agora aparecem na barra de ferramentas ao lado do seletor de Modo de Fixação de Restrições.When you select a constrainable view, an ellipsis will now appear in the toolbar next to the Constraints Pinning Mode selector. Clique nas reticências para exibir um pop-over para edição das restrições na exibição selecionada.Click the ellipsis to display a popover for editing constraints on the selected view.
new ios constraints editor
Novo pop-over do Editor de Restrições do iOS.New iOS constraints editor popover.
  • Agora você pode arquivar e publicar aplicativos iOS por meio do Visual Studio no Windows.You can now archive and publish iOS apps from Visual Studio on Windows. Crie arquivos enquanto está emparelhado a um computador Mac definindo a configuração para Versão|iPhone, clicando com o botão direito do mouse no projeto iOS no Gerenciador de Soluções e selecionando a opção de menu Arquivar... .Create an archive while paired to a Mac machine by setting the configuration to Release|iPhone, right-clicking your iOS project in the Solution Explorer, and selecting the Archive... menu option. No Gerenciador de Arquivos, você pode salvar um .ipa em disco para distribuição ad hoc ou carregá-lo no App Store Connect para publicar seu aplicativo na App Store.From the archive manager you can save an .ipa to disk for ad-hoc distribution or upload to App Store Connect to publish your app to the App Store.
  • Quando você clica com o botão direito do mouse em um arquivo .plist no Gerenciador de Soluções, há novas opções para abri-lo rapidamente usando o designer de plist genérico ou o editor de XML.When you right-click a .plist file in the Solution Explorer, there are new options to quickly open it using the generic plist designer or the XML editor.
new plist options
Novas opções para abrir arquivos .plist.New options to open .plist files.

Problemas conhecidosKnown Issues

Confira todos os problemas e as soluções alternativas disponíveis no Visual Studio 2019 versão 16.3 seguindo o link abaixo.See all issues and available workarounds in Visual Studio 2019 version 16.3 by following the below link.

Visual Studio 2019 Known Issues Visual Studio 2019 Known Issues


Comentários e sugestõesFeedback and suggestions

Adoraríamos ouvir sua opinião!We would love to hear from you! Em caso de problemas, informe-nos por meio da opção Relatar um Problema no canto superior direito do Instalador ou do próprio IDE do Visual Studio.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. OThe Feedback Icon está localizado no canto superior direito.icon is located in the upper right-hand corner. Você pode fazer uma sugestão de produto ou acompanhar os problemas na Comunidade de Desenvolvedores do Visual Studio, em que você pode fazer perguntas, encontrar respostas e propor novos recursos.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. Você também pode obter ajuda gratuita com a instalação por meio de nosso suporte via chat ao vivo.You can also get free installation help through our Live Chat support.


BlogsBlogs

Aproveite as informações e recomendações disponíveis no site Blogs de Ferramentas de Desenvolvedor para ficar em dia com as novas versões e conferir postagens detalhadas sobre uma grande variedade de recursos.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Histórico de notas sobre a versão do Visual Studio 2019Visual Studio 2019 Release Notes History

Para obter mais informações sobre versões anteriores do Visual Studio 2019, consulte a página Histórico de notas sobre a versão do Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Início da página

Top of Page