PowerShell 支持生命周期

备注

本文档是关于对 PowerShell 的支持。 Windows PowerShell (1.0 - 5.1) 是 Windows 操作系统的一个组件。 组件获得的支持与其父产品或平台相同。 有关详细信息,请参阅产品和服务生命周期信息

PowerShell 受 Microsoft 新式生命周期策略支持,但支持日期与 .NET Core 的支持生命周期关联。 在此服务方法中,客户可以选择长期支持 (LTS) 版本或当前版本。

PowerShell 的 LTS 版本基于 .NET 的 LTS 版本。 LTS 版本更新仅包含关键安全更新和旨在最大程度地减小对现有工作负载的影响的服务修补程序。 在结束对 .NET 的支持之前,将一直支持 PowerShell 的 LTS 版本。

当前版本是在 LTS 版本之间出现的版本。 当前版本可以包含关键修补程序、创新和新功能。 当前版本在后续版本(当前版本或 LTS 版本)发布后的六个月内受支持。

重要

必须安装最新的修补程序更新才能获得支持。 例如,如果你运行的是 PowerShell 7.0,并且已发布 7.0.1,则必须更新到 7.0.1 才能获得支持。

支持的平台

PowerShell 在多个操作系统 (OS) 和处理器体系结构上运行。 若要获得 Microsoft 的支持,OS 必须满足以下条件:

  • .NET Core 支持该 OS 的版本和处理器体系结构。
  • 至少支持该 OS 版本一年。
  • 该 OS 版本不是临时版本或等效版本。
  • OS 发布者当前支持该 OS 版本。
  • PowerShell 团队已测试分发版。

如果某个平台版本已到达平台所有者定义的生命周期终止日期,PowerShell 也会终止支持相应平台版本。 以前发布的包对需要访问的客户仍可用,但不再提供任何种类的正式支持和更新。

Windows

下表列出了 PowerShell 版本以及支持它们的 Windows 版本。 这些版本在 PowerShell 版本到达支持终止日期Windows 版本到达支持终止日期之前受支持。

  • ✅ 指示仍支持 OS 或 PowerShell 版本
  • ❌ 指示不支持 OS 或 PowerShell 版本
  • 🟡 指示该 OS 版本不再支持 PowerShell 版本
  • 当 OS 版本和 PowerShell 版本都具有 ✅ 时,将支持该组合
Windows 7.0 (LTS) 7.1 7.2 (LTS-current) 7.3(预览版)
✅ Windows Server 2016、2019 或 2022 🟡
✅Windows Server 2012 R2 🟡
✅ Windows Server Core(2012 R2 或更高版本) 🟡
✅ Windows Server Nano(1809 或更高版本) 🟡
❌Windows Server 2012 🟡 🟡
❌ Windows Server 2008 R2 🟡 🟡
✅ Windows 11 🟡
✅ Windows 10 1607+ 🟡
✅ Windows 8.1 🟡

备注

对特定版本的 Windows 的支持由 Microsoft 支持部门生命周期策略决定。 有关详细信息,请参阅:

以下处理器体系结构在 Windows 上支持 PowerShell。

Windows 7.0 (LTS) 7.2 (LTS-current) 7.3(预览版)
Nano Server 版本 1803 及更高版本 x64、Arm32 X64 X64
Windows Server 2012 R2 及更高版本 x64、x86 x64、x86 x64、x86
Windows Server Core 2012 R2 及更高版本 x64、x86 x64、x86 x64、x86
Windows 10 or 11 客户端 x64、x86 x64、x86、Arm64 x64、x86、Arm64
Windows 8.1 客户端 x64、x86 x64、x86 x64、x86

macOS

下表包含 PowerShell 版本列表以及 macOS 版本的支持状态。 这些版本在 PowerShell 版本到达支持终止日期或 macOS 版本到达支持终止日期之前仍受支持。

  • ✅ 指示仍支持 OS 或 PowerShell 版本
  • ❌ 指示不支持 OS 或 PowerShell 版本
  • 🟡 指示该 OS 版本不再支持 PowerShell 版本
  • 当 OS 版本和 PowerShell 版本都具有 ✅ 时,将支持该组合
macOS 7.0 (LTS) 7.1 7.2 (LTS-current) 7.3(预览版)
✅ macOS Big Sur 11.5 🟡
✅ macOS Catalina 10.15 🟡
✅ macOS Mojave 10.14 🟡
✅ macOS High Sierra 10.13 🟡

尚未测试 macOS Monterey 12.0。

对 macOS 的支持由 Apple 定义。 有关详细信息,请参阅:

以下处理器体系结构在 macOS 上支持 PowerShell:

macOS 7.0 (LTS) 7.2 (LTS-current) 7.3(预览版)
macOS Big Sur 11.5 X64 x64、Arm64 x64、Arm64
macOS High Sierra 10.13 及更高版本 X64 X64 X64

Alpine Linux

下表列出了支持的 PowerShell 版本以及支持它们的 Alpine 版本。 这些版本在 PowerShell 到达支持终止日期Alpine 版本到达有效期之前仍受支持。

  • ✅ 指示仍支持 OS 或 PowerShell 版本
  • ❌ 指示不支持 OS 或 PowerShell 版本
  • 🟡 指示该 OS 版本不再支持 PowerShell 版本
  • 当 OS 版本和 PowerShell 版本都具有 ✅ 时,将支持该组合
Alpine 7.0 (LTS) 7.1 7.2 (LTS-current) 7.3(预览版)
✅ 3.14 🟡
✅ 3.13 🟡
✅ 3.12 🟡
✅ 3.11 🟡
❌ 3.10 🟡 🟡
❌ 3.9 🟡 🟡

正在针对 PowerShell 7.3(预览版)测试 Alpine 3.15。

以下处理器体系结构在 Alpine 上支持 PowerShell。

Alpine 7.0 (LTS) 7.2 (LTS-current) 7.3(预览版)
所有支持的版本 X64 X64 X64

PowerShell 未在使用 Arm 处理器的 Alpine 上进行测试。

Debian Linux

下表列出了当前支持的 PowerShell 版本以及支持它们的 Debian 版本。 这些版本在 PowerShell 版本到达支持终止日期Debian 版本到达支持终止日期之前仍受支持。

  • ✅ 指示仍支持 OS 或 PowerShell 版本
  • ❌ 指示不支持 OS 或 PowerShell 版本
  • 🟡 指示该 OS 版本不再支持 PowerShell 版本
  • 当 OS 版本和 PowerShell 版本都具有 ✅ 时,将支持该组合
Debian 7.0 (LTS) 7.1 7.2 (LTS-current) 7.3(预览版)
✅ 11 🟡
✅ 10 🟡
✅ 9 🟡 🟡 🟡 🟡
❌ 8 🟡

以下处理器体系结构在 Debian 上支持 PowerShell。

Debian 7.0 (LTS) 7.2 (LTS-current) 7.3(预览版)
版本 9 及更高版本 x64、Arm32、Arm64 x64、Arm32、Arm64 x64、Arm32、Arm64

Red Hat Enterprise Linux (RHEL)

下表列出了当前支持的 PowerShell 版本以及支持它们的 RHEL 版本。 这些版本在 PowerShell 版本到达支持终止日期RHEL 版本到达支持终止日期之前仍受支持。

  • ✅ 指示仍支持 OS 或 PowerShell 版本
  • ❌ 指示不支持 OS 或 PowerShell 版本
  • 🟡 指示该 OS 版本不再支持 PowerShell 版本
  • 当 OS 版本和 PowerShell 版本都具有 ✅ 时,将支持该组合
RHEL 7.0 (LTS) 7.1 7.2 (LTS-current) 7.3(预览版)
✅ 8 🟡
✅ 7 🟡

以下处理器体系结构在 RHEL 上支持 PowerShell。

RHEL 7.0 (LTS) 7.2 (LTS-current) 7.3(预览版)
所有支持的版本 X64 x64、Arm64 x64、Arm64

Ubuntu Linux

下表列出了当前受支持的 PowerShell 版本以及支持它们的 Ubuntu 版本。 这些版本在 PowerShell 版本到达支持终止日期Ubuntu 版本到达支持终止日期之前仍受支持。

  • ✅ 指示仍支持 OS 或 PowerShell 版本
  • ❌ 指示不支持 OS 或 PowerShell 版本
  • 🟡 指示该 OS 版本不再支持 PowerShell 版本
  • 当 OS 版本和 PowerShell 版本都具有 ✅ 时,将支持该组合
Ubuntu 7.0 (LTS) 7.1 7.2 (LTS-current) 7.3(预览版)
✅ 22.04 (LTS) 🟡
✅ 20.04 (LTS) 🟡
✅ 18.04 (LTS) 🟡
❌ 16.04 (LTS) 🟡 🟡

仅 Ubuntu 的 LTS 版本受正式支持。 Microsoft 不支持临时版本或其等效版本。 临时版本受社区支持。 有关详细信息,请参阅社区支持的分布

以下处理器体系结构在 Ubuntu 上支持 PowerShell。

Ubuntu 7.0 (LTS) 7.2 (LTS-current) 7.3(预览版)
所有支持的版本 x64、Arm32、Arm64 x64、Arm32、Arm64 x64、Arm32、Arm64

Raspberry Pi OS

Raspberry Pi OS(以前称为 Raspbian)是基于 Debian 的免费操作系统。

重要

ARMv6 体系结构设备(包括 Raspberry Pi Zero 和 Raspberry Pi 2 之前的 Raspberry Pi 设备)不支持 .NET。

Windows PowerShell 兼容性

PowerShell 的支持生命周期不包含 PowerShell 发布包之外提供的模块。 例如,使用 Windows Server 随附的 ActiveDirectory 模块受 Windows 支持生命周期支持。

实验性功能

实验性功能只能获得社区支持。

有关许可的说明

PowerShell 是在 MIT 许可下发布的。 根据此许可规定,如果没有付费支持协议,那么用户只能获得社区支持。 对于社区支持,Microsoft 无法保证及时作出响应或进行修复。

获取支持

PowerShell 的支持通过传统 Microsoft 支持协议提供,包括付费支持Microsoft 企业协议Microsoft 软件保障。 还可通过针对相应问题填写支持请求,从而付费获取有关 PowerShell 的辅助支持

还有社区支持选项。 可以在 GitHub 上提出问题、bug 或功能请求。 此外,你还可以从 Microsoft PowerShell 技术社区PowerShell 中心页的社区部分列出的任何论坛中获得社区其他成员的帮助。 我们不能确保社区能够及时解决问题。 如果问题需要立即解决,应使用传统的付费支持选项。

重要

必须安装最新的修补程序更新才能获得支持。 例如,如果你运行的是 PowerShell 7.0,并且已发布 7.0.1,则必须更新到 7.0.1 才能获得支持。

PowerShell 的支持终止日期

根据这些生命周期策略,下表列出了当前支持的版本将不再受支持的日期:

版本 结束支持
7.2 (LTS-current) 2024 年 11 月 8 日
7.0 (LTS) 2022 年 12 月 3 日

特定平台上的 PowerShell 支持基于所使用的 .NET 版本的支持策略。

已停用版本的支持终止日期为:

版本 结束支持
7.1 2022 年 5 月 8 日
6.2 2020 年 9 月 4 日
6.1 2019 年 9 月 28 日
6.0 2019 年 2 月 13 日

版本历史记录

下表包含 PowerShell 主要版本的时间线。 此表仅供历史参考。 它不用于确定支持生命周期。

版本 发布日期 注意
PowerShell 7.3(预览版) 2022 年 1 月 基于 .NET 7.0(预览版)生成
PowerShell 7.2 (LTS-current) 2021 年 11 月 基于 .NET 6.0 (LTS-current) 生成
PowerShell 7.1 2020 年 11 月 基于 .NET 5.0 生成
PowerShell 7.0 (LTS) 2020 年 3 月 基于 .NET Core 3.1 (LTS) 生成
PowerShell 6.2 2019 年 3 月
PowerShell 6.1 2018 年 9 月 基于 .NET Core 2.1 生成
PowerShell 6.0 2018 年 1 月 第一版,基于 .NET Core 2.0 生成。 可在 Windows、Linux 和 macOS 上安装
Windows PowerShell 5.1 2016 年 8 月 在 Windows 10 周年更新和 Windows Server 2016、WMF 5.1 中发布。
Windows PowerShell 5.0 2016 年 2 月 在 Windows Management Framework (WMF) 5.0 中发布
Windows PowerShell 4.0 2013 年 10 月 在 Windows 8.1 中与 Windows Server 2012 R2、WMF 4.0 集成。
Windows PowerShell 3.0 2012 年 10 月 在 Windows 8 中与 Windows Server 2012 WMF 3.0 集成
Windows PowerShell 2.0 2009 年 7 月 在 Windows 7 中与 Windows Server 2008 R2、WMF 2.0 集成
Windows PowerShell 1.0 2006 年 11 月 Windows Server 2008 的可选组件