Postupy: vytvoření ikony nebo jiného obrázku

Můžete vytvořit nový obrázek, rastrový obrázek, ikonu, kurzor nebo panel nástrojů a potom použít Editor obrázků k přizpůsobení jeho vzhledu. Po vytvoření šablony prostředkumůžete také vytvořit nový rastrový obrázek.

Ikony a kurzory: prostředky obrázků pro zařízení s displejem

Ikony a kurzory jsou grafické prostředky, které mohou obsahovat více obrázků v různých velikostech a barevná schémata pro různé typy zobrazovacích zařízení. kurzor má také aktivní bod, Windows umístění používá ke sledování jeho pozice. Ikony a kurzory jsou vytvářeny a upravovány pomocí editoru obrázků, stejně jako rastrové obrázky a další obrázky.

Když vytvoříte novou ikonu nebo kurzor, Editor obrázků nejprve vytvoří obrázek standardního typu. Obrázek je původně vyplněn barvou obrazovky (průhledná). Pokud je obrázek kurzorem, je aktivním bodem zpočátku levý horní roh s souřadnicemi 0,0 .

Editor obrázků standardně podporuje vytváření dalších imagí pro zařízení uvedená v následující tabulce. Můžete vytvořit obrázky pro jiná zařízení zadáním parametrů šířka, Výška a počet barev do dialogového okna vlastní obrázek .

Barva Šířka (pixely) Výška (v pixelech)
Jednobarevné 16 16
Jednobarevné 32 32
Jednobarevné 48 48
Jednobarevné 64 64
Jednobarevné 96 96
16 16 16
16 32 32
16 64 64
16 48 48
16 96 96
256 16 16
256 32 32
256 48 48
256 64 64
256 96 96

Vytvoření obrázku zařízení (ikona nebo kurzor)

Když vytvoříte novou ikonu nebo prostředek kurzoru, Editor obrázků nejprve vytvoří obrázek v konkrétním stylu (32 × 32, 16 barev pro ikony a 32 × 32, monochromaticke pro kurzory). Pak můžete přidat obrázky v různých velikostech a stylech na počáteční ikonu nebo kurzor a podle potřeby upravit každou další bitovou kopii pro různá zobrazovací zařízení. Můžete také upravit obrázek pomocí operace vyjmutí a vložení z existujícího typu obrázku nebo z rastrového obrázku vytvořeného v grafickém programu.

Když v editoru obrázkůotevřete ikonu nebo prostředek kurzoru, otevře se ve výchozím nastavení obrázek přesně vyhovující aktuálnímu zobrazovacímu zařízení.

Poznámka

Pokud projekt ještě neobsahuje soubor. RC, přečtěte si téma Vytvoření nového souboru skriptu prostředků.

Dialogové okno < nový > typ obrázku zařízení umožňuje vytvořit novou image zařízení zadaného typu. Chcete-li otevřít dialogové okno nový <Device> Obrázek , přejděte na příkaz Obrázek nabídky > nový typ obrázku. K dispozici jsou následující vlastnosti cílového typu obrázku a vlastní.

Vlastnost typ cílové image obsahuje seznam dostupných typů imagí, kde můžete vybrat typ obrázku, který chcete otevřít:

16 x 16, 16 barev
32 x 32, 16 barev
48 x 48, 16 barev
64 x 64, 16 barev
96 x 96, 16 barev

16 x 16, 256 barev
32 x 32, 256 barev
48 x 48, 256 barev
64 x 64, 256 barev
96 x 96, 256 barev

16 × 16, monochromatické
32 x 32, monochromatické
48 x 48, monochromatické
64 x 64, monochromatické
96 x 96, monochromatický

Poznámka

V tomto seznamu se nezobrazí žádné existující image.

Vlastní vlastnost otevře dialogové okno vlastní obrázek , ve kterém můžete vytvořit novou image s vlastní velikostí a počtem barev.

Dialogové okno vlastní obrázek umožňuje vytvořit novou image s vlastní velikostí a počtem barev. K dispozici jsou následující vlastnosti:

Vlastnost Popis
Width (Šířka) Poskytuje prostor pro zadání šířky vlastní image v pixelech (1-512, limit 2048).
Height (Výška) Poskytuje prostor pro zadání výšky vlastní image v pixelech (1-512, limit 2048).
Barvy Poskytuje prostor pro výběr počtu barev pro vlastní image: 2, 16 nebo 256.

Pomocí dialogového okna < otevřít > obrázek zařízení otevřete obrázky zařízení v projektech v jazyce C++. Zobrazí seznam existujících imagí zařízení v aktuálním prostředku (image, které jsou součástí aktuálního prostředku). Zahrnutá je následující vlastnost:

Vlastnost Popis
Aktuální image Zobrazí seznam imagí zahrnutých v prostředku. Vyberte typ image, který chcete otevřít.

Vytvoření nové ikony nebo kurzoru

  1. V Prostředkyklikněte pravým tlačítkem na soubor .rc a pak zvolte Vložit prostředek. Pokud už máte v souboru .rc existující prostředek obrázku, například kurzor, můžete kliknout pravým tlačítkem na složku Kurzor a vybrat Vložit kurzor.

  2. V dialogovém okně Vložit prostředek vyberte ikonu nebo kurzor a zvolte Nový. U ikon tato akce vytvoří prostředek ikony s ikonou 32 × 32, 16 barev. U kurzorů se vytvoří obrázek 32 × 32, 2 barevná barva.

    Pokud se vedle typu prostředku obrázku v dialogovém okně Vložit prostředek zobrazí znaménko plus ( ), znamená to, že jsou k dispozici + šablony panelu nástrojů. Výběrem znaménka plus rozbalte seznam šablon, vyberte šablonu a zvolte Nová.

Přidání obrázku pro jiné zobrazovací zařízení

  1. Přejděte do nabídky Image > New Device Image (Obrázek nového zařízení) nebo klikněte pravým tlačítkem v podokně Editor obrázků a zvolte New Device Image (Nový obrázek zařízení).

  2. Vyberte typ image, který chcete přidat. Můžete také vybrat Vlastní a vytvořit ikonu, jejíž velikost není ve výchozím seznamu dostupná.

Zkopírování image zařízení

  1. Přejděte do nabídky Obrázek > Otevřít image zařízení a zvolte obrázek ze seznamu aktuálních imagí. Vyberte například 32 × 32 barevnou verzi ikony.

  2. Zkopírujte aktuálně zobrazený obrázek ikony (Ctrl + C).

  3. Otevřete jiný obrázek ikony v jiném okně Editoru obrázků. Otevřete například 16 × 16 barevnou verzi ikony.

  4. Vložte obrázek ikony (Ctrl + V) z jednoho okna Editoru obrázků do druhého. Pokud vcházíte větší velikost do menší velikosti, můžete velikost obrázku změnit pomocí úchytů ikony.

Odstranění image zařízení

Zatímco se obrázek ikony zobrazuje v Editoru obrázků, přejděte do nabídky Image Delete Device Image (Obrázek > odstranit obrázek zařízení). Když odstraníte poslední obrázek ikony v prostředku, odstraní se také prostředek.

Poznámka

Když stisknete klávesu Del, obrázky a barvy, které jste nakreslili na ikoně, se odstraní, ale ikona zůstane a můžete ji změnit. Pokud omylem stisknete Del, stisknutím kláves Ctrl + Z akci vrátíte zpět.

Vytvoření transparentních nebo inverzních oblastí v imagích zařízení

V Editoru obrázků mápočáteční ikona nebo obrázek kurzoru transparentní atribut. I když jsou obrázky ikon a kurzorů obdélníkové, mnoho z nich se nezobrazuje, protože části obrázku jsou průhledné a podkladový obrázek na obrazovce se zobrazuje prostřednictvím ikony nebo kurzoru. Při přetažení ikony se části obrázku mohou zobrazovat v obrácené barvě. Tento efekt vytvoříte nastavením barvy obrazovky a inverzní barvy v okně Barvy.

Barva obrazovky a inverzní barvy, které se aplikují na ikony a kurzory, buď tvarují a obarvení odvozeného obrázku, nebo přiřaďte inverzní oblasti. Barvy označují části obrázku, které mají tyto atributy. Při úpravách můžete změnit barvy, které představují atributy barvy obrazovky a inverzní barvy. Tyto změny neovlivní vzhled ikony nebo kurzoru v aplikaci.

Poznámka

Dialogová okna a příkazy nabídky, které se zobrazí, se můžou lišit od těch popsaných v nápovědě v závislosti na aktivních nastaveních nebo edici. Pokud chcete nastavení změnit, přejděte do nabídky Nástroje Import a > export Nastavení. Další informace najdete v tématu Přizpůsobení integrovaného vývojového Visual Studio .

Vytvoření transparentních nebo inverzních oblastí

  1. V okně Barvy zvolte selektor Screen-Color (Barva obrazovky) nebo Inverse-Color (Inverzní barva).

  2. Použijte na obrázek obrazovku nebo inverzní barvu pomocí nástroje pro kreslení. Další informace o nástrojích pro kreslení najdete v tématu Použití nástroje pro kreslení.

Změna obrazovky nebo inverzní barvy

  1. Vyberte buď selektor Screen-Color, nebo inverzní selektor barvy.

  2. Zvolte barvu z palety Barvy v okně Barvy.

    Doplňková barva se automaticky přiřadí druhému selektoru.

    Tip

    Pokud dvakrát kliknete na selektor Screen-Color (Barva obrazovky) nebo Inverse-Color (Inverzní barva), zobrazí se dialogové okno Výběr vlastní barvy.

Použití palety s 256 barvami

Pomocí Editoru obrázků lze ikony a kurzory nastavit na velikost velké (64 × 64) s paletou s 256 barvami, ze které si můžete vybrat. Po vytvoření prostředku se vybere styl image zařízení.

Vytvoření ikony nebo kurzoru s 256 barvami

  1. V Prostředkyklikněte pravým tlačítkem na soubor .rc a pak zvolte Vložit prostředek. Pokud už máte v souboru .rc existující prostředek obrázku, například kurzor, můžete kliknout pravým tlačítkem na složku Kurzor a vybrat Vložit kurzor.

  2. V dialogovém okně Vložit prostředek vyberte ikonu nebo kurzor a zvolte Nový.

  3. Přejděte do nabídky Obrázek > Nový obrázek zařízení a vyberte styl obrázku s 256 barvami.

Volba barvy z palety s 256 barvami pro velké ikony

Pokud chcete nakreslit s výběrem z palety s 256 barvami, musíte vybrat barvy z palety Barvy v okně Barvy.

  1. Vyberte velkou ikonu nebo kurzor nebo vytvořte novou velkou ikonu nebo kurzor.

  2. Zvolte barvu z 256 barev zobrazených na paletě Barvy v okně Barvy.

    Vybraná barva se stane aktuální barvou na paletě Barvy v okně Barvy.

    Poznámka

    Počáteční paleta použitá pro 256 barevných obrázků odpovídá paletě vrácené CreateHalftonePalette rozhraním WINDOWS API. Tuto paletu by měly používat všechny ikony Windows prostředí, aby se během realizace palety blikal.

Nastavení horkého bodu kurzoru

Aktivním místem kurzoru je bod, Windows odkazuje při sledování pozice kurzoru. Ve výchozím nastavení je aktivní bod nastavený do levého horního rohu kurzoru se souřadnicemi 0,0 . Vlastnost Hotspot v okno Vlastnosti zobrazuje souřadnice aktivního bodu.

  1. Na panelu nástrojů Editoru obrázkůzvolte nástroj Nastavit hotspot.

  2. Vyberte pixel, který chcete přiřadit jako aktivní bod kurzoru.

    Vlastnost Hotspot v okně Vlastnosti zobrazí nové souřadnice.

Vytvoření a uložení bitmapy jako .gif nebo .jpeg

Při vytváření rastrového obrázku se obrázek vytvoří ve formátu bitmapy (.bmp). Obrázek ale můžete uložit jako gif nebo JPEG nebo v jiných grafických formátech.

Poznámka

Tento proces se nevztahuje na ikony a kurzory.

  1. Přejděte do nabídky File > Open (Soubor) Open (Otevřít) a pak vyberte File (Soubor).

  2. V dialogovém okně Nový soubor zvolte složku Visual C++, pak v poli Šablony vyberte Soubor bitmapy (.bmp) a vyberte Otevřít.

    Rastrový obrázek se otevře v editoru obrázků.

  3. Podle potřeby proveďte změny nové bitmapy.

  4. Když je rastrový obrázek stále otevřený v Editoru obrázků, přejděte do nabídky Soubor > Uložit název souboru .bmp jako.

  5. V dialogovém okně Uložit soubor jako zadejte název souboru a příponu, která označuje formát souboru, který chcete přidat do pole Název souboru. Příklad: myfile.gif.

    Poznámka

    Bitmapu musíte vytvořit nebo otevřít mimo projekt, abyste ji mohli uložit jako jiný formát souboru. Pokud ho vytvoříte nebo otevřete v rámci projektu, příkaz Uložit jako nebude k dispozici. Další informace najdete v tématu Zobrazení prostředků v souboru skriptu prostředků mimo Project (Standalone).

  6. Vyberte Uložit.

Převod obrázku z jednoho formátu do jiného

Obrázky GIF nebo JPEG můžete otevřít v Editoru obrázků a uložit je jako rastrové obrázky. Můžete také otevřít bitmapový soubor a uložit ho jako GIF nebo JPEG. Obrázky, se které pracujete, nemusí být součástí projektu pro úpravy ve vývojovém prostředí (viz samostatné úpravy obrázků).

  1. Otevřete obrázek v Editoru obrázků.

  2. Přejděte do nabídky Soubor Uložit > název souboru jako.

  3. V dialogovém okně Uložit soubor jako zadejte do pole Název souboru název souboru a příponu, která označuje formát, který chcete.

  4. Vyberte Uložit.

Přidání nového prostředku image do nespravovaného projektu C++

  1. V Prostředkyklikněte pravým tlačítkem na soubor .rc a pak zvolte Vložit prostředek. Pokud už v souboru .rc máte existující prostředek obrázku, například kurzor, můžete jednoduše kliknout pravým tlačítkem na složku Kurzor a vybrat Insert Cursor (Vložit kurzor).

  2. V dialogovém okně Vložit prostředekvyberte typ prostředku obrázku, který chcete vytvořit (například Bitmapa) a pak zvolte Nový.

    Pokud se vedle typu prostředku obrázku v dialogovém okně Vložit prostředek zobrazí znaménko plus ( ), znamená to, že jsou k dispozici + šablony panelu nástrojů. Výběrem znaménka plus rozbalte seznam šablon, vyberte šablonu a zvolte Nová.

Přidání nového prostředku obrázku do projektu v programovacím jazyce .NET

  1. V Průzkumník řešení klikněte pravým tlačítkem na složku projektu (například WindowsApplication1).

  2. V místní nabídce vyberte Přidat a pak zvolte Přidat novou položku.

  3. V podokně Kategorie rozbalte složku Místní Project položky a pak zvolte Prostředky.

  4. V podokně Šablony zvolte typ prostředku, který chcete přidat do projektu.

    Prostředek se přidá do projektu v Průzkumník řešení a tento prostředek se otevře v Editoru obrázků. Teď můžete k úpravě image použít všechny nástroje dostupné v Editoru obrázků. Další informace o přidávání obrázků do spravovaného projektu najdete v tématu Načítání obrázku při návrhu.

Požadavky

Žádná

Viz také

Editor obrázků pro ikony
Postupy: Úprava obrázku
Postupy: Použití nástroje pro kreslení
Postupy: Práce s barvou
Klávesy akcelerátoru