Editor obrázků pro ikony (C++)

Když vyberete soubor obrázku (například .ico, .bmp, .png) v Průzkumník řešení, obrázek se otevře v Editoru obrázků stejným způsobem, jakým se soubory kódu otevřou v Editoru kódu. Když je karta Editor obrázků aktivní, zobrazí se panely nástrojů s mnoha nástroji pro vytváření a úpravy obrázků. Kromě rastrových obrázků, ikon a kurzorů můžete upravovat obrázky ve formátu GIF nebo JPEG pomocí příkazů v nabídce Obrázek a nástrojů na panelu nástrojů Editor obrázků.

Grafické prostředky jsou obrázky, které definujete pro vaši aplikaci. Pomocí tvarů můžete nakreslit volný tvar nebo ho kreslit. Můžete vybrat části obrázku pro úpravy, překlopení nebo změnu velikosti, nebo můžete vytvořit vlastní štětec z vybrané části obrázku a nakreslit ho tímto štětcem. Můžete definovat vlastnosti obrázku, ukládat obrázky v různých formátech a převádět obrázky z jednoho formátu do druhého.

Poznámka

Pomocí Editoru obrázků můžete zobrazit 32bitové obrázky, ale nemůžete je upravovat.

K práci se soubory prostředků ve spravovaných projektech můžete také použít Editor obrázků a Binární editor. Všechny spravované prostředky, které chcete upravit, musí být propojené prostředky. Editory Visual Studio prostředků nepodporují úpravy vložených prostředků.

Kromě vytváření nových grafických prostředků můžete importovat existující obrázky pro úpravy a pak je přidat do projektu. Můžete také otevřít a upravit obrázky, které nejsou součástí projektu pro úpravy samostatných obrázků.

Informace o editoru obrázků najdete v tématu Vytvoření ikony nebo jiného obrázku,úpravě obrázku,použití nástroje pro kreslení,práci s barvami aklávesy akcelerátoru.

Poznámka

Stáhněte si zdarma knihovnu Visual Studio obrázků, která obsahuje mnoho animací, rastrových obrázků a ikon, které můžete použít ve svých aplikacích. Další informace o tom, jak stáhnout knihovnu, najdete v Visual Studio Image Library.

Nabídka obrázku

Nabídka Obrázek, která se zobrazí jenom v případě, že je Editor obrázků aktivní, obsahuje příkazy pro úpravy obrázků, správu palet barev a nastavení možností okna Editoru obrázků. Při práci s ikonami a kurzory jsou k dispozici také příkazy pro použití obrázků zařízení.

Příkaz Popis
Invertovat barvy Invertuje barvy.
Překlopit vodorovně Překlopí obrázek nebo výběr vodorovně.
Překlopit svisle Převrátí obrázek nebo výběr svisle.
Otočit o 90 stupňů stupňů Otočí obrázek nebo výběr o 90 stupňů.
Okno Zobrazit barvy Otevře okno Barvy, ve kterém můžete zvolit barvy, které se mají použít pro váš obrázek.
Použití výběru jako štětce Umožňuje vytvořit vlastní štětec z části obrázku.

Váš výběr se stane vlastním štětcem, který rozmístí barvy ve výběru napříč obrázkem. Kopie výběru jsou ponechány podél přetahování cesty. Čím pomaleji přetáhnete, tím více kopií se načítá.
Kopírování a výběr obrysu Vytvoří kopii aktuálního výběru a nastíní ji.

Pokud je barva pozadí obsažená v aktuálním výběru, bude vyloučena, pokud vyberete transparentní.
Úprava barev Otevře Selektor vlastních barev, který umožňuje přizpůsobit barvy, které používáte pro obrázek.
Načíst paletu Otevře dialogové okno Načíst paletu barev, ve kterém můžete načíst barvy palety dříve uložené do souboru .pal.
Uložit paletu Uloží barvy palety do souboru .pal.
Kreslení neprůhledné Když vyberete , aktuální výběr bude neprůhledný.

Po zaškrtnutí tohoto políčka se aktuální výběr stane transparentním.
Editor panelu nástrojů Otevře dialogové okno Nový prostředek panelu nástrojů.
Mřížka Nastavení Otevře dialogové okno Nastavení, ve kterém můžete pro obrázek zadat mřížky.
Nový typ image Otevře dialogové <Device> okno Nový typ bitové kopie.

Prostředek s jednou ikonou může obsahovat několik obrázků různých velikostí a okna mohou používat odpovídající velikost ikony v závislosti na tom, jak se budou zobrazovat. Nový typ zařízení velikost ikony neupraví, ale v rámci ikony vytvoří nový obrázek. Platí jenom pro ikony a kurzory.
Aktuální typ obrázku ikona/kurzor Otevře podnabídku se seznamem prvních devíti dostupných obrázků kurzoru nebo ikony. Poslední příkaz v podnabídce Další otevře dialogové okno Otevřít <Device> obrázek.
Odstranění typu image Odstraní vybraný obrázek zařízení.
Nástroje Spustí podnabídku, která obsahuje všechny nástroje dostupné na panelu nástrojů Editoru obrázků.

Dialogové okno Nastavení mřížky umožňuje určit nastavení mřížky pro obrázek a zobrazit čáry mřížky nad upravovaný obrázek. Čáry jsou užitečné pro úpravy obrázku, ale neuloží se jako součást samotného obrázku.

Vlastnost Popis
Mřížka pixelů Pokud je toto políčko zaškrtnuté, zobrazí se kolem každého pixelu v Editoru obrázků mřížka.

Mřížka se zobrazí pouze v rozlišení 4× a vyšším.
Mřížka dlaždic Když je tato možnost vybraná, zobrazí se mřížka kolem bloků pixelů v Editoru obrázků, která je určena hodnotami mezer mřížky.
Width (Šířka) Určuje šířku každého bloku dlaždic.

Tato vlastnost je užitečná při kreslení rastrových obrázků obsahujících více obrázků uspořádaných v pravidelných intervalech.
Height (Výška) Určuje výšku každého bloku dlaždic.

Tato vlastnost je užitečná při kreslení rastrových obrázků obsahujících více obrázků uspořádaných v pravidelných intervalech.

Panel nástrojů

Panel nástrojů Editor obrázků obsahuje nástroje pro kreslení, kreslení, zadávání textu, mazání a manipulaci se zobrazeními. Obsahuje také selektor možností, pomocí kterého můžete vybrat možnosti pro použití jednotlivých nástrojů. Můžete si například vybrat z různých šířek štětců, faktorů zvětšení a stylů čar.

Všechny nástroje dostupné na panelu nástrojů Editor obrázků jsou také k dispozici v nabídce Nástroje > obrázků. Pokud chcete použít panel nástrojů Editor obrázků a selektor možností, vyberte nástroj nebo požadovanou možnost.

Panel nástrojů Editoru obrázků.
Panel nástrojů Editoru obrázků

Tip

Popisy tlačítek se zobrazí, když najedete kurzorem na tlačítko panelu nástrojů. Tyto tipy vám můžou pomoct identifikovat funkci jednotlivých tlačítek.

Vzhledem k tomu, že mnoho nástrojů pro kreslení je k dispozici naklávesnici , je někdy užitečné skrýt panel nástrojů Editor obrázků.

  • Pokud chcete zobrazit nebo skrýt panel nástrojů Editor obrázků, přejděte do nabídky Zobrazit panely nástrojů a zvolte > Editor obrázků.

Poznámka

Prvky z tohoto panelu nástrojů se zobrazí jako nedostupné, když v Editoru obrázků není otevřený soubor obrázku z aktuálního projektu nebo řešení.

přepínač možnosti

Pomocí selektoru možností můžete zadat šířku čáry, tah štětce a další možnosti. Ikona tlačítka pro výběr možnosti se změní v závislosti na tom, který nástroj jste vybrali.

Selektor-tvaru na panelu nástrojů Editoru obrázků
Selektor možností na panelu nástrojů Editoru obrázků

Textový nástroj

Pomocí dialogového okna Textový nástroj můžete přidat text do prostředku kurzoru, bitmapy nebo ikony.

Pokud chcete toto dialogové okno otevřít, otevřete Editor obrázků, přejděte do nabídky Nástroje obrázků a vyberte > příkaz Textový nástroj.

Tip

Kliknutím pravým tlačítkem na dialogové okno Textový nástroj můžete získat přístup k výchozí místní nabídce, která obsahuje seznam standardních Windows příkazů.

Otevřením dialogového okna Písmo textového nástroje můžete změnit písmo, styl nebo velikost písma kurzoru. Změny se použijí na text zobrazený v oblasti Text.

Pokud chcete toto dialogové okno otevřít, vyberte tlačítko Písmo v dialogovém okně Textový nástroj. Dostupné vlastnosti jsou:

Vlastnost Popis
Písmo Vypíše dostupná písma.
Styl písma Vypíše dostupné styly pro zadané písmo.
Velikost Uvádí dostupné velikosti bodů pro zadané písmo.
Ukázka Ukazuje ukázku toho, jak se bude text zobrazovat se zadaným nastavením písma.
Skript Vypíše dostupné skripty jazyka pro zadané písmo.

Když vyberete jiný jazykový skript, bude znaková sada pro tento jazyk dostupná pro vytváření vícejazyčných dokumentů.

Změna písma textu na obrázku

Tady je příklad přidání textu k ikoně v aplikaci Windows manipulaci s písmem textu.

  1. Vytvořte formulářové aplikace Windows C++. Podrobnosti najdete v tématu Postupy: Vytváření aplikací Windows Forms. Ve výchozím nastavení se do projektu přidá soubor app.ico.

  2. V Průzkumník řešení na soubor app.ico poklikejte. Otevře se Editor obrázků.

  3. Přejděte do nabídky Image > Tools (Nástroje obrázků) a vyberte Text Tool (Textový nástroj).

  4. V dialogovém okně Textový nástroj zadejte do prázdné textové oblasti C++. Tento text se zobrazí v poli s velikostí, které se nachází v levém horním rohu souboru app.ico v Editoru obrázků.

  5. V Editoru obrázků přetáhněte pole pro velikosti do středu souboru app.ico, aby se zlepšila čitelnost textu.

  6. V dialogovém okně Textový nástroj vyberte tlačítko Písmo.

  7. V dialogovém okně Písmo textového nástroje:

    • V seznamu dostupných písem, která jsou uvedená v seznamu Písmo, vyberte Times New Roman (Časy nového latinku).

    • V seznamu dostupných stylů písem uvedených v seznamu Styl písma vyberte Tučné.

    • Ze seznamu dostupných velikostí bodů uvedených v seznamu Velikost vyberte 10.

    • Vyberte OK. Dialogové okno Písmo textového nástroje se zavře a na text se použije nové nastavení písma.

  8. V dialogovém okně Textový nástroj zvolte Zavřít. Pole s velikostí kolem vašeho textu zmizí z Editoru obrázků.

V textové oblasti se zobrazí text, který se zobrazí jako součást prostředku. Na začátku je tato oblast prázdná.

Poznámka

Pokud je transparentní pozadí nastavené, umístí se do obrázku pouze text. Pokud je nastavené neprůhledné pozadí, za text se umístí ohraničující obdélník vyplněný barvou pozadí.

Podokna

V okně Editor obrázků se zobrazují dvě zobrazení obrázku s rozdělenou čárou, která odděluje obě podokna. Můžete přetáhnout příčku ze strany na stranu, a změnit tak relativní velikosti podoken. Aktivní podokno zobrazuje hranici výběru.

Jedno zobrazení je skutečné velikosti a druhé je zvětšeno výchozím faktorem 6. Zobrazení v těchto dvou podoknech se aktualizují automaticky. Všechny změny provedené v jednom podokně se okamžitě zobrazí v druhém podokně. Díky oběma podoknům můžete snadno pracovat se zvětšeným zobrazením obrázku, ve kterém můžete rozlišit jednotlivé pixely a současně sledovat vliv práce na zobrazení skutečné velikosti obrázku.

Levé podokno používá tolik místa, kolik je potřeba (až polovina okna Obrázek) k zobrazení výchozího zobrazení zvětšení obrázku 1:1. V pravém podokně se zobrazí výchozí obrázek se zvětšením 6:1. Zvětšení v jednotlivých podoknech můžete změnit pomocí nástroje Lupa na panelu nástrojů Editoru obrázků nebo pomocí kláves akcelerátoru.

Menší podokno okna Editor obrázků můžete zvětšit a pomocí těchto dvou podoken zobrazit různé oblasti velkého obrázku. Vyberte ji v podokně.

Relativní velikosti podoken můžete změnit umístěním ukazatele na dělený pruh a přesunutím dělicího pruhu doprava nebo doleva. Pokud chcete pracovat jenom v jednom podokně, může se rozdělit pruh až na obě strany.

Pokud je podokno Editor obrázků zvětšeno faktorem 4 nebo vyšším, můžete zobrazit mřížku pixelů, která odděluje jednotlivé pixely na obrázku.

Změna faktoru zvětšení

Editor obrázků ve výchozím nastavení zobrazuje zobrazení v levém podokně se skutečnou velikostí a zobrazení v pravém podokně v 6násobné skutečné velikosti. Faktor zvětšení (zobrazený ve stavovém řádku v dolní části pracovního prostoru) je poměr mezi skutečnou velikostí obrázku a zobrazenou velikostí. Výchozí faktor je 6 a rozsah je od 1 do 10.

  1. Vyberte podokno Editor obrázků, jehož faktor zvětšení chcete změnit.

  2. Na panelu nástrojů Editoru obrázků vyberte šipku napravo od nástroje Lupa a v podnabídce vyberte faktor zvětšení: 1x, 2x, 6x nebo 8x.

    Poznámka

    Pokud chcete vybrat jiný faktor zvětšení než ten, který je uvedený v nástroji Magnify, použijte klávesy akcelerátoru.

Zobrazení nebo skrytí mřížky pixelů

U všech podoken Editoru obrázků s faktorem zvětšení 4 nebo vyšším můžete zobrazit mřížku, která odděluje jednotlivé pixely na obrázku.

  1. Přejděte do nabídky Image > Grid Nastavení.

  2. Pokud chcete mřížku zobrazit, zaškrtněte políčko Mřížka pixelů. Pokud chcete mřížku skrýt, zrušte zaškrtnutí tohoto políčka.

Požadavky

Žádná

Viz také

Editory prostředků
Ikony