Vytváření sestav Power BI pomocí nástrojů pro usnadnění přístupuCreating reports in Power BI using accessibility tools

Pro autory, kteří při vytváření sestav používají nástroje pro usnadnění přístupu, nabízí Power BI spoustu integrovaných funkcí, které jim pomáhají.For report creators who use accessibility tools to create reports, Power BI has many built-in capabilities that can help in the process.

Stisknutím klávesy Alt se zobrazí klávesové zkratky

Tento článek popisuje množství typů nástrojů pro usnadnění přístupu, které jsou dostupné autorům sestav v Power BI Desktopu.This article describes the many types of accessibility tools available for report creators in Power BI Desktop.

Navigace na úrovni aplikaceApp-level navigation

Při navigaci v Power BI Desktopu můžete stisknutím kláves Ctrl+F6 přesouvat fokus po hlavních oblastech aplikace.When navigating in Power BI Desktop, you can move focus to the main areas of the app by pressing Ctrl + F6. Fokus se v hlavní oblasti Power BI Desktopu posouvá v následujícím pořadí:Shifting focus in the main area of Power BI Desktop progresses in the following order:

  1. Objekty na plátněObjects on canvas
  2. Karty stránekPage tabs
  3. Podokna (každé zvlášť, zleva doprava přes všechna otevřená)Panes (each one separately, left to right for whatever ones are open)
  4. Navigátor zobrazeníView navigator
  5. ZápatíFooter
  6. Přihlásit seSign in
  7. Žlutý panel s upozorněním / chybou / aktualizacemiYellow warning / error / updates bar

Mezi nejčastější postupy patří použití klávesy Enter k výběru nebo vstupu do nějaké oblasti a následné použití klávesy Esc k jejímu opuštění.In most cases, using Enter to select, or enter an area, and then using Esc to exit are common procedures in Power BI.

Navigace na pásu karetRibbon navigation

Při stisknutí klávesy Alt se nad každým příkazem v aktuálním zobrazení pásu karet ukážou čtverečky označované jako klávesové zkratky.Press Alt to see the little boxes called KeyTips over each command available in the current view of the ribbon. Pak můžete stisknout písmeno zobrazené v klávesové zkratce, která se nachází nad příkazem, který chcete použít.Then you can press the letter shown in the KeyTip that hovers over the command you want to use.

Například na následujícím obrázku byly stisknutím klávesy Alt zobrazeny klávesové zkratky, které obsahují písmena pro dostupné příkazy.For example, in the following image the Alt key has been pressed to display KeyTips, which contain the letters for available accessible commands. Stisknutím klávesy M by se pak otevřela karta Modelování na pásu karet.Then pressing M would open the Modeling tab on the ribbon.

Stisknutím klávesy Alt se zobrazí klávesové zkratky

V závislosti na tom, jaké písmeno stisknete, se mohou zobrazit další klávesové zkratky.Depending on which letter you press, you might see additional KeyTips. Pokud je například aktivní karta Domovská stránka a stisknete W, zobrazí se karta Zobrazení spolu s klávesovými zkratkami skupin na této kartě Zobrazení. Můžete pokračovat ve stiscích písmen zobrazených v klávesových zkratkách, dokud nestisknete písmeno konkrétního příkazu, který chcete použít.For example, if the Home tab is active and you press W, the View tab is displayed along with the KeyTips for the groups in that View ribbon tab. You can continue pressing letters displayed in KeyTips until you press the letter of the specific command you want to use. Stisknutím klávesy Esc přejdete k předchozí sadě klávesových zkratek. Stisknutím klávesy Alt zrušíte prováděnou akci a skryjete klávesové zkratky.To move to the previous set of KeyTips, press Esc. To cancel the action you’re taking and hide the KeyTips, press the Alt key.

Navigace v podokně vizuálůVisual pane navigation

Pokud chcete přejít do podokna Vizualizace, nejprve zajistěte, aby byl fokus na tomto podokně – opakovaně stiskněte klávesy Ctrl+F6, dokud se do tohoto podokna nedostanete.To navigate the Visualizations pane, you first must make sure your focus is on the pane, by pressing Ctrl + F6 until you reach that pane. Když uživatel prochází podokno Vizualizace, přesune se fokus nejprve na záhlaví.When a user navigates through the visualizations pane, the focus first lands on the header. Počínaje shora je pořadí ovládacích prvků následující, jak znázorňuje následující obrázek:Starting from the top, the tab order is the following, and is shown in the following image:

  1. Název záhlavíThe header title
  2. Šipka pro rozbalení/sbaleníThe expand / collapse carat
  3. Ikona prvního vizuáluThe first visual icon

Pořadí ovládacích prvků pro podokna

Když se dostanete k vizuálům, můžete pomocí šipkových kláves přejít na konkrétní vizuál a stisknutím klávesy Enter ho vybrat.When you get to the visuals, you can use arrow keys to navigate to a particular visual, and press Enter to select it. Pokud používáte čtečku obrazovky, zavolá se, pokud jste vytvořili nový graf a řekne vám, o který typ jde, nebo vám řekne, že jste graf určitého typu změnili na jiný typ grafu.If you’re using a screen reader, it calls out if you’ve created a new chart and tell you what type it is, or it tells you that you’ve changed a chart of a particular type to another type of chart.

Po oddílu vizuálů v tomto podokně se následně fokus přesune na pivoty podokna, jak ukazuje následující obrázek.After the visuals section of the pane, the focus order then shifts to the pane pivots, as shown in the following image.

Pivoty podokna

Když je fokus na pivotech podokna, při stisknutí tabulátoru se přesune jen na ikonu vybraného podokna.When focus is on the pane pivots, tabbing lands only on the icon for the pane that is selected. K přepnutí do jiných podoken použijte šipkové klávesy.To switch to other panes, use arrow keys.

Zdroj políField well

Když je fokus na pivotech podokna, jak bylo popsáno v předchozí části, posunete se opětovným stisknutím tabulátoru na zdroj polí.When focus is on the pane pivots, as described in the previous section, pressing tab again advances focus to the Field Well.

Ve zdroji polí se fokus postupně přesouvá na:In the Field well, focus order moves to:

  • název jednotlivých zdrojů (první)each well's title (first)
  • dané pole v jednotlivých zdrojích (další)followed by a given field in each well (next)
  • rozevírací tlačítko pro otevření nabídky pole (jako další)the dropdown button to open the field menu (after that)
  • tlačítko pro odebrání (poslední)then the removal button (last)

Toto přesouvání fokusu znázorňuje následující obrázek.The following image shows this focus progression ordering.

Přesouvání fokusu ve zdroji polí

Čtečka obrazovky bude předčítat název a popis zdroje.A screen reader will read out the well’s name and its tooltip. U každého pole ve zdroji předčítá čtečka obrazovky název pole a jeho popis.For each field in a well, a screen reader reads the field name and its tooltip. Pokud je zdroj prázdný, měl by se fokus přesunout do celého prázdného zdroje.If a well is empty, the focus should move to the entire empty well. Čtečka obrazovky by měla předčítat název zdroje, popis a to, zda je prázdný.The screen reader should read the well name, tooltip, and that it is empty.

Když je otevřená nabídka pole, můžete ji procházet klávesami Tab nebo Shift+Tab, případně šipkami nahoru / dolů.When the field menu is open, you can move through it by using Tab or Shift + Tab or Up / Down arrow keys. Čtečka obrazovky bude předčítat názvy možností.A screen reader will call out the option names.

Pokud chcete přesunout některé pole z jednoho kontejneru ve zdroji polí do jiného, můžete použít klávesnici a následně možnost Přesunout v nabídce zdroje polí, jak je znázorněno na následujícím obrázku.If you’d like to move a field from one bucket in the field well to another bucket, you can use your keyboard, and use the Move to option in the field well menu, as shown in the following image.

Přesunutí pole pomocí nabídky

Podokno formátováníFormatting pane

V podokně formátování se fokus přesouvá shora dolů podle pořadí karet.The focus order for the Formatting pane moves from the top, then down, in card order. Fokus přejde na název karty a následně na přepínač zapnuto/vypnuto, pokud existuje.The focus goes around the card name, followed by its On / Off toggle button, if it exists. Když je fokus na názvu karty, předčítá čtečka obrazovky název této karty a to, zda je karta rozbalená nebo sbalená.When the focus is on the card name, a screen reader reads out the name of the card, and whether the card is expanded or collapsed. Stisknutím klávesy Enter můžete kartu sbalit nebo rozbalit.You can press Enter to expand or collapse the card. Klávesu Enter lze použít také k přepnutí přepínače do polohy Zapnuto nebo Vypnuto.The Enter key also works to switch On or Off the toggle button.

Přesouvání fokusu v podokně formátování

Pokud je otevřená nějaká karta, můžete klávesou Tab procházet ovládací prvky na této kartě a následně přejít na další kartu.If a card is open, Tab moves through the controls in the card before going on to the next card. U ovládacích prvků na kartě předčítá čtečka obrazovky název, aktuální hodnotu a typ ovládacího prvku.For the controls in a card, a screen reader calls out the title, the current value, and the control type.

Přesouvání fokusu na otevřené kartě

Navigace v seznamu PoleFields list navigation

Stisknutím klávesy Tab můžete procházet seznam Pole.You can press Tab to navigate around the Fields list. Pokud jsou tabulky sbaleny, přesouvá se fokus podobně jako v podokně formátování v následujícím pořadí:Similar to the formatting pane, if tables are collapsed the focus order cycles through in the following order:

  1. Záhlaví seznamu PoleThe Fields list header
  2. Panel hledáníThe search bar
  3. Názvy jednotlivých tabulekEach table name

Přesouvání fokusu v seznamu Pole

Stisknutím kláves Alt+Shift+9 rozbalíte všechny tabulky ve zdroji Pole.To expand all the tables in the Fields well, press Alt + Shift + 9. Stisknutím kláves Alt+Shift+1 všechny tabulky sbalíte.To collapse all the tables press Alt + Shift + 1. Pokud chcete rozbalit jednu tabulku, stiskněte klávesu se šipkou vpravo.To expand a single table, press the Right arrow key. Pokud chcete sbalit jednu tabulku, stiskněte klávesu se šipkou vlevo.To collapse a single table, press the Left arrow key. Pokud je některá tabulka rozbalená, pak se při stisknutí tabulátoru a navigaci v seznamu polí procházejí zobrazená pole, podobně jako v podokně formátování.Similar to the formatting pane, if a table is expanded, then tabbing and navigating through the fields list includes the fields that are being shown. Čtečka obrazovky předčítá, zda je tabulka rozbalená nebo sbalená.A screen reader calls out whether you have expanded or collapsed a table.

Přesouvání fokusu v seznamu Pole s rozbalenými tabulkami

Pole můžete zaškrtnout tak, že na ně přejdete a stisknete klávesu Enter.You can checkmark a field by navigating to the desired field and pressing Enter. Čtečka obrazovky předčítá pole, na kterém je fokus, a to, jestli je nebo není zaškrtnuté.A screen reader calls out the field the focus is on, and whether the field is checked or unchecked.

Uživatelé, kteří používají myš, zpravidla přesouvají pole na plátno nebo do kontejnerů relevantních filtrů.Mouse users typically drag-and-drop fields to the canvas, or to the relevant filter buckets they desire. Pokud chcete použít klávesnici, můžete pole přidat do kontejneru filtru tak, že stisknutím kláves Shift+F10 přejdete na místní nabídku pole, pomocí šipkových kláves přejdete na Přidat do filtrů a potom stisknete klávesu Enter u typu filtru, do kterého chcete toto pole přidat.If you’d like to use your keyboard, you can add a field to a filter bucket by entering a field’s context menu by pressing Shift + F10, using arrow keys to navigate to Add to filters, and then pressing Enter on the type of filter to which you’d like to add the field.

Přidání pole do kontejneru filtru

Navigace v podokně výběruSelection pane navigation

V podokně Výběr se fokus přesouvá takto:The Selection pane has the following focus order progression:

  1. Název záhlavíHeader title
  2. Tlačítko KonecExit button
  3. Přepínač pořadí vrstev nebo karetLayer / tab order switcher
  4. Tlačítko pro přesun o vrstvu nahoruMove up in layer button
  5. Tlačítko pro přesun o vrstvu dolůMove down in layer button
  6. Tlačítko pro zobrazeníShow button
  7. Tlačítko pro skrytíHide button
  8. ObjektyObjects

Přesouvání fokusu v podokně výběru

Stisknutím tabulátoru můžete procházet jednotlivé prvky a stisknutím klávesy Enter vybrat ten, o který máte zájem.You can tab through the focus order and press Enter to select the element you're interested in.

Když se dostanete k přepínači pořadí vrstev nebo karet, můžete pomocí šipkových kláves přepnout mezi pořadím vrstev a pořadím karet.When you get to the layer / tab order switcher, use the left and right arrow keys to switch between the layer order and tab order.

Když se dostanete k objektům v podokně Výběr, aktivujete stisknutím klávesy F6 podokno Výběr.When you get to the objects in the Selection pane, press F6 to activate the Selection pane. Po aktivaci podokna Výběr můžete pomocí kláves se šipkami nahoru a dolů přejít k různým objektům v podokně Výběr.After activating the Selection pane, you can use the up / down arrow keys to navigate to the different objects in the Selection pane. Jakmile přejdete na objekt vašeho zájmu, můžete provést několik různých akcí:Once you’ve navigated to an object of interest, there are a few different actions you can take:

  • Stisknutím kláves Ctrl+Shift+S objekt skryjete nebo zobrazíte.Press Ctrl + Shift + S to hide / show an object
  • Stisknutím kláves Ctrl+Shift+F přesunete objekt o vrstvu nahoru.Press Ctrl + Shift + F to move an object up in the layer order
  • Stisknutím kláves Ctrl+Shift+B přesunete objekt o vrstvu dolů.Press Ctrl + Shift + B to move an object down in the layer order
  • Stisknutím kláves Ctrl+Space vyberete více objektů.Press Ctrl + Space to multi-select objects

Dialogy v Power BI DesktopuPower BI Desktop dialogs

Všechny dialogy v Power BI Desktopu jsou přístupné prostřednictvím klávesnice a fungují s čtečkami obrazovky.All dialogs in Power BI Desktop are accessible through keyboard navigation and work with screen readers.

Mezi dialogy v Power BI Desktopu patří:Dialogs in Power BI Desktop include the following:

  • Dialog Rychlé míryQuick Measures dialog
  • Dialog Podmíněné formátování a datové pruhyConditional Formatting & data bars dialog
  • Dialog průzkumníku Q&AQ&A Explorer dialog
  • Dialog ZačínámeGetting Started dialog
  • Nabídka Soubor a dialog O produktuFile menu and About dialog
  • Panel upozorněníWarning bar
  • Dialog obnovení souboruFile Restore dialog
  • Dialog se zamračenými smajlíkyFrowns dialog

Podpora vysokého kontrastuHigh contrast support

Pokud ve Windows používáte režimy vysokého kontrastu, aplikují se tato nastavení a vybrané palety také na sestavy Power BI Desktopu.When you use high contrast modes in Windows, those settings and the palette you select are also applied to reports in Power BI Desktop.

Nastavení vysokého kontrastu ve Windows

Power BI Desktop automaticky zjišťuje, který motiv s vysokým kontrastem se používá ve Windows, a tato nastavení aplikuje na sestavy.Power BI Desktop automatically detects which high contrast theme Windows is using and applies those settings to your reports. Barvy s vysokým kontrastem v sestavě zůstanou i po publikování ve službě Power BI nebo jinde.Those high contrast colors follow the report when published to the Power BI service, or elsewhere.

Nastavení vysokého kontrastu ve Windows

Další krokyNext steps

Sada článků o usnadnění přístupu v Power BI:The collection of articles for Power BI accessibility are the following: