Herstellen einer Verbindung mit Azure HDInsight und Ausführen von Apache Hive-Abfragen mithilfe von Data Lake Tools für Visual StudioUse Data Lake Tools for Visual Studio to connect to Azure HDInsight and run Apache Hive queries

Hier erfahren Sie, wie Sie mit Microsoft Azure Data Lake- und Stream Analytics-Tools für Visual Studio (auch als Data Lake Tools bezeichnet) eine Verbindung mit Apache Hadoop-Clustern in Azure HDInsight herstellen und Hive-Abfragen übermitteln können.Learn how to use Microsoft Azure Data Lake and Stream Analytics Tools for Visual Studio (also called Data Lake Tools) to connect to Apache Hadoop clusters in Azure HDInsight and submit Hive queries.

Weitere Informationen zur Verwendung von HDInsight finden Sie unter Einführung in HDInsight und Erste Schritte mit HDInsight.For more information about using HDInsight, see Introduction to HDInsight and Get started with HDInsight.

Weitere Informationen zum Herstellen einer Verbindung mit einem Apache Storm-Cluster finden Sie im Artikel zum Entwickeln von C#-Topologien für Apache Storm in HDInsight mithilfe von Visual Studio.For more information about connecting to an Apache Storm cluster, see Develop C# topologies for Apache Storm on HDInsight by using Visual Studio.

Sie können Data Lake Tools für Visual Studio verwenden, um auf Data Lake Analytics und HDInsight zuzugreifen.You can use Data Lake Tools for Visual Studio to access Azure Data Lake Analytics and HDInsight. Weitere Informationen zu Data Lake Tools finden Sie unter Entwickeln von U-SQL-Skripts mit Data Lake Tools für Visual Studio.For information about Data Lake Tools, see Develop U-SQL scripts by using Data Lake Tools for Visual Studio.

VoraussetzungenPrerequisites

Um dieses Tutorial durchzuführen und Data Lake Tools für Visual Studio zu verwenden, benötigen Sie Folgendes:To complete this tutorial and use Data Lake Tools for Visual Studio, you need the following items:

Installieren von Data Lake-Tools für Visual StudioInstall Data Lake Tools for Visual Studio

  • Visual Studio 2017 oder Visual Studio 2019Visual Studio 2017 or Visual Studio 2019
    Achten Sie bei der Installation darauf, dass Sie mindestens die Workload Azure development (Azure-Entwicklung) oder Datenspeicherung und -verarbeitung einbeziehen.During installation, ensure you include at least Workloads Azure development or Data storage and processing.

    Navigieren Sie für vorhandene Installationen über die Menüleiste zu Extras > Tools und Features abrufen... , um den Visual Studio-Installer zu öffnen.For existing installations, from the menu bar, navigate to Tools > Get Tools and Features... to open Visual Studio Installer. Wählen Sie dann mindestens die Workload Azure development (Azure-Entwicklung) oder Datenspeicherung und -verarbeitung aus.Then select at least Workloads Azure development or Data storage and processing.

    Screenshot vom Visual Studio-Installer

  • Visual Studio 2013 und 2015Visual Studio 2013 and 2015
    Data Lake Tools herunterladen.Download Data Lake Tools. Wählen Sie die passende Version von Data Lake Tools für Ihre Visual Studio-Version aus.Choose the version of Data Lake Tools that matches your version of Visual Studio.

Hinweis

Derzeit ist nur die englische Version von Data Lake Tools für Visual Studio verfügbar.Currently, only the English version of Data Lake Tools for Visual Studio is available.

Aktualisieren von Data Lake Tools für Visual StudioUpdate Data Lake Tools for Visual Studio

  1. Öffnen Sie Visual Studio.Open Visual Studio.

  2. Navigieren Sie über die Menüleiste zu Extras > Extensions und Updates... .From the menu bar, navigate to Tools > Extensions and Updates....

  3. Erweitern Sie im Fenster Extensions und Updates die Option Updates auf der linken Seite.From the Extensions and Updates window, expand Updates on the left.

  4. Wenn ein Update verfügbar ist, wird Azure Data Lake and Stream Analytic Tools (Azure Data Lake- und Stream Analytics-Tools) im Hauptfenster angezeigt.If an update is available, Azure Data Lake and Stream Analytic Tools will appear in the main window. Wählen Sie Update aus.Select Update.

Hinweis

Sie können Data Lake Tools Version 2.3.0.0 oder höher nur verwenden, um eine Verbindung mit Interactive Query-Clustern herzustellen und interaktive Hive-Abfragen auszuführen.You can use only Data Lake Tools version 2.3.0.0 or later to connect to Interactive Query clusters and run interactive Hive queries.

Herstellen einer Verbindung mit Azure-AbonnementsConnect to Azure subscriptions

Mithilfe von Data Lake Tools für Visual Studio können Sie eine Verbindung mit Ihren HDInsight-Clustern herstellen, einige einfache Verwaltungsvorgänge durchführen und Hive-Abfragen ausführen.You can use Data Lake Tools for Visual Studio to connect to your HDInsight clusters, perform some basic management operations, and run Hive queries.

Hinweis

Informationen zum Herstellen einer Verbindung mit einem generischen Hadoop-Cluster finden Sie unter Write and submit Hive queries by using Visual Studio (Schreiben und Übermitteln von Hive-Abfragen mithilfe von Visual Studio).For information about connecting to a generic Hadoop cluster, see Write and submit Hive queries by using Visual Studio.

So stellen Sie eine Verbindung mit Ihrem Azure-Abonnement her:To connect to your Azure subscription:

  1. Öffnen Sie Visual Studio.Open Visual Studio.

  2. Navigieren Sie über die Menüleiste zu Ansicht > Server-Explorer.From the menu bar, navigate to View > Server Explorer.

  3. Klicken Sie im Server-Explorer mit der rechten Maustaste auf den Knoten Azure, klicken Sie auf Verbindung mit Microsoft Azure-Abonnement herstellen... , und melden Sie sich an.From Server Explorer, right-click Azure, select Connect to Microsoft Azure Subscription..., and complete the sign in process.

  4. Im Server-Explorer wird eine Liste der vorhandenen HDInsight-Cluster angezeigt.From Server Explorer, a list of existing HDInsight clusters appears. Wenn Sie noch keine Cluster haben, können Sie über das Azure-Portal, Azure PowerShell oder das HDInsight SDK Cluster erstellen.If you don't have any clusters, you can create one by using the Azure portal, Azure PowerShell, or the HDInsight SDK. Weitere Informationen finden Sie unter Erstellen von HDInsight-Clustern.For more information, see Create HDInsight clusters.

    Screenshot der Clusterliste von Data Lake Tools für Visual Studio im Server-ExplorerScreenshot of the Data Lake Tools for Visual Studio cluster list in Server Explorer

  5. Erweitern Sie einen HDInsight-Cluster.Expand an HDInsight cluster. Hive-Datenbanken, das Standardspeicherkonto, verknüpfte Speicherkonten und das Hadoop-Dienstprotokoll werden angezeigt.Hive Databases, a default storage account, linked storage accounts, and Hadoop Service log appear. Sie können die einzelnen Elemente weiter erweitern.You can further expand the entities.

Nach dem Herstellen der Verbindung mit Ihrem Azure-Abonnement können Sie die folgenden Aufgaben durchführen.After you've connected to your Azure subscription, you can perform the following tasks.

So stellen Sie in Visual Studio eine Verbindung mit dem Azure-Portal her:To connect to the Azure portal from Visual Studio:

  1. Navigieren Sie im Server-Explorer zu Azure > HDInsight, und wählen Sie Ihren Cluster aus.From Server Explorer, navigate to Azure > HDInsight and select your cluster.

  2. Klicken Sie mit der rechten Maustaste auf einen HDInsight-Cluster, und wählen Sie dann Cluster in Azure-Portal verwalten aus.Right-click an HDInsight cluster, and select Manage Cluster in Azure Portal.

So können Sie in Visual Studio Fragen stellen und/oder Feedback geben:To ask questions and/or provide feedback from Visual Studio:

  1. Navigieren Sie im Server-Explorer zu Azure > HDInsight.From Server Explorer, navigate to Azure > HDInsight.

  2. Klicken Sie mit der rechten Maustaste auf HDInsight, und wählen Sie entweder MSDN-Forum aus, um Fragen zu stellen, oder Feedback abgeben, um Feedback einzureichen.Right-click HDInsight and select either MSDN Forum to ask questions, or Give Feedback to give feedback.

Sie können einen Cluster verknüpfen, indem Sie mit der rechten Maustaste auf HDInsight klicken und dann die Option zum Verknüpfen eines HDInsight-Clusters auswählen.You could link a cluster by right clicking on HDInsight then select Link a HDInsight Cluster. Geben Sie Verbindungs-URL, Benutzername und Kennwort ein, klicken Sie auf Weiter und dann auf Fertig stellen. Der Cluster sollte erfolgreich unter „HDInsight-Knoten“ aufgelistet werden.Enter Connection Url, user name and password, click Next then Finish, the cluster should be listed under HDInsight node successful.

Screenshot von Data Lake Tools für das Dialogfeld von Visual Studio zum Verknüpfen von Clustern

Klicken Sie mit der rechten Maustaste auf den verknüpften Cluster, und wählen Sie Bearbeiten aus. Der Benutzer kann die Clusterinformationen aktualisieren.Right click on the linked cluster, select Edit, user could update the cluster information. Beachten Sie, dass die Option zum Hinzufügen von HDInsight-Clustern derzeit nur Hive unterstützt.Note that Add HDInsight cluster only supports Hive for now.

Screenshot von Data Lake Tools für das Dialogfeld von Visual Studio zum Verknüpfen von Clustern – Update

Erkunden der verknüpften RessourcenExplore linked resources

Im Server-Explorer werden das Standardspeicherkonto und verknüpfte Speicherkonten angezeigt.From Server Explorer, you can see the default storage account and any linked storage accounts. Wenn Sie das Standardspeicherkonto erweitern, werden die Container im Speicherkonto angezeigt.If you expand the default storage account, you can see the containers on the storage account. Das Standardspeicherkonto und der Standardcontainer sind markiert.The default storage account and the default container are marked. Klicken Sie mit der rechten Maustaste auf einen der Container, um seinen Inhalt anzuzeigen.Right-click any of the containers to view the container contents.

Screenshot der Liste der verknüpften Ressourcen von Data Lake Tools für Visual Studio im Server-ExplorerScreenshot of Data Lake Tools for Visual Studio list linked resources in Server Explorer

Nach dem Öffnen eines Containers können Sie mithilfe der folgenden Schaltflächen Blobs hochladen, löschen und herunterladen:After opening a container, you can use the following buttons to upload, delete, and download blobs:

Screenshot der Blobvorgänge von Data Lake Tools für Visual Studio im Server-ExplorerScreenshot of Data Lake Tools for Visual Studio blob operations in Server Explorer

Ausführen interaktiver Apache Hive-AbfragenRun interactive Apache Hive queries

Apache Hive ist eine Data Warehouse-Infrastruktur, die auf Hadoop basiert.Apache Hive is a data warehouse infrastructure that's built on Hadoop. Hive wird für die Datenzusammenfassung, Abfragen und die Analyse verwendet.Hive is used for data summarization, queries, and analysis. Sie können Data Lake Tools für Visual Studio verwenden, um Hive-Abfragen in Visual Studio auszuführen.You can use Data Lake Tools for Visual Studio to run Hive queries from Visual Studio. Weitere Informationen zu Hive finden Sie unter Verwenden von Apache Hive mit HDInsight.For more information about Hive, see Use Apache Hive with HDInsight.

Interactive Query verwendet Hive unter LLAP in Apache Hive 2.1.Interactive Query uses Hive on LLAP in Apache Hive 2.1. Interactive Query bietet Interaktivität für komplexe Data Warehouse-Abfragen von umfangreichen, gespeicherten Datasets.Interactive Query brings interactivity to complex data warehouse-style queries on large, stored datasets. Die Ausführung von Hive-Abfragen mit Interactive Query ist im Vergleich zu herkömmlichen Hive-Batchaufträgen deutlich schneller.Running Hive queries on Interactive Query is much faster compared to traditional Hive batch jobs.

Hinweis

Das Ausführen von interaktiven Hive-Abfragen ist nur möglich, wenn Sie eine Verbindung mit einem HDInsight Interactive Query-Cluster herstellen.You can run interactive Hive queries only when you connect to an HDInsight Interactive Query cluster.

Sie können Data Lake Tools für Visual Studio auch verwenden, um den Inhalt eines Hive-Auftrags anzuzeigen.You can also use Data Lake Tools for Visual Studio to see what’s inside a Hive job. Data Lake Tools für Visual Studio sammelt die YARN-Protokolle bestimmter Hive-Aufträge und zeigt sie an.Data Lake Tools for Visual Studio collects and surfaces the Yarn logs of certain Hive jobs.

Navigieren Sie im Server-Explorer zu Azure > HDInsight, und wählen Sie Ihren Cluster aus.From Server Explorer, navigate to Azure > HDInsight and select your cluster. Das ist der Ausgangspunkt im Server-Explorer für die folgenden Abschnitte.This will be the starting point in Server Explorer for the sections to follow.

Anzeigen der Beispieltabelle „hivesampletable“View hivesampletable

Alle HDInsight-Cluster verfügen über eine Hive-Beispieltabelle mit dem Namen hivesampletable.All HDInsight clusters have a default sample Hive table called hivesampletable.

Navigieren Sie von Ihrem Cluster zu Hive-Datenbanken > Standard > hivesampletable.From your cluster, navigate to Hive Databases > default > hivesampletable.

  • So zeigen Sie das hivesampletable-Schema an:To view hivesampletable schema:
    Erweitern Sie hivesampletable.Expand hivesampletable.

  • So zeigen Sie hivesampletable-Daten an:To view hivesampletable data:
    Klicken Sie mit der rechten Maustaste auf hivesampletable und dann auf Erste 100 Zeilen anzeigen.Right-click hivesampletable, and select View Top 100 Rows. Dies entspricht dem Ausführen der folgenden Hive-Abfrage mithilfe des Hive-ODBC-Treibers:This is equivalent to running the following Hive query by using the Hive ODBC driver:

    SELECT * FROM hivesampletable LIMIT 100

    Sie können die Anzahl der Zeilen anpassen.You can customize the row count.

    Screenshot einer HDInsight Hive Visual Studio-SchemaabfrageScreenshot of an HDInsight Hive Visual Studio schema query

Erstellen von Hive-TabellenCreate Hive tables

Zum Erstellen einer Hive-Tabelle können Sie die grafische Benutzeroberfläche oder Hive-Abfragen verwenden.To create a Hive table, you can use the GUI or you can use Hive queries. Informationen zum Verwenden von Hive-Abfragen finden Sie unter Ausführen von Apache Hive-Abfragen.For information about using Hive queries, see Run Apache Hive queries.

  1. Navigieren Sie von Ihrem Cluster zu Hive-Datenbanken > Standard.From your cluster, navigate to Hive Databases > default.

  2. Klicken Sie mit der rechten Maustaste auf Standard, und wählen Sie dann Tabelle erstellen aus.Right-click default, and select Create Table.

  3. Konfigurieren Sie die Tabelle wie gewünscht.Configure the table as desired.

  4. Klicken Sie auf Tabelle erstellen, um den Auftrag zum Erstellen der neuen Hive-Tabelle zu übermitteln.Select Create Table to submit the job to create the new Hive table.

    Screenshot des Fensters „Tabelle erstellen“ der HDInsight Visual Studio-ToolsScreenshot of the HDInsight Visual Studio Tools Create Table window

Erstellen und Ausführen von Hive-AbfragenCreate and run Hive queries

Zum Erstellen und Ausführen von Hive-Abfragen stehen Ihnen zwei Möglichkeiten zur Auswahl:You have two options for creating and running Hive queries:

  • Erstellen von Ad-hoc-AbfragenCreate ad-hoc queries
  • Erstellen einer Hive-AnwendungCreate a Hive application

So können Sie Ad-hoc-Abfragen erstellen und ausführenTo create, and run ad-hoc queries:

  1. Klicken Sie mit der rechten Maustaste auf den Cluster, in dem Sie die Abfrage ausführen möchten, und wählen Sie dann Hive-Abfrage schreiben aus.Right-click the cluster where you want to run the query, and select Write a Hive Query.

  2. Geben Sie die Hive-Abfragen ein.Enter the Hive queries.

    Der Hive-Editor unterstützt IntelliSense.The Hive editor supports IntelliSense. Data Lake Tools für Visual Studio unterstützt das Laden von Remotemetadaten, wenn Sie Ihr Hive-Skript bearbeiten.Data Lake Tools for Visual Studio supports loading remote metadata when you edit your Hive script. Wenn Sie beispielsweise SELECT * FROM eingeben, listet IntelliSense alle vorgeschlagenen Tabellennamen auf.For example, if you type SELECT * FROM, IntelliSense lists all the suggested table names. Wird ein Tabellenname angegeben, listet IntelliSense die Spaltennamen auf.When a table name is specified, IntelliSense lists the column names. Die Tools unterstützen die meisten Hive-DML-Anweisungen, Unterabfragen und integrierte UDFs.The tools support most Hive DML statements, subqueries, and built-in UDFs.

    Screenshot von Beispiel 1 für HDInsight Visual Studio-ToolsScreenshot of an HDInsight Visual Studio Tools IntelliSense example 1

    Screenshot von Beispiel 2 für HDInsight Visual Studio-ToolsScreenshot of an HDInsight Visual Studio Tools IntelliSense example 2

    Hinweis

    IntelliSense schlägt nur die Metadaten des Clusters vor, der auf der HDInsight-Symbolleiste ausgewählt ist.IntelliSense suggests only the metadata of the cluster that is selected in the HDInsight toolbar.

  3. Wählen Sie den Ausführungsmodus aus:Choose execution mode:

    • InteractiveInteractive

      Achten Sie darauf, dass Interactive (Interaktiv) ausgewählt ist, und klicken Sie dann auf Senden.Ensure Interactive is selected and then select Execute.

      Screenshot: Abfrage und Ausführen

    • BatchBatch

      Achten Sie darauf, dass Batch ausgewählt ist, und klicken Sie dann auf Senden.Ensure Batch is selected and then select Submit. Konfigurieren Sie den Auftragsnamen, Argumente, zusätzliche Konfigurationen und das Statusverzeichnis für das Skript, wenn Sie die Option für erweitertes Senden auswählen:If you select the advanced submit option, configure Job Name, Arguments, Additional Configurations, and Status Directory for the script.

      Screenshot: Abfrage und Batch

      Screenshot einer HDInsight Hadoop Hive-AbfrageScreenshot of an HDInsight Hadoop Hive query

      Hinweis

      Sie können keine Batches an Interactive Query-Cluster senden.You can not submit batches to Interactive Query clusters. Dazu müssen Sie den interaktiven Modus verwenden.You must use interactive mode.

So erstellen Sie eine Hive-Lösung und führen Sie sie aus:To create and run a Hive solution:

  1. Navigieren Sie über die Menüleiste zu Datei > Neu > Projekt... .From the menu bar, navigate to File > New > Project....

  2. Navigieren Sie im linken Bereich zu Installiert > Azure Data Lake > HIVE (HDInsight) .In the left pane, navigate to Installed > Azure Data Lake > HIVE (HDInsight).

  3. Wählen Sie im mittleren Bereich Hive Application (Hive-Anwendung) aus.In the middle pane, select Hive Application. Geben Sie die Eigenschaften ein, und klicken Sie dann auf OK.Enter the properties, and then select OK.

    Screenshot eines neuen Hive-Projekts in den HDInsight Visual Studio-ToolsScreenshot of an HDInsight Visual Studio Tools new Hive project

  4. Doppelklicken Sie im Projektmappen-Explorer auf Script.hql, um das Skript zu öffnen.In Solution Explorer, double-click Script.hql to open the script.

Anzeigen der Auftragszusammenfassung und -ausgabeView job summary and output

Die Auftragszusammenfassung unterscheidet sich zwischen den Modi Batch und Interactive (Interaktiv).The job summary varies slightly between Batch and Interactive mode.

AuftragszusammenfassungJob summary

Klicken Sie auf die Schaltfläche Aktualisieren, um den Status zu aktualisieren, bis sich der Auftragsstatus in Abgeschlossen ändert.Use the Refresh button to update the status until the job status changes to Finished.

  • Wenn Sie die Auftragsdetails im Batch-Modus anzeigen möchten, klicken Sie unten auf die Links, um die Auftragsabfrage, die Auftragsausgabe, das Auftragsprotokoll oder das YARN-Protokoll anzuzeigen.For the job details from Batch mode, select the links at the bottom to see Job Query, Job Output, Job log, or Yarn log.

  • Wenn Sie die Auftragsdetails im interaktiven Modus anzeigen möchten, klicken Sie auf die Registerkarten Ausgabe und HiveServer2-Ausgabe.For the job details from Interactive mode, see tabs Output and HiveServer2 Output.

    Auftragsdetailsjob details

Anzeigen von AuftragsdiagrammenView job graph

Aktuell werden Auftragsdiagramme nur für Hive-Aufträge angezeigt, die Tez als Ausführungs-Engine verwenden.Currently, job graphs are only shown for Hive jobs that use Tez as the execution engine. Informationen zum Aktivieren von Tez finden Sie unter Verwenden von Apache Hive in HDInsight.For information about enabling Tez, see Use Apache Hive in HDInsight. Weitere Informationen finden Sie im Abschnitt „Verwenden von Apache Tez anstelle von MapReduce“ unter Optimieren von Apache Hive-Abfragen in Azure HDInsight.See also, Use Apache Tez instead of Map Reduce.

Um alle Operatoren am Scheitelpunkt anzuzeigen, doppelklicken Sie auf die Scheitelpunkte des Auftragsdiagramms.To view all the operators inside the vertex, double-click on the vertices of the job graph. Sie können auch auf einen bestimmten Operator zeigen, um weitere Details anzuzeigen.You can also point to a specific operator to see more details about the operator.

Das Auftragsdiagramm wird möglicherweise auch dann nicht angezeigt, wenn Tez als Ausführung-Engine beim Start der Tez-Anwendung verwendet wird.The job graph may not appear even if Tez is specified as the execution engine if no Tez application is launched. Dies kann daran liegen, dass der Auftrag keine DML-Anweisungen enthält, oder dass die DML-Anweisungen etwas zurückgegeben können, ohne dass eine Tez-Anwendung gestartet werden muss.This might happen because the job does not contain DML statements, or the DML statements can return without launching a Tez application. Durch SELECT * FROM table1 wird die Tez-Anwendung z.B. nicht gestartet.For example, SELECT * FROM table1 will not launch the Tez application.

AuftragsdiagrammJob graph

Details zur TaskausführungTask Execution Detail

In der Auftragsdiagramm können Sie Details zur Taskausführung auswählen, um strukturierte und visualisierte Informationen zu Hive-Aufträgen anzeigen.From the job graph, you can select Task Execution Detail to get structured and visualized information for Hive jobs. Sie können auch weitere Auftragsinformationen abrufen.You can also get more job details. Im Fall von Leistungsproblemen können Sie in der Ansicht weitere Details zum Problem anzeigen.If performance issues occur, you can use the view to get more details about the issue. Beispielsweise können Sie Informationen zur Funktion jeder Aufgabe und ausführliche Informationen zu einzelnen Aufgaben (Lese-/Schreibzugriff auf Daten, Zeitplan, Start- und Endzeit usw.) anzeigen.For example, you can get information about how each task operates, and detailed information about each task (data read/write, schedule/start/end time, and so on). Mithilfe der visualisierten Informationen können Sie Auftragskonfigurationen oder die Systemarchitektur optimieren.Use the information to tune job configurations or system architecture based on the visualized information.

Screenshot der Aufgabenausführungsansicht von Data Lake Tools für Visual StudioScreenshot of the Data Lake Visual Studio Tools Task Execution View window

Anzeigen von Hive-AufträgenView Hive jobs

Sie können Auftragsabfragen, die Auftragsausgabe, Auftragsprotokolle und YARN-Protokolle für Hive-Aufträge anzeigen.You can view job queries, job output, job logs, and Yarn logs for Hive jobs.

In der neuesten Version der Tools können Sie den Inhalt Ihrer Hive-Aufträge anzeigen, indem Sie YARN-Protokolle erfassen und anzeigen.In the most recent release of the tools, you can see what’s inside your Hive jobs by collecting and surfacing Yarn logs. Ein YARN-Protokoll kann Ihnen bei der Untersuchung von Leistungsproblemen helfen.A Yarn log can help you investigating performance issues. Weitere Informationen zur Erfassung von YARN-Protokollen durch HDInsight finden Sie unter Zugriff auf YARN-Anwendungsprotokolle unter Windows-basiertem HDInsight.For more information about how HDInsight collects Yarn logs, see Access HDInsight application logs programmatically.

So zeigen Sie Hive-Aufträge an:To view Hive jobs:

  1. Klicken Sie mit der rechten Maustaste auf einen HDInsight-Cluster, und klicken Sie dann auf Aufträge anzeigen.Right-click an HDInsight cluster, and select View Jobs. Eine Liste der für den Cluster ausgeführten Hive-Aufträge wird angezeigt.A list of the Hive jobs that ran on the cluster appears.

  2. Wählen Sie einen Auftrag aus.Select a job. Wählen Sie im Fenster Hive Job Summary (Hive-Auftragszusammenfassung) eine der folgenden Optionen aus:In the Hive Job Summary window, select one of the following:

    • Job Query (Auftragsabfrage)Job Query
    • AuftragsausgabeJob Output
    • Job Log (Auftragsprotokoll)Job Log
    • Yarn log (YARN-Protokoll)Yarn log

    Screenshot des Fensters „View Hive Jobs“ (Hive-Aufträge anzeigen) der HDInsight Visual Studio-ToolsScreenshot of the HDInsight Visual Studio Tools View Hive Jobs window

Ausführen von Apache Pig-SkriptsRun Apache Pig scripts

  1. Navigieren Sie über die Menüleiste zu Datei > Neu > Projekt... .From the menu bar, navigate to File > New > Project....

  2. Navigieren Sie im linken Bereich zu Installiert > Azure Data Lake > Pig (HDInsight) .In the left pane, navigate to Installed > Azure Data Lake > Pig (HDInsight).

  3. Wählen Sie im mittleren Bereich Pig-Anwendung aus.In the middle pane, select Pig Application. Geben Sie die Eigenschaften ein, und klicken Sie dann auf OK.Enter the properties, and then select OK.

  4. Doppelklicken Sie im Projektmappen-Explorer auf Script.pig, um das Skript zu öffnen.In Solution Explorer, double-click Script.pig to open the script.

Feedback und bekannte ProblemeFeedback and known issues

  • Ein Problem, aufgrund dessen mit NULL-Werten gestartete Ergebnisse nicht angezeigt werden, wurde behoben.An issue in which results that are started with null values aren't shown has been fixed. Wenden Sie sich an das Supportteam, falls die Ausführung bei Ihnen durch dieses Problem blockiert wird.If you're blocked on this issue, contact the support team.
  • Das von Visual Studio erstellte HQL-Skript wird abhängig von der lokalen Regionseinstellung des Benutzers codiert.The HQL script that Visual Studio creates is encoded, depending on the user’s local region setting. Das Skript wird nicht korrekt ausgeführt, wenn Sie es als Binärdatei in einen Cluster hochladen.The script doesn't execute correctly if you upload the script to a cluster as a binary file.

Nächste SchritteNext steps

In diesem Artikel haben Sie erfahren, wie Sie das Data Lake Tools für Visual Studio-Paket verwenden, um in Visual Studio eine Verbindung mit HDInsight-Clustern herzustellen.In this article, you learned how to use the Data Lake Tools for Visual Studio package to connect to HDInsight clusters from Visual Studio. Zudem haben Sie gelernt, wie Sie eine Hive-Abfrage ausführen.You also learned how to run a Hive query. Weitere Informationen und Beispiele finden Sie in diesen Artikeln:For more information, see these articles: