Lernprogramm: Erstellen eines Quick-Diagrammberichts offline (Berichts-Generator)Tutorial: Create a Quick Chart Report Offline (Report Builder)

In diesem Tutorial verwenden Sie einen Assistenten, um ein Kreisdiagramm in einem paginierten Reporting ServicesReporting Services -Bericht im Berichts-GeneratorReport Builderzu erstellen.In this tutorial, you use a wizard to create a pie chart in a Reporting ServicesReporting Services paginated report in Berichts-GeneratorReport Builder. Anschließend fügen Sie Prozentwerte hinzu und nehmen geringfügige Änderungen am Kreisdiagramm vor.Then you add percentages and modify the pie chart a little.

Dieses Lernprogramm kann auf zwei unterschiedliche Arten absolviert werden.You can do this tutorial two different ways. Beide Methoden liefern das gleiche Ergebnis – ein Kreisdiagramm entsprechend der folgenden Abbildung:Both methods have the same outcome-a pie chart like the one in this illustration:

Kreisdiagramm im Berichts-GeneratorReport Builder quick pie chart

VoraussetzungenPrerequisites

Sowohl bei Verwendung von XML-Daten als auch bei einer Transact-SQLTransact-SQL-Abfrage benötigen Sie Zugriff auf den Berichts-Generator.Whether you use XML data or a Transact-SQLTransact-SQL query, you need to have access to Report Builder. Sie können Berichts-GeneratorReport Builder auf einem Reporting ServicesReporting Services -Berichtsserver starten (entweder im nativem Modus oder im integrierten SharePoint-Modus), oder Sie können Berichts-GeneratorReport Builder aus dem Microsoft Download Center herunterladen.You can start Berichts-GeneratorReport Builder from a Reporting ServicesReporting Services report server in native mode or in SharePoint integrated mode, or you can download Berichts-GeneratorReport Builder from the Microsoft Download Center. Weitere Informationen finden Sie unter Installieren des Berichts-Generators.For more information, see Install Report Builder.

Zwei Möglichkeiten zum Absolvieren des LernprogrammsTwo Ways To Do This Tutorial

Verwenden von XML-Daten für dieses LernprogrammUsing XML data for this tutorial

Sie können XML-Daten verwenden, die Sie aus diesem Thema kopieren und in den Assistenten einfügen.You can use XML data that you copy from this topic and paste into the wizard. Es muss keine Verbindung zu einem Reporting ServicesReporting Services-Berichtsserver im einheitlichen Modus oder im integrierten SharePoint-Modus bestehen, und Sie benötigen keinen Zugriff auf eine SQL Server-Instanz.You don't need to be connected to a Reporting ServicesReporting Services report server in native mode or in SharePoint integrated mode, and you don't need access to an instance of SQL Server.

Erstellen des Kreisdiagramms mit XML-DatenCreate the pie chart with XML data

Verwenden einer Transact-SQLTransact-SQL -Abfrage, die Daten für dieses Tutorial enthältUsing a Transact-SQLTransact-SQL query that contains data for this tutorial

Sie können aus diesem Thema eine Abfrage mit Daten kopieren und diese in den Assistenten einfügen.You can copy a query with data included in it from this topic and paste it into the wizard. Sie benötigen den Namen einer SQL Server-Instanz sowie Anmeldeinformationen für den schreibgeschützten Zugriff auf eine beliebige Datenbank.You will need the name of an instance of SQL Server and credentials sufficient for read-only access to any database. In der Datasetabfrage im Tutorial werden zwar Literaldaten verwendet, jedoch muss die Abfrage durch eine SQL Server-Instanz verarbeitet werden, um die für ein Berichtsdataset erforderlichen Metadaten zurückzugeben.The dataset query in the tutorial uses literal data, but the query must be processed by an instance of SQL Server to return the metadata that is required for a report dataset.

Der Vorteil der Verwendung der Transact-SQLTransact-SQL -Abfrage besteht darin, dass in allen anderen Berichts-GeneratorReport Builder -Tutorials die gleiche Methode verwendet wird. Sie wissen daher bereits, was zu tun ist, wenn Sie die anderen Tutorials durcharbeiten.The advantage of using the Transact-SQLTransact-SQL query is that all the other Berichts-GeneratorReport Builder tutorials use the same method, so when you do the other tutorials, you will already know what to do.

Für die Transact-SQLTransact-SQL -Abfrage müssen noch einige andere Voraussetzungen erfüllt sein.The Transact-SQLTransact-SQL query does require a few other prerequisites. Weitere Informationen finden Sie unter Voraussetzungen für Lernprogramme (Berichts-Generator).For more information, see Prerequisites for Tutorials (Report Builder).

Erstellen des Kreisdiagramms mit einer Transact-SQL-Abfrage, die Daten enthältCreate the pie chart with a Transact-SQL query that contains data

Erstellen des Kreisdiagramms mit XML-DatenCreating the pie chart with XML data

  1. Starten Sie den Berichts-Generator aus dem Reporting ServicesReporting Services -Webportal, vom Berichtsserver im integrierten SharePoint-Modus oder von Ihrem Computer.Start Report Builder from the Reporting ServicesReporting Services web portal, or the report server in SharePoint integrated mode, or from your computer.

    Das Dialogfeld Erste Schritte wird angezeigt.The Getting Started dialog box appears.

    Erste Schritte mit dem Berichts-GeneratorReport Builder Get Started

    Falls das Dialogfeld Erste Schritte nicht angezeigt wird, klicken Sie auf Datei >Neuzu erstellen.If the Getting Started dialog box does not appear, click File >New. Das Dialogfeld Neuer Bericht oder neues Dataset verfügt größtenteils über den gleichen Inhalt wie das Dialogfeld Erste Schritte .The New Report or Dataset dialog box has most of the same contents as the Getting Started dialog box.

  2. Vergewissern Sie sich, dass im linken Bereich Neuer Bericht ausgewählt ist.In the left pane, verify that New Report is selected.

  3. Klicken Sie im rechten Bereich auf Diagramm-Assistentund anschließend auf Erstellen.In the right pane, click Chart Wizard, and then click Create.

  4. Klicken Sie auf der Seite Dataset auswählen auf Dataset erstellenund anschließend auf Weiter.In the Choose a dataset page, click Create a dataset, and then click Next.

  5. Klicken Sie auf der Seite Verbindung mit einer Datenquelle auswählen auf Neu.In the Choose a connection to a data source page, click New.

    Das Dialogfeld Datenquelleneigenschaften wird angezeigt.The Data Source Properties dialog box opens.

  6. Sie können jedes gewünschte Element als Datenquelle bezeichnen.You can name a data source anything you want. Geben Sie im Feld Name den Namen MyPieChartein.In the Name box, type MyPieChart.

  7. Klicken Sie im Dialogfeld Verbindungstyp auswählen auf XML.In the Select connection type box, click XML.

  8. Klicken Sie zunächst auf die Registerkarte Anmeldeinformationen und anschließend auf Aktuellen Windows-Benutzer verwenden. Möglicherweise ist eine Kerberos-Delegierung erforderlich. Klicken Sie anschließend auf OK.Click the Credentials tab, select Use current Windows user. Kerberos delegation might be required, and then click OK.

  9. Klicken Sie auf der Seite Verbindung mit einer Datenquelle auswählen auf MyPieChartund anschließend auf Weiter.In the Choose a connection to a data source page, click MyPieChart, and then click Next.

  10. Kopieren Sie den folgenden Text, und fügen Sie ihn in das große Feld im oberen Bereich der Seite Abfrage entwerfen ein.Copy the following text and paste it in the large box in the top of the Design a query page.

    <Query>  
    <ElementPath>Root /S  {@Sales (Integer)} /C {@FullName} </ElementPath>  
    <XmlData>  
    <Root>  
    <S Sales="150">  
      <C FullName="Jae Pak" />  
    </S>  
    <S Sales="350">  
      <C FullName="Jillian  Carson" />  
    </S>  
    <S Sales="250">  
      <C FullName="Linda C Mitchell" />  
    </S>  
    <S Sales="500">  
      <C FullName="Michael Blythe" />  
    </S>  
    <S Sales="450">  
      <C FullName="Ranjit Varkey" />  
    </S>  
    </Root>  
    </XmlData>  
    </Query>  
    
  11. (Optional) Klicken Sie auf die Schaltfläche Ausführen ( ! ), um die Daten anzuzeigen, auf denen das Diagramm basiert.(Optional) Click the Run button (!) to see the data your chart will be based on.

    Abfrageansicht im Berichts-GeneratorReport Builder Design Query

  12. Klicken Sie auf Weiter.Click Next.

  13. Klicken Sie auf der Seite Diagrammtyp auswählen auf Kreisdiagramm. Danach klicken Sie auf Weiter.In the Choose a chart type page, click Pie, and then click Next.

  14. Doppelklicken Sie auf der Seite Diagrammfelder anordnen auf das Feld Vertrieb im Feld Verfügbare Felder.In the Arrange chart fields page, double-click the Sales field in the Available fields box.

    Beachten Sie, dass der Wert automatisch in das Feld Werte verschoben wird, da es sich um einen numerischen Wert handelt.Note that it automatically moves to the Values box, because it is a numerical value.

    Assistent zum Anordnen von Feldern im Berichts-GeneratorReport Builder Wizard Arrange Fields

  15. Ziehen Sie das Feld FullName aus dem Feld Verfügbare Felder in das Feld Kategorien (oder doppelklicken Sie auf das Feld, damit es in das Feld Kategorien verschoben wird). Klicken Sie anschließend auf Weiter.Drag the FullName field from the Available fields box to the Categories box (or double-click it; it will go to the Categories box), and then click Next.

    Die Vorschauseite zeigt Ihr neues Kreisdiagramm mit aussagekräftigen Daten.The Preview page shows your new pie chart with representational data. Anstelle der Namen der Vertriebsmitarbeiter enthält die Legende "Full Name 1", "Full Name 2" usw.; außerdem ist die Größe der Kreissegmente nicht exakt.The legend reads Full Name 1, Full Name 2, etc., rather than the salespeople's names, and the size of the slices of pie are not accurate. Diese Darstellung soll nur eine Vorstellung vom Aussehen des Berichts vermitteln.This is just to give you an idea of what your report will look like.

    Neue Diagrammvorschau im Berichts-GeneratorReport Builder New Chart Preview

  16. Klicken Sie auf Fertig stellen.Click Finish.

    Jetzt sehen Sie Ihren neuen Kreisdiagrammbericht in der Entwurfsansicht, immer noch mit aussagekräftigen Daten.Now you see your new pie chart report in Design View, still with representational data.

    Neues Tortendiagramm in der Entwurfsansicht im Berichts-GeneratorReport Builder New Pie in Design View

  17. Klicken Sie auf der Registerkarte Home des Menübands auf Ausführen , um das tatsächliche Kreisdiagramm anzuzeigen.To see your actual pie chart, click Run on the Home tab of the Ribbon.

    Neues Ausführungsdiagramm im Berichts-GeneratorReport Builder New Chart Run

  18. Fahren Sie mit Nach der Ausführung des Assistenten in diesem Artikel fort, um Ihr Kreisdiagramm weiter zu ändern.To continue modifying your pie chart, go to After You Run the Wizard in this article.

Erstellen des Kreisdiagramms mit einer Transact-SQLTransact-SQL -AbfrageCreating the pie chart with a Transact-SQLTransact-SQL query

  1. Starten Sie den Berichts-Generator aus dem Reporting ServicesReporting Services -Webportal, vom Berichtsserver im integrierten SharePoint-Modus oder von Ihrem Computer.Start Report Builder from the Reporting ServicesReporting Services web portal, from the report server in SharePoint integrated mode, or from your computer.

    Das Dialogfeld Erste Schritte wird angezeigt.The Getting Started dialog box appears.

    Hinweis

    Falls das Dialogfeld Erste Schritte nicht angezeigt wird, klicken Sie auf Datei >Neuzu erstellen.If the Getting Started dialog box does not appear, click File >New. Das Dialogfeld Neuer Bericht oder neues Dataset verfügt größtenteils über den gleichen Inhalt wie das Dialogfeld Erste Schritte .The New Report or Dataset dialog box has most of the same contents as the Getting Started dialog box.

  2. Vergewissern Sie sich, dass im linken Bereich Neuer Bericht ausgewählt ist.In the left pane, verify that New Report is selected.

  3. Klicken Sie im rechten Bereich auf Diagramm-Assistentund anschließend auf Erstellen.In the right pane, click Chart Wizard, and then click Create.

  4. Klicken Sie auf der Seite Dataset auswählen auf Dataset erstellenund anschließend auf Weiter.In the Choose a dataset page, click Create a dataset, and then click Next.

  5. Wählen Sie auf der Seite Verbindung mit einer Datenquelle auswählen eine vorhandene Datenquelle aus, oder navigieren Sie zum Berichtsserver, und wählen Sie eine Datenquelle aus. Klicken Sie anschließend auf Weiter.In the Choose a connection to a data source page, select an existing data source or browse to the report server and select a data source, and then click Next. Möglicherweise müssen Benutzername und Kennwort eingegeben werden.You may need to enter a user name and password.

    Hinweis

    Welche Datenquelle Sie auswählen, ist unwichtig, solange Sie über ausreichende Berechtigungen verfügen.The data source you choose is unimportant, as long as you have adequate permissions. Aus der Datenquelle werden keine Daten abgerufen.You will not be getting data from the data source. Weitere Informationen finden Sie unter Voraussetzungen für Lernprogramme (Berichts-Generator).For more information, see Prerequisites for Tutorials (Report Builder).

  6. Klicken Sie auf der Seite Abfrage entwerfen auf Als Text bearbeiten.On the Design a Query page, click Edit as Text.

  7. Fügen Sie die folgende Abfrage in den Abfragebereich ein:Paste the following query into the query pane:

    SELECT 150 AS Sales, 'Jae Pak' AS FullName   
    UNION SELECT 350 AS Sales, 'Jillian Carson' AS FullName   
    UNION SELECT 250 AS Sales, 'Linda C Mitchell' AS FullName   
    UNION SELECT 500 AS Sales, 'Michael Blythe' AS FullName   
    UNION SELECT 450 AS Sales, 'Ranjit Varkey' AS FullName   
    
  8. (Optional) Klicken Sie auf die Schaltfläche „Ausführen“ ( ! ), um die Daten anzuzeigen, auf denen das Diagramm basiert.(Optional) Click the Run button (!) to see the data your chart will be based on.

  9. Klicken Sie auf Weiter.Click Next.

  10. Klicken Sie auf der Seite Diagrammtyp auswählen auf Kreisdiagramm. Danach klicken Sie auf Weiter.In the Choose a chart type page, click Pie, and then click Next.

  11. Doppelklicken Sie auf der Seite Diagrammfelder anordnen auf das Feld Vertrieb im Feld Verfügbare Felder.In the Arrange chart fields page, double-click the Sales field in the Available fields box.

    Beachten Sie, dass der Wert automatisch in das Feld Werte verschoben wird, da er ein numerischer Wert ist.Note that it automatically moves to the Values box, because it's a numerical value.

  12. Ziehen Sie das Feld FullName aus dem Feld Verfügbare Felder in das Feld Kategorien (oder doppelklicken Sie auf das Feld, damit es in das Feld Kategorien verschoben wird). Klicken Sie anschließend auf Weiter.Drag the FullName field from the Available fields box to the Categories box (or double-click it; it will go to the Categories box), and then click Next.

  13. Klicken Sie auf Fertig stellen.Click Finish.

    Nun sehen Sie den neuen Kreisdiagrammbericht auf der Entwurfsoberfläche.You're now looking at your new pie chart report on the design surface. Was Sie sehen, ist symbolisch.What you see is representational. Anstelle der Namen der Vertriebsmitarbeiter enthält die Legende "Full Name 1", "Full Name 2" usw.; außerdem ist die Größe der Kreissegmente nicht exakt.The legend reads Full Name 1, Full Name 2, etc., rather than the salespeople's names, and the size of the slices of pie are not accurate. Diese Darstellung soll nur eine Vorstellung vom Aussehen des Berichts vermitteln.This is just to give you an idea of what your report will look like.

  14. Klicken Sie auf der Registerkarte Home des Menübands auf Ausführen , um das tatsächliche Kreisdiagramm anzuzeigen.To see your actual pie chart, click Run on the Home tab of the Ribbon.

Nach der Ausführung des AssistentenAfter You Run the Wizard

Nachdem Sie den Kreisdiagrammbericht erstellt haben, können Sie etwas experimentieren.Now that you have your pie chart report, you can play with it. Klicken Sie auf der Registerkarte Ausführen des Menübands auf Entwurf, um das Diagramm weiter ändern zu können.On the Run tab of the Ribbon, click Design, so you can continue modifying it.

Vergrößern des DiagrammsMake the chart bigger

Das Kreisdiagramm muss unter Umständen vergrößert werden.You may want the pie chart to be bigger.

  • Klicken Sie auf das Diagramm, um es auszuwählen. Klicken Sie dabei jedoch nicht auf ein Element des Diagramms. Ziehen Sie anschließend die rechte untere Ecke, um die Größe zu ändern.Click the chart, but not on any element in the chart, to select it and drag the lower-right corner to resize it.

Beachten Sie, dass sich die Entwurfsoberfläche beim Ziehen vergrößert.Notice the design surface gets larger as you drag.

Hinzufügen eines BerichtstitelsAdd a report title

  1. Markieren Sie am oberen Rand des Diagramms den Text Diagrammtitel , und geben Sie anschließend einen Titel (beispielsweise Sales Pie Chart) ein.Select the words Chart title at the top of the chart, and then type a title, such as Sales Pie Chart.
  2. Ändern Sie bei ausgewähltem Titel im Bereich „Eigenschaften“ folgende Werte: Farbe in Schwarz und Schriftgrad in 12 Punkt.With the title selected, in the Properties pane, change Color to Black and FontSize to 12pt.

Hinzufügen von ProzentsätzenAdd percentages

  1. Klicken Sie mit der rechten Maustaste auf das Kreisdiagramm und anschließend auf Datenbezeichnungen anzeigen.Right-click the pie chart and select Show Data Labels. Die Datenbezeichnungen sollten innerhalb jedes Segments des Kreisdiagramms angezeigt werden.The data labels appear within each slice on the pie chart.

  2. Klicken Sie mit der rechten Maustaste auf die Bezeichnungen und anschließend auf Reihenbezeichnungseigenschaften.Right-click the labels and select Series Label Properties. Das Dialogfeld Reihenbezeichnungseigenschaften wird angezeigt.The Series Label Properties dialog box appears.

  3. Geben Sie den Typ #PERCENT{P0} für das Feld Bezeichnungsdaten ein.In the Label data box, type #PERCENT{P0}.

    Wenn Sie {P0} eingeben, erhalten Sie den Prozentsatz ohne Dezimalstellen.The {P0} gives you the percentage without decimal places. Wenn Sie nur #PERCENT eingeben, haben die Zahlen zwei Dezimalstellen.If you type just #PERCENT, your numbers will have two decimal places. #PERCENT ist ein Schlüsselwort, das eine Berechnung oder eine Funktion für Sie ausführt. Dies ist nur ein Beispiel unter vielen.#PERCENT is a keyword that performs a calculation or function for you; there are many others.

  4. Klicken Sie auf Ja , um zu bestätigen, dass UseValueAsLabel auf Falsefestgelegt werden soll.Click Yes to confirm you want to set UseValueAsLabel to False.

  5. Wählen Sie auf der Registerkarte Schriftgrad die Option Fett , und ändern Sie den Wert von Farbe in Weiß.On the Font tab, select Bold and change Color to White.

  6. Klicken Sie auf OK.Click OK.

Weitere Informationen zum Anpassen von Diagrammbezeichnungen und -legenden finden Sie unter Anzeigen von Prozentwerten in einem Kreisdiagramm (Berichts-Generator und SSRS) sowie unter Ändern des Texts eines Legendenelements (Berichts-Generator und SSRS).For more information about customizing chart labels and legends, see Display Percentage Values on a Pie Chart (Report Builder and SSRS) and Change the Text of a Legend Item (Report Builder and SSRS).

Wie geht es weiter?What's Next?

Nachdem Sie nun Ihren ersten Bericht in Berichts-GeneratorReport Buildererstellt haben, können Sie die anderen Tutorials durcharbeiten und die ersten Berichte mit Ihren eigenen Daten erstellen.Now that you have created your first report in Berichts-GeneratorReport Builder, you are ready to try the other tutorials and to start creating reports from your own data. Zur Ausführung von Berichts-GeneratorReport Buildermüssen Sie berechtigt sein, mithilfe einer Verbindungszeichenfolge, durch die die Verbindung mit der Datenquelle hergestellt wird, auf Ihre Datenquellen (beispielsweise Datenbanken) zuzugreifen.To run Berichts-GeneratorReport Builder, you need permission to access your data sources, such as databases, with a connection string, which actually connects you to the data source. Der Systemadministrator hat diese Informationen und kann Ihnen bei der Einrichtung helfen.Your system administrator will have this information and can set you up.

Zur Bearbeitung der anderen Tutorials benötigen Sie den Namen einer SQL Server-Instanz sowie Anmeldeinformationen für den schreibgeschützten Zugriff auf eine beliebige Datenbank.To work through the other tutorials, you need the name of an instance of SQL Server and credentials sufficient for read-only access to any database. Auch dabei können Sie sich an den Systemadministrator wenden.Your system administrator can also set that up for you.

Schließlich benötigen Sie die URL und die Berechtigungen, um die Berichte auf einem Berichtsserver oder einer SharePoint-Website zu speichern, die mit einem Berichtsserver integriert ist.Finally, to save your reports to a report server or a SharePoint site that is integrated with a report server, you need the URL and permissions. Sie können jeden Bericht, den Sie erstellen, direkt auf Ihrem Computer ausführen. Berichte haben jedoch mehr Funktionalität, wenn sie vom Berichtsserver oder von einer SharePoint-Website aus ausgeführt werden.You can run any report you create directly from your computer, but reports have more functionality when run from the report server or SharePoint site. Sie benötigen Berechtigungen zum Ausführen Ihrer Berichte oder anderer Berichte auf dem Berichtsserver oder einer SharePoint-Website, auf der sie veröffentlicht werden.You need permissions to run your reports or others from the report server or SharePoint site where they are published. Wenden Sie sich an den Systemadministrator, um Zugriff zu erhalten.Talk to your system administrator to obtain access.

Außerdem sollten Sie sich zunächst mit einigen Grundlagen und Begriffen vertraut machen.It may help to read about some of the concepts and terms before you get started. Siehe Konzepte von Reporting Services (SSRS).See Reporting Services Concepts (SSRS). Außerdem sollten Sie das Erstellen Ihres ersten Berichts sorgfältig planen.Also, spend some time planning, before you create your first report. Der Aufwand lohnt sich.It will be time well spent. Weitere Informationen finden Sie unter Planen eines Berichts (Berichts-Generator).See Planning a Report (Report Builder).

Nächste SchritteNext steps

Lernprogramme für den Berichts-Generator Report Builder Tutorials
Berichts-Generator in SQL ServerReport Builder in SQL Server

Haben Sie dazu Fragen?More questions? Stellen Sie eine Frage im Reporting Services-ForumTry asking the Reporting Services forum