Lernprogramm: Hinzufügen eines Balkendiagramms zu einem Bericht (Berichts-Generator)Tutorial: Add a Bar Chart to Your Report (Report Builder)

In diesem Tutorial verwenden Sie einen Assistenten in Berichts-GeneratorReport Builder, um ein Kreisdiagramm in einem paginierten Reporting ServicesReporting Services-Bericht zu erstellen.In this tutorial, you use a wizard in Berichts-GeneratorReport Builder to create a bar chart in a Reporting ServicesReporting Services paginated report. Anschließend fügen Sie einen Filter hinzu und erweitern das Diagramm.Then you add a filter and enhance the chart.

In einem Balkendiagramm werden Kategoriedaten horizontal angezeigt.A bar chart displays category data horizontally. Diese Darstellung bietet folgende Vorteile:This can help to:

  • Bessere Lesbarkeit langer KategorienamenImprove readability of long category names.
  • Bessere Verständlichkeit von Zeiten, die als Werte ausgegeben werdenImprove understandability of times plotted as values.
  • Vergleichen des relativen Werts mehrerer ReihenCompare the relative value of multiple series.

Die folgende Abbildung zeigt das zu erstellende Balkendiagramm mit den Umsätzen der fünf besten Vertriebsmitarbeiter für die Jahre 2014 und 2015 vom niedrigsten bis zum höchsten Umsatz im Jahr 2015.The following illustration shows the bar chart that you will create, with sales for 2014 and 2015 for the top five salespeople, from most to least 2015 sales.

Berichts-Generator-Balkendiagramm

Hinweis

In diesem Lernprogramm werden die Schritte für den Assistenten in einem Verfahren zusammengefasst.In this tutorial, the steps for the wizard are consolidated into one procedure. Das erste Tutorial dieser Reihe enthält Schrittanleitungen zum Navigieren zu einem Berichtsserver, zum Erstellen eines Datasets und zum Auswählen einer Datenquelle: Tutorial: Erstellen eines einfachen Tabellenberichts (Berichts-Generator).For step-by-step instructions about how to browse to a report server, create a dataset, and choose a data source, see the first tutorial in this series: Tutorial: Creating a Basic Table Report (Report Builder).

Ungefähre Dauer dieses Lernprogramms: 15 MinutenEstimated time to complete this tutorial: 15 minutes.

AnforderungenRequirements

Weitere Informationen zu den Anforderungen finden Sie unter Voraussetzungen für Tutorials (Berichts-Generator).For more information about requirements, see Prerequisites for Tutorials (Report Builder).

1. Erstellen eines Diagrammberichts mithilfe des Diagramm-Assistenten1. Create a Chart Report from the Chart Wizard

Darin erstellen Sie ein eingebettetes Dataset, wählen eine freigegebene Datenquelle aus, und erstellen mithilfe des Diagramm-Assistenten ein Balkendiagramm.In which you create an embedded dataset, choose a shared data source, and create a bar chart by using the Chart Wizard.

Hinweis

In diesem Tutorial sind die Datenwerte in der Abfrage enthalten, sodass keine externe Datenquelle benötigt wird.In this tutorial, the query contains the data values so that it does not need an external data source. Die Abfrage ist daher relativ lang.This makes the query quite long. In einer Geschäftsumgebung wären die Daten nicht in der Abfrage enthalten.In a business environment, a query would not contain the data. Dieses Szenario dient nur zu Lernzwecken.This is for learning purposes only.

  1. Starten Sie den Berichts-Generator aus dem Reporting ServicesReporting Services -Webportal, vom Berichtsserver im integrierten SharePoint-Modus oder von Ihrem Computer.Start Report Builder from the Reporting ServicesReporting Services web portal, from the report server in SharePoint integrated mode, or from your computer.

    Das Dialogfeld Erste Schritte wird angezeigt.The Getting Started dialog box appears.

    Erste Schritte mit dem Berichts-GeneratorReport Builder Get Started

    Wenn das Dialogfeld Erste Schritte nicht angezeigt wird, klicken Sie auf Datei >Neu.If you don't see the Getting Started dialog box, click File >New. Das Dialogfeld Neuer Bericht oder neues Dataset verfügt größtenteils über den gleichen Inhalt wie das Dialogfeld Erste Schritte .The New Report or Dataset dialog box has most of the same contents as the Getting Started dialog box.

  2. Vergewissern Sie sich, dass im linken Bereich Neuer Bericht ausgewählt ist.In the left pane, verify that New Report is selected.

  3. Klicken Sie im rechten Bereich auf Diagramm-Assistent.In the right pane, click Chart Wizard.

  4. Klicken Sie auf der Seite Dataset auswählen auf Dataset erstellenund anschließend auf Weiter.On the Choose a dataset page, click Create a dataset, and then click Next.

  5. Wählen Sie auf der Seite Verbindung mit einer Datenquelle auswählen eine vorhandene Datenquelle aus, oder navigieren Sie zum Berichtsserver, und wählen Sie eine Datenquelle aus. Klicken Sie anschließend auf Weiter.On the Choose a connection to a data source page, select an existing data source or browse to the report server and select a data source, and then click Next. Möglicherweise müssen Benutzername und Kennwort eingegeben werden.You may need to enter a user name and password.

    Hinweis

    Welche Datenquelle Sie auswählen, ist unwichtig, solange Sie über ausreichende Berechtigungen verfügen.The data source you choose is unimportant, as long as you have adequate permissions. Aus der Datenquelle werden keine Daten abgerufen.You will not be getting data from the data source. Weitere Informationen finden Sie unter Alternative Methoden zum Herstellen einer Datenverbindung (Berichts-Generator).For more information, see Alternative Ways to Get a Data Connection (Report Builder).

  6. Klicken Sie auf der Seite Abfrage entwerfen auf Als Text bearbeiten.On the Design a query page, click Edit as Text.

  7. Fügen Sie die folgende Abfrage in den Abfragebereich ein:Paste the following query into the query pane:

    SELECT 'Luis' as FirstName, 'Alverca' as LastName, CAST(170000.00 AS money) AS SalesYear2015, CAST(150000. AS money) AS SalesYear2014  
    UNION SELECT 'Jeffrey' as FirstName, 'Zeng' as LastName, CAST(210000. AS money) AS SalesYear2015, CAST(190000. AS money) AS SalesYear2014  
    UNION SELECT 'Houman' as FirstName, 'Pournasseh' as LastName, CAST(150000. AS money) AS SalesYear2015, CAST(180000. AS money) AS SalesYear2014  
    UNION SELECT 'Robin' as FirstName, 'Wood' as LastName, CAST(75000. AS money) AS SalesYear2015, CAST(175000. AS money) AS SalesYear2014  
    UNION SELECT 'Daniela' as FirstName, 'Guaita' as LastName,  CAST(170000. AS money) AS SalesYear2015, CAST(175000. AS money) AS SalesYear2014  
    UNION SELECT 'John' as FirstName, 'Yokim' as LastName, CAST(160000. AS money) AS SalesYear2015, CAST(195000. AS money) AS SalesYear2014  
    UNION SELECT 'Delphine' as FirstName, 'Ribaute' as LastName, CAST(180000. AS money) AS SalesYear2015, CAST(205000. AS money) AS SalesYear2014  
    UNION SELECT 'Robert' as FirstName, 'Hernady' as LastName, CAST(140000. AS money) AS SalesYear2015, CAST(180000. AS money) AS SalesYear2014  
    UNION SELECT 'Tanja' as FirstName, 'Plate' as LastName, CAST(150000. AS money) AS SalesYear2015, CAST(160000. AS money) AS SalesYear2014  
    UNION SELECT 'David' as FirstName, 'Bradley' as LastName, CAST(210000. AS money) AS SalesYear2015, CAST(180000. AS money) AS SalesYear2014  
    UNION SELECT 'Michal' as FirstName, 'Jaworski' as LastName, CAST(175000. AS money) AS SalesYear2015, CAST(220000. AS money) AS SalesYear2014  
    UNION SELECT 'Chris' as FirstName, 'Ashton' as LastName, CAST(195000. AS money) AS SalesYear2015, CAST(205000. AS money) AS SalesYear2014  
    UNION SELECT 'Pongsiri' as FirstName, 'Hirunyanitiwatna' as LastName, CAST(175000. AS money) AS SalesYear2015, CAST(215000. AS money) AS SalesYear2014  
    UNION SELECT 'Brian' as FirstName, 'Burke' as LastName, CAST(187000. AS money) AS SalesYear2015, CAST(207000. AS money) AS SalesYear2014  
    
  8. (Optional) Klicken Sie auf die Schaltfläche „Ausführen“ (!), um die Daten anzuzeigen, auf denen das Diagramm basiert.(Optional) Click the Run button (!) to see the data your chart will be based on.

  9. Klicken Sie auf Weiter.Click Next.

2. Erstellen eines Balkendiagramms2. Create a Bar Chart

  1. Das Säulendiagramm ist der Standarddiagrammtyp der Seite Diagrammtyp auswählen .On the Choose a chart type page, the column chart is the default chart type.

  2. Klicken Sie auf Balkenund anschließend auf Weiter.Click Bar, and then click Next.

    Auf der Seite Diagrammfelder anordnen stehen im Bereich Verfügbare Felder vier Felder zur Verfügung: FirstName, LastName, SalesYear2015 und SalesYear2014.On the Arrange chart fields page, there are four fields in the Available fields pane: FirstName, LastName, SalesYear2015, and SalesYear2014.

  3. Ziehen Sie "LastName" in den Bereich "Kategorien".Drag LastName to the Categories pane.

  4. Ziehen Sie „SalesYear2015“ in den Bereich „Werte“.Drag SalesYear2015 to the Values pane. „SalesYear2015“ steht für den Umsatz der einzelnen Vertriebsmitarbeiter im Jahr 2015.SalesYear2015 represents the sales amount for each salesperson for the year 2015. Im Bereich Werte wird [Sum(SalesYear2015)] angezeigt, da im Diagramm der aggregierte Wert für die einzelnen Produkte angezeigt wird.The Values pane displays [Sum(SalesYear2015)] because the chart displays the aggregate for each product.

  5. Ziehen Sie „SalesYear2014“ im Bereich „Werte“ unter „SalesYear2015“.Drag SalesYear2014 to the Values pane under SalesYear2015. „SalesYear2014“ steht für den Umsatz der einzelnen Vertriebsmitarbeiter im Jahr 2014.SalesYear2014 represents the sales amount for each salesperson for the year 2014.

  6. Klicken Sie auf Weiter.Click Next.

  7. Klicken Sie auf Fertig stellen.Click Finish.

    Das Diagramm wird der Entwurfsoberfläche hinzugefügt.The chart is added to the design surface. Beachten Sie, dass das neue Balkendiagramm nur aussagekräftige Daten zeigt.Note that the new bar chart just shows representational data. Statt der Namen der Personen enthält die Legende Last Name A, Last Name B usw., um Ihnen einen Überblick zu übermitteln, wie Ihr Bericht aussehen wird.The legend reads Last Name A, Last Name B, etc., rather than the people's names, just to give an idea of what your report will look like.

  8. Klicken Sie auf das Diagramm, um die Diagrammziehpunkte anzuzeigen.Click the chart to display the chart handles. Ziehen Sie die rechte untere Ecke des Diagramms, um das Diagramm zu vergrößern.Drag the bottom-right corner of the chart to increase the size of the chart. Beachten Sie, dass sich die Entwurfsoberfläche beim Ziehen vergrößert.Notice the design surface gets larger as you drag.

  9. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Das Balkendiagramm zeigt die Umsätze der einzelnen Vertriebsmitarbeiter in den Jahren 2014 und 2015 an.The bar chart displays sales for each sales person for the years 2014 and 2015. Die Balkenlänge entspricht dem jeweiligen Gesamtumsatz.The length of the bar corresponds to the sales total.

3. Anzeigen aller Namen auf der vertikalen Achse3. Display All the Names on the Vertical Axis

Standardmäßig werden auf der vertikalen Achse nur einige der Werte angezeigt.By default, only some of the values on the vertical axis appear. Sie können das Diagramm so ändern, dass alle Kategorien angezeigt werden.You can change the chart to display all categories.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Klicken Sie mit der rechten Maustaste auf die vertikale Achse, und klicken Sie anschließend auf Eigenschaften für vertikale Achsen.Right-click the vertical axis, then click Vertical Axis Properties.

  3. Geben Sie unter Achsenbereich und -intervallim Feld Intervall den Wert 1ein.Under Axis range and interval, in the Interval box, type 1.

  4. Klicken Sie auf OK.Click OK.

  5. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Hinweis

Wenn Sie die Namen der Vertriebsmitarbeiter auf der vertikalen Achse nicht lesen können, können Sie das Diagramm vergrößern oder die Formatierungsoptionen für die Achsenbezeichnungen ändern.If you cannot read the salesperson names on the vertical axis, you can make your chart taller or change the formatting options for the axis labels.

Anzeigen der Nachnamen und Vornamen auf der vertikalen AchseDisplay Last Name and First Name on Vertical Axis

Sie können den Kategorieausdruck so ändern, dass die Nach- und Vornamen der einzelnen Vertriebsmitarbeiter angezeigt werden.You can change the category expression to include last name followed by first name of each sales person.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Doppelklicken Sie auf das Diagramm, um den Bereich Diagrammdaten anzuzeigen.Double-click the chart to display the Chart Data pane.

  3. Klicken Sie mit der rechten Maustaste im Bereich Kategoriegruppen auf „[LastName]“, und klicken Sie anschließend auf Kategoriegruppeneigenschaften.In the Category Groups area, right-click [LastName], and then click Category Group Properties.

  4. Klicken Sie unter "Bezeichnung" auf die Ausdrucksschaltfläche ("Fx").In Label, click the expression (Fx) button.

  5. Geben Sie den folgenden Ausdruck ein: =Fields!LastName.Value & ", " & Fields!FirstName.ValueType the following expression: =Fields!LastName.Value & ", " & Fields!FirstName.Value

    Durch diesen Ausdruck wird eine Verkettung aus dem Nachnamen, einem Komma und dem Vornamen erstellt.This expression concatenates the last name, a comma, and the first name.

  6. Klicken Sie auf OK.Click OK.

  7. Klicken Sie auf OK.Click OK.

  8. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Sollten beim Ausführen des Berichts keine Vornamen angezeigt werden, können Sie die Daten manuell aktualisieren.If the first names do not appear when you run the report, you can refresh the data manually. Klicken Sie im Vorschaumodus auf der Registerkarte Ausführen in der Gruppe Navigation auf Aktualisieren.While still in preview mode, on the Run tab in the Navigation group, click Refresh.

Hinweis

Wenn Sie die Namen der Vertriebsmitarbeiter auf der vertikalen Achse nicht lesen können, können Sie das Diagramm vergrößern oder die Formatierungsoptionen für die Achsenbezeichnungen ändern.If you cannot read the salesperson names on the vertical axis, you can make your chart taller or change the formatting options for the axis labels.

4. Ändern der Sortierreihenfolge der vertikalen Achse4. Change the Sort Order on the Vertical Axis

Beim Sortieren der Daten eines Diagramms wird die Reihenfolge der Werte auf der Kategorieachse geändert.When you sort the data on a chart, you are changing the order of values on the category axis.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Doppelklicken Sie auf das Diagramm, um den Bereich Diagrammdaten anzuzeigen.Double-click the chart to display the Chart Data pane.

  3. Klicken Sie mit der rechten Maustaste im Bereich Kategoriegruppen auf „[LastName]“, und klicken Sie anschließend auf Kategoriegruppeneigenschaften.In the Category Groups area, right-click [LastName], and then click Category Group Properties.

  4. Klicken Sie auf Sortierung.Click Sorting. Auf der Seite Ändern Sie die Sortieroptionen wird eine Liste mit Sortierausdrücken angezeigt.The Change sorting options page displays a list of sort expressions. Standardmäßig enthält diese Liste einen einzelnen Sortierungsausdruck, der dem ursprünglichen Kategoriegruppenausdruck entspricht.By default, this list has one sort expression that is the same as the original category group expression.

  5. Klicken Sie unter Sortieren nachauf [SalesYear2015].In Sort by, click [SalesYear2015].

  6. Wählen Sie in der Liste Reihenfolge A bis Z aus, sodass die Namen in der Reihenfolge vom höchsten bis zum niedrigsten Umsatz im Jahr 2015 angezeigt werden.in the Order list, select A to Z so that the names appear in order from largest to smallest 2015 sales.

  7. Klicken Sie auf OK.Click OK.

  8. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Die Namen auf der horizontalen Achse werden von den höchsten bis zu den niedrigsten Umsätzen im Jahr 2015 sortiert, Zeng steht also ganz oben.The names on the horizontal axis are sorted from largest to smallest 2015 sales, with Zeng at the top.

5. Verschieben der Legende5. Move the Legend

Um die Lesbarkeit der Diagrammwerte zu verbessern, können Sie gegebenenfalls die Diagrammlegende verschieben.To improve the readability of the chart values, you might want to move the chart legend. So können Sie zum Beispiel in einem Balkendiagramm mit einer horizontalen Anordnung der Balken die Legende oberhalb oder unterhalb des Diagrammbereichs platzieren.For example, in a bar chart where bars are shown horizontally, you can change the position of the legend so that it is above or below the chart area. Dann bleibt horizontal mehr Platz für die Balken.This gives more horizontal space to the bars.

So zeigen Sie die Legende unterhalb des Diagrammbereichs eines Balkendiagramms anTo display the legend below the chart area of a bar chart

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Klicken Sie mit der rechten Maustaste auf die Legende des Diagramms.Right-click the legend on the chart.

  3. Wählen Sie Legendeneigenschaftenaus.Select Legend Properties.

  4. Wählen Sie unter Legendenpositioneine andere Position aus.For Legend position, select a different position. Legen Sie z. B. eine Position unten in der Mitte fest.For example, set the position to the middle bottom option.

    Wenn Sie die Legende über oder unter einem Diagramm platzieren, ändert sich das Layout der Legende von vertikal zu horizontal.When the legend is placed at the top or bottom of a chart, the layout of the legend changes from vertical to horizontal. In der Dropdownliste Layout können Sie ein anderes Layout auswählen.You can select a different layout from the Layout drop-down list.

  5. Klicken Sie auf OK.Click OK.

  6. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

6. Benennen des Diagramms6. Title the Chart

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Markieren Sie am oberen Diagrammrand den Text Diagrammtitel, und geben Sie anschließend Folgendes ein: Umsätze für 2014 und 2015.Select the words Chart Title at the top of the chart, then type: Sales for 2014 and 2015.

  3. Legen Sie bei ausgewähltem Titel im Bereich „Eigenschaften“ folgende Werte fest: Farbe auf Schwarz und Schriftgrad auf 12 pt.In the Properties pane, with the title selected, set Color to Black and FontSize to 12pt.

  4. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

7. Formatieren und Beschriften der horizontalen Achse7. Format and Label the Horizontal Axis

Standardmäßig werden die Werte auf der horizontalen Achse in einem allgemeinen Format angezeigt, dessen Größe automatisch an die Diagrammgröße angepasst wird.By default, the horizontal axis displays values in a general format that is automatically scaled to fit the size of the chart. Sie können es in das Währungsformat ändern.You can change it to the currency format.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Klicken Sie unten im Diagramm auf die horizontale Achse, um sie auszuwählen.Click the horizontal axis along the bottom of the chart to select it.

  3. Klicken Sie auf der Registerkarte Start in der Gruppe Number (Zahl) auf Currency (Währung).On the Home tab > Number group > Currency. Die horizontalen Achsenbezeichnungen werden zu Währungsbezeichnungen geändert.The horizontal axis labels change to currency.

  4. (Optional) Entfernen Sie die Dezimalstellen.(Optional) Remove the decimal digits. Klicken Sie in der Nähe der Schaltfläche Währung zweimal auf die Schaltfläche Dezimalstelle löschen .Near the Currency button, click the Decrease Decimal button twice.

  5. Klicken Sie mit der rechten Maustaste auf die horizontale Achse, und klicken Sie anschließend auf Eigenschaften für horizontale Achsen.Right-click the horizontal axis, and click Horizontal Axis Properties.

  6. Wählen Sie auf der Registerkarte Zahl die Option aus, mit der Werte als Tausender-Werte angezeigt werden.On the Number tab, select Show values in Thousands.

  7. Klicken Sie auf OK.Click OK.

  8. Klicken Sie mit der rechten Maustaste auf die horizontale Achse, und wählen Sie Achsentitel anzeigenaus.Right-click the horizontal axis, and select Show Axis Title.

  9. Geben Sie im Feld Achsentitel den Text Sales in thousands ein, und drücken Sie die EINGABETASTE.In the Axis Title box, type Sales in thousands and press Enter.

    Hinweis: Während der Eingabe sieht es so aus, als würde sich das Feld „Achsentitel“ auf der vertikalen Achse befinden.Note: While you're typing, the Axis Title box appears to be on the vertical axis. Wenn Sie jedoch die EINGABETASTE drücken, wird es zur horizontalen Achse verschoben.But when you press Enter, it goes to the horizontal axis.

  10. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Auf der horizontalen Achse des Berichts werden die Umsätze als Währung in Tausendern ohne Dezimalstellen angezeigt.The report displays the sales amount on the horizontal axis as currency in thousands, with no decimal digits.

8. Hinzufügen eines Filters zum Anzeigen der fünf besten Werte8. Add a Filter to Display the Top Five Values

Sie können dem Diagramm einen Filter hinzufügen, um anzugeben, welche Daten des Datasets ein- oder ausgeschlossen werden sollen.You can add a filter to the chart to specify which data from the dataset to include or exclude in the chart.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Doppelklicken Sie auf das Diagramm, um den Bereich Diagrammdaten anzuzeigen.Double-click the chart to display the Chart Data pane.

  3. Klicken Sie im Bereich Kategoriegruppen mit der rechten Maustaste auf das Feld [LastName]. Klicken Sie danach auf Kategoriegruppeneigenschaften.In the Category Groups area, right-click the [LastName] field, and then click Category Group Properties.

  4. Klicken Sie auf Filter.Click Filters. Die Seite Filter ändern zeigt eine Liste von Filterausdrücken an.The Change filters page can display a list of filter expressions. Standardmäßig ist diese Liste leer.By default, this list is empty.

  5. Klicken Sie auf Hinzufügen.Click Add. Ein neuer leerer Filter wird angezeigt.A new blank filter appears.

  6. Geben Sie unter Ausdruck [Sum(SalesYear2015)] ein.In Expression, type [Sum(SalesYear2015)]. Dadurch wird der zugrunde liegende Ausdruck =Sum(Fields!SalesYear2015.Value)erstellt, der durch Klicken auf die Schaltfläche fx angezeigt wird.This creates the underlying expression =Sum(Fields!SalesYear2015.Value), which you can see if you click the fx button.

  7. Überprüfen Sie, ob der Datentyp gleich Textist.Verify that the data type is Text.

  8. Wählen Sie in Operatorin der Dropdownliste den Eintrag Erste N aus.In Operator, select Top N from the drop-down list.

  9. Geben Sie unter Wertden folgenden Ausdruck ein: =5In Value, type the following expression: =5

  10. Klicken Sie auf OK.Click OK.

  11. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Sollten die Ergebnisse nicht gefiltert werden, wenn Sie den Bericht ausführen, können Sie die Daten manuell aktualisieren.If the results are not filtered when you run the report, you can refresh the data manually. Klicken Sie auf der Registerkarte Ausführen in der Gruppe Navigation auf Aktualisieren.On the Run tab in the Navigation group, click Refresh.

Im Diagramm werden die Namen der fünf besten Vertriebsmitarbeiter gemäß den Umsatzdaten des Jahres 2015 angezeigt.The chart shows the top five salesperson names from the 2015 sales data.

9. Hinzufügen eines Berichtstitels9. Add a Report Title

  1. Klicken Sie auf der Entwurfsoberfläche auf Zum Hinzufügen eines Titels klicken.On the design surface, click Click to add title.

  2. Geben Sie Umsatz-Balkendiagrammein, drücken Sie die EINGABETASTE, und geben Sie anschließend Top Five-Verkaufsschlager 2015ein, was anschließend in etwa wie folgt aussehen sollte:Type Sales Bar Chart, press ENTER, and then type Top Five Sellers for 2015, so it looks like this:

    Umsatz-BalkendiagrammSales Bar Chart

    Top Five-Verkaufsschlager 2015Top Five Sellers for 2015

  3. Markieren Sie Umsatz-Balkendiagramm, und klicken Sie auf die Schaltfläche Fett .Select Sales Bar Chart, and click the Bold button.

  4. Markieren Sie Top Five-Verkaufsschlager 2015, und legen Sie auf der Registerkarte Stamm im Abschnitt Schriftart den Schriftgrad auf 10fest.Select Top Five Sellers for 2015, and in the Font section on the Home tab, set the font size to 10.

  5. (Optional) Das Textfeld „Titel“ muss ggf. vergrößert werden, damit die beiden Textzeilen hineinpassen, und der obere Rand des Balkendiagramms muss heruntergezogen werden, um die beiden Textzeilen aufzunehmen.(Optional) You may need to make the Title text box taller, and bring down the top of the bar chart, to accommodate the two lines of text.

    Dieser Titel wird am Anfang des Berichts angezeigt.This title will appear at the top of the report. Ist keine Kopfzeile definiert, erfüllen die Elemente über dem Berichtshauptteil die Funktion einer Berichtskopfzeile.When there is no page header defined, items at the top of the report body are the equivalent of a report header.

  6. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

10. Speichern des Berichts10. Save the Report

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Klicken Sie auf Datei > Speichern als.Click File > Save As.

  3. Geben Sie im Feld Namedie Zeichenfolge Umsatz-Balkendiagrammein.In Name, type Sales Bar Chart.

    Sie können ihn entweder auf Ihrem Computer oder auf dem Berichtsserver speichern.You can save it either to your computer or to the report server.

  4. Klicken Sie auf Speichern.Click Save.

Next StepsNext Steps

Sie haben das Lernprogramm "Hinzufügen eines Balkendiagramms zu einem Bericht" erfolgreich abgeschlossen.You have successfully completed the Adding a Bar Chart to Your Report tutorial. Weitere Informationen zu Diagrammen finden Sie unter Diagramme und Balkendiagramme.To learn more about charts, see Charts and Bar Charts.

Weitere InformationenSee Also

Lernprogramme für den Berichts-GeneratorReport Builder Tutorials
Berichts-Generator in SQL ServerReport Builder in SQL Server